vala-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. %global api_ver 0.22
  2. Summary: A modern programming language for GNOME
  3. Summary: GNOME 用のモダンなプログラミング言語
  4. Name: vala
  5. Version: 0.22.1
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  9. License: LGPLv2+ and BSD
  10. URL: http://live.gnome.org/Vala
  11. Source0: http://download.gnome.org/sources/vala/0.22/vala-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: glib2-devel
  14. BuildRequires: flex
  15. BuildRequires: bison
  16. BuildRequires: libxslt
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Vala is a new programming language that aims to bring modern programming
  21. language features to GNOME developers without imposing any additional
  22. runtime requirements and without using a different ABI compared to
  23. applications and libraries written in C.
  24. valac, the Vala compiler, is a self-hosting compiler that translates
  25. Vala source code into C source and header files. It uses the GObject
  26. type system to create classes and interfaces declared in the Vala source
  27. code. It's also planned to generate GIDL files when gobject-
  28. introspection is ready.
  29. The syntax of Vala is similar to C#, modified to better fit the GObject
  30. type system.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: pkgconfig
  36. %description devel
  37. Vala is a new programming language that aims to bring modern programming
  38. language features to GNOME developers without imposing any additional
  39. runtime requirements and without using a different ABI compared to
  40. applications and libraries written in C.
  41. This package contains development files for %{name}. This is not necessary for
  42. using the %{name} compiler.
  43. %package tools
  44. Summary: Tools for creating projects and bindings for %{name}
  45. Group: Development/Languages
  46. License: LGPLv2+
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: gnome-common intltool libtool
  49. Provides: %{name}-vapigen = %{version}-%{release}
  50. Obsoletes: %{name}-vapigen < %{version}-%{release}
  51. %description tools
  52. Vala is a new programming language that aims to bring modern programming
  53. language features to GNOME developers without imposing any additional
  54. runtime requirements and without using a different ABI compared to
  55. applications and libraries written in C.
  56. This package contains tools to generate Vala projects, as well as API bindings
  57. from existing C libraries, allowing access from Vala programs.
  58. %package doc
  59. Summary: Documentation for %{name}
  60. Group: Documentation
  61. License: LGPLv2+
  62. BuildArch: noarch
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: devhelp
  65. Provides: %{name}-docs = %{version}-%{release}
  66. Obsoletes: %{name}-docs < %{version}-%{release}
  67. %description doc
  68. Vala is a new programming language that aims to bring modern programming
  69. language features to GNOME developers without imposing any additional
  70. runtime requirements and without using a different ABI compared to
  71. applications and libraries written in C.
  72. This package contains documentation in a devhelp HTML book.
  73. %prep
  74. %setup -q
  75. %build
  76. %configure --enable-vapigen
  77. # Don't use rpath!
  78. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  79. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  80. make %{?_smp_mflags}
  81. # checks currently utilize installed Vala, not the one being compiled
  82. #%check
  83. #make check
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  95. %{_bindir}/vala
  96. %{_bindir}/valac
  97. %{_bindir}/vala-%{api_ver}
  98. %{_bindir}/valac-%{api_ver}
  99. %{_datadir}/vala-%{api_ver}
  100. %{_libdir}/libvala-%{api_ver}.so.*
  101. %{_mandir}/*/valac*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_includedir}/vala-%{api_ver}
  105. %{_libdir}/libvala-%{api_ver}.so
  106. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  107. %{_datadir}/aclocal/vala.m4
  108. %{_datadir}/aclocal/vapigen.m4
  109. %{_datadir}/pkgconfig/vapigen.pc
  110. %{_datadir}/pkgconfig/vapigen-%{api_ver}.pc
  111. %{_datadir}/vala/Makefile.vapigen
  112. %files tools
  113. %defattr(-,root,root,-)
  114. %{_bindir}/vala-gen-introspect
  115. %{_bindir}/vapicheck
  116. %{_bindir}/vapigen
  117. %{_bindir}/vala-gen-introspect-%{api_ver}
  118. %{_bindir}/vapicheck-%{api_ver}
  119. %{_bindir}/vapigen-%{api_ver}
  120. %{_libdir}/vala-%{api_ver}
  121. %{_mandir}/*/*gen*
  122. %files doc
  123. %defattr(-,root,root,-)
  124. %{_datadir}/devhelp/books/vala-%{api_ver}
  125. %changelog
  126. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  127. - new upstream release
  128. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  129. - new upstream release
  130. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  131. - new upstream release
  132. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  133. - new upstream release
  134. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  135. - new upstream release
  136. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  137. - new upstream release
  138. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  139. - new upstream release
  140. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  141. - new upstream release
  142. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  143. - new upstream release
  144. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  145. - new upstream release
  146. - remove BuildRequires: gtk2-devel, xulrunner-devel
  147. - add BuildRequires: glib2-devel, libxslt
  148. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  149. - new upstream release
  150. - remove BuildRequires: devhelp
  151. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  152. - new upstream release
  153. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  154. - new upstream release
  155. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  156. - new upstream release
  157. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  158. - rebuilt with rpm-4.8.1 for pkg-config
  159. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  160. - new upstream release
  161. - made -doc subpackage noarch
  162. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  163. - new upstream release
  164. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  165. - new upstream release
  166. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  167. - new upstream release
  168. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  169. - new upstream release
  170. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  171. - new upstream release
  172. - change BuildRequires: gecko-libs -> xulrunner-devel
  173. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  174. - new upstream release
  175. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  176. - new upstream release
  177. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  178. - new upstream release
  179. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  180. - initial build for Vine Linux
  181. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  182. - Update to 0.7.5
  183. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  185. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  186. - Patch broken ModuleInit attribute (upstream bug 587444)
  187. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  188. - Update to 0.7.4
  189. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  190. - Update to 0.7.3
  191. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  192. - Update to 0.6.1
  193. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  194. - Update to 0.5.7
  195. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  196. - Update to 0.5.6
  197. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  198. - Update to 0.5.3
  199. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  200. - Fix bug in Emacs version detection
  201. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  202. - Use buildsystem variables to determine available Emacs version
  203. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  204. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  205. - Update to 0.5.2
  206. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  207. - Update to 0.5.1
  208. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  209. - Update to 0.3.5
  210. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  211. - Add vala-mode for editing Vala code in Emacs
  212. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  213. - Update to 0.3.4
  214. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  215. - Update to 0.3.3
  216. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  217. - Update to 0.3.2
  218. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  219. - Update to 0.2.0
  220. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  221. - Update to 0.1.7
  222. - -tool subpackage now requires gnome-common, intltool and libtoolize
  223. for out-of-the-box vala-gen-project support
  224. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  225. - Autorebuild for GCC 4.3
  226. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  227. - Update to 0.1.6
  228. - Revert vapi addition, needed declarations have been inlined (r846)
  229. - Rename -docs subpackage to -doc, to comply with guidelines
  230. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  231. - Manually add Gee vapi file to package (bz #428692)
  232. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  233. - Backport patch to autodetect location of automake shared files
  234. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  235. - Add build dependency on gtk2-devel
  236. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  237. - Enable project generator tool
  238. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  239. - Update to 0.1.5
  240. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  241. - Add build dependency on devhelp
  242. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  243. - Update to 0.1.4
  244. - Put newly-added documentation in its own subpackage (depends on devhelp)
  245. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  246. - vapigen subpackage: add missing Require: on perl-XML-Twig
  247. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  248. - Split -vapigen subpackage. It is functionally self-contained and the license
  249. is more restricted
  250. - Updated license declarations
  251. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  252. - Licensing and URL updates
  253. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  254. - Enable binding generation tools
  255. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  256. - Update to 0.1.3
  257. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  258. - Update to 0.0.8
  259. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  260. - Update to 0.0.7
  261. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  262. - Update to 0.0.6
  263. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  264. - Initial package