shotwell-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272
  1. Name: shotwell
  2. Version: 0.15.1
  3. Release: 1%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. # http://redmine.yorba.org/issues/5181
  15. Patch0: shotwell-usrmove.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: GConf2-devel
  18. BuildRequires: LibRaw-devel
  19. BuildRequires: LibRaw-static
  20. BuildRequires: WebKit3-gtk-devel
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: gtk3-devel
  25. #BuildRequires: gstreamer-devel
  26. #BuildRequires: gstreamer-plugins-base-devel
  27. BuildRequires: gstreamer1-devel
  28. BuildRequires: gstreamer1-plugins-base-devel
  29. BuildRequires: json-glib-devel
  30. BuildRequires: libexif-devel
  31. BuildRequires: libgee-devel
  32. BuildRequires: libgee-vala
  33. BuildRequires: libgphoto2-devel
  34. BuildRequires: libgudev1-devel
  35. BuildRequires: libgexiv2-devel >= 0.2.0
  36. BuildRequires: libsoup-devel
  37. BuildRequires: libxml2-devel
  38. BuildRequires: lcms2-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: unique3-devel
  41. BuildRequires: vala-devel >= 0.9.5
  42. BuildRequires: rest-devel
  43. # used by shotwell-settings-migrator
  44. Requires: dconf
  45. Vendor: Project Vine
  46. Distribution: Vine Linux
  47. Packager: kudoh
  48. %description
  49. Shotwell is a new open source photo manager designed for the GNOME desktop
  50. environment. It allows you to import photos from your camera, view and edit
  51. them, and share them with others.
  52. %description -l ja
  53. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  54. 画像管理ツールです。
  55. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  56. 他の人々と共有するなどができます。
  57. %prep
  58. %setup -q -n %{name}-%{version}
  59. %patch0 -p1 -b .usrmove
  60. %build
  61. # We can't use the configure macro: it's not a standard autotools configure script
  62. export CFLAGS="%{optflags}"
  63. export LIB=%{_lib}
  64. # HACK: Remove fatal-warnings to succeed build with vala 0.13.
  65. #sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
  66. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
  67. #sed -i -e 's/\\n/\n/g' configure.mk
  68. make %{?_smp_mflags}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  72. export XDG_DISABLE_MAKEFILE_UPDATES=1
  73. # otherwise gettext always returns English text regardless of LANGUAGE asked
  74. export LANG=en_US.utf8
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  77. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  78. # put hi-res icons in place
  79. (
  80. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  81. rm -rf 16x16 24x24 scalable
  82. tar xf %{SOURCE1}
  83. )
  84. %find_lang %{name} --all-name
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post
  88. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  89. update-desktop-database &> /dev/null || :
  90. %postun
  91. if [ $1 -eq 0 ] ; then
  92. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  93. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  94. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  95. fi
  96. update-desktop-database &> /dev/null || :
  97. %posttrans
  98. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  99. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  100. %files -f %{name}.lang
  101. %defattr(-,root,root,-)
  102. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  103. %{_bindir}/shotwell
  104. %{_libexecdir}/shotwell/shotwell-settings-migrator
  105. %{_libexecdir}/shotwell/shotwell-video-thumbnailer
  106. %{_libdir}/shotwell/plugins/builtin
  107. %{_datadir}/GConf/gsettings/shotwell.convert
  108. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
  109. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
  110. %{_datadir}/gnome/help/
  111. %{_datadir}/shotwell
  112. %{_datadir}/appdata/shotwell.appdata.xml
  113. %{_datadir}/applications/shotwell.desktop
  114. %{_datadir}/applications/shotwell-viewer.desktop
  115. %{_datadir}/icons/hicolor/*
  116. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  117. %exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
  118. %changelog
  119. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
  120. - new upstream release
  121. - remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
  122. - change BuildRequires: libgee-devel instead of libgee06-devel
  123. - add BuildRequires: libgee-vala
  124. * Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
  125. - build with libgphoto2 2.5.0-1
  126. * Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
  127. - new upstream release
  128. - changed archive typr to xz
  129. - changed BuildRequires: libgee-devel to libgee06-devel
  130. - changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
  131. gstreamer1-devel and gstreamer1-plugins-base-devel
  132. - added Requires: dconf
  133. - added Patch0,1 from Fedora
  134. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
  135. - rebuild with exiv2-0.23
  136. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
  137. - new upstream release
  138. - dropt Source2
  139. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
  140. - new upstream release
  141. - remove Patch0
  142. - change BuildRequires: gtk3-devel instead of gtk2-devel
  143. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  144. - change BuildRequires: unique3-devel instead of unique-devel
  145. - remove BuildRequires: hal-devel
  146. - add BuildRequires: rest-devel, lcms2-devel
  147. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
  148. - new upstream release
  149. * Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
  150. - new upstream release
  151. * Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
  152. - new upstream release
  153. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  154. - new upstream release
  155. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  156. - add BuildRequires: gstreamer-plugins-base-devel
  157. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  158. - rebuilt with libgexiv2-0.2.2-2
  159. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  160. - new upstream release
  161. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  162. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  163. - update Summary and description
  164. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  165. - add hi-res icons (SOURCE1)
  166. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  167. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  168. - dropt Patch0
  169. - added BuildRequires: LibRaw-static
  170. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  171. - add Patch1 (shotwell-0.8.1-vala.patch)
  172. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  173. - new upstream release
  174. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  175. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  176. - rebuilt with rpm-4.8.1 for pkg-config
  177. - fixed %%changelog in Tue Sep 14 2010
  178. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  179. - new upstream release
  180. - changed source URL
  181. - added Patch0 to work around desktop file incorrect comment
  182. - changed BuildRequires: vala-devel >= 0.9.5
  183. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  184. - new upstream release
  185. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  186. - new upstream release
  187. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  188. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  189. - fixed LIB_DIRS in libraw-config (for lib64)
  190. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  191. - new upstream release
  192. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  193. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  194. - new upstream release
  195. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  196. - new upstream release
  197. - added BuildRequires: libgudev1-devel
  198. - applied new naming policy to spec
  199. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  200. - new upstream release
  201. - proved Japanese description
  202. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  203. - new upstrema release
  204. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  205. - intial build for VineSeed
  206. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  207. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  208. - Update to 0.3.2
  209. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  210. - Version 0.3.0
  211. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  212. - Rebuild against new libgee
  213. * Wed Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  214. - Bring icon cache handling in sync with current guidelines
  215. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  216. - Initial packaging