pango-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620
  1. %define glib2_version 2.38.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.3.9
  4. %define fontconfig_version 2.10.91
  5. %define cairo_version 1.12.2
  6. # biarch support
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. %define _querymodules_suffix %{nil}
  9. %if %{build_compat32}
  10. %define _querymodules_suffix -32
  11. %endif
  12. Summary: System for layout and rendering of internationalized text.
  13. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  14. Name: pango
  15. Version: 1.36.1
  16. Release: 1%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.36/pango-%{version}.tar.xz
  20. URL: http://www.pango.org
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. # We need to prereq this so we can run pango-querymodules
  23. Requires: glib2 >= %{glib2_version}
  24. Requires: freetype2 >= %{freetype2_version}
  25. BuildRequires: libtool >= 1.4.2
  26. BuildRequires: glib2-devel >= %{glib2_version}
  27. BuildRequires: pkgconfig >= %{pkgconfig_version}
  28. BuildRequires: freetype2-devel >= %{freetype2_version}
  29. BuildRequires: fontconfig-devel >= %{fontconfig_version}
  30. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  31. BuildRequires: cairo-devel >= %{cairo_version}
  32. BuildRequires: libSM-devel
  33. BuildRequires: gobject-introspection-devel
  34. BuildRequires: libthai-devel
  35. BuildRequires: harfbuzz-devel
  36. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  37. # Look for pango.modules in an arch-specific directory
  38. Patch0: pango-1.31.2-lib64.patch
  39. Patch1: pango-1.28.1-gobject-introspection.patch
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. Packager: Takemikaduchi
  43. %description
  44. Pango is a system for layout and rendering of internationalized text.
  45. %description -l ja
  46. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  47. %package devel
  48. Summary: System for layout and rendering of internationalized text.
  49. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}
  52. Requires: glib2-devel >= %{glib2_version}
  53. Requires: freetype2-devel >= %{freetype2_version}
  54. Requires: cairo-devel >= %{cairo_version}
  55. Requires: libX11-devel, libXft-devel, libXrender-devel
  56. Requires: harfbuzz-devel
  57. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  58. %description devel
  59. The pango-devel package includes the static libraries, header files,
  60. and developer docs for the pango package.
  61. Install pango-devel if you want to develop programs which will use
  62. pango.
  63. #####################################################################
  64. # compat32
  65. %package -n compat32-%{name}
  66. Summary: System for layout and rendering of internationalized text.
  67. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  68. Group: Development/Libraries
  69. %description -n compat32-%{name}
  70. Pango is a system for layout and rendering of internationalized text.
  71. %description -n compat32-%{name} -l ja
  72. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  73. %package -n compat32-%{name}-devel
  74. Summary: Development files for pango
  75. Summary(ja): pango 用の開発ファイル
  76. Group: Development/Libraries
  77. Requires: compat32-%{name} = %{version}
  78. Requires: %{name}-devel = %{version}
  79. %description -n compat32-%{name}-devel
  80. The pango-devel package includes the static libraries, header files,
  81. and developer docs for the pango package.
  82. %prep
  83. %setup -q -n pango-%{version}
  84. %patch0 -p1 -b .lib64
  85. # %patch1 -p1 -b .gi
  86. %build
  87. ###%configure --with-included-modules=basic-fc
  88. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  89. %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
  90. make %{?_smp_mflags}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make DESTDIR=$RPM_BUILD_ROOT install
  94. # biarch support
  95. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
  96. touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
  97. %if %{build_compat32}
  98. cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
  99. $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
  100. %endif
  101. # remove unpackaged files
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
  104. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
  105. %clean
  106. rm -rf $RPM_BUILD_ROOT
  107. %post
  108. /sbin/ldconfig
  109. %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
  110. %postun -p /sbin/ldconfig
  111. %if %{build_compat32}
  112. %post -n compat32-%{name}
  113. /sbin/ldconfig
  114. %{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
  115. %postun -p /sbin/ldconfig -n compat32-%{name}
  116. %endif
  117. %files
  118. %defattr(-, root, root)
  119. %doc README AUTHORS COPYING NEWS
  120. %doc pango-view/HELLO.txt
  121. #doc README AUTHORS COPYING ChangeLog
  122. #doc examples/HELLO.utf8
  123. %{_bindir}/pango-querymodules
  124. %{_bindir}/pango-view
  125. %{_libdir}/libpango*-*.so.*
  126. %{_libdir}/pango
  127. %{_libdir}/girepository-1.0
  128. %{_mandir}/man*/*
  129. %dir %{_sysconfdir}/pango
  130. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  131. %files devel
  132. %defattr(-, root, root)
  133. %{_libdir}/libpango*.so
  134. %{_includedir}/*
  135. %{_libdir}/pkgconfig/*
  136. %{_datadir}/gtk-doc/*
  137. %{_datadir}/gir-1.0
  138. %if %{build_compat32}
  139. %files -n compat32-%{name}
  140. %defattr(-, root, root)
  141. %{_libdir}/libpango*-*.so.*
  142. %{_bindir}/pango-querymodules%{_querymodules_suffix}
  143. %{_libdir}/pango
  144. %dir %{_sysconfdir}/pango/%{_arch}
  145. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  146. %files -n compat32-%{name}-devel
  147. %defattr(-, root, root)
  148. %{_libdir}/libpango*.so
  149. %endif
  150. %changelog
  151. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
  152. - new upstream release
  153. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
  154. - new upstream release
  155. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
  156. - new upstream release
  157. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  158. - new upstream release
  159. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
  160. - new upstream release
  161. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
  162. - new upstream release
  163. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
  164. - new upstream release
  165. - update Patch0 (pango-1.31.2-lib64.patch)
  166. - add BuildRequires: harfbuzz-devel
  167. * Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  168. - new upstream release
  169. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  170. - new upstream release
  171. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
  172. - add BuildRequires: libthai-devel
  173. * Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
  174. - new upstream release
  175. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
  176. - new upstream release
  177. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
  178. - new upstream release with security fixes (CVE-2011-0020, 0064)
  179. - add Vendor/Distri tags
  180. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  181. - add BuildRequires: libSM-devel, gobject-introspection-devel
  182. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  183. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  184. - build with rpm-4.8.1-1 for pkg-config file
  185. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  186. - new upstream release
  187. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  188. - new upstream release
  189. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  190. - changed %%makeinstall to make install with DESTDIR option
  191. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  192. - new upstream release
  193. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  194. - new upstream release
  195. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  196. - new upstream release
  197. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  198. - new upstream release
  199. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  200. - new upstream release
  201. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  202. - new upstream release
  203. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  204. - removed %%if !%%{build_compat32} case condition
  205. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  206. - new upstream release
  207. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  208. - new upstream release
  209. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  210. - new upstream release
  211. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  212. - new upstream release
  213. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  214. - new upstream release
  215. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  216. - new upstream release
  217. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  218. - new upstream release
  219. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  220. - spec in UTF-8 actually
  221. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  222. - new upstream release
  223. - rebuilt with xorg-x11 7.3
  224. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  225. - new upstream release
  226. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  227. - used %{?_dist_release}
  228. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  229. - new upstream release
  230. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  231. - new upstream release
  232. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  233. - new upstream release
  234. - added Patch0 instead of Patch5
  235. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  236. - replace build with new environment
  237. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  238. - rebuild with new environment
  239. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  240. - new upstream release
  241. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  242. - new upstream release
  243. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  244. - new upstream release
  245. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  246. - new upstream release
  247. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  248. - new upstream release
  249. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  250. - new upstream release
  251. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  252. - rebuild with cairo-1.2.0
  253. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  254. - add Patch10 to create fake style(italic/bold) for all fonts.
  255. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  256. - This patch is not applied in upstream, but it seems usefull
  257. for us.
  258. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  259. - new upstream release
  260. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  261. - new upstream release
  262. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  263. - new upstream release
  264. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  265. - fix broken dependancy
  266. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  267. - new upstream release
  268. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  269. - new upstream release
  270. - add compat32 package for x86_64 arch support
  271. - add Patch5 for biarch support
  272. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  273. - new upstream release
  274. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  275. - new upstream release
  276. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  277. - new upstream release
  278. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  279. - rebuild with cairo-0.9
  280. - add patch10 to disable building example programs
  281. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  282. - new upstream release
  283. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  284. - new upstream release
  285. - drop obsolete patches
  286. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  287. - new upstream release
  288. - import upstream patches from fedora package.
  289. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  290. - new upstream release
  291. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  292. - new upstream release
  293. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  294. - remove unneeded dependancy to freetype2-devel
  295. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  296. - add patch10 to build against freetype-2.1.7
  297. - rebuild with freetype-2.1.7
  298. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  299. - new upstream release
  300. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  301. - new upstream release
  302. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  303. - new upstream release
  304. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  305. - merge patch1,2 from rawhide package.
  306. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  307. - new upstream release
  308. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  309. - new upstream release
  310. - Build for Vine Linux, specfile are based on rawhide release
  311. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  312. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  313. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  314. - explicitly require pangoxft to be built, so we catch situations such
  315. as xft.pc moving to /usr/X11R6
  316. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  317. hack
  318. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  319. - 1.1.3
  320. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  321. - Require the necessary freetype version, don't just
  322. BuildRequires it (#74744)
  323. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  324. - Own /etc/pango (#73962, Enrico Scholz)
  325. - Remove .la files from the build root
  326. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  327. - require glib 2.0.6-3, try rebuild on more arches
  328. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  329. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  330. as in gdmgreeter)
  331. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  332. - Fix linked list manipulation problem that was causing hang for anaconda
  333. - Fix warning from loading mini-fonts with context == NULL
  334. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  335. - Fix major memory leak in the last patch
  336. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  337. - Actually use language tags at the rendering layer (should fix #68211)
  338. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  339. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  340. - Fix bug causing hex boxes to be misrendered
  341. leaving RPATH (#66005)
  342. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  343. fonts with embedded bitmaps (#67851)
  344. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  345. - Make basic-x shaper work with our big-5 fonts
  346. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  347. - New upstream tarball with hooks for change-on-the fly font rendering
  348. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  349. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  350. ABI changes for pango's OpenType code.
  351. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  352. - Add some Korean aliases that the installer wants
  353. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  354. - automated rebuild
  355. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  356. - devel package requires fontconfig/Xft devel packages
  357. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  358. - rebuild in different environment
  359. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  360. - Snapshot with Xft2/fontconfig support
  361. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  362. - Version 1.0.2
  363. - Patch for charmaps problem
  364. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  365. - automated rebuild
  366. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  367. - rebuild in different environment
  368. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  369. - add patch to adjust to newer version of freetype
  370. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  371. - Update to version 1.0.1, remove patch
  372. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  373. - Patch from CVS for big speedup with FreeType-2.0.9
  374. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  375. - Rebuild
  376. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  377. - Version 1.0.0
  378. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  379. - Update to 0.26
  380. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  381. - Bump for rebuild
  382. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  383. - Update to 0.25
  384. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  385. - add horrible buildrequires hack
  386. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  387. - 0.24.90 cvs snap
  388. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  389. - Version 0.24
  390. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  391. - automated rebuild
  392. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  393. - new snap 0.23.90
  394. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  395. - rebuild with 64-bit-fixed glib
  396. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  397. - Version 0.22
  398. - add explicit check for required glib2 version before we do the build,
  399. so we don't end up with bad RPMs on --nodeps builds
  400. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  401. no one had updated recently
  402. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  403. - Version 0.21
  404. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  405. - cvs snap
  406. - new cvs snap with a bugfix
  407. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  408. - sync with Owen's changes, fix up dependency versions
  409. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  410. - 0.19
  411. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  412. - build CVS snap
  413. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  414. - no relinking junk
  415. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  416. - Version 0.18
  417. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  418. - Configure --disable-gtk-doc
  419. - BuildRequires freetype-devel, XFree86-devel
  420. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  421. - 0.17
  422. - libtool hackarounds
  423. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  424. - 0.16, rename back to pango from pango-gtkbeta
  425. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  426. - Obsolete fribidi-gtkbeta
  427. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  428. - Remove that patch I just put in
  429. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  430. - Patch pangox.pc.in to include -Iincludedir
  431. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  432. - final 0.13
  433. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  434. - New 0.13 tarball
  435. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  436. - 0.13pre1
  437. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  438. - Rename to 0.12b to avoid versioning problems
  439. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  440. - Move to a CVS snapshot
  441. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  442. - Move back to /usr
  443. - Version 0.12
  444. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  445. - Add missing %%defattr
  446. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  447. - Rebuild with a prefix of /opt/gtk-beta
  448. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  449. - version 0.11
  450. - add --without-qt
  451. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  452. - Make the devel package require *-gtkbeta-* not the normal packages.
  453. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  454. - GTK+ snapshot version installing in /opt/gtk-beta
  455. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  456. - Created spec file