network-manager-applet-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. %define dbus_version 1.4.20
  2. %define dbus_glib_version 0.96
  3. %define gtk3_version 3.10.0
  4. %define wireless_tools_version 29
  5. %define libnl3_version 3.2.14
  6. %define ppp_version 2.4.5
  7. %define applet_version 0.9.8.8
  8. #define snapshot .git20090414
  9. #define applet_snapshot %{nil}
  10. Name: network-manager-applet
  11. Summary: GNOME applications for use with NetworkManager
  12. Summary(ja): NetworkManager 用 GNOME アプリケーション
  13. Version: 0.9.8.8
  14. Release: 1%{?snapshot}%{?_dist_release}
  15. Group: Applications/Internet
  16. License: GPLv2+
  17. URL: http://www.gnome.org/projects/NetworkManager/
  18. Source: %{name}-%{version}.tar.xz
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. Requires(post): chkconfig
  21. Requires(preun): chkconfig
  22. Requires: libnm-gtk = %{version}-%{release}
  23. Requires: NetworkManager >= %{version}
  24. Requires: dbus
  25. Requires: dbus-glib
  26. Requires: libnotify
  27. Requires: gnome-keyring
  28. Requires: nss
  29. Requires: gnome-icon-theme
  30. Obsoletes: NetworkManager-gnome < 0.9.7.0
  31. Provides: NetworkManager-gnome = 0.9.7.0
  32. BuildRequires: NetworkManager-glib-devel >= %{version}
  33. BuildRequires: ModemManager-glib-devel
  34. BuildRequires: dbus-devel >= %{dbus_version}
  35. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  36. BuildRequires: gtk3-devel
  37. BuildRequires: GConf2-devel
  38. BuildRequires: libgnome-keyring-devel
  39. BuildRequires: gettext
  40. BuildRequires: libnotify-devel >= 0.7
  41. BuildRequires: libgudev1-devel
  42. BuildRequires: libsecret-devel
  43. BuildRequires: iso-codes
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: Takemikaduchi
  47. %description
  48. This package contains GNOME utilities and applications for use with
  49. NetworkManager, including a panel applet for wireless networks.
  50. %package -n libnm-gtk
  51. Summary: Private libraries for NetworkManager GUI support
  52. Group: Development/Libraries
  53. Requires: gtk3 >= %{gtk3_version}
  54. Obsoletes: NetworkManager-gtk < 0.9.7.0
  55. Provides: NetworkManager-gtk = 0.9.7.0
  56. %description -n libnm-gtk
  57. This package contains private libraries to be used only by nm-applet and
  58. the GNOME Control Center.
  59. %package -n libnm-gtk-devel
  60. Summary: Private header files for NetworkManager GUI support
  61. Group: Development/Libraries
  62. Requires: libnm-gtk = %{version}-%{release}
  63. Requires: gtk3-devel
  64. Requires: dbus-glib-devel
  65. Requires: pkgconfig
  66. Obsoletes: NetworkManager-gtk-devel < 0.9.7.0
  67. Provides: NetworkManager-gtk-devel = 0.9.7.0
  68. %description -n libnm-gtk-devel
  69. This package contains private header and pkg-config files to be used only by
  70. nm-applet and the GNOME control center.
  71. %prep
  72. %setup -q
  73. %build
  74. NOCONFIGURE=1 ./autogen.sh
  75. %configure --disable-static
  76. make
  77. %install
  78. %{__rm} -rf $RPM_BUILD_ROOT
  79. # install the applet
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  82. mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-vpn-properties
  83. %find_lang nm-applet
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post
  87. touch --no-create %{_datadir}/icons/hicolor
  88. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  89. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  90. fi
  91. %postun
  92. touch --no-create %{_datadir}/icons/hicolor
  93. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  94. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  95. fi
  96. if [ $1 -eq 0 ]; then
  97. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  98. fi
  99. %posttrans
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %post -n libnm-gtk -p /sbin/ldconfig
  102. %postun -n libnm-gtk -p /sbin/ldconfig
  103. %files -f nm-applet.lang
  104. %defattr(-,root,root,0755)
  105. %{_bindir}/nm-applet
  106. %{_bindir}/nm-connection-editor
  107. %{_libexecdir}/nm-applet-migration-tool
  108. %{_datadir}/applications/*.desktop
  109. %{_datadir}/nm-applet/
  110. %{_datadir}/GConf/gsettings/nm-applet.convert
  111. %{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
  112. %{_datadir}/icons/hicolor/16x16/apps/*.png
  113. %{_datadir}/icons/hicolor/22x22/apps/*.png
  114. %{_datadir}/icons/hicolor/32x32/apps/*.png
  115. %{_datadir}/icons/hicolor/48x48/apps/*.png
  116. %{_datadir}/icons/hicolor/scalable/apps/*.svg
  117. %{_sysconfdir}/xdg/autostart/nm-applet.desktop
  118. %dir %{_datadir}/gnome-vpn-properties
  119. ##%{_libdir}/gnome-bluetooth/plugins/libnma.so
  120. %{_mandir}/man1/nm-applet.1.gz
  121. %{_mandir}/man1/nm-connection-editor.1.gz
  122. %files -n libnm-gtk
  123. %defattr(-,root,root,-)
  124. %{_libdir}/libnm-gtk.so.*
  125. %{_libdir}/girepository-1.0/NMGtk-1.0.typelib
  126. %dir %{_datadir}/libnm-gtk
  127. %{_datadir}/libnm-gtk/*.ui
  128. %files -n libnm-gtk-devel
  129. %defattr(-,root,root,-)
  130. %{_includedir}/libnm-gtk
  131. %{_libdir}/pkgconfig/libnm-gtk.pc
  132. %{_libdir}/libnm-gtk.so
  133. %{_datadir}/gir-1.0/NMGtk-1.0.gir
  134. %changelog
  135. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.8-1
  136. - new upstream release
  137. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.4-1
  138. - new upstream release
  139. - remove Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
  140. - add BuildRequires: ModemManager-glib-devel
  141. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-2
  142. - add Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
  143. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-1
  144. - update to 0.9.8.2
  145. - add BuildRequires: libsecret-devel
  146. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.0-1
  147. - initial package split from NetworkManager