gnumeric-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.10.9
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.12.9
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # default font: VL Gothic
  14. Patch0: gnumeric-1.11.5-vlgothic.patch
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. BuildRequires: bison
  18. BuildRequires: flex
  19. BuildRequires: goffice-devel >= %{goffice_version}
  20. BuildRequires: pygobject3-devel
  21. BuildRequires: perl python-devel
  22. BuildRequires: automake
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: desktop-file-utils
  25. Requires(postun,posttrans): glib2
  26. Requires(post,postun): desktop-file-utils
  27. Obsoletes: %{name}-devel
  28. %description
  29. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  30. applications and desktop tools to be used in conjunction with a window
  31. manager for the X Window System.
  32. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  33. replacement for commercial spreadsheets. It provides import/export from
  34. MS Excel files and many other formats (csv, latex, xbase, applix).
  35. %description -l ja
  36. GNOME (GNU Network Object Model Environment)は
  37. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  38. GUIアプリケーションおよびデスクトップツールのセットです。
  39. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  40. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  41. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  42. を読込み、出力できます.
  43. %prep
  44. %setup -q
  45. %patch0 -p1 -b .vlgothic
  46. %build
  47. %ifarch alpha
  48. MYARCH_FLAGS="--host=alpha-redhat-linux"
  49. %endif
  50. %configure \
  51. --without-gda \
  52. --with-perl \
  53. --with-python
  54. make
  55. %install
  56. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  57. make DESTDIR=$RPM_BUILD_ROOT install
  58. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  59. desktop-file-install --vendor gnome --delete-original \
  60. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  61. --add-category Office \
  62. --add-category Application \
  63. --add-category Spreadsheet \
  64. --remove-mime-type="zz-application/zz-winassoc-xls" \
  65. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  66. %find_lang %{name}-%{version}
  67. %find_lang %{name}-%{version}-functions
  68. cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
  69. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  70. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  71. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
  72. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  73. %clean
  74. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. scrollkeeper-update > /dev/null 2>&1 || :
  78. touch --no-create %{_datadir}/icons/hicolor || :
  79. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  80. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  81. fi
  82. update-desktop-database -q &> /dev/null || :
  83. %postun
  84. /sbin/ldconfig
  85. scrollkeeper-update > /dev/null 2>&1 || :
  86. touch --no-create %{_datadir}/icons/hicolor || :
  87. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  88. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  89. fi
  90. update-desktop-database -q &> /dev/null || :
  91. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  92. %posttrans
  93. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  94. %files -f %{name}-%{version}.lang
  95. %defattr (-, root, root)
  96. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  97. %{_bindir}/*
  98. %{_libdir}/libspreadsheet*.so
  99. %{_libdir}/%{name}
  100. %{_libdir}/goffice/0.10/plugins/%{name}
  101. %{_datadir}/appdata/gnumeric.appdata.xml
  102. %{_datadir}/applications/*.desktop
  103. %{_datadir}/glib-2.0/schemas/*.xml
  104. %{_datadir}/gnome/help/%{name}
  105. %{_datadir}/%{name}
  106. %{_datadir}/pixmaps/*
  107. %{_datadir}/omf/*
  108. %{_datadir}/icons/hicolor/*
  109. %{_mandir}/man*/*
  110. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  111. %changelog
  112. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
  113. - new upstream release
  114. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
  115. - new upstream release
  116. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
  117. - new upstream release
  118. * Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
  119. - new upstream release
  120. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
  121. - new upstream release
  122. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  123. - new upstream release
  124. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  125. - new upstream release
  126. * Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  127. - new upstream release
  128. * Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  129. - new upstream release
  130. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
  131. - new upstream release
  132. - add Patch0 (gnumeric-1.11.5-vlgothic.patch)
  133. - remove Patch1 (gnumeric-1.10.17-libgsf.patch)
  134. * Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
  135. - rebuild with libgsf-1.14.22
  136. - add Patch1 (gnumeric-1.10.17-libgsf.patch)
  137. * Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
  138. - new upstream release
  139. - update Patch0
  140. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
  141. - new upstream release
  142. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
  143. - new upstream release
  144. - add Patch0 (gnumeric-1.10.13-vlgothic.patch)
  145. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
  146. - new upstream release
  147. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
  148. - new upstream release
  149. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
  150. - new upstream release
  151. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  152. - new upstream release
  153. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  154. (fix error of MIME type)
  155. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  156. - new upstream release
  157. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  158. - new upstream release
  159. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  160. - new upstream release
  161. - fix %post and %postun
  162. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  163. - new upstream release
  164. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  165. - new upstream release
  166. - add BuildRequires: libSM-devel
  167. - fix BuildRequires: goffice-devel >= 0.8.1
  168. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  169. - spec in UTF-8 (fixed)
  170. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  171. - spec in UTF-8
  172. - added BuildRequires: libffi-devel
  173. - added %%pre, %%preun section
  174. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  175. - new upstream release
  176. - built with libgda-3.1.4, libgnomedb-3.1.2
  177. - applied new versioning policy
  178. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  179. - new upstream release
  180. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  181. - rebuild
  182. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  183. - new upstream release
  184. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  185. - new upstream release
  186. - updated build dependancies
  187. - rebuilt with libgsf-1.14.0
  188. - built with libgda and libgnomedb again
  189. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  190. - new upstream release
  191. - updated build dependancies
  192. - not compile with libgda and libgnomedb in this version
  193. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  194. - new upstream release
  195. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  196. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  197. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  198. - new upstream release
  199. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  200. - new upstream release
  201. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  202. - new upstream release
  203. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  204. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  205. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  206. - new upstream release
  207. - added BuildRequires: desktop-file-utils
  208. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  209. - new upstream release
  210. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  211. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  212. - new upstream release
  213. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  214. - new upstream release
  215. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  216. - new upstream release
  217. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  218. - new upstream release
  219. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  220. - new upstream release
  221. - clean up spec file (a little bit!)
  222. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  223. - new upstream release
  224. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  225. - new upstream release
  226. - to use intltool-0.28
  227. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  228. - new upstream release
  229. - rebuild with new toolchains
  230. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  231. - new upstream release
  232. - build with new libgnomeprint, libgnomeprintui
  233. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  234. - new upstream release
  235. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  236. - rebuild with newer libgda, libgnomedb
  237. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  238. - updated to 1.2.0 (stable release)
  239. - guile support is temporarily off this version.
  240. * Tue Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  241. - update to 1.1.20 (gtk+-2 port)
  242. - based on Redhat Rawhide 1.1.20-1
  243. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  244. - update to 1.0.13
  245. - rebuild with gal 0.24
  246. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  247. - guile support on
  248. - rebuild with new gal, bonobo, libgda
  249. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  250. - New upstream release, remove xmliobackward.patch
  251. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  252. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  253. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  254. - New upstream release, fix for xml importing files with non ASCII characters.
  255. - Without guile, changelog.archive, requires, build scripts, description
  256. * Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  257. - files: add gnumericConf.sh, which was missing
  258. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  259. - New upstream release.
  260. - BuildPrereq oaf-devel
  261. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  262. - New upstream release.
  263. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  264. - New upstream release.
  265. - Default font and Japanese fonts in excel
  266. - requires
  267. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  268. - New upstream release.
  269. - fixed plugins, apply patch2, remove patch3
  270. - files - no longer devel package
  271. - function-reference.html in help file
  272. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  273. - New upstream release.
  274. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  275. - New upstream release.
  276. - Fixed several owner dir.
  277. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  278. - Build against with new gal
  279. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  280. - New upstream release.
  281. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  282. - New upstream release.
  283. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  284. - New upstream release.
  285. - Applied XIM over-the-spot patch.
  286. - Fixed directories owner.
  287. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  288. - New upstream release.
  289. - Enable Bonobo.
  290. - Merged several RH patches.
  291. - Added BuildPreReq tags.
  292. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  293. - Fixed packaging mistake.
  294. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  295. - Rebuild for GAL 0.7
  296. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  297. - New upstream release.
  298. - Use rpmmacros.
  299. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  300. - 0.56-0vl2
  301. - update ja.po
  302. - avoid core dump when inserting a row
  303. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  304. - updated to 0.56
  305. - remake spec with the orginal gnumeric spec file.
  306. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  307. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  308. - updated to 0.53
  309. - remake SPEC based on gnumeric original.
  310. - added libxml183 patch for libxml 1.8.3
  311. * Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  312. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  313. - Added --without-bonobo and --without-gb.
  314. - Added %define for sysconfdir
  315. * Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  316. - Updated version requirements for gnome-print, and gnome-libs.
  317. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  318. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  319. * Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  320. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  321. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  322. - Updated to 0.47
  323. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  324. - Updated the libglade dependancy.
  325. - Remove req for guile. We can build without it.
  326. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  327. - Added small fix so glade generated dialogs appear.
  328. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  329. - Added the gnome-print requirement.
  330. - Updated the file list to try and quiet down the updating.
  331. - added the sysconfdir
  332. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  333. - Updated the spec file.
  334. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  335. - Version 0.2