gnome-shell-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. %define pkg_version 3.10.2.1
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. License: GPLv2+
  11. Group: User Interface/Desktops
  12. URL: http://live.gnome.org/GnomeShell
  13. Requires: mutter
  14. Requires: caribou
  15. Requires: ca-certificates
  16. Requires: at-spi2-atk
  17. Requires: telepathy-logger
  18. Requires: network-manager-applet
  19. Requires: gnome-tweak-tool
  20. BuildRequires: gnome-common
  21. BuildRequires: libtool
  22. BuildRequires: automake
  23. BuildRequires: autoconf
  24. BuildRequires: pkgconfig
  25. BuildRequires: gtk2-devel
  26. BuildRequires: clutter-devel
  27. BuildRequires: mutter-devel
  28. BuildRequires: gjs-devel
  29. BuildRequires: gnome-desktop3-devel
  30. BuildRequires: gnome-menus-devel
  31. BuildRequires: libSM-devel
  32. BuildRequires: libffi-devel
  33. BuildRequires: startup-notification-devel
  34. BuildRequires: gnome-doc-utils
  35. BuildRequires: desktop-file-utils
  36. BuildRequires: libcroco-devel
  37. BuildRequires: librsvg2-devel
  38. BuildRequires: gobject-introspection-devel
  39. BuildRequires: control-center-devel
  40. BuildRequires: gcr-devel
  41. BuildRequires: gstreamer-devel
  42. BuildRequires: dbus-glib-devel
  43. BuildRequires: telepathy-logger-devel
  44. BuildRequires: polkit-devel
  45. BuildRequires: pulseaudio-libs-devel
  46. BuildRequires: evolution-data-server-devel
  47. BuildRequires: folks-devel
  48. BuildRequires: NetworkManager-glib-devel
  49. BuildRequires: libnm-gtk-devel
  50. BuildRequires: libgudev1-devel
  51. BuildRequires: libcanberra-gtk3-devel
  52. BuildRequires: caribou-devel
  53. BuildRequires: ca-certificates
  54. BuildRequires: intltool
  55. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  56. Vendor: Project Vine
  57. Distribution: Vine Linux
  58. Packager: Takemikaduchi
  59. %description
  60. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  61. It provides core interface functions like switching to windows and launching
  62. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  63. hardware and introduces innovative user interface concepts to provide a delightful
  64. and easy to use experience.
  65. %package docs
  66. Summary: Documentation for %{name}
  67. Summary(ja): %{name} 用のドキュメント
  68. Group: Documentation
  69. Requires: %{name} = %{version}-%{release}
  70. BuildArch: noarch
  71. %description docs
  72. This package contains documentation for %{name}.
  73. %prep
  74. %setup -q
  75. %patch101 -p1 -b .vine
  76. %build
  77. autoreconf -if
  78. %configure \
  79. --disable-static
  80. %{__make} %{?_smp_mflags}
  81. %install
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  84. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  85. %find_lang %{name}
  86. %clean
  87. %{__rm} -rf ${RPM_BUILD_ROOT}
  88. %post
  89. /sbin/ldconfig
  90. touch --no-create %{_datadir}/icons/hicolor
  91. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  92. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  93. fi
  94. %postun
  95. /sbin/ldconfig
  96. touch --no-create %{_datadir}/icons/hicolor
  97. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  98. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  99. fi
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %posttrans
  102. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  103. %files -f %{name}.lang
  104. %defattr(-,root,root,-)
  105. %doc COPYING NEWS README
  106. %{_bindir}/gnome-shell
  107. %{_bindir}/gnome-shell-extension-tool
  108. %{_bindir}/gnome-shell-extension-prefs
  109. %{_bindir}/gnome-shell-perf-tool
  110. %{_libdir}/%{name}/*
  111. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  112. %{_libexecdir}/gnome-shell-calendar-server
  113. %{_libexecdir}/gnome-shell-hotplug-sniffer
  114. %{_libexecdir}/gnome-shell-perf-helper
  115. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  116. %{_datadir}/applications/gnome-shell.desktop
  117. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  118. %{_datadir}/applications/evolution-calendar.desktop
  119. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  120. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  121. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  122. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  123. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  124. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  125. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  126. %{_datadir}/%{name}/*
  127. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  128. %{_mandir}/man1/%{name}.1.gz
  129. %files docs
  130. %defattr(-,root,root,-)
  131. %{_datadir}/gtk-doc/html/shell
  132. %{_datadir}/gtk-doc/html/st
  133. %changelog
  134. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  135. - new upstream release
  136. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  137. - new upstream release
  138. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  139. - new upstream release
  140. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  141. - new upstream release
  142. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  143. - new upstream release
  144. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  145. - new upstream release
  146. - update Patch101 (gnome-shell-vine-settings.patch)
  147. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  148. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  149. - create %%{name}-docs subpackage
  150. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  151. - new upstream release
  152. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  153. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  154. - new upstream release
  155. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  156. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  157. - new upstream release
  158. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  159. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  160. - rebuild with telepathy-logger-0.6.0
  161. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  162. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  163. - new upstream release
  164. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  165. - new upstream release
  166. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  167. - update Patch101 (gnome-shell-vine-settings.patch)
  168. - change BuildRequires: ca-certificates instead of openssl
  169. - add BuildRequires: libcanberra-gtl3-devel
  170. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  171. - new upstream release
  172. - remove Patch103 (gnome-shell-ja.po-date.patch)
  173. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  174. - new upstream release
  175. - update Patch101,103
  176. - remove Patch0,102
  177. - add BuildRequires: gcr-devel
  178. - remove BuildRequires: GConf2-devel
  179. - add Requires: at-spi2-atk
  180. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  181. - new upstream release
  182. - remove Patch1
  183. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  184. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  185. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  186. - rename Patch103 (gnome-shell-ja.po-date.patch)
  187. - drop Patch102
  188. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  189. - new upstream release
  190. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  191. - new upstream release
  192. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  193. - new upstream release
  194. - update Patch101
  195. - update Patch102
  196. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  197. - add BuildRequires: libgudev1-devel, openssl
  198. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  199. - new upstream release
  200. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  201. - add Requires: caribou
  202. - remove Patch0
  203. - update Patch101
  204. - update Patch102
  205. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  206. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  207. - rebuild with gnome-menus-3.1.5
  208. - add Patch0 (gnome-shell-git20110821.patch)
  209. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  210. - new upstream release
  211. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  212. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  213. - remove BuildRequires: xulrunner-devel
  214. - add Patch101 (gnome-shell-vine-settings.patch)
  215. - add Patch102 (gnome-shell-vine-customize.patch)
  216. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  217. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  218. - add Requires: mutter
  219. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  220. - new upstream release
  221. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  222. - initial build for Vine Linux