avidemux-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419
  1. %define _pkgbuilddir %{_builddir}/%{name}_%{version}
  2. Name: avidemux
  3. Version: 2.5.2
  4. Release: 4%{?_dist_release}
  5. Summary: Graphical video editing and transcoding tool
  6. Group: Applications/Multimedia
  7. License: GPLv2+
  8. URL: http://www.avidemux.org/
  9. Source0: http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
  10. Source1: %{name}-gtk.desktop
  11. Source2: %{name}-qt.desktop
  12. # Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
  13. # http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
  14. Patch0: 2.5.0-coreImage-parallel-build.patch
  15. Patch1: avidemux-2.5-pulseaudio-default.patch
  16. Patch2: avidemux-2.4-qt4.patch
  17. Patch3: avidemux-2.5-i18n.patch
  18. Patch4: avidemux-2.5-libmpeg2enc-altivec.patch
  19. Patch5: avidemux-2.5-checkfunction-includes.patch
  20. Patch6: avidemux-2.5.1-tmplinktarget.patch
  21. Patch7: avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch
  22. ## Vine customization patches
  23. Patch10: avidemux-2.4.3-alsa-device-default.patch
  24. Patch11: avidemux-2.5.2-no-qt4-ui.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. Requires: %{name}-cli = %{version}
  27. Requires: %{name}-gui = %{version}
  28. Obsoletes: %{name}-qt < 2.5.0
  29. # *-devel pacages provided by other self-build-* should only be listed
  30. # in self-build-%{name}.spec as PreReq.
  31. # Compiling
  32. BuildRequires: cmake
  33. #BuildRequires: gettext-devel
  34. BuildRequires: gettext
  35. # Libraries
  36. BuildRequires: nasm >= 0.98.38
  37. BuildRequires: libxml2-devel >= 2.6.8
  38. BuildRequires: fontconfig-devel
  39. #BuildRequires: freetype-devel
  40. BuildRequires: freetype2-devel
  41. BuildRequires: js-devel
  42. BuildRequires: libXv-devel
  43. BuildRequires: libXmu-devel
  44. # Required by gtk: libXi-devel, libXext-devel, libX11-devel
  45. # Required by qt: libXt-devel, libXext-devel, libX11-devel
  46. BuildRequires: libsamplerate-devel
  47. BuildRequires: jack-audio-connection-kit-devel
  48. # Sound out
  49. BuildRequires: alsa-lib-devel >= 1.0.3
  50. BuildRequires: esound-devel >= 0.2.0
  51. BuildRequires: pulseaudio-libs-devel
  52. # Video out
  53. BuildRequires: SDL-devel >= 1.2.7
  54. # Audio Codecs
  55. #BuildRequires: a52dec-devel >= 0.7.4
  56. #BuildRequires: faac-devel >= 1.24
  57. #BuildRequires: faad2-devel >= 2.0
  58. #BuildRequires: lame-devel >= 3.96.1
  59. #BuildRequires: libmad-devel >= 0.15.1
  60. BuildRequires: libogg-devel >= 1.1
  61. BuildRequires: libvorbis-devel >= 1.0.1
  62. # BuildRequires: self-build-a52dec >= 0.7.4
  63. # BuildRequires: self-build-faac >= 1.24
  64. # BuildRequires: self-build-faad2 >= 2.0
  65. # BuildRequires: self-build-lame >= 3.96.1
  66. # BuildRequires: self-build-libmad >= 0.15.1
  67. #BuildRequires: libdca-devel
  68. # BuildRequires: self-build-libdca
  69. # Video Codecs
  70. #BuildRequires: xvidcore-devel >= 1.0.2
  71. #BuildRequires: x264-devel
  72. #BuildRequires: ffmpeg-devel
  73. # BuildRequires: self-build-xvidcore >= 1.0.2
  74. # BuildRequires: self-build-x264
  75. # BuildRequires: self-build-ffmpeg
  76. # FIXME: aften not packaged, add BR when it is
  77. # Finally...
  78. BuildRequires: desktop-file-utils
  79. %description
  80. Avidemux is a free video editor designed for simple cutting, filtering and
  81. encoding tasks. It supports many file types, including AVI, DVD compatible
  82. MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
  83. using projects, job queue and powerful scripting capabilities.
  84. For compatability reasons, avidemux is a meta-package which installs the
  85. graphical, command line and plugin packages. If you want a smaller setup,
  86. you may selectively install one or more of the avidemux-* subpackages.
  87. %package cli
  88. Summary: CLI for %{name}
  89. Group: Applications/Multimedia
  90. Requires: %{name} = %{version}-%{release}
  91. %description cli
  92. This package provides a command-line interface to editing videos with %{name}.
  93. %package gtk
  94. Summary: GTK interface for %{name}
  95. Group: Applications/Multimedia
  96. BuildRequires: gtk2-devel >= 2.8.0
  97. BuildRequires: cairo-devel
  98. # Slightly higher so it is default, but it can be avoided by installing
  99. # avidemux-qt directly or it can be removed later once avidemux-qt is installed
  100. Provides: %{name}-gui = %{version}-%{release}.1
  101. Requires: %{name} = %{version}-%{release}
  102. %description gtk
  103. This package provides the GTK graphical interface for %{name}.
  104. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  105. %package qt
  106. Summary: Qt interface for %{name}
  107. Group: Applications/Multimedia
  108. # 4.5.0-9 fixes a failure when there are duplicate translated strings
  109. # https://bugzilla.redhat.com/show_bug.cgi?id=491514
  110. BuildRequires: qt4-devel >= 4.5.0-9
  111. BuildRequires: qt4-designer
  112. Provides: %{name}-gui = %{version}-%{release}
  113. Requires: %{name} = %{version}-%{release}
  114. %description qt
  115. This package contains the Qt graphical interface for %{name}.
  116. %endif
  117. %package devel
  118. Summary: Development files for %{name}
  119. Group: Development/Libraries
  120. Requires: %{name} = %{version}-%{release}
  121. %description devel
  122. This package contains files required to develop with or extend %{name}.
  123. %prep
  124. %__rm -rf $RPM_BUILD_ROOT
  125. %setup -q -n avidemux_%{version}
  126. # change hardcoded libdir paths
  127. %ifarch x86_64 ppc64
  128. %__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
  129. %__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
  130. %endif
  131. %patch0 -p1 -b .parallel
  132. %patch1 -p1 -b .pulse
  133. #%patch2 -p1 -b .qt4
  134. %patch3 -p1 -b .i18n
  135. %patch4 -p1 -b .altivec
  136. %patch5 -p1 -b .cfincludes
  137. #%patch6 -p1 -b .tmplinktarget
  138. %patch7 -p1 -b .blind
  139. #%patch10 -p1 -b .alsa
  140. %{!?with_qt_ui:%patch11 -p1 -b .qt4}
  141. %build
  142. # Out of source build
  143. %__mkdir_p build && cd build
  144. %cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
  145. -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
  146. -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
  147. ..
  148. %__make %{?_smp_mflags}
  149. # Create the temp link directory manuall since otherwise it happens too early
  150. %__mkdir_p %{_pkgbuilddir}/build/%{_lib}
  151. find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
  152. xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
  153. %__mkdir_p ../build_plugins && cd ../build_plugins
  154. %cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
  155. -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
  156. -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
  157. ../plugins
  158. %__make %{?_smp_mflags}
  159. %install
  160. %__rm -rf $RPM_BUILD_ROOT
  161. # Temporary workaround since the i18n files aren't being built
  162. %__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/%{name}
  163. %__make -C build install DESTDIR=$RPM_BUILD_ROOT
  164. %__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
  165. # Install the build configuration for devel package
  166. %__install -d -m755 $RPM_BUILD_ROOT%{_includedir}
  167. %__install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
  168. # Find and remove all la files
  169. find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
  170. # Install .desktop shortcuts
  171. desktop-file-install --vendor vine \
  172. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  173. %{SOURCE1}
  174. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  175. desktop-file-install --vendor vine \
  176. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  177. %{SOURCE2}
  178. %endif
  179. find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
  180. %find_lang %{name}
  181. %clean
  182. %__rm -rf $RPM_BUILD_ROOT
  183. %post -p /sbin/ldconfig
  184. %postun -p /sbin/ldconfig
  185. %files -f %{name}.lang
  186. %defattr(-,root,root,-)
  187. %doc AUTHORS COPYING README TODO
  188. %{_datadir}/%{name}/
  189. %{_datadir}/ADM_scripts/
  190. %{_libdir}/libADM*
  191. %{_libdir}/ADM_plugins/
  192. %files cli
  193. %defattr(-,root,root,-)
  194. %{_bindir}/avidemux2_cli
  195. %files gtk
  196. %defattr(-,root,root,-)
  197. %{_bindir}/avidemux2_gtk
  198. %{_datadir}/applications/*gtk*.desktop
  199. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  200. %files qt
  201. %defattr(-,root,root,-)
  202. #{_datadir}/%{name}/i18n/
  203. %{_bindir}/avidemux2_qt4
  204. %{_datadir}/applications/*qt*.desktop
  205. %endif
  206. %files devel
  207. %defattr(-,root,root,-)
  208. %{_includedir}/ADM_coreConfig.h
  209. %changelog
  210. * Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
  211. - add Patch7 (avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch)
  212. * Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
  213. - unapply avidemux-2.4-qt4.patch
  214. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
  215. - change release to sync with self-build-avidemux
  216. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
  217. - new upstream release
  218. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
  219. - new upstream release
  220. - update patches accordingly
  221. - build with x264 >= 0.0.0-9.20090522
  222. - dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
  223. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
  224. - corrected release number
  225. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
  226. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  227. - changed to PreReq: self-build-libmad >= 0.15.1 from libmad-devel
  228. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
  229. - change release to sync with self-build-avidemux
  230. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
  231. - added avidemux-x264.patch from Gentoo
  232. * Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
  233. - applied avidemux-2.4.3-alsa-device-default.patch
  234. * Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
  235. - initial build based on RPM Fusion of Fedora package
  236. - changed to BuildRequires: gettext from gettext-devel
  237. - added BuildRequires: qt4-designer for gtk subpackage
  238. - dropped avidemux-2.4.3-qt4.patch
  239. * Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
  240. - Add CMake patch for PPC64
  241. - Update patches for 2.4.3
  242. - Remove outdated libmad patch (Nov. 2007)
  243. * Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
  244. - Add another patch to fix ppc64 build (pointer type), first
  245. patch was for libmad
  246. * Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
  247. - Add patch to fix ppc64 build
  248. * Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
  249. - retag
  250. * Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
  251. - Update to 2.4.3
  252. * Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
  253. - ppc64 uint_32 fun
  254. * Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
  255. - rebuild
  256. * Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
  257. - Update to 2.4.2
  258. * Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
  259. - Disable --new-faad
  260. - 20080521 subversion snapshot
  261. * Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
  262. - Disable %%{?_smp_mflags}
  263. * Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
  264. - Update to 2.4.1
  265. - Don't list the bin files twice, revisited
  266. - Default to GTK frontend
  267. * Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
  268. - Make pulseaudio default for sound out
  269. - Don't list the bin files twice
  270. - Don't build with arts support
  271. * Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
  272. - Don't list the .desktop files twice (bz#1870)
  273. - Oops, we should have %%{svndate}svn in release tag!
  274. * Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
  275. - F-8/F-7 x86_64 does seem to need --with-newfaad
  276. * Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
  277. - Update to version 2.4 (20080126svn) and include fixes from devel branch
  278. * Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
  279. - Fix many copy/paste errors and desktop file's Exec field
  280. * Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
  281. - Update to 2.4 final
  282. - Split up desktop files and make them pass desktop-file-validate
  283. - Add structure to split into gtk and qt pacakges
  284. - Disable qt4 for now, doesn't compile
  285. * Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
  286. - move js-include to a place where it is honored
  287. * Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
  288. - Fix macro problem
  289. - Fix changelog date
  290. - Rebuild with faad, but don't pass --newfaad
  291. * Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
  292. - Rebuild with no faad
  293. * Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
  294. - Rebuild for ffmpeg dependency problems
  295. - Update License: tag per Fedora guidelines
  296. * Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
  297. - more features with new BR's: x264-devel libXv-devel
  298. - make a note regarding the libdca-devel problem
  299. - remove the "0:" from the versioned BR's
  300. * Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
  301. - don't use smp_mflags during make for now
  302. * Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
  303. - Update to 2.3.0 Final
  304. - Use find_lang
  305. * Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
  306. - Update to 2.1.2
  307. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  308. - switch to new release field
  309. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  310. - add dist
  311. * Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
  312. - Update to 2.1.0
  313. - Drop epoch
  314. - gtk 2.6 now, so drop FC3 support
  315. * Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
  316. - Remove bogus BR ffmpeg-devel (#555)
  317. * Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
  318. - Add missing BR desktop-file-utils (thanks to ixs)
  319. * Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
  320. - Update to 2.0.42
  321. * Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
  322. - Update to 2.0.34
  323. - Rename package to avidemux -- no need for avidemux2 afaics
  324. * Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
  325. - Update to 2.0.34-test1
  326. - BR gettext, libtool
  327. * Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
  328. - Initial RPM release.