qyoto-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
  2. %global monodir /usr/lib/mono
  3. Name: qyoto
  4. Summary: .NET/Mono bindings for the Qt libraries
  5. Summary(ja): Qt ライブラリの .NET/Mono バインディング
  6. Version: 4.14.2
  7. Release: 1%{?_dist_release}
  8. # libqyoto LGPLv2+, mono bindings GPLv2+
  9. License: LGPLv2+ and GPLv2+
  10. Group: System Environment/Libraries
  11. URL: http://techbase.kde.org/Development/Languages/Qyoto
  12. Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake
  15. BuildRequires: mono-devel
  16. BuildRequires: phonon-devel
  17. BuildRequires: qimageblitz-devel
  18. BuildRequires: qt4-devel
  19. #BuildRequires: pkgconfig(QtWebKit)
  20. BuildRequires: qscintilla-devel
  21. BuildRequires: qwt-qt4-devel
  22. BuildRequires: smokeqt-devel >= %{version}
  23. BuildRequires: sqlite3-devel
  24. # common name some other distros use
  25. Provides: mono-qt = %{version}-%{release}
  26. Requires: qt4 >= %{_qt4_version}
  27. Requires: smokeqt >= %{version}
  28. %{?mono_arches:ExclusiveArch: %{mono_arches}}
  29. %description
  30. %{summary}.
  31. %package devel
  32. Summary: Development libraries for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Provides: mono-qt-devel = %{version}-%{release}
  37. %description devel
  38. This package contains development files for the .NET/Mono bindings
  39. for the Qt libraries.
  40. %prep
  41. %setup -q
  42. %build
  43. mkdir -p %{_target_platform}
  44. pushd %{_target_platform}
  45. %cmake \
  46. -DCMAKE_BUILD_TYPE=release \
  47. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  48. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  49. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  50. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  51. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  52. ..
  53. popd
  54. make %{?_smp_mflags} -C %{_target_platform}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  58. %post -p /sbin/ldconfig
  59. %postun -p /sbin/ldconfig
  60. %clean
  61. rm -rf $RPM_BUILD_ROOT
  62. %files
  63. %doc AUTHORS COPYING README
  64. # LGPLv2+
  65. %{_libdir}/libqyoto.so.2*
  66. # bindings GPLv2+
  67. %{_libdir}/libqtscript-sharp.so
  68. %{_libdir}/libphonon-sharp.so
  69. %{_libdir}/libqttest-sharp.so
  70. %{_libdir}/libqtuitools-sharp.so
  71. %{_libdir}/libqtwebkit-sharp.so
  72. %{_libdir}/libqscintilla-sharp.so
  73. %{monodir}/gac/qt-dotnet/
  74. %{monodir}/gac/qtscript/
  75. %{monodir}/gac/qttest/
  76. %{monodir}/gac/qtuitools/
  77. %{monodir}/gac/qtwebkit/
  78. %{monodir}/gac/phonon/
  79. %{monodir}/gac/qscintilla/
  80. %{monodir}/qyoto/
  81. %dir %{_datadir}/qyoto/
  82. %{_datadir}/qyoto/key.snk
  83. %files devel
  84. %{_bindir}/csrcc
  85. %{_bindir}/uics
  86. %{_includedir}/qyoto/
  87. %{_libdir}/pkgconfig/qyoto.pc
  88. %{_libdir}/pkgconfig/qtwebkit-sharp.pc
  89. %{_libdir}/pkgconfig/qttest-sharp.pc
  90. %{_libdir}/pkgconfig/qtuitools-sharp.pc
  91. %{_libdir}/pkgconfig/qtscript-sharp.pc
  92. %{_libdir}/libqyoto.so
  93. %{_datadir}/qyoto/cmake/
  94. %changelog
  95. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
  96. - splitted from kdebindings
  97. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  98. - new upstream release
  99. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  100. - updated to 4.6.1
  101. - added BR: kdesdk-devel
  102. - disabled attica plugins temporaly
  103. - rebuilt with mono-2.10.1
  104. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  105. - rebuilt with rpm-4.8.1 for pkg-config
  106. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  107. - new upstream release
  108. - added Patch50
  109. - added more japanese summaries
  110. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  111. - new upstream release
  112. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  113. - new upstream release
  114. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  115. - new upstream release
  116. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  117. - new upstream release
  118. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  119. - new upstream release
  120. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  121. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  122. - built with new toolchain
  123. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  124. - new upstream release
  125. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  126. - merged 4.3.1-2 %changelog
  127. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  128. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  129. - use %%{_prefix}/lib for mono-dll (for x86_64)
  130. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  131. - new upstream release
  132. - built with PyQt4-4.6
  133. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  134. - define %%{mono_dir} to specify mono library install path
  135. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  136. - new upstream release
  137. - fixed ruby modules installation path
  138. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  139. - new upstream release
  140. - spilt sub package based on Fedora
  141. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  142. - applied new versioning policy
  143. - added Patch1
  144. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  145. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  146. - added --with-qt-libraries option
  147. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  148. - rebuild for VineSeed
  149. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  150. - new upstream release
  151. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  152. - rebuild for VineSeed
  153. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  154. - new upstream release
  155. - update Patch0
  156. - drop Patch1
  157. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  158. - new upstream release
  159. - add Patch1
  160. - add --enable-libsuffix option
  161. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  162. - rebuild for VineSeed
  163. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  164. - new upstream release
  165. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  166. - rebuild for VineSeed
  167. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  168. - new upstream release
  169. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  170. - rebuild for VineSeed
  171. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  172. - new upstream release
  173. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  174. - rebuild for VineSeed
  175. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  176. - new upstream release
  177. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  178. - rebuild for VineSeed
  179. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  180. - new upstream release
  181. - renew BuildPrereq and build section
  182. - renew %%files
  183. - enable python
  184. - change spec to make main and devel package
  185. - add BuildPrereq: ruby ruby-devel
  186. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  187. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  188. - build for VineSeed
  189. - disable python and mozilla
  190. - objprelink (i386 only)
  191. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  192. - 2.2.2
  193. - build kmozilla binding only on x86/alpha
  194. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  195. - Make sure %%{name}-kmozilla isn't built on ia64
  196. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  197. - Move python bindings to separate package
  198. - Add perl bindings
  199. - Shut up rpmlint
  200. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  201. - 2.1
  202. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  203. - initial RPM