perl-File-Copy-Recursive-vl.spec 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define pkgname File-Copy-Recursive
  2. # Basic Information
  3. Summary: Perl extension for recursively copying files and directories
  4. Summary(ja): 再帰的にファイルおよびディレクトリをコピーする Perl 拡張
  5. Name: perl-%{pkgname}
  6. Version: 0.45
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: yasumichi
  12. License: Artistic or GPL
  13. URL: https://metacpan.org/release/File-Copy-Recursive
  14. Source0: https://cpan.metacpan.org/modules/by-module/File/File-Copy-Recursive-%{version}.tar.gz
  15. BuildArch: noarch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. # Dependency
  18. BuildRequires: perl >= 2:5.34.0
  19. BuildRequires: perl(Carp)
  20. BuildRequires: perl(Cwd)
  21. BuildRequires: perl(Exporter)
  22. BuildRequires: perl(ExtUtils::MakeMaker)
  23. BuildRequires: perl(File::Copy)
  24. BuildRequires: perl(File::Glob)
  25. BuildRequires: perl(File::Spec)
  26. BuildRequires: perl(File::Temp)
  27. BuildRequires: perl(Path::Tiny)
  28. BuildRequires: perl(strict)
  29. BuildRequires: perl(vars)
  30. BuildRequires: perl(warnings)
  31. BuildRequires: perl(Test::Deep)
  32. BuildRequires: perl(Test::Exception)
  33. BuildRequires: perl(Test::Fatal)
  34. BuildRequires: perl(Test::File)
  35. BuildRequires: perl(Test::More)
  36. BuildRequires: perl(Test::Warnings)
  37. Requires: perl >= 2:5.34.0
  38. # rpm's perl dep generators fails to catch this
  39. Requires: perl(File::Glob)
  40. %description
  41. This module copies and moves directories recursively (or single files,
  42. well... singley) to an optional depth and attempts to preserve each file or
  43. directory's mode.
  44. %description -l ja
  45. このモジュールは、ディレクトリ(あるいは、単一のファイル)をオプションにより深
  46. さを考慮し、各ファイルおよびディレクトリのモードを保ちながら、再帰的にコピー
  47. または移動します。
  48. %prep
  49. %setup -q -n File-Copy-Recursive-%{version}
  50. %build
  51. %{__perl} Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
  52. %{__make} %{?_smp_mflags}
  53. %install
  54. %{__make} pure_install DESTDIR=%{buildroot}
  55. chmod -R u+w %{buildroot}/*
  56. %check
  57. %{__make} test
  58. %clean
  59. %{__rm} -rf ${RPM_BUILD_ROOT}
  60. %files
  61. %doc Changes README
  62. %{perl_vendorlib}/File
  63. %{_mandir}/man3/*
  64. %changelog
  65. * Sat Nov 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.45-1
  66. - new upstream release.
  67. - built with perl-5.34.0.
  68. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38-2
  69. - rebuilt with perl-5.16.3.
  70. * Sun Oct 09 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.38-1
  71. - initial build for Vine Linux