perl-Exporter-Tiny-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. # Test::Warnings introduced in Fedora 18
  2. %if 0%{?fedora} < 18 && 0%{?rhel} < 7
  3. %global no_test_warnings 1
  4. %else
  5. %global no_test_warnings 0
  6. %endif
  7. Summary: An exporter with the features of Sub::Exporter but only core dependencies
  8. Name: perl-Exporter-Tiny
  9. Version: 1.002002
  10. Release: 1%{?_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPL+ or Artistic
  15. URL: https://metacpan.org/release/Exporter-Tiny
  16. Source0: https://cpan.metacpan.org/modules/by-module/Exporter/Exporter-Tiny-%{version}.tar.gz
  17. BuildArch: noarch
  18. # Module Build
  19. BuildRequires: coreutils
  20. BuildRequires: findutils
  21. BuildRequires: make
  22. BuildRequires: perl >= 2:5.26.2
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. # Module Runtime
  25. BuildRequires: perl(Carp)
  26. BuildRequires: perl(strict)
  27. BuildRequires: perl(warnings)
  28. # Test Suite
  29. BuildRequires: perl(lib)
  30. BuildRequires: perl(Test::More)
  31. # Optional Tests
  32. BuildRequires: perl(Test::Fatal)
  33. %if ! %{no_test_warnings}
  34. BuildRequires: perl(Test::Warnings)
  35. %endif
  36. # Runtime
  37. Requires: perl >= 2:5.34.0
  38. Requires: perl(Carp)
  39. # Avoid doc-file dependency on perl(base)
  40. %{?perl_default_filter}
  41. %description
  42. Exporter::Tiny supports many of Sub::Exporter's external-facing features
  43. including renaming imported functions with the -as, -prefix and -suffix
  44. options; explicit destinations with the into option; and alternative
  45. installers with the installer option. But it's written in only about 40%%
  46. as many lines of code and with zero non-core dependencies.
  47. Its internal-facing interface is closer to Exporter.pm, with configuration
  48. done through the @EXPORT, @EXPORT_OK and %%EXPORT_TAGS package variables.
  49. Exporter::Tiny performs most of its internal duties (including resolution of
  50. tag names to sub names, resolution of sub names to coderefs, and installation
  51. of coderefs into the target package) as method calls, which means they can be
  52. overridden to provide interesting behavior.
  53. %prep
  54. %setup -q -n Exporter-Tiny-%{version}
  55. %build
  56. perl Makefile.PL INSTALLDIRS=vendor
  57. make %{?_smp_mflags}
  58. %install
  59. make pure_install DESTDIR=%{buildroot}
  60. find %{buildroot} -type f -name .packlist -delete
  61. %{_fixperms} -c %{buildroot}
  62. %check
  63. make test
  64. %files
  65. %if 0%{?_licensedir:1}
  66. %license COPYRIGHT LICENSE
  67. %else
  68. %doc COPYRIGHT LICENSE
  69. %endif
  70. %doc Changes CREDITS examples/ README TODO
  71. %{perl_vendorlib}/Exporter/
  72. %{_mandir}/man3/Exporter::Tiny.3*
  73. %{_mandir}/man3/Exporter::Tiny::Manual::Etc.3*
  74. %{_mandir}/man3/Exporter::Tiny::Manual::Exporting.3*
  75. %{_mandir}/man3/Exporter::Tiny::Manual::Importing.3*
  76. %{_mandir}/man3/Exporter::Tiny::Manual::QuickStart.3*
  77. %{_mandir}/man3/Exporter::Shiny.3*
  78. %changelog
  79. * Thu Nov 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.002002-1
  80. - new upstream release.
  81. - built with perl-5.34.0.
  82. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.002001-3
  83. - initial build for Vine Linux.
  84. - rebuilt with perl-5.26.
  85. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.002001-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  87. * Wed Jul 18 2018 Paul Howarth <paul@city-fan.org> - 1.002001-1
  88. - Update to 1.002001
  89. - Added support for generating and exporting non-code symbols such as $Foo,
  90. @Bar, and %%Baz
  91. - Improved test coverage, up from 88.78%% on coveralls.io to 96.74%%
  92. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-6
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  94. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-5
  95. - Perl 5.28 rebuild
  96. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-4
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  98. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-3
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  100. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-2
  101. - Perl 5.26 rebuild
  102. * Mon May 22 2017 Paul Howarth <paul@city-fan.org> - 1.000000-1
  103. - Update to 1.000000
  104. - Repackage as 1.000000
  105. - All shipped files are now GPL+ or Artistic
  106. - Drop EL-5 support
  107. - Drop BuildRoot: and Group: tags
  108. - Drop explicit buildroot cleaning in %%install section
  109. - Drop explicit %%clean section
  110. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.044-2
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  112. * Mon Jan 30 2017 Paul Howarth <paul@city-fan.org> - 0.044-1
  113. - Update to 0.044
  114. - Support { -as => CODE } to programmatically rename functions
  115. - Restructure documentation
  116. - Simplify find command using -delete
  117. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-6
  118. - Perl 5.24 rebuild
  119. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.042-5
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  121. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.042-4
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  123. * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-3
  124. - Perl 5.22 rebuild
  125. * Fri Mar 6 2015 Paul Howarth <paul@city-fan.org> - 0.042-2
  126. - Correct license tagging (#1199491)
  127. * Thu Oct 9 2014 Paul Howarth <paul@city-fan.org> - 0.042-1
  128. - Update to 0.042
  129. - Add an 'unimport' feature
  130. - Option validation needs to happen after expanding tags
  131. - Housekeeping on %%TRACKED
  132. * Wed Sep 17 2014 Paul Howarth <paul@city-fan.org> - 0.040-1
  133. - Update to 0.040
  134. - Document warning and error messages produced by Exporter::Tiny
  135. - Exporter::Tiny would previously cause B.pm to be loaded into memory any
  136. time it exported anything: it no longer does
  137. - No longer die when redefining locally defined subs
  138. - Warn when redefining any subs
  139. - Use %%license where possible
  140. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.038-3
  141. - Perl 5.20 rebuild
  142. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.038-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  144. * Fri Apr 4 2014 Paul Howarth <paul@city-fan.org> - 0.038-1
  145. - Update to 0.038
  146. - Added: Support Exporter.pm's import negation syntax qw( !foo )
  147. - Added: Support Exporter.pm's regexp import syntax qw( /foo/ )
  148. - Fix minor error in documentation of generators
  149. - Improved handling of hashrefs of options passed to tags, and hashrefs of
  150. options found within %%EXPORT_TAGS arrayrefs
  151. - Only attempt to merge hashes if we're sure they're both really hashes!
  152. * Mon Mar 17 2014 Paul Howarth <paul@city-fan.org> - 0.036-2
  153. - Sanitize for Fedora submission
  154. * Thu Mar 13 2014 Paul Howarth <paul@city-fan.org> - 0.036-1
  155. - Initial RPM version