perl-Eval-Closure-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. Summary: Safely and cleanly create closures via string eval
  2. Name: perl-Eval-Closure
  3. Version: 0.14
  4. Release: 2%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPL+ or Artistic
  9. URL: https://metacpan.org/pod/Eval::Closure
  10. Source0: https://cpan.metacpan.org/authors/id/D/DO/DOY/Eval-Closure-0.14.tar.gz
  11. BuildArch: noarch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(PadWalker)
  15. BuildRequires: perl(Perl::Tidy)
  16. BuildRequires: perl(Scalar::Util)
  17. BuildRequires: perl(Sub::Exporter)
  18. BuildRequires: perl(Test::Fatal)
  19. BuildRequires: perl(Test::More)
  20. BuildRequires: perl(Test::Output)
  21. BuildRequires: perl(Test::Requires)
  22. BuildRequires: perl(Try::Tiny)
  23. Requires: perl(Perl::Tidy)
  24. Requires: perl >= 2:5.34.0
  25. %{?perl_default_filter}
  26. %description
  27. String eval is often used for dynamic code generation. For instance, Moose uses
  28. it heavily, to generate inlined versions of accessors and constructors, which
  29. speeds code up at runtime by a significant amount. String eval is not without
  30. its issues however - it's difficult to control the scope it's used in (which
  31. determines which variables are in scope inside the eval), and it's easy to miss
  32. compilation errors, since eval catches them and sticks them in $@ instead.
  33. This module attempts to solve these problems. It provides an eval_closure
  34. function, which evals a string in a clean environment, other than a fixed list
  35. of specified variables. Compilation errors are rethrown automatically.
  36. %prep
  37. %setup -q -n Eval-Closure-%{version}
  38. %build
  39. %{__perl} Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf %{buildroot}
  43. make pure_install DESTDIR=%{buildroot}
  44. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  45. %{_fixperms} %{buildroot}/*
  46. %check
  47. make test
  48. %clean
  49. rm -rf %{buildroot}
  50. %files
  51. %doc Changes LICENSE README
  52. %{perl_vendorlib}/*
  53. %{_mandir}/man3/*
  54. %changelog
  55. * Sun Nov 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.14-2
  56. - new upstream release.
  57. - built with perl-5.34.0.
  58. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.14-1
  59. - new upstream release.
  60. - rebuilt with perl-5.26.
  61. * Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.11-1
  62. - updated to 0.11
  63. - built with perl 5.16.3
  64. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
  65. - initial build for Vine Linux
  66. * Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
  67. - update to latest upstream version
  68. * Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
  69. - update to latest upstream version
  70. - update description
  71. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  73. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
  74. - Perl mass rebuild
  75. * Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
  76. - update to latest upstream version
  77. * Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
  78. - update to latest upstream version
  79. * Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
  80. - update to latest upstream version
  81. * Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
  82. - update to latest upstream version
  83. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  85. * Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
  86. - update to latest upstream version
  87. * Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
  88. - Specfile autogenerated by cpanspec 1.78.