perl-EV-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Summary: Wrapper for the libev high-performance event loop library
  2. Summary(ja): 高性能イベントループライブラリ libev の Perl ラッパー
  3. Name: perl-EV
  4. Version: 4.33
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. # Note: The source archive includes a libev/ folder which contents are licensed
  10. # as "BSD or GPLv2+". However, those are removed at build-time and
  11. # perl-EV is instead built against the system-provided libev.
  12. License: GPL+ or Artistic
  13. URL: https://metacpan.org/pod/EV
  14. Source0: https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
  15. Patch0: perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
  16. Patch1: perl-EV-4.30-Don-t-check-bundled-libev.patch
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(common::sense)
  19. BuildRequires: gdbm-devel
  20. BuildRequires: libxcrypt-devel
  21. BuildRequires: libev-source >= %{version}
  22. BuildRequires: perl(AnyEvent)
  23. BuildRequires: perl(Canary::Stability)
  24. Requires: perl
  25. # As per review, a perl-EV-devel subpackage had at first been pushed to the
  26. # repositories. It now has broken deps if it's not properly obsoleted/provided.
  27. # TODO: Remove those two lines during the Fedora 17 development cycle.
  28. Provides: %{name}-devel = %{version}-%{release}
  29. Obsoletes: %{name}-devel < 4.03-5
  30. %{?perl_default_filter}
  31. %description
  32. This module provides an interface to libev
  33. (<http://software.schmorp.de/pkg/libev.html>). While the included documentation
  34. is comprehensive, one might also consult the documentation of libev itself
  35. (<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
  36. semantics or some discussion on the available backends, or how to force a
  37. specific backend with "LIBEV_FLAGS", or just about in any case because it has
  38. much more detailed information.
  39. %debug_package
  40. %prep
  41. %setup -q -n EV-%{version}
  42. %patch0 -p1
  43. %patch1 -p0
  44. # remove all traces of the bundled libev
  45. rm -fr libev/*
  46. # use the sources from the system libev
  47. mkdir -p ./libev
  48. cp -r /usr/share/libev-source/* ./libev/
  49. %build
  50. PERL_CANARY_STABILITY_NOPROMPT=1 | %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" NO_PACKLIST=1 NO_PERLLOCAL=1
  51. %{make_build}
  52. %install
  53. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  54. %{_fixperms} $RPM_BUILD_ROOT/*
  55. %check
  56. make test
  57. %clean
  58. rm -rf %{buildroot}
  59. %files
  60. %defattr(-,root,root,-)
  61. %license COPYING
  62. %doc Changes README
  63. %{perl_vendorarch}/auto/*
  64. %{perl_vendorarch}/EV.pm
  65. %{perl_vendorarch}/EV
  66. %{perl_vendorarch}/EV/*.h
  67. %{_mandir}/man3/*.3*
  68. %changelog
  69. * Wed Nov 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.33-1
  70. - new upstream release.
  71. - built with perl-5.34.0.
  72. - imported Patch1 from rawhide.
  73. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.25-1
  74. - new upstream release.
  75. - rebuilt with perl-5.26.
  76. - added BR:libxcrypt-devel.
  77. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.03-2
  78. - build with Perl 5.16
  79. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
  80. - initial build for Vine Linux
  81. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  83. * Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
  84. - Build-require exact or higher version of libev-source (bug #759021)
  85. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
  86. - Perl mass rebuild
  87. * Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
  88. - Add the correct Obsoletes/Provides to avoid broken deps from the -devel
  89. subpackage removal.
  90. * Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
  91. - Readded the header file to the main package, as per guidelines:
  92. -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
  93. * Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
  94. - Some more fixes as part of the review process:
  95. - Fix the license tag to be only the license of perl-EV, and add a note about
  96. the included libev sources.
  97. - Removed manual cleaning of the buildroot since it has been useless since
  98. Fedora 10 and even EPEL (>=6) doesn't need it now.
  99. * Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
  100. - Fixes asked during the review process:
  101. - Filter the private shared EV.so out of the automatic Provides
  102. - Put the header files in a -devel package
  103. - Removed the Buildroot line since it's useless for newer versions of Fedora
  104. and this package can only go in Fedora >= 15 due to its libev dependency)
  105. * Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
  106. - Update to 4.03.
  107. - Use the system libev instead of the bundled one.
  108. * Sun Nov 8 2009 kwizart < kwizart at gmail.com > - 3.8-1
  109. - Update to 3.8
  110. * Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
  111. - Update to 3.6
  112. * Mon Mar 2 2009 kwizart < kwizart at gmail.com > - 3.53-1
  113. - Update to 3.53
  114. * Tue Feb 3 2009 kwizart < kwizart at gmail.com > - 3.52-1
  115. - Update to 3.52
  116. * Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
  117. - Update to 3.44
  118. - WIP conditional --with systemlibev
  119. * Tue Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
  120. - Update to 3.431
  121. - Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
  122. - Add libev README and LICENSE
  123. * Tue Jul 8 2008 kwizart < kwizart at gmail.com > - 3.43-1
  124. - Update to 3.43
  125. * Mon Jun 9 2008 kwizart < kwizart at gmail.com > - 3.42-2
  126. - Disable filter AnyEvent
  127. * Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
  128. - Update to 3.42
  129. * Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
  130. - Initial package for Fedora