perl-Devel-GlobalDestruction-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. Summary: Expose PL_dirty, the flag that marks global destruction
  2. Name: perl-Devel-GlobalDestruction
  3. Version: 0.14
  4. Release: 10%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPL+ or Artistic
  9. URL: https://metacpan.org/pod/Devel::GlobalDestruction
  10. Source: https://cpan.metacpan.org/authors/id/H/HA/HAARG/Devel-GlobalDestruction-%{version}.tar.gz
  11. BuildArch: noarch
  12. BuildRequires: perl >= 2:5.34.0
  13. BuildRequires: perl(ExtUtils::CBuilder)
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(Sub::Exporter::Progressive)
  16. BuildRequires: perl(XSLoader)
  17. Requires: perl >= 2:5.34.0
  18. # Don't "provide" private Perl libs
  19. %{?perl_default_filter}
  20. %description
  21. Perl's global destruction is a little tricky to deal with with respect to
  22. finalizers because it's not ordered and objects can sometimes disappear.
  23. Writing defensive destructors is hard and annoying, and usually if global
  24. destruction is happening you only need the destructors that free up non
  25. process local resources to actually execute.
  26. For these constructors you can avoid the mess by simply bailing out if
  27. global destruction is in effect.
  28. %prep
  29. %setup -q -n Devel-GlobalDestruction-%{version}
  30. %build
  31. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}" NO_PACKLIST=1 NO_PERLLOCAL=1
  32. make %{?_smp_mflags}
  33. %install
  34. rm -rf %{buildroot}
  35. make pure_install DESTDIR=%{buildroot}
  36. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  37. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  38. %{_fixperms} %{buildroot}
  39. %check
  40. make test
  41. %clean
  42. rm -rf %{buildroot}
  43. %files
  44. %defattr(-,root,root,-)
  45. %doc Changes t/
  46. %{perl_vendorlib}/Devel/
  47. %{_mandir}/man3/Devel::GlobalDestruction.3pm*
  48. %changelog
  49. * Sun Nov 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.14-10
  50. - new upstream release.
  51. - built with perl-5.34.0.
  52. * Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.13-1
  53. - updated to 0.13
  54. - built with perl 5.16.3
  55. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.04-1
  56. - initial build for Vine Linux
  57. * Fri Jan 13 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
  58. - Update to 0.04
  59. - To detect a perl with ${^GLOBAL_PHASE}, check for the feature itself
  60. instead of a specific perl version
  61. - Update the documentation to reflect the use of ${^GLOBAL_PHASE} if available
  62. - Stop depending on Scope::Guard for the tests
  63. - Upgrade ppport.h from version 3.13 to 3.19
  64. - Drop no-longer-necessary buildreq perl(Scope::Guard)
  65. - Use DESTDIR rather than PERL_INSTALL_ROOT
  66. - BR: perl(XSLoader)
  67. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
  68. - Fedora 17 mass rebuild
  69. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-2
  70. - Perl mass rebuild
  71. * Fri Jun 24 2011 Paul Howarth <paul@city-fan.org> - 0.03-1
  72. - Update to 0.03
  73. - Drop the XS code on perl versions recent enough to have ${^GLOBAL_PHASE}
  74. (5.13.7 onwards)
  75. - Require at least Perl 5.6
  76. - Use XSLoader without a fallback to DynaLoader
  77. - Use our instead of use vars
  78. - This release by FLORA -> update source URL
  79. - Package is noarch from perl 5.13.7
  80. - Package Changes file
  81. - Use %%{?perl_default_filter}
  82. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-12
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  84. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-11
  85. - Rebuild to fix problems with vendorarch/lib (#661697)
  86. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-10
  87. - Mass rebuild with perl-5.12.0
  88. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-9
  89. - Mass rebuild with perl-5.12.0
  90. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.02-8
  91. - rebuild against perl 5.10.1
  92. * Sun Aug 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.02-7
  93. - bump
  94. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-6
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  96. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-5
  97. - Stripping bad provides of private Perl extension libs
  98. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-4
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  100. * Mon Nov 03 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-3
  101. - bump
  102. * Sat Nov 01 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-2
  103. - tweak summary
  104. * Sun Oct 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-1
  105. - clean up for review submission
  106. * Sun Oct 19 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-0.1
  107. - initial RPM packaging
  108. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)