perl-Data-OptList-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. Name: perl-Data-OptList
  2. Summary: Parse and validate simple name/value option pairs
  3. Version: 0.112
  4. Release: 1%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPL+ or Artistic
  9. URL: https://metacpan.org/pod/Data::OptList
  10. Source0: https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Data-OptList-%{version}.tar.gz
  11. BuildArch: noarch
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. BuildRequires: perl(List::Util)
  14. BuildRequires: perl(Params::Util)
  15. #BuildRequires: perl(Sub::Install) >= 0.921
  16. #BuildRequires: perl(Test::More)
  17. #BuildRequires: perl(Test::Pod)
  18. Requires: perl
  19. # Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
  20. Obsoletes: %{name}-tests < %{version}-%{release}
  21. Provides: %{name}-tests = %{version}-%{release}
  22. %description
  23. Hashes are great for storing named data, but if you want more than one entry
  24. for a name, you have to use a list of pairs. Even then, this is really boring
  25. to write:
  26. $values = [
  27. foo => undef,
  28. bar => undef,
  29. baz => undef,
  30. xyz => { ... },
  31. ];
  32. With Data::OptList, you can do this instead:
  33. $values = Data::OptList::mkopt([
  34. qw(foo bar baz),
  35. xyz => { ... },
  36. ]);
  37. This works by assuming that any defined scalar is a name and any reference
  38. following a name is its value.
  39. %prep
  40. %setup -q -n Data-OptList-%{version}
  41. %build
  42. perl Makefile.PL INSTALLDIRS=vendor
  43. make %{?_smp_mflags}
  44. %install
  45. make pure_install DESTDIR=%{buildroot}
  46. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  47. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  48. %{_fixperms} %{buildroot}
  49. %check
  50. #make test RELEASE_TESTING=1
  51. %files
  52. %license LICENSE
  53. %doc Changes README t/
  54. %{perl_vendorlib}/Data/
  55. %{_mandir}/man3/Data::OptList.3pm*
  56. %changelog
  57. * Thu Nov 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.112-1
  58. - new upstream release.
  59. - rebuilt with perl-5.34.0.
  60. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.110-1
  61. - new upstream release.
  62. - rebuilt with perl-5.26.
  63. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.109-1
  64. - update to 0.109-1
  65. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.107-1
  66. - initial build for Vine Linux
  67. * Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 0.107-5
  68. - obsolete/provide old -tests subpackage to support upgrades
  69. * Fri Jan 20 2012 Paul Howarth <paul@city-fan.org> - 0.107-4
  70. - drop -tests subpackage (general lack of interest in this), but include
  71. them as documentation for the main package
  72. - drop redundant %%{?perl_default_filter}
  73. - don't use macros for commands
  74. - can't find any dependency cycle so drop %%{?perl_bootstrap} usage
  75. - drop ExtUtils::MakeMaker version requirement to 6.30, actual working minimum
  76. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.107-3
  77. - package LICENSE file
  78. - run test suite even when bootstrapping, as it should still pass
  79. - run release tests too
  80. - enhance %%description so it makes sense
  81. - BR: perl(Test::More)
  82. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.107-2
  83. - Perl mass rebuild
  84. - add perl_bootstrap macro
  85. * Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 0.107-1
  86. - update to latest upstream version
  87. - clean up spec for modern rpmbuild
  88. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.106-4
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  90. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-3
  91. - rebuild to fix problems with vendorarch/lib (#661697)
  92. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-2
  93. - Mass rebuild with perl-5.12.0
  94. * Mon Mar 08 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.106-1
  95. - update by Fedora::App::MaintainerTools 0.004
  96. - PERL_INSTALL_ROOT => DESTDIR
  97. - updating to latest GA CPAN version (0.106)
  98. - added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
  99. - added a new br on perl(List::Util) (version 0)
  100. - altered br on perl(Sub::Install) (0.92 => 0.921)
  101. - added a new req on perl(List::Util) (version 0)
  102. - added a new req on perl(Params::Util) (version 0.14)
  103. - added a new req on perl(Sub::Install) (version 0.921)
  104. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.104-4
  105. - rebuild against perl 5.10.1
  106. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  108. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  110. * Wed Feb 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.104-1
  111. - update to 0.104
  112. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.103-2
  113. - Rebuild for perl 5.10 (again)
  114. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.103-1
  115. - rebuild for new perl
  116. - bump to 0.103
  117. - fix license tag
  118. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-2
  119. - bump
  120. * Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-1
  121. - Specfile autogenerated by cpanspec 1.69.1.