perl-Coro-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. Name: perl-Coro
  2. Version: 6.57
  3. Release: 1%{?_dist_release}
  4. Summary: The only real threads in perl
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPL+ or Artistic
  9. URL: https://metacpan.org/pod/Coro
  10. Source0: https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/Coro-%{version}.tar.gz
  11. Patch0: %{name}-5.25-ucontext-default.patch
  12. BuildRequires: perl(Canary::Stability)
  13. BuildRequires: perl(AnyEvent)
  14. BuildRequires: perl(common::sense)
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Guard)
  17. BuildRequires: perl(Scalar::Util)
  18. BuildRequires: perl(Storable)
  19. BuildRequires: perl(Time::HiRes)
  20. # Recommended optional modules
  21. BuildRequires: perl(AnyEvent::AIO)
  22. BuildRequires: perl(AnyEvent::BDB)
  23. BuildRequires: perl(BDB)
  24. # perl-EV not packaged
  25. BuildRequires: perl(EV)
  26. BuildRequires: perl(Event)
  27. BuildRequires: perl(IO::AIO)
  28. Requires: perl
  29. # Export correct required versions
  30. Requires: perl(AnyEvent)
  31. Requires: perl(AnyEvent::AIO)
  32. Requires: perl(AnyEvent::BDB)
  33. Requires: perl(EV)
  34. Requires: perl(Event)
  35. Requires: perl(Guard)
  36. Requires: perl(Storable)
  37. %{?perl_default_filter}
  38. # Filter underspecified dependencies
  39. %global __requires_exclude %{?__requires_exclude:__requires_exclude|}^perl\\(AnyEvent\\)$
  40. %global __requires_exclude %__requires_exclude|^perl\\(AnyEvent\\) >= 4.800001$
  41. %global __requires_exclude %__requires_exclude|^perl\\(AnyEvent::AIO\\)$
  42. %global __requires_exclude %__requires_exclude|^perl\\(AnyEvent::BDB\\)$
  43. %global __requires_exclude %__requires_exclude|^perl\\(EV\\)$
  44. %global __requires_exclude %__requires_exclude|^perl\\(Event\\)$
  45. %global __requires_exclude %__requires_exclude|^perl\\(Guard\\)$
  46. %global __requires_exclude %__requires_exclude|^perl\\(Storable\\)$
  47. %global __requires_exclude %__requires_exclude|^perl\\(Coro\\)$
  48. %global __provides_exclude %{?__provides_exclude:__provides_exclude|}^perl\\(Coro\\)$
  49. %description
  50. This module collection manages continuations in general, most often in the
  51. form of cooperative threads (also called coros, or simply "coro" in the
  52. documentation). They are similar to kernel threads but don't (in general) run
  53. in parallel at the same time even on SMP machines. The specific flavor of
  54. thread offered by this module also guarantees you that it will not switch
  55. between threads unless necessary, at easily-identified points in your
  56. program, so locking and parallel access are rarely an issue, making thread
  57. programming much safer and easier than using other thread models.
  58. %debug_package
  59. %prep
  60. %setup -q -n Coro-%{version}
  61. # use ucontext backend on non-x86 (setjmp didn't work on s390(x))
  62. %patch0 -p1 -b .ucontext-default
  63. for F in Coro/jit-*.pl; do
  64. sed -i -e '/^#!/d' "$F"
  65. chmod -x "$F"
  66. done
  67. %global wrong_shbangs eg/myhttpd
  68. %if %{defined fix_shbang_line}
  69. %fix_shbang_line %wrong_shbangs
  70. %else
  71. # at least EL6 doesn't have the %%fix_shbang_line macro
  72. sed -i -e '/^#!/ s|.*|#!%{__perl}|' %wrong_shbangs
  73. %endif
  74. %build
  75. # Disable FORTIFY_SOURCE on ARM as it breaks setjmp - RHBZ 750805
  76. %ifarch %{arm}
  77. RPM_OPT_FLAGS=$(echo "${RPM_OPT_FLAGS}" | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2/-D_FORTIFY_SOURCE=0/g')
  78. %endif
  79. # Interractive configuration. Use default values.
  80. %{__perl} Makefile.PL INSTALLDIRS=perl NO_PACKLIST=1 NO_PERLLOCAL=1 \
  81. OPTIMIZE="$RPM_OPT_FLAGS" </dev/null
  82. make %{?_smp_mflags}
  83. %install
  84. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  85. find %{buildroot} -type f -name '*.bs' -size 0 -delete
  86. %{_fixperms} %{buildroot}/*
  87. %check
  88. make test
  89. %files
  90. %defattr(-,root,root,-)
  91. %license COPYING
  92. %doc Changes README README.linux-glibc
  93. %doc doc/* eg
  94. %{perl_archlib}/auto/*
  95. %{perl_archlib}/Coro*
  96. %{_mandir}/man3/*
  97. %changelog
  98. * Thu Nov 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.57-1
  99. - new upstream release.
  100. - rebuilt with perl-5.34.0.
  101. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.54-1
  102. - new upstream release.
  103. - rebuilt with perl-5.26.
  104. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.41-1
  105. - updated to 6.41
  106. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 6.07-2
  107. - build with Perl 5.16
  108. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.07-1
  109. - initial build for Vine Linux
  110. * Tue Feb 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 6.07-3
  111. - Add patch to fix build on ARM. RHBZ 750805
  112. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.07-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  114. * Fri Dec 09 2011 Petr Pisar <ppisar@redhat.com> - 6.07-1
  115. - 6.07 bump
  116. * Thu Nov 03 2011 Nicolas Chauvet <kwizart@gmail.com> - 6.06-2
  117. - Fix ucontext on ARM - rhbz750805
  118. * Fri Aug 12 2011 Petr Sabata <contyk@redhat.com> - 6.06-1
  119. - 6.06 bump
  120. * Fri Aug 05 2011 Petr Sabata <contyk@redhat.com> - 6.05-1
  121. - 6.05 bump
  122. * Thu Aug 04 2011 Petr Sabata <contyk@redhat.com> - 6.04-1
  123. - 6.04 bump
  124. * Fri Jul 29 2011 Petr Pisar <ppisar@redhat.com> - 6.02-1
  125. - 6.02 bump
  126. - Major version 6 breaks compatibility: Unreferenced coro objects will now be
  127. destroyed and cleaned up automatically (e.g. async { schedule }).
  128. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 5.372-4
  129. - Perl mass rebuild
  130. * Fri Apr 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 5.372-3
  131. - Added explicit versionned Requires: on perl(EV)
  132. - Removed automatically added unversionned Requires: on perl(EV)
  133. * Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 5.372-2
  134. - Rebuild with EV support.
  135. * Mon Mar 07 2011 Petr Pisar <ppisar@redhat.com> - 5.372-1
  136. - 5.372 bump
  137. * Mon Feb 21 2011 Petr Pisar <ppisar@redhat.com> - 5.37-1
  138. - 5.37 bump
  139. - Fix State.xs syntax (RT#65991)
  140. - Version unversioned Provides
  141. * Mon Feb 14 2011 Petr Pisar <ppisar@redhat.com> - 5.26-1
  142. - 5.26 bump
  143. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.25-4
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  145. * Fri Jan 21 2011 Mathieu Bridon <bochecha@fedoraproject.org> 5.25-3
  146. - Allow building on systems without %%fix_shbang_line macro (needed for EL6)
  147. * Mon Jan 10 2011 Dan Horák <dan[at]danny.cz> 5.25-2
  148. - use ucontext backend on non-x86
  149. * Tue Jan 04 2011 Petr Pisar <ppisar@redhat.com> 5.25-1
  150. - 5.25 import
  151. - Disable perl(EV) support as it's not packaged yet