perl-Clone-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. Name: perl-Clone
  2. Version: 0.45
  3. Release: 1%{?_dist_release}
  4. Summary: Recursively copy perl datatypes
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: shaolin
  9. License: GPL+ or Artistic
  10. URL: https://metacpan.org/pod/Clone
  11. Source0: https://cpan.metacpan.org/authors/id/A/AT/ATOOMIC/Clone-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: libxcrypt-devel
  14. BuildRequires: perl(ExtUtils::ParseXS)
  15. BuildRequires: perl(Taint::Runtime)
  16. BuildRequires: perl(Test::More)
  17. Requires: perl
  18. # don't "provide" private Perl libs
  19. %global _use_internal_dependency_generator 0
  20. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
  21. %global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
  22. %global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
  23. %description
  24. This module provides a clone() method which makes recursive
  25. copies of nested hash, array, scalar and reference types,
  26. including tied variables and objects.
  27. clone() takes a scalar argument and an optional parameter that
  28. can be used to limit the depth of the copy. To duplicate lists,
  29. arrays or hashes, pass them in by reference.
  30. %debug_package
  31. %prep
  32. %setup -q -n Clone-%{version}
  33. find . -type f -exec chmod -c -x {} ';'
  34. %build
  35. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  36. make %{?_smp_mflags}
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  40. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  41. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  42. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  43. chmod -R u+w $RPM_BUILD_ROOT/*
  44. %check
  45. make test
  46. %clean
  47. rm -rf $RPM_BUILD_ROOT
  48. %files
  49. %defattr(-,root,root,-)
  50. %doc Changes
  51. %{perl_vendorarch}/auto/Clone/
  52. %{perl_vendorarch}/Clone.pm
  53. %{_mandir}/man3/*.3*
  54. %changelog
  55. * Tue Nov 16 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.45-1
  56. - new upstream release.
  57. - built with perl-5.34.0.
  58. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.41-1
  59. - new upstream release.
  60. - rebuilt with perl-5.26.
  61. - added BR:libxcrypt-devel.
  62. * Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.38-1
  63. - new upstream release
  64. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.31-2
  65. - build with Perl 5.16
  66. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
  67. - initial build for Vine Linux
  68. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  70. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
  71. - Perl mass rebuild
  72. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  74. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
  75. - 661697 rebuild for fixing problems with vendorach/lib
  76. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
  77. - Mass rebuild with perl-5.12.0
  78. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
  79. - rebuild against perl 5.10.1
  80. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  82. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
  83. - filter private Perl solibs from provides
  84. - remove some executable bits -- keep rpmlint happy
  85. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
  86. - update to 0.31
  87. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  89. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
  90. - Rebuild for perl 5.10 (again)
  91. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
  92. - Autorebuild for GCC 4.3
  93. * Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
  94. - rebuild for new perl
  95. * Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
  96. - bump to 0.28
  97. * Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
  98. - license fix
  99. * Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
  100. - bump to 0.27
  101. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
  102. - bump to 0.22
  103. * Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
  104. - bump for fc6
  105. * Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
  106. - bump to 0.20
  107. - new BR: perl-Taint-Runtime
  108. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
  109. - bump for FC-5
  110. * Fri Jan 6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
  111. - don't pass optflags twice
  112. - remove .bs files
  113. * Thu Jan 5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
  114. - Initial package for Fedora Extras