perl-Class-Method-Modifiers-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. # Run optional tests
  2. %bcond_with perl_Class_Method_Modifiers_enables_optional_test
  3. Name: perl-Class-Method-Modifiers
  4. Summary: Provides Moose-like method modifiers
  5. Version: 2.13
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPL+ or Artistic
  11. URL: https://metacpan.org/release/Class-Method-Modifiers
  12. Source0: https://cpan.metacpan.org/authors/id/E/ET/ETHER/Class-Method-Modifiers-%{version}.tar.gz
  13. BuildArch: noarch
  14. # Module Build
  15. BuildRequires: coreutils
  16. BuildRequires: findutils
  17. BuildRequires: make
  18. BuildRequires: perl >= 2:5.34.0
  19. BuildRequires: perl(ExtUtils::MakeMaker)
  20. BuildRequires: perl(strict)
  21. BuildRequires: perl(warnings)
  22. # Module Runtime
  23. BuildRequires: perl(B)
  24. BuildRequires: perl(base)
  25. BuildRequires: perl(Carp)
  26. BuildRequires: perl(Exporter)
  27. # Test Suite
  28. BuildRequires: perl(File::Spec)
  29. BuildRequires: perl(if)
  30. BuildRequires: perl(Test::Fatal)
  31. BuildRequires: perl(Test::More)
  32. BuildRequires: perl(Test::Requires)
  33. # Optional Test Requirements
  34. %if 0%{!?perl_bootstrap:1} && %{with perl_Class_Method_Modifiers_enables_optional_test}
  35. BuildRequires: perl(CPAN::Meta)
  36. BuildRequires: perl(Moose)
  37. %endif
  38. # Runtime
  39. Requires: perl >= 2:5.34.0
  40. Requires: perl(B)
  41. Requires: perl(Carp)
  42. Requires: perl(Exporter)
  43. # Avoid doc-file dependencies
  44. %{?perl_default_filter}
  45. %description
  46. Method modifiers are a powerful feature from the CLOS (Common Lisp Object
  47. System) world.
  48. In its most basic form, a method modifier is just a method that calls
  49. '$self->SUPER::foo(@_)'. I for one have trouble remembering that exact
  50. invocation, so my classes seldom re-dispatch to their base classes. Very
  51. bad!
  52. 'Class::Method::Modifiers' provides three modifiers: 'before', 'around',
  53. and 'after'. 'before' and 'after' are run just before and after the method
  54. they modify, but can not really affect that original method. 'around' is
  55. run in place of the original method, with a hook to easily call that
  56. original method. See the 'MODIFIERS' section for more details on how the
  57. particular modifiers work.
  58. %prep
  59. %setup -q -n Class-Method-Modifiers-%{version}
  60. # Drop unnecessary exec permissions from test files
  61. chmod -c -x t/*.t
  62. %build
  63. perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
  64. make %{?_smp_mflags}
  65. %install
  66. make pure_install DESTDIR=%{buildroot}
  67. %{_fixperms} %{buildroot}
  68. %check
  69. make test
  70. %files
  71. %license LICENSE
  72. %doc Changes CONTRIBUTING README t/
  73. %{perl_vendorlib}/Class/
  74. %{_mandir}/man3/Class::Method::Modifiers.3*
  75. %changelog
  76. * Sun Nov 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.13-1
  77. - new upstream release.
  78. - built with perl-5.34.0.
  79. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12-13
  80. - initial build for Vine Linux.
  81. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-12
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  83. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-11
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  85. * Sat Jun 30 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-10
  86. - Perl 5.28 re-rebuild of bootstrapped packages
  87. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-9
  88. - Perl 5.28 rebuild
  89. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-8
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  91. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-7
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  93. * Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-6
  94. - Perl 5.26 re-rebuild of bootstrapped packages
  95. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-5
  96. - Perl 5.26 rebuild
  97. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-4
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  99. * Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-3
  100. - Perl 5.24 re-rebuild of bootstrapped packages
  101. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-2
  102. - Perl 5.24 rebuild
  103. * Sat Mar 05 2016 Petr Šabata <contyk@redhat.com> - 2.12-1
  104. - 2.12 bump, documentation fixes
  105. - %%license is now supported in EPEL too
  106. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.11-7
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  108. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-6
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  110. * Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-5
  111. - Perl 5.22 re-rebuild of bootstrapped packages
  112. * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-4
  113. - Perl 5.22 rebuild
  114. * Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-3
  115. - Perl 5.20 re-rebuild of bootstrapped packages
  116. * Fri Sep 05 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-2
  117. - Perl 5.20 rebuild
  118. * Thu Sep 4 2014 Paul Howarth <paul@city-fan.org> <paul@city-fan.org> - 2.11-1
  119. - Update to 2.11
  120. - Add documentation for modifying multiple methods at once (GitHub #2)
  121. - Use %%license where possible
  122. * Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.10-3
  123. - Perl 5.20 rebuild
  124. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10-2
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  126. * Sun Mar 16 2014 Paul Howarth <paul@city-fan.org> <paul@city-fan.org> - 2.10-1
  127. - Update to 2.10
  128. - Remove erroneous perl 5.8 requirement
  129. - Support for handling lvalue methods
  130. - Convert to building with Dist::Zilla
  131. - Repository migrated to the github moose organization
  132. - Refresh configure_requires checking in generated Makefile.PL
  133. - New CONTRIBUTING file
  134. - Updated tests:
  135. - Compile test now only runs for authors
  136. - Check-deps test replaced by information-only report-prereqs test
  137. - Drop obsoletes/provides for old tests sub-package
  138. - Drop redundant Group tag
  139. - Classify buildreqs by usage
  140. - Make %%files list more explicit
  141. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03-3
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  143. * Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 2.03-2
  144. - Perl 5.18 rebuild
  145. * Fri Feb 15 2013 Iain Arnell <iarnell@gmail.com> 2.03-1
  146. - update to latest upstream version
  147. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-2
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  149. * Sat Jan 05 2013 Iain Arnell <iarnell@gmail.com> 2.00-1
  150. - update to latest upstream version
  151. * Sun Oct 28 2012 Iain Arnell <iarnell@gmail.com> 1.12-1
  152. - update to latest upstream version
  153. * Sat Oct 27 2012 Iain Arnell <iarnell@gmail.com> 1.10-1
  154. - update to latest upstream version
  155. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-3
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  157. * Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 1.09-2
  158. - Perl 5.16 rebuild
  159. * Tue Apr 03 2012 Iain Arnell <iarnell@gmail.com> 1.09-1
  160. - update to latest upstream version
  161. * Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> 1.08-3
  162. - drop tests subpackage; move tests to main package documentation
  163. * Tue Jan 17 2012 Iain Arnell <iarnell@gmail.com> - 1.08-2
  164. - rebuilt again for F17 mass rebuild
  165. * Fri Jan 13 2012 Iain Arnell <iarnell@gmail.com> 1.08-1
  166. - update to latest upstream version
  167. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.07-3
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  169. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.07-2
  170. - Perl mass rebuild
  171. * Sun Mar 13 2011 Iain Arnell <iarnell@gmail.com> 1.07-1
  172. - update to latest upstream version
  173. - clean up spec for modern rpmbuild
  174. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.05-4
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  176. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.05-3
  177. - 661697 rebuild for fixing problems with vendorach/lib
  178. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.05-2
  179. - Mass rebuild with perl-5.12.0
  180. * Mon Mar 01 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.05-1
  181. - update by Fedora::App::MaintainerTools 0.004
  182. - PERL_INSTALL_ROOT => DESTDIR
  183. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 1.04-2
  184. - rebuild against perl 5.10.1
  185. * Fri Jul 31 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.04-1
  186. - auto-update to 1.04 (by cpan-spec-update 0.01)
  187. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.02-2
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  189. * Mon Jun 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.02-1
  190. - auto-update to 1.02 (by cpan-spec-update 0.01)
  191. - altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  192. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.01-4
  193. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  194. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-3
  195. - remove MM version qualifier (F-8's is older)
  196. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-2
  197. - bump
  198. * Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-1
  199. - initial Fedora packaging
  200. - generated with cpan2dist (CPANPLUS::Dist::Fedora version 0.0.1)