perl-B-Hooks-EndOfScope-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352
  1. %bcond_with test
  2. # Run extra test
  3. %bcond_with perl_B_Hooks_EndOfScope_enables_extra_test
  4. # Run optional test
  5. %bcond_with perl_B_Hooks_EndOfScope_enables_optional_test
  6. Summary: Execute code after scope compilation finishes
  7. Name: perl-B-Hooks-EndOfScope
  8. Version: 0.25
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPL+ or Artistic
  14. URL: https://metacpan.org/release/B-Hooks-EndOfScope
  15. Source0: https://cpan.metacpan.org/authors/id/E/ET/ETHER/B-Hooks-EndOfScope-%{version}.tar.gz
  16. Patch0: B-Hooks-EndOfScope-0.13-shellbangs.patch
  17. BuildArch: noarch
  18. # Build
  19. BuildRequires: coreutils
  20. BuildRequires: findutils
  21. BuildRequires: make
  22. BuildRequires: perl >= 2:5.34.0
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. BuildRequires: perl(lib)
  25. BuildRequires: perl(Text::ParseWords)
  26. # Dependencies of bundled ExtUtils::HasCompiler
  27. BuildRequires: perl(base)
  28. BuildRequires: perl(Config)
  29. BuildRequires: perl(DynaLoader)
  30. BuildRequires: perl(Exporter)
  31. BuildRequires: perl(File::Basename)
  32. BuildRequires: perl(File::Spec::Functions)
  33. BuildRequires: perl(File::Temp)
  34. # Common Module Requirements
  35. BuildRequires: perl(Module::Implementation)
  36. BuildRequires: perl(Sub::Exporter::Progressive)
  37. BuildRequires: perl(strict)
  38. BuildRequires: perl(warnings)
  39. # PP Implementation Only
  40. BuildRequires: perl(Carp)
  41. BuildRequires: perl(constant)
  42. BuildRequires: perl(Hash::Util::FieldHash)
  43. BuildRequires: perl(Scalar::Util)
  44. BuildRequires: perl(Tie::Hash)
  45. BuildRequires: perl(Tie::StdHash)
  46. # XS Implementation Only
  47. BuildRequires: perl(Variable::Magic)
  48. # Test suite
  49. %if %{with test}
  50. BuildRequires: perl(Config)
  51. BuildRequires: perl(Devel::Hide)
  52. BuildRequires: perl(File::Glob)
  53. BuildRequires: perl(File::Spec)
  54. BuildRequires: perl(IPC::Open2)
  55. BuildRequires: perl(Test::More)
  56. # Optional Tests
  57. %if %{with perl_B_Hooks_EndOfScope_enables_optional_test}
  58. BuildRequires: perl(CPAN::Meta)
  59. BuildRequires: perl(CPAN::Meta::Prereqs)
  60. %endif
  61. # Author/Release tests
  62. # Note:
  63. # * Test::Pod::No404s intentionally omitted as it would fail due to
  64. # missing connectivity in the koji build environment
  65. # * ExtUtils::HasCompiler is bundled, so we don't need to BuildRequire it
  66. %if %{with perl_B_Hooks_EndOfScope_enables_extra_test}
  67. BuildRequires: perl(blib)
  68. BuildRequires: perl(Encode)
  69. BuildRequires: perl(IO::Handle)
  70. BuildRequires: perl(IPC::Open3)
  71. BuildRequires: perl(Path::Tiny)
  72. BuildRequires: perl(Pod::Coverage::TrustPod)
  73. BuildRequires: perl(Pod::Wordlist)
  74. BuildRequires: perl(Test::CPAN::Changes)
  75. BuildRequires: perl(Test::CPAN::Meta)
  76. BuildRequires: perl(Test::Deep)
  77. BuildRequires: perl(Test::EOL)
  78. BuildRequires: perl(Test::Kwalitee)
  79. BuildRequires: perl(Test::MinimumVersion)
  80. BuildRequires: perl(Test::Mojibake)
  81. BuildRequires: perl(Test::More)
  82. BuildRequires: perl(Test::NoTabs)
  83. BuildRequires: perl(Test::Pod)
  84. BuildRequires: perl(Test::Pod::Coverage)
  85. BuildRequires: perl(Test::Portability::Files)
  86. BuildRequires: perl(Test::Spelling), hunspell-en
  87. %endif
  88. %endif
  89. # Runtime
  90. Requires: perl >= 2:5.34.0
  91. %description
  92. This module allows you to execute code when Perl has finished compiling the
  93. surrounding scope.
  94. %prep
  95. %setup -q -n B-Hooks-EndOfScope-%{version}
  96. # Remove shellbangs from tests to placate rpmlint
  97. %patch0
  98. # British-English spelling LICENCE upsets US spell checker
  99. echo LICENCE >> xt/author/pod-spell.t
  100. %build
  101. perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
  102. make %{?_smp_mflags}
  103. %install
  104. make pure_install DESTDIR=%{buildroot}
  105. %{_fixperms} -c %{buildroot}
  106. %if %{with test}
  107. %check
  108. %if %{with perl_B_Hooks_EndOfScope_enables_extra_test}
  109. export AUTHOR_TESTING=1
  110. %endif
  111. make test
  112. %if %{with perl_B_Hooks_EndOfScope_enables_extra_test}
  113. make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
  114. %endif
  115. %endif
  116. %files
  117. %license LICENCE
  118. %doc Changes CONTRIBUTING README t/
  119. %{perl_vendorlib}/B/
  120. %{_mandir}/man3/B::Hooks::EndOfScope.3*
  121. %{_mandir}/man3/B::Hooks::EndOfScope::PP.3*
  122. %{_mandir}/man3/B::Hooks::EndOfScope::XS.3*
  123. %changelog
  124. * Sat Nov 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.25-1
  125. - new upstream release.
  126. - built with perl-5.34.0.
  127. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24-6
  128. - initial build for Vine Linux.
  129. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.24-5
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  131. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24-4
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  133. * Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.24-3
  134. - Perl 5.28 re-rebuild of bootstrapped packages
  135. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.24-2
  136. - Perl 5.28 rebuild
  137. * Tue Apr 24 2018 Paul Howarth <paul@city-fan.org> - 0.24-1
  138. - Update to 0.24
  139. - Fix memory corruption on perls 5.8.0 - 5.8.3
  140. - Improve use of constants in compile-time perl version checks
  141. - BR: perl-generators unconditionally
  142. - Drop legacy Group: tag
  143. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-6
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  145. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-5
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  147. * Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-4
  148. - Perl 5.26 re-rebuild of bootstrapped packages
  149. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-3
  150. - Perl 5.26 rebuild
  151. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-2
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  153. * Thu May 26 2016 Paul Howarth <paul@city-fan.org> - 0.21-1
  154. - Update to 0.21
  155. - Work with Object::Remote by removing require() call on Tie::StdHash in PP
  156. * Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.20-3
  157. - Perl 5.24 re-rebuild of bootstrapped packages
  158. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.20-2
  159. - Perl 5.24 rebuild
  160. * Sat May 7 2016 Paul Howarth <paul@city-fan.org> - 0.20-1
  161. - Update to 0.20
  162. - Remove unnecessary and erroneous extra crud in inc/
  163. * Tue May 3 2016 Paul Howarth <paul@city-fan.org> - 0.19-1
  164. - Update to 0.19
  165. - More Makefile.PL updates
  166. - Makefile.PL now checks for a working compiler using ExtUtils::HasCompiler
  167. (inlined into the build) rather than ExtUtils::CBuilder (CPAN RT#113685)
  168. - Simplify find command using -delete
  169. - Fix EPEL conditional - only currently buildable for EPEL 7 onwards
  170. - Drop BR: for Test::Pod::No404s, which breaks koji builds
  171. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.15-5
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  173. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-4
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  175. * Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.15-3
  176. - Perl 5.22 re-rebuild of bootstrapped packages
  177. * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.15-2
  178. - Perl 5.22 rebuild
  179. * Fri May 15 2015 Paul Howarth <paul@city-fan.org> - 0.15-1
  180. - Update to 0.15
  181. - Updated the tooling for generating Makefile.PL
  182. - Removed Tie::StdHash from prereqs, which is not require()able as a module
  183. on its own, despite being indexed (GH #3)
  184. - Fixed the addition in release 0.14 of Hash::Util::FieldHash as a
  185. prerequisite (which is not available prior to perl 5.010) for pure-perl
  186. installations (CPAN RT#104435)
  187. * Sun Feb 1 2015 Paul Howarth <paul@city-fan.org> - 0.14-1
  188. - Update to 0.14
  189. - Line numbers in shipped code are now the same as the repository source, for
  190. easier debugging
  191. - More accurate dynamic prereq declarations
  192. - Use %%license
  193. * Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.13-5
  194. - Perl 5.20 re-rebuild of bootstrapped packages
  195. * Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.13-4
  196. - Perl 5.20 rebuild
  197. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-3
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  199. * Wed Jan 15 2014 Paul Howarth <paul@city-fan.org> - 0.13-2
  200. - Bootstrap EPEL-7 build
  201. * Wed Jan 8 2014 Paul Howarth <paul@city-fan.org> - 0.13-1
  202. - Update to 0.13
  203. - Variable::Magic added as a runtime recommendation for greater visibility
  204. (CPAN RT#89245)
  205. - Fixed broken logic in compiler detection on older perls
  206. - Fixed inaccurate repository metadata
  207. - This release by ETHER -> update source URL
  208. - Drop Pod Coverage patch, no longer needed
  209. - Update shellbang patch
  210. - Don't run the release tests when bootstrapping
  211. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-4
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  213. * Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.12-3
  214. - Perl 5.18 rebuild
  215. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-2
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  217. * Wed Dec 5 2012 Paul Howarth <paul@city-fan.org> - 0.12-1
  218. - Update to 0.12
  219. - Complete pure-perl implementation in addition to the one based on
  220. Variable::Magic; you can specify the implementation explicitly by use-ing
  221. B::Hooks::EndOfScope::PP or B::Hooks::EndOfScope::XS, or by setting
  222. $ENV{B_HOOKS_ENDOFSCOPE_IMPLEMENTATION} to either 'XS' or 'PP'
  223. - Switch from using Sub::Exporter to the more conservative
  224. Sub::Exporter::Progressive
  225. - Add patch to fix POD coverage issues in new pure-perl implementation
  226. - This release by BOBTFISH -> update source URL
  227. - BR: perl(ExtUtils::CBuilder) ≥ 0.26, perl(Devel::Hide) ≥ 0.0007,
  228. perl(Module::Implementation) ≥ 0.05 and perl(Module::Runtime) ≥ 0.012
  229. - BR: perl(Sub::Exporter::Progressive) rather than perl(Sub::Exporter)
  230. - BR: perl(base), perl(constant), perl(Hash::Util::FieldHash) and
  231. perl(Scalar::Util) for the pure-perl implementation
  232. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-3
  233. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  234. * Fri Jun 15 2012 Petr Pisar <ppisar@redhat.com> - 0.11-2
  235. - Perl 5.16 rebuild
  236. * Thu Feb 23 2012 Paul Howarth <paul@city-fan.org> - 0.11-1
  237. - Update to 0.11 (a minor efficiency improvement)
  238. - Bump perl(Variable::Magic) version requirement to 0.48
  239. * Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.10-1
  240. - Update to 0.10 (stop propagating our magic through localisation)
  241. - Package LICENSE file
  242. - Downgrade ExtUtils::MakeMaker version requirement to 6.30
  243. - Upgrade Test::More version requirement to 0.89
  244. - Drop Test::Pod version requirement for EPEL-6 spec compatibility
  245. - BR: perl(Test::EOL) and perl(Test::NoTabs) for additional test coverage
  246. - Clean up for modern rpmbuild since we have no branches prior to EPEL-6
  247. - Don't specify BuildRoot:
  248. - Skip cleaning of buildroot in %%install
  249. - Remove %%clean section
  250. - Drop redundant %%defattr
  251. - Remove shellbangs from tests to placate rpmlint
  252. * Tue Jan 17 2012 Paul Howarth <paul@city-fan.org> - 0.09-1
  253. - Update to 0.09 (improve distribution metadata)
  254. - Run release tests too
  255. - BR: perl(Pod::Coverage::TrustPod), perl(Test::Pod) and
  256. perl(Test::Pod::Coverage) for release tests
  257. - Spec clean-up:
  258. - Make %%files list more explicit
  259. - Use DESTDIR rather than PERL_INSTALL_ROOT
  260. - Use tabs
  261. - Split buildreqs by Build/Module/Tests/Release tests
  262. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-8
  263. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  264. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.08-7
  265. - Perl mass rebuild
  266. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-6
  267. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  268. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-5
  269. - Rebuild to fix problems with vendorarch/lib (#661697)
  270. * Thu Apr 29 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-4
  271. - Mass rebuild with perl-5.12.0
  272. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.08-3
  273. - rebuild against perl 5.10.1
  274. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-2
  275. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  276. * Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-1
  277. - auto-update to 0.08 (by cpan-spec-update 0.01)
  278. - altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  279. - altered br on perl(Variable::Magic) (0.31 => 0.34)
  280. * Sun Mar 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.07-1
  281. - update to 0.07
  282. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
  283. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  284. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.04-1
  285. - update for submission
  286. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.04-0.1
  287. - initial RPM packaging
  288. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)