clearsilver-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %bcond_with ruby
  2. Summary: A fast, powerful, and language-neutral HTML template system.
  3. Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
  4. Name: clearsilver
  5. Version: 0.10.5
  6. Release: 13%{_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. # Technically, the license is "Neotonic ClearSilver", but it is a copy of
  11. # ASL 1.1 with the trademarks as the only difference.
  12. License: ASL 1.1
  13. URL: http://clearsilver.net/
  14. Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
  15. Patch0: clearsilver-0.10.5-conf.patch
  16. Patch1: clearsilver-0.10.5-regression.patch
  17. Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
  18. Patch3: clearsilver-ruby-1.9.patch
  19. Patch4: clearsilver-ruby-2.2.patch
  20. # GCC 5 compatibility, bug #1190760
  21. Patch5: clearsilver-0.10.5-gcc5.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: perl
  24. BuildRequires: perl-generators
  25. BuildRequires: perl(ExtUtils::MakeMaker)
  26. %if %{with ruby}
  27. BuildRequires: ruby
  28. BuildRequires: ruby-devel >= 1.9.3
  29. %endif
  30. BuildRequires: zlib-devel
  31. BuildRequires: libxcrypt-devel
  32. %description
  33. ClearSilver is a fast, powerful, and language-neutral template system.
  34. It is designed to make it easy to create template driven static or
  35. dynamic websites.
  36. %description -l ja
  37. Clearsilver は高速、強力で言語中立なテンプレートシステムです。
  38. テンプレート駆動の静的あるいは動的な Web サイトの構築を
  39. 容易にすることを目指して設計されています。
  40. %package -n perl-%{name}
  41. Summary: Perl interface to the ClearSilver HTML templating system
  42. Requires: perl >= 2:5.34.0
  43. %description -n perl-%{name}
  44. %{summary}.
  45. %if %{with ruby}
  46. %package -n ruby-%{name}
  47. Summary: Ruby interface to the ClearSilver HTML templating system
  48. %description -n ruby-%{name}
  49. %{summary}.
  50. %endif
  51. %debug_package
  52. %prep
  53. %setup -q
  54. %patch0 -p1 -b .conf
  55. %patch1 -p1
  56. %patch2 -p1
  57. %if %{with ruby}
  58. %patch3 -p1
  59. %patch4 -p1
  60. %endif
  61. %patch5 -p2
  62. touch configure
  63. sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
  64. %build
  65. %configure \
  66. %if ! %{with ruby}
  67. --disable-ruby \
  68. %endif
  69. --disable-csharp
  70. %ifarch x86_64
  71. perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
  72. %endif
  73. make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
  74. cd perl && %{__perl} Makefile.PL INSTALLDIRS=vendor && cd ..
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make DESTDIR=${RPM_BUILD_ROOT} install
  78. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  79. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  80. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  81. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  82. chmod -R u+w $RPM_BUILD_ROOT/*
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files
  86. %defattr(-,root,root)
  87. %license CS_LICENSE LICENSE
  88. %doc INSTALL README
  89. %{_bindir}/*
  90. %{_includedir}/ClearSilver/
  91. %{_libdir}/*.a
  92. %{_mandir}/man*/*.gz
  93. %files -n perl-clearsilver
  94. %doc CS_LICENSE LICENSE
  95. %defattr(-,root,root,-)
  96. %{perl_vendorarch}/auto/ClearSilver/
  97. %{perl_vendorarch}/ClearSilver.pm
  98. %if %{with ruby}
  99. %files -n ruby-clearsilver
  100. %{ruby_vendorarchdir}/*.so
  101. %{ruby_vendorlibdir}/*.rb
  102. %endif
  103. %changelog
  104. * Sat Nov 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-13
  105. - rebuilt with perl-5.34.0.
  106. - dropped python support.
  107. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-12
  108. - rebuilt with perl-5.26.
  109. - added BR:libxcrypt-devel.
  110. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
  111. - added Patch5 for gcc5.
  112. - disabled ruby stuff.
  113. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
  114. - rebuild with ruby-2.2.3
  115. - add Patch4 (clearsilver-ruby-2.2.patch) from fedora
  116. * Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
  117. - rebuilt with perl 5.16.3 and ruby 2.1.5
  118. * Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
  119. - rebuilt with ruby-2.0.0.353.
  120. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
  121. - rebuild with ruby-1.9.3
  122. - add patch3 to build with ruby-1.9
  123. - add patch2 for CVE-2011-4357
  124. * Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
  125. - rebuilt with python-2.7.
  126. * Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
  127. - rebuilt with perl-5.12.3 and python-2.6.
  128. * Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
  129. - applied new versioning policy, spec in utf-8
  130. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
  131. - rebuilt with python-2.5.2
  132. - added clearsilver-0.10.5-conf.patch
  133. * Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
  134. - rebuilt with perl-5.10.0.
  135. * Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
  136. - x86_64: make to skip testing.
  137. * Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
  138. - add --disable-csharp for configure script
  139. * Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
  140. - initial build for Vine Linux