qca2-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. %define qt4_ver 4.6.3
  2. Name: qca2
  3. Summary: Qt Cryptographic Architecture
  4. Version: 2.0.2
  5. Release: 8%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://delta.affinix.com/qca
  9. Source0: http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: qt4-devel = %{qt4_ver}
  12. BuildRequires: pkgconfig
  13. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  14. %description
  15. Taking a hint from the similarly-named Java Cryptography Architecture,
  16. QCA aims to provide a straightforward and cross-platform crypto API,
  17. using Qt datatypes and conventions. QCA separates the API from the
  18. implementation, using plugins known as Providers. The advantage of this
  19. model is to allow applications to avoid linking to or explicitly depending
  20. on any particular cryptographic library. This allows one to easily change
  21. or upgrade crypto implementations without even needing to recompile the
  22. application!
  23. %package devel
  24. Summary: Qt Cryptographic Architecture development files
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: qt4-devel = %{_qt4_version}
  28. %description devel
  29. This packages contains the development files for QCA
  30. %prep
  31. %setup -q -n qca-%{version}
  32. %build
  33. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  34. MAKE=%{_bindir}/make \
  35. ./configure \
  36. --prefix=%{_prefix} \
  37. --includedir=%{_includedir} \
  38. --libdir=%{_libdir} \
  39. --datadir=%{_datadir} \
  40. --no-separate-debug-info \
  41. --verbose
  42. sed -i -e /strip/d Makefile
  43. make %{?_smp_mflags}
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make install INSTALL_ROOT=$RPM_BUILD_ROOT
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %post -p /sbin/ldconfig
  50. %postun -p /sbin/ldconfig
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc COPYING README TODO
  54. %{_bindir}/qcatool2
  55. %{_libdir}/*.so.*
  56. %{_mandir}/*/*
  57. %files devel
  58. %defattr(-,root,root,-)
  59. %{_includedir}/QtCrypto
  60. %{_libdir}/*.so
  61. %{_libdir}/pkgconfig/qca2.pc
  62. %{_libdir}/libqca.prl
  63. %{_libdir}/qt-%{_qt4_version}/mkspecs/features/crypto.prf
  64. %changelog
  65. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
  66. - rebuilt with rpm-4.8.1
  67. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
  68. - rebuilt with qt-4.6.3 again
  69. - change BuildRequires: qt4-devel = %{qt4_ver} (add version)
  70. * Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
  71. - rebuilt with qt-4.6.3
  72. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
  73. - rebuilt with new toolchain, qt4-4.6.1
  74. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
  75. - rebuilt with qt-4.5.3
  76. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
  77. - Initial build for Vine Linux
  78. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  80. * Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
  81. - new upstream release - qt 4.5-compat-fixes
  82. * Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
  83. - new upstream release
  84. - removed 64bit patch - now upstream
  85. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  87. * Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
  88. - crypto.prf is in libdir not datadir
  89. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
  90. - Autorebuild for GCC 4.3
  91. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
  92. - version 2.0.0 final
  93. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
  94. - fix build on x86_64
  95. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
  96. - missing BR: openssl
  97. * Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
  98. - review from bug 289681 (thanks Rex)
  99. * Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
  100. - initial package