R-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577
  1. %define pkg_name R
  2. %define pkg_version 3.4.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
  13. # Source1: R.desktop
  14. # Patch0: R-release.diff.gz
  15. # To avoid 'make check error'
  16. Patch1: reg-tests-3.R.patch
  17. Patch2: reg-tests-3.Rout.save.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: gcc-c++
  20. BuildRequires: gcc-gfortran libgfortran
  21. BuildRequires: texinfo
  22. %if %{?_dist_release} == "vl6"
  23. # BuildRequires: tcl tk
  24. BuildRequires: tcl85-devel tk85-devel
  25. %endif
  26. %if %{?_dist_release} >= "vl7"
  27. BuildRequires: tcl-devel tk-devel
  28. %endif
  29. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  30. BuildRequires: readline-devel ncurses-devel
  31. BuildRequires: zlib-devel bzip2-devel xz-devel
  32. BuildRequires: pcre-devel
  33. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  34. BuildRequires: cairo-devel pango-devel
  35. BuildRequires: libicu-devel
  36. BuildRequires: curl-devel
  37. BuildRequires: texlive-common
  38. BuildRequires: texlive-collection-basic
  39. BuildRequires: texlive-collection-latexextra
  40. BuildRequires: texlive-collection-fontsextra
  41. %if %{?_dist_release} == "vl6"
  42. BuildRequires: texlive-collection-texinfo
  43. %endif
  44. %if %{?_dist_release} >= "vl7"
  45. BuildRequires: texlive-collection-plainextra
  46. BuildRequires: texlive-collection-fontsrecommended
  47. %endif
  48. BuildRequires: java-devel
  49. Requires: libgfortran
  50. Requires: libicu
  51. # Requires: tcl tk
  52. %if %{?_dist_release} == "vl6"
  53. Requires: tcl85 tk85
  54. %endif
  55. %if %{?_dist_release} >= "vl7"
  56. Requires: tcl tk
  57. %endif
  58. Conflicts: R-devel < %{version}-%{release}
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. Packager: ara_t
  62. %description
  63. 'GNU S' - A language and environment for statistical computing and
  64. graphics. R is similar to the award-winning S system, which was
  65. developed at Bell Laboratories by John Chambers et al. It provides
  66. a wide variety of statistical and graphical techniques (linear and
  67. nonlinear modelling, statistical tests, time series analysis,
  68. classification, clustering, ...).
  69. R is designed as a true computer language with control-flow
  70. constructions for iteration and alternation, and it allows users to
  71. add additional functionality by defining new functions.
  72. For computationally intensive tasks, C, C++ and Fortran code
  73. can be linked and called at run time.
  74. %description -l ja
  75. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  76. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  77. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  78. 幅広い統計解析・視覚化手法を提供する。
  79. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  80. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  81. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  82. 使用することができる。
  83. # %package devel
  84. # Summary: files for development of R packages.
  85. # Summary(ja): Rパッケージ開発用ファイル
  86. # Group: Development/Libraries
  87. # Requires: R = %{version}-%{release}
  88. # %description devel
  89. # Install R-devel if you are going to develop or compile R packages.
  90. # This is just a stub package containing the documentation on
  91. # "Writing R Extensions". However, installing it will ensure that
  92. # the build environment for R packages is correct.
  93. # %description -l ja devel
  94. # Rパッケージを開発したりコンパイルする場合には、このR-develを
  95. # インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  96. # が含まれているだけのサブパッケージですが、正しくRパッケージを
  97. # 開発するための助けになるでしょう。
  98. %package -n libRmath
  99. Summary: standalone math library from the R project
  100. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  101. Group: System Environment/Libraries
  102. %description -n libRmath
  103. A standalone library of mathematical and statistical functions derived
  104. from the R project. This packages provides the shared libRmath library.
  105. %description -l ja -n libRmath
  106. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  107. 共有ライブラリを提供する。
  108. %package -n libRmath-devel
  109. Summary: standalone math library from the R project
  110. Summary(ja): libRmathの開発ライブラリ
  111. Group: Development/Libraries
  112. Requires: libRmath = %{version}-%{release}
  113. %description -n libRmath-devel
  114. A standalone library of mathematical and statistical functions derived
  115. from the R project. This packages provides the header files.
  116. %description -l ja -n libRmath-devel
  117. libRmathのヘッダファイル(Rmath.h)
  118. %package -n libRmath-static
  119. Summary: Static R Standalone math library
  120. Summary(ja): libRmath の静的ライブラリ
  121. Group: Development/Libraries
  122. Requires: libRmath-devel = %{version}-%{release}
  123. %description -n libRmath-static
  124. A standalone library of mathematical and statistical functions derived
  125. from the R project. This package provides the static libRmath library.
  126. %prep
  127. %{__rm} -rf ${RPM_BUILD_ROOT}
  128. %setup -q
  129. # %patch0 -p1
  130. %patch1
  131. %patch2
  132. cat > R.desktop <<EOF
  133. [Desktop Entry]
  134. Name=GNU R
  135. Comment=A language for data analysis and graphics
  136. TryExec=/usr/bin/R
  137. Exec=/usr/bin/R
  138. Icon=/usr/share/icons/logo.jpg
  139. Terminal=true
  140. Type=Application
  141. Categories=Education;Science;
  142. StartupNotify=false
  143. EOF
  144. %build
  145. export R_PDFVIEWER="%{_bindir}/xdg-open"
  146. export R_PRINTCMD="lpr"
  147. export R_BROWSER="%{_bindir}/xdg-open"
  148. export TZ="Asia/Tokyo"
  149. %{configure} --enable-R-shlib --with-tcltk \
  150. %if %{?_dist_release} == "vl6"
  151. --with-tcl-config=%{_libdir}/tclConfig85.sh \
  152. --with-tk-config=%{_libdir}/tkConfig85.sh
  153. %endif
  154. %{__make} %{?_smp_mflags}
  155. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  156. LANG=C %{__make} check
  157. %{__make} pdf
  158. %install
  159. %{make_install}
  160. %{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
  161. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  162. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  163. # Install libRmath files
  164. (cd src/nmath/standalone; %{make_install})
  165. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  166. echo "%{_libdir}/R/lib" > \
  167. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  168. # Fix lication of R_HOME_DIR in shell wrapper
  169. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  170. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  171. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  172. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  173. > ${RPM_BUILD_ROOT}%{_bindir}/R
  174. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  175. # add R into menu
  176. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  177. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  178. %{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
  179. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  180. # move PDF manuals
  181. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  182. %{__mv} ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/manual/*.pdf \
  183. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  184. %clean
  185. %{__rm} -rf ${RPM_BUILD_ROOT}
  186. %post -p %{_syssbindir}/ldconfig
  187. %postun -p %{_syssbindir}/ldconfig
  188. %post -n libRmath -p %{_syssbindir}/ldconfig
  189. %postun -n libRmath -p %{_syssbindir}/ldconfig
  190. %files
  191. %defattr(-, root, root)
  192. %{_bindir}/R
  193. %{_bindir}/Rscript
  194. %{_libdir}/R
  195. %{_datadir}/applications/*
  196. %{_datadir}/icons/*
  197. %{_mandir}/man1/*
  198. %{_docdir}/%{name}-%{version}/*
  199. %{_sysconfdir}/ld.so.conf.d/*
  200. # %files devel
  201. # %defattr(-, root, root)
  202. # %doc doc/manual/R-exts.pdf
  203. %files -n libRmath
  204. %defattr(-, root, root)
  205. %{_libdir}/libRmath.so
  206. %files -n libRmath-devel
  207. %defattr(-, root, root)
  208. %{_libdir}/pkgconfig/*.pc
  209. %{_includedir}/Rmath.h
  210. %files -n libRmath-static
  211. %defattr(-, root, root)
  212. %{_libdir}/libRmath.a
  213. %changelog
  214. * Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  215. - Updated to 3.4.0
  216. - add Patch1 and Patch2 to avoid 'make check' error
  217. - add export TZ="Asia/Tokyo" to avoid 'make check' error
  218. - delete descrption about info
  219. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
  220. - Updated to 3.3.3
  221. * Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
  222. - use tcl-8.5/tk-8.5 for Vine6.5
  223. - BuildRequires to tcl85-devel/tk85-devel
  224. - Requires to tcl85/tk85
  225. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
  226. - merge SPEC file for Vine6
  227. - drop devel package
  228. - move PDF manuals to /usr/share/doc/R-%%{version}
  229. - revert logo of menu item to logo.jpg
  230. * Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
  231. - Updated to 3.3.2
  232. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  233. - Updated to 3.3.1
  234. - delete BuildRequires: texlive-collection-lang*
  235. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  236. - add BuildRequires: texlive-collection-lang*
  237. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  238. - Updated to 3.3.0
  239. - add BuildRequires: pcre-devel xz-devel
  240. - change logo of menu item to Rlogo.svg
  241. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  242. - correct SPEC file
  243. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  244. - Updated to 3.2.4-revised
  245. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  246. - Updated to 3.2.4
  247. - fixed build error in src/extra/xz
  248. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  249. - add BuildRequires: curl-devel
  250. - add BuildRequires: libgomp
  251. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  252. - Updated to 3.2.3
  253. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  254. - rebuild with icu-56.1
  255. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  256. - Updated to 3.2.2
  257. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  258. - add configure options: --with-tcltk
  259. - add BuildRequires: tcl-devel tk-devel
  260. - add Requires: tcl tk
  261. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  262. - Updated to 3.2.1
  263. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  264. - add "LIBS=-lbz2" to configure option
  265. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  266. - Updated to 3.2.0
  267. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  268. - Updated to 3.1.3
  269. - added BuildRequires: texlive-collection-fontsextra for Vine6
  270. - changed option "make check-all" to "make check"
  271. - to avoid error in checking of mgcv package
  272. - changed orders of BuildRequires
  273. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  274. - rebuild with icu-54.1
  275. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  276. - Updated to 3.1.2
  277. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  278. - Updated to 3.1.1
  279. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  280. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  281. - add patch (2014-04-26)
  282. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  283. - Updated to 3.1.0
  284. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  285. - Updated to 3.0.3
  286. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  287. - rebuild current VineSeed
  288. - add patch (2014-01-06)
  289. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  290. - add Requires: libicu
  291. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  292. - combine spec files Vine6 and VineSeed
  293. - correct the days of the week in changelog
  294. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  295. - delete BuildRequires: texlive-collection-texinfo
  296. - add BuildRequires: texlive-collection-plainextra
  297. - add BuildRequires: texlive-collection-latexextra
  298. - add BuildRequires: texlive-collection-fontsrecommended
  299. - for VineSeed
  300. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  301. - Updated to 3.0.2
  302. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  303. - Updated to 3.0.1
  304. - add BuildRequires: java-1.6.0-openjdk-devel
  305. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  306. - Updated to 3.0.0
  307. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  308. - Updated to 2.15.3
  309. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  310. - use BuildRequires ncurses-devel instead of libtermcap-devel
  311. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  312. - Updated to 2.15.2
  313. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  314. - changed group to Applications/Edutainment
  315. - added R to menu
  316. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  317. - Updated to 2.15.1
  318. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  319. - Updated to 2.15.0
  320. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  321. - Updated to 2.14.2
  322. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  323. - Updated to 2.14.1
  324. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  325. - Updated to 2.14.0
  326. - add BuildRequires: texlive-collection-fontsextra
  327. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  328. - Updated to 2.13.2
  329. - add BuildRequires: texlive-common
  330. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  331. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  332. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  333. - synchronized to VinePlus/5 package
  334. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  335. - Updated to 2.13.1
  336. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  337. - Updated to 2.13.0
  338. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  339. - Updated to 2.12.2
  340. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  341. - add BuildRequires: libicu-devel
  342. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  343. - synchronized to VinePlus/5 package
  344. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  345. - Updated to 2.12.1
  346. - added --enable-R-shlib option to %%configure
  347. - added static subpackage
  348. - use BR: texlive instead of tetex on VineSeed
  349. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  350. - rebuilt with rpm-4.8.1 for pkg-config
  351. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  352. - recompiled because tcl/tk were not linked
  353. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  354. - Updated to 2.11.0
  355. - added Requires: libgfortran
  356. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  357. - Updated to 2.10.1
  358. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  359. - patched to 2.10.0
  360. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  361. - spec in UTF-8
  362. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  363. - Updated to 2.10.0
  364. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  365. - Updated to 2.9.2
  366. - deleted BuildRequires: lapack-devel blas-devel
  367. - rewrote SPEC file
  368. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  369. - Updated to 2.5.1
  370. - added BuildRequires: gcc-gfortran for VineSeed
  371. - added BuildRequires: lapack-devel blas-devel
  372. v- fixed %preun script
  373. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  374. - Updated to 2.4.1
  375. - Added INFO option
  376. - Exclude Japanese Rprofile.site
  377. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  378. - Updated to 2.4.0
  379. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  380. - Added optimization flags
  381. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  382. - Packaged for VineLinux3.2
  383. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  384. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  385. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  386. - Packaged for VineLinux3.2
  387. - Slipped texinfo
  388. - Fixed preun error
  389. - Preset Japanese fonts
  390. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  391. - Packaged for VineLinux3.2
  392. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  393. - Restored CAPABILITIES file lost in 2.2.1beta
  394. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  395. - Configure uses --without-blas by default.
  396. - Install pdf manuals.
  397. - All toplevel documentation files are installed into _libdir/R
  398. as they may be required by R (qv note on AUTHORS and THANKS below).
  399. - Legacy scripts for rebuilding package indices removed.
  400. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  401. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  402. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  403. - The files AUTHORS and THANKS need to be installed into _libdir/R
  404. as they are required by the function contributors(). Previously
  405. they were installed only as documentation files.
  406. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  407. - Corrected date error in SPEC file.
  408. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  409. - Dropped support for Red Hat boxed set.
  410. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  411. including support for shared R library.
  412. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  413. with the default optimization flags, so there is a temporary work-around.
  414. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  415. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  416. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  417. - Install R-data.info file as well.
  418. - Make info processing conditional on texinfo version, not platform release,
  419. so that if a new enough version is installed, we will build and install info.
  420. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  421. - Built R 2.1.0. R now supports internationalization, so the patch
  422. to set the locale to "C" is now dropped.
  423. - install.packages() exits gracefully with a helpful message if
  424. the file INSTALL is not present, so this is now included in the
  425. R-devel package.
  426. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  427. - Added support for Scientific Linux (http://www.scientificlinux.org)
  428. A distribution based on RHEL. Thanks to Jon Peatfield.
  429. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  430. - Fixed file ownership in R-devel and libRmath packages
  431. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  432. - R-devel package is now a stub package with no files, except a documentation
  433. file (RPM won't accept sub-packages with no files). R now conflicts
  434. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  435. - Created libRmath subpackage with shared library.
  436. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  437. - Created R-devel and libRmath-devel subpackages
  438. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  439. - Built R 2.0.1
  440. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  441. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  442. gives "lpr".
  443. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  444. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  445. - Info support is now conditional on the macro Rinfo, which is only
  446. defined for Fedora 1 and 2.
  447. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  448. - Built R 2.0.0
  449. - There is no longer a BUGS file, so this is not installed as a
  450. documentation file.