phonon-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. %define qt4_ver 4.8.6
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  5. %define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
  6. %global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
  7. Name: phonon
  8. Summary: Multimedia framework api
  9. Summary(ja): マルチメディアフレームワーク API
  10. Version: 4.8.2
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://phonon.kde.org/
  15. Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.7.1/src/phonon-%{version}.tar.xz
  16. Patch1: phonon-4.7.1-no_rpath.patch
  17. ## Upstream patches
  18. ## Vine patches
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: automoc4 >= 0.9.86
  21. BuildRequires: cmake >= 2.6.2
  22. BuildRequires: glib2-devel
  23. BuildRequires: libqzeitgeist-devel
  24. BuildRequires: libxcb-devel
  25. BuildRequires: libxml2-devel
  26. BuildRequires: qt4-devel >= 4.6.0
  27. BuildRequires: openssl-devel
  28. BuildRequires: pulseaudio-libs-devel >= 0.9.15
  29. # TODO: enable the following Requires in next release
  30. Requires: phonon-backend >= 4.4
  31. Requires: pulseaudio-libs >= %{pulseaudio_version}
  32. Requires: qt4 >= %{_qt4_version}
  33. %description
  34. Phonon is a cross-platform portable Multimedia Support Abstraction,
  35. which allows you to play multiple audio or video formats with the same
  36. quality on all platforms, no matter which underlying architecture is
  37. used.
  38. %package devel
  39. Summary: Development files for phonon
  40. Summary(ja): phonon の開発用ファイル
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: qt4-devel >= %{_qt4_version}
  44. %description devel
  45. Header files for developing applications using phonon
  46. %prep
  47. %setup -q
  48. %patch1 -p1 -b .no_rpath
  49. %build
  50. %ifarch x86_64
  51. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  52. %endif
  53. mkdir -p %{_target_platform}
  54. pushd %{_target_platform}
  55. %cmake \
  56. -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
  57. ..
  58. popd
  59. make %{?_smp_mflags} -C %{_target_platform}
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  63. # symlink for qt/phonon compatibility
  64. ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
  65. # own these dirs
  66. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
  67. mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %post -p /sbin/ldconfig
  71. %postun -p /sbin/ldconfig
  72. %files
  73. %defattr(-,root,root)
  74. %doc COPYING.LIB
  75. %{_libdir}/*.so.*
  76. %{_qt4_plugindir}/designer/*.so
  77. %{_datadir}/dbus-1/interfaces/*
  78. # kde4-specific dirs
  79. %dir %{_libdir}/kde4/plugins/phonon_backend
  80. %dir %{_datadir}/kde4/services/phononbackends
  81. %files devel
  82. %defattr(-,root,root)
  83. %dir %{_includedir}/KDE
  84. %{_includedir}/KDE/Phonon/
  85. %{_includedir}/phonon/
  86. %{_libdir}/*.so
  87. %dir %{_libdir}/cmake/
  88. %{_libdir}/cmake/phonon/
  89. %{_libdir}/pkgconfig/*.pc
  90. %{_datadir}/phonon/buildsystem/
  91. %{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
  92. %changelog
  93. * Fri Nov 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.8.2-1
  94. - new upstream release
  95. * Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
  96. - new upstream release
  97. - update Patch1
  98. - remove Patch50 (phonon-4.5.57-plugindir.patch)
  99. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
  100. - new upstream release
  101. * Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  102. - new upstream release
  103. * Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  104. - added Patch100 and 200 to build with pulseaudio-1.0
  105. * Sun Jun 5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  106. - new upstream release
  107. - added BR: libqzeitgeist-devel
  108. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
  109. - rebuilt with qt4-4.7.2
  110. * Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
  111. - new upstream release
  112. - rebuilt with qt4-4.7.1 on VineSeed
  113. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
  114. - new upstream release
  115. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
  116. - added sybolic link in %%{_qt4_headerdir}
  117. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  118. - new upstream release
  119. - dropt Patch51 and 57
  120. - rebuilt with rpm-4.8.1
  121. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  122. - new upstream release
  123. - dropt Patch1, 50, 54 and 100
  124. - added Patch57
  125. * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
  126. - F11: patch/modularize pa device-manager bits
  127. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  128. - added qmake path to PATH (if x86_64)
  129. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  130. - new upstream release
  131. - built with new toolchain
  132. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  133. - added Patch102 and 103 from FC
  134. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  135. - fix for '#' in filenames
  136. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  137. - restore patches to the xine backend
  138. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  139. - added Patch100 and 101 from FC
  140. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  141. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  142. - added backend sub-pakcages
  143. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  144. - new upstream release
  145. - add BuildPrereq: cmake
  146. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  147. - new upstream release
  148. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  149. - new upstream release
  150. - update %%files
  151. - add BuildPrereq: xine-lib-devel libxcb-devel
  152. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  153. - new upstream release
  154. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  155. - added script to append qmake path
  156. - added option -DLIB_INSTALL_DIR at cmake
  157. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  158. - initial release for VineSeed