php-ext-mailparse-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. %bcond_without php80
  2. %bcond_without php74
  3. %define extname mailparse
  4. Summary: Email message manipulation for PHP
  5. Summary(ja): PHP用e-mailメッセージ操作拡張
  6. Name: php-ext-%{extname}
  7. Version: 3.1.1
  8. Release: 1%{_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: tomop
  13. License: The PHP License
  14. URL: https://pecl.php.net/package/mailparse
  15. Source: https://pecl.php.net/get/%{extname}-%{version}.tgz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. %description
  18. Mailparse is an extension for parsing and working with email messages.
  19. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  20. %description -l ja
  21.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  22. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  23. %if %{with php74}
  24. %package -n php74-ext-mailparse
  25. Summary: Email message manipulation for PHP-7.4
  26. Summary(ja): PHP-7.4用e-mailメッセージ操作拡張
  27. Group: programming
  28. BuildRequires: php74-devel
  29. %if "%{?req_php74_api}" != ""
  30. Requires: %{req_php74_api}
  31. %endif
  32. %description -n php74-ext-mailparse
  33. Mailparse is an extension for parsing and working with email messages.
  34. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  35. %description -n php74-ext-mailparse -l ja
  36.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  37. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  38. %endif
  39. %if %{with php80}
  40. %package -n php80-ext-mailparse
  41. Summary: Email message manipulation for PHP-8.0
  42. Summary(ja): PHP-8.0用e-mailメッセージ操作拡張
  43. Group: programming
  44. BuildRequires: php80-devel
  45. %if "%{?req_php80_api}" != ""
  46. Requires: %{req_php80_api}
  47. %endif
  48. %description -n php80-ext-mailparse
  49. Mailparse is an extension for parsing and working with email messages.
  50. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  51. %description -n php80-ext-mailparse -l ja
  52.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  53. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  54. %endif
  55. %debug_package
  56. %prep
  57. %setup -q -c -n %{extname}-%{version}
  58. cp %{extname}-%{version}/{LICENSE,README.md,CREDITS} ./
  59. %if %{with php74}
  60. cp -a %{extname}-%{version} php74
  61. pushd php74
  62. phpize74
  63. popd
  64. %endif
  65. %if %{with php80}
  66. cp -a %{extname}-%{version} php80
  67. pushd php80
  68. phpize80
  69. popd
  70. %endif
  71. %build
  72. %if %{with php74}
  73. pushd php74
  74. %configure --with-php-config=%{_bindir}/php-config74
  75. %__make %{?_smp_mflags}
  76. popd
  77. %endif
  78. %if %{with php80}
  79. pushd php80
  80. %configure --with-php-config=%{_bindir}/php-config80
  81. %__make %{?_smp_mflags}
  82. popd
  83. %endif
  84. %install
  85. rm -rf %{buildroot}
  86. %if %{with php74}
  87. mkdir -p %{buildroot}%{_libdir}/php74/
  88. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  89. pushd php74
  90. %makeinstall INSTALL_ROOT=%{buildroot}
  91. popd
  92. cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{extname}.ini <<EOF
  93. ; Enable %{extname} extension module
  94. extension=%{extname}.so
  95. EOF
  96. %endif
  97. %if %{with php80}
  98. mkdir -p %{buildroot}%{_libdir}/php80/
  99. mkdir -p %{buildroot}%{_sysconfdir}/php80/php.d
  100. pushd php80
  101. %makeinstall INSTALL_ROOT=%{buildroot}
  102. popd
  103. cat > %{buildroot}%{_sysconfdir}/php80/php.d/%{extname}.ini <<EOF
  104. ; Enable %{extname} extension module
  105. extension=%{extname}.so
  106. EOF
  107. %endif
  108. %clean
  109. rm -rf %{buildroot}
  110. %if %{with php74}
  111. %files -n php74-ext-mailparse
  112. %defattr(-,root,root)
  113. %license LICENSE
  114. %doc README CREDITS
  115. %{_libdir}/php74/*
  116. %config(noreplace) %{_sysconfdir}/php74/php.d/*
  117. %endif
  118. %if %{with php80}
  119. %files -n php80-ext-mailparse
  120. %defattr(-,root,root)
  121. %license LICENSE
  122. %doc README CREDITS
  123. %{_libdir}/php80/*
  124. %config(noreplace) %{_sysconfdir}/php80/php.d/*
  125. %endif
  126. %changelog
  127. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  128. - new upstream release.
  129. - added php80 support.
  130. - dropped php73 support.
  131. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
  132. - dropped Patch0: fixed in upstream.
  133. - added php74 support.
  134. - dropped php72 support.
  135. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-2
  136. - added php73 support.
  137. * Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-1
  138. - new upstream release.
  139. - built with php72.
  140. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-2
  141. - rebuilt with php5-5.6.7.
  142. * Fri Dec 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  143. - initial build.