Cython-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. Summary: A language for writing Python extension modules
  2. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  3. Name: Cython
  4. Version: 0.29.26
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Apache
  10. URL: https://cython.org/
  11. Source0: https://github.com/cython/cython/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python-rpm-macros
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python2-rpm-macros
  17. %debug_package
  18. %description
  19. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  20. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  21. This allows the compiler to generate very efficient C code from Cython code.
  22. The generated C code compiles with Python 2.4 and later (including Python 3).
  23. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  24. %package -n python3-Cython
  25. Summary: A language for writing Python extension modules
  26. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  27. Group: programming
  28. BuildRequires: python3-devel
  29. BuildRequires: python3-setuptools
  30. BuildRequires: python3-rpm-macros
  31. %description -n python3-Cython
  32. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  33. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  34. This allows the compiler to generate very efficient C code from Cython code.
  35. The generated C code compiles with Python 2.4 and later (including Python 3).
  36. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  37. %prep
  38. %setup -q -n cython-%{version}
  39. %build
  40. %{py2_build}
  41. %{py3_build}
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. %{py2_install}
  45. %{py3_install}
  46. %clean
  47. rm -rf $RPM_BUILD_ROOT
  48. %files
  49. %defattr(-,root,root,-)
  50. %license COPYING.txt LICENSE.txt
  51. %doc README.txt USAGE.txt
  52. #{_bindir}/cygdb
  53. #{_bindir}/cython
  54. #{_bindir}/cythonize
  55. %{python_sitearch}/Cython
  56. %{python_sitearch}/pyximport
  57. %{python_sitearch}/Cython-%{version}-*-info
  58. %{python_sitearch}/cython.*
  59. %files -n python3-Cython
  60. %license COPYING.txt LICENSE.txt
  61. %doc README.txt USAGE.txt
  62. %{_bindir}/cygdb
  63. %{_bindir}/cython
  64. %{_bindir}/cythonize
  65. %{python3_sitearch}/*
  66. %changelog
  67. * Tue Jan 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.26-1
  68. - new upstream release.
  69. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.21-1
  70. - new upstream release.
  71. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.13-1
  72. - new upstream release.
  73. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.4-1
  74. - new upstream release
  75. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  76. - new upstream release
  77. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21.2-1
  78. - new upstream release
  79. - moved to Development/Languages Group
  80. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.2-1
  81. - new upstream release
  82. * Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-1
  83. - new upstream release
  84. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.1-1
  85. - initial build for Vine Linux