netatalk-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %bcond_with force_uidgid
  2. %define rel_suffix %{?with_force_uidgid:.force_uidgid}
  3. %define _sysconfdir /etc
  4. ################################################# BASIC PACKAGE INFORMATION
  5. Summary: AppleTalk and AppleShare/IP services for Linux
  6. Summary(ja): Linux 用 AppleTalk, AppleShare/IP サービス
  7. Name: netatalk
  8. Version: 2.2.2
  9. Release: 2%{_dist_release}%{rel_suffix}
  10. License: GPLv2+
  11. Group: System Environment/Daemons
  12. URL: http://netatalk.sourceforge.net/
  13. Source0: %{name}-%{version}.tar.bz2
  14. # patch for default config file
  15. Patch10: netatalk-2.2.0-config-utf8.patch
  16. ############################################################## REQUIREMENTS
  17. Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
  18. Requires: cracklib, openssl, tcp_wrappers, pam, perl
  19. BuildRequires: openssl-devel, avahi-devel, pam-devel, libdb-devel,
  20. BuildRequires: quota, libgcrypt-devel, libacl-devel
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Obsoletes: netatalk-1.4b2+asun
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: shaolin
  26. %description
  27. Netatalk is a freely-available Open Source AFP fileserver. It also provides a
  28. kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
  29. running Netatalk is capable of serving many Macintosh clients simultaneously
  30. as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
  31. and for accessing AppleTalk printers via Printer Access Protocol (PAP).
  32. Included are a number of minor printing and debugging utilities.
  33. %description -l ja
  34. このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
  35. 扱うことができ, Macintosh と通信が可能になります.
  36. Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
  37. 稼働させることができるデーモンプログラムが収められています.
  38. %package devel
  39. Group: Development/Libraries
  40. Summary: Headers for AppleTalk development
  41. Summary(ja): AppleTalk 開発用ヘッダファイル
  42. %description devel
  43. This package contains the header files for building AppleTalk networking
  44. programs.
  45. %prep
  46. %setup -q
  47. %patch10 -p1 -b .cjk-config
  48. %if %{with force_uidgid}
  49. perl -pi -e 's/uid_t uid$/uid_t uid;/' etc/afpd/uid.c
  50. %endif
  51. %build
  52. touch AUTHORS
  53. ln -s NEWS ChangeLog
  54. rm -f README.cjk4.cjk
  55. libtoolize --force
  56. aclocal -I macros
  57. automake --add-missing
  58. autoconf
  59. autoheader
  60. CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
  61. ./configure \
  62. --prefix=%{_prefix} \
  63. --libdir=%{_libdir} \
  64. --libexecdir=%{_libdir}/netatalk \
  65. --sysconfdir=%{_sysconfdir} \
  66. --mandir=%{_mandir} \
  67. --localstatedir=%{_var} \
  68. --enable-shared \
  69. --enable-zeroconf \
  70. --disable-srvloc \
  71. --disable-ddp \
  72. --with-cnid-dbd-backend \
  73. --with-cnid-cdb-backend \
  74. --with-cnid-default-backend=dbd \
  75. --with-uams-path=%{_libdir}/netatalk \
  76. --enable-redhat-sysv \
  77. --with-cracklib \
  78. --with-pam \
  79. --with-shadow \
  80. --enable-tcp-wrappers \
  81. --with-acls \
  82. --enable-pgp-uam \
  83. %if %{with force_uidgid}
  84. --enable-force-uidgid
  85. %endif
  86. make all
  87. %install
  88. ### INSTALL (USING "make install") ###
  89. rm -rf ${RPM_BUILD_ROOT}
  90. mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
  91. make DESTDIR=$RPM_BUILD_ROOT install
  92. ## netatalk/at.h is now provided by glibc
  93. rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
  94. ## for Bonjour (requires nss-mdns)
  95. #install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
  96. #install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
  97. %pre
  98. ### COPY OLD PREFERENCE FILES ###
  99. if [ -d /etc/atalk ] ; then
  100. mkdir -p /etc/netatalk/
  101. cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
  102. fi
  103. exit 0
  104. %post
  105. ### RUN CHKCONFIG ###
  106. /sbin/chkconfig --add netatalk
  107. /sbin/ldconfig
  108. if test -r /var/lock/atalkd ; then
  109. /etc/rc.d/init.d/netatalk restart >&2
  110. fi
  111. %preun
  112. ### RUN CHKCONFIG ###
  113. /sbin/chkconfig --del netatalk
  114. %triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
  115. /sbin/chkconfig --add netatalk
  116. %clean
  117. rm -rf ${RPM_BUILD_ROOT}
  118. %files
  119. %defattr(-,root,root)
  120. %doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
  121. %doc ChangeLog NEWS
  122. %doc doc/[A-L,N-Z]*
  123. %config(noreplace) /etc/netatalk/Apple*
  124. %config(noreplace) /etc/netatalk/*.conf
  125. %config /etc/pam.d/netatalk
  126. %config /etc/rc.d/init.d/netatalk
  127. %dir %{_sysconfdir}/netatalk
  128. %dir %{_sysconfdir}/netatalk/msg
  129. #%{_sysconfdir}/avahi/services/afpd.service
  130. %{_bindir}/*
  131. %{_sbindir}/*
  132. %{_libdir}/netatalk/*
  133. %exclude %{_libdir}/netatalk/*.a
  134. %exclude %{_libdir}/netatalk/*.la
  135. %{_mandir}/*/*
  136. %files devel
  137. %defattr(-,root,root)
  138. %{_libdir}/*.a
  139. %{_libdir}/*.la
  140. %{_libdir}/netatalk/*.a
  141. %{_libdir}/netatalk/*.la
  142. %dir %{_includedir}/atalk
  143. %{_includedir}/atalk/*.h
  144. %dir %{_includedir}/netatalk
  145. %{_includedir}/netatalk/*.h
  146. %{_datadir}/aclocal/netatalk.m4
  147. %changelog
  148. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
  149. - rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
  150. * Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
  151. - new upstream release.
  152. - added build option 'force_uidgid'.
  153. * Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
  154. - new upstream release
  155. - fix configure options; add missing BRs
  156. * Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
  157. - now back from the upstream confusion (and one more or two...)
  158. new upstream release 2.2.0 at the official site
  159. * Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
  160. - fix Patch10 to follow HAT-san's strong and confident objection
  161. (no need to set ATALK_NAME explicitly in netatalk.conf)
  162. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  163. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  164. - add Source100 to add one missing header file in the tarball
  165. - revise Patch10
  166. - explicitly specify --disable-ddp for the first time
  167. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  168. - new upstream release
  169. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  170. - rebuild with openssl-1.0.0c
  171. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  172. - fix Patch10 & update description - upon HAT-san's suggestions
  173. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  174. - new upstream release
  175. - update Vine patch
  176. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  177. - new upstream release
  178. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  179. - new upstream release
  180. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  181. - rebuilt both for VineSeed / VinePlus-4.0
  182. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  183. - updated to the cjk-6 patch
  184. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  185. - Patch14 updated for db46
  186. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  187. - remove openslp dependency
  188. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  189. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  190. - TODO: remember to revise this fix after VineSeed changes default locale
  191. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  192. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  193. - revise description (thanks HAT-san for pointing this out)
  194. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  195. (without this, uams_* modules won't get .so suffix)
  196. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  197. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  198. (Patch10 now includes all the modifications and more fixes)
  199. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  200. - add patch13 and patch14 for db-4.3.
  201. - move files in %%_libexecdir to %%libdir.
  202. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  203. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  204. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  205. - security fix: added Patch10 (CAN-2004-0974)
  206. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  207. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  208. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  209. - updated to 2.0 with cjk patch
  210. (see the above Patch section for details)
  211. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  212. - merge the patch repairing bug for System 7.5.5
  213. - (patch6 netatalk-1.5.3.oldsys.patch)
  214. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  215. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  216. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  217. - euc and kana patch originally by
  218. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  219. - applied to netatalk-1.5.2 by me
  220. - README.vine
  221. - omit VERSION from doc, omit perl from require
  222. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  223. - this package is removed because the release number duplicated
  224. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  225. - move acleandir.rc to the doc directory, remove executable flag.
  226. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  227. - updated to new upstream release
  228. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  229. - added Japanese Summary for devel and corrected Group
  230. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  231. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  232. (say atd.pid doesn't have anything to do with netatalk!!)
  233. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  234. - updated to new upstream release
  235. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  236. - install man pages into %%{_mandir}
  237. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  238. - let pre script exit 0
  239. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  240. - spec cleanup
  241. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  242. - restart atalk daemons in the %%post section
  243. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  244. - v1.5.1.1-0vl1
  245. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  246. - v1.5.0-0vl1
  247. - release 1.5.0 for sourceforge
  248. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  249. - v1.5pre6-1rh7
  250. - pre-release 6 for sourceforge
  251. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  252. - v1.5pre5-1
  253. - pre-release 5 for sourceforge
  254. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  255. - v1.5pre5-0
  256. - pre-release 5 for sourceforge (prebuild)
  257. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  258. - v1.5pre4-1
  259. - pre-release 4 for sourceforge
  260. - modified/split mandrake spec for redhat 7 build
  261. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  262. - v1.5pre3-1mdk
  263. - pre-release 3 for sourceforge
  264. - moved away from 1.4.99 ...
  265. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  266. - v1.4.99-0.20001108mdk
  267. - pre-release 2 for sourceforge
  268. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  269. - v1.4.99-0.20000927mdk
  270. - pre-release 1 for sourceforge