123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199 |
- # The (empty) main package is arch, to have the package built and tests run
- # on all arches, but the actual result package is the noarch -devel subpackge.
- # Debuginfo packages are disabled to prevent rpmbuild from generating an empty
- # debuginfo package for the empty main package.
- %global debug_package %{nil}
- %global commit 10219c95fe65
- Name: eigen3
- Version: 3.2.4
- Release: 2%{?_dist_release}
- Summary: A lightweight C++ template library for vector and matrix math
- Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
- Group: Development/Libraries
- License: MPLv2.0 and LGPLv2+ and BSD
- URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
- # Source file is at: http://bitbucket.org/eigen/eigen/get/3.1.3.tar.bz2
- # Renamed source file so it's not just a version number
- Source0: eigen-%{version}.tar.bz2
- # Fix build with recent suitesparse versions
- Patch0: eigen-3.2.3_suitesparse.patch
- # Vine Patch
- Patch700: eigen-3.2.4_BVHsegfault.patch
- #BuildRequires: atlas-devel
- BuildRequires: fftw3-devel
- BuildRequires: glew-devel
- BuildRequires: gmp-devel
- BuildRequires: gsl-devel
- BuildRequires: mpfr-devel
- #BuildRequires: sparsehash-devel
- BuildRequires: suitesparse-devel
- BuildRequires: gcc-gfortran
- #BuildRequires: SuperLU-devel
- BuildRequires: qt4-devel
- BuildRequires: cmake
- BuildRequires: doxygen
- BuildRequires: graphviz
- BuildRequires: texlive-collection-latex
- #BuildRequires: tex(latex)
- %description
- %{summary}.
- %package devel
- Summary: A lightweight C++ template library for vector and matrix math
- Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
- Group: Development/Libraries
- BuildArch: noarch
- # -devel subpkg only atm, compat with other distros
- Provides: %{name} = %{version}-%{release}
- # not *strictly* a -static pkg, but the results are the same
- Provides: %{name}-static = %{version}-%{release}
- %description devel
- %{summary}.
- %package doc
- Summary: Developer documentation for Eigen
- Summary(ja): Eigen の開発用ドキュメント
- Group: Documentation
- BuildArch: noarch
- Requires: %{name}-devel = %{version}-%{release}
- %description doc
- Developer documentation for Eigen.
- %prep
- %setup -q -n eigen-eigen-%{commit}
- %patch0 -p1
- %patch700 -p1
- %build
- mkdir %{_target_platform}
- pushd %{_target_platform}
- #cmake .. -DBLAS_LIBRARIES="cblas" -DSUPERLU_INCLUDES=%{_includedir}/SuperLU
- %cmake .. -DBLAS_LIBRARIES="cblas"
- popd
- make -C %{_target_platform} %{?_smp_mflags}
- make doc -C %{_target_platform} %{?_smp_mflags}
- rm -f %{_target_platform}/doc/html/installdox
- rm -f %{_target_platform}/doc/html/unsupported/installdox
- %install
- rm -rf %{buildroot}
- %make_install -C %{_target_platform}
- %check
- # Run tests but make failures non-fatal. Note that upstream doesn't expect the
- # tests to pass consistently since they're seeded randomly.
- make -C %{_target_platform} %{?_smp_mflags} buildtests
- make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
- %clean
- rm -rf %{buildroot}
- %files devel
- %doc COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
- %{_includedir}/eigen3
- %{_datadir}/pkgconfig/*
- %files doc
- %doc %{_target_platform}/doc/html
- %changelog
- * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.2.4-2
- - Initial build for Vine Linux
- * Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
- - Update to release 3.2.4
- * Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
- - Backport upstream Rotation2D fix
- * Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
- - Update to release 3.2.3
- - Drop upstreamed eigen3-ppc64.patch
- * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
- - Update to release 3.2.2
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
- - Add ppc64 support
- * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
- - Make doc package noarch
- * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
- - Split off doc to a separate package
- * Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
- - Udpate to release 3.2.1
- * Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
- - Build and run tests
- - Drop -DBLAS_LIBRARIES_DIR, not used
- - Add some BR to enable tests of corresponding backends
- - spec cleanup
- * Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
- - Update to release 3.2
- * Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
- - Add upstream patch to fix malloc/free bugs (rhbz#978971)
- * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
- - Update to release 3.1.3
- - Add patch for unused typedefs warning with gcc4.8
- * Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
- - Update to release 3.1.2
- * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
- - Update to release 3.0.6 (fixes GCC 4.7 warnings)
- * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
- - Update to release 3.0.5
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
- - Update to release 3.0.4
- * Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
- - Update to release 3.0.3
- * Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
- - Patched sources to fix build failure
- - Removed fixes made upstream
- - Added project name to source tarball filename
- * Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
- - Update to release 3.0.0
- * Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
- - Change blas-devel buildrequirement to atlas-devel
- - Don't make the built-in experimental blas library
- * Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
- - Initial package
|