libsndfile-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library to handle various audio file formats.
  3. Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
  4. Name: libsndfile
  5. Version: 1.0.31
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+ and GPLv2+ and BSD
  11. URL: http://libsndfile.github.io/libsndfile/
  12. Source0: https://github.com/libsndfile/libsndfile/releases/download/%{version}/libsndfile-%{version}.tar.bz2
  13. Patch0: %{name}-1.0.25-system-gsm.patch
  14. Patch1: %{name}-1.0.25-zerodivfix.patch
  15. # security fix
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: alsa-lib-devel
  18. BuildRequires: flac-devel
  19. BuildRequires: libogg-devel
  20. BuildRequires: libvorbis-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: sqlite3-devel
  23. BuildRequires: gsm-devel
  24. BuildRequires: python3
  25. BuildRequires: opus-devel
  26. %description
  27. libsndfile is a C library for reading and writing sound files such as
  28. AIFF, AU and WAV files through one standard interface. It can currently
  29. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  30. point WAV files and a number of compressed formats.
  31. %package devel
  32. Summary: Libraries, includes, etc to develop libsndfile applications
  33. Summary(ja): libsndfile アプリケーションを開発するためのファイル集
  34. Group: programming
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: pkgconfig
  37. %description devel
  38. Libraries, include files, etc you can use to develop libsndfile applications.
  39. %package utils
  40. Summary: Command Line Utilities for libsndfile
  41. Summary(ja): libsndfileのコマンドラインユーティリティ
  42. Group: multimedia,system
  43. Requires: %{name} = %{version}-%{release}
  44. %description utils
  45. libsndfile is a C library for reading and writing sound files such as
  46. AIFF, AU, WAV, and others through one standard interface.
  47. This package contains command line utilities for libsndfile.
  48. # compat32
  49. %package -n compat32-%{name}
  50. Summary: A library to handle various audio file formats.
  51. Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
  52. Group: system,legacy
  53. %description -n compat32-%{name}
  54. libsndfile is a C library for reading and writing sound files such as
  55. AIFF, AU and WAV files through one standard interface. It can currently
  56. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  57. point WAV files and a number of compressed formats.
  58. %package -n compat32-%{name}-devel
  59. Summary: Libraries, includes, etc to develop libsndfile applications
  60. Summary(ja): libsndfile アプリケーションを開発するためのファイル集
  61. Group: programming,legacy
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. Requires: compat32-pkgconfig
  64. Requires: %{name}-devel = %{version}-%{release}
  65. %description -n compat32-%{name}-devel
  66. Libraries, include files, etc you can use to develop libsndfile applications.
  67. %debug_package
  68. %prep
  69. %autosetup -p1
  70. rm -r src/GSM610
  71. autoreconf -I m4 -fiv # for system-gsm patch
  72. %build
  73. %configure \
  74. --disable-dependency-tracking \
  75. --enable-sqlite \
  76. --enable-alsa \
  77. --enable-largefile \
  78. --disable-static
  79. # Get rid of rpath
  80. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  81. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  82. make %{?_smp_mflags}
  83. %install
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. rm -rf __docs
  86. mkdir __docs
  87. cp -pR $RPM_BUILD_ROOT%{_docdir}/%{name}/* __docs
  88. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
  89. find %{buildroot} -type f -name "*.la" -delete
  90. # fix multilib issues
  91. %if %{__isa_bits} == 64
  92. %define wordsize 64
  93. %else
  94. %define wordsize 32
  95. %endif
  96. mv $RPM_BUILD_ROOT%{_includedir}/sndfile.h \
  97. $RPM_BUILD_ROOT%{_includedir}/sndfile-%{wordsize}.h
  98. cat > $RPM_BUILD_ROOT%{_includedir}/sndfile.h <<EOF
  99. #include <bits/wordsize.h>
  100. #if __WORDSIZE == 32
  101. # include "sndfile-32.h"
  102. #elif __WORDSIZE == 64
  103. # include "sndfile-64.h"
  104. #else
  105. # error "unexpected value for __WORDSIZE macro"
  106. #endif
  107. EOF
  108. %check
  109. LD_LIBRARY_PATH=$PWD/src/.libs make check
  110. %files
  111. %defattr(-,root,root)
  112. %license COPYING
  113. %doc AUTHORS ChangeLog NEWS README*
  114. %{_libdir}/libsndfile.so.*
  115. %files devel
  116. %defattr(-,root,root)
  117. %doc __docs/*
  118. %{_libdir}/libsndfile.so
  119. %{_includedir}/sndfile.h
  120. %{_includedir}/sndfile.hh
  121. %{_includedir}/sndfile-%{wordsize}.h
  122. %{_libdir}/pkgconfig/sndfile.pc
  123. %files utils
  124. %{_bindir}/*
  125. %{_mandir}/man1/*
  126. # compat32
  127. %if %{build_compat32}
  128. %files -n compat32-%{name}
  129. %defattr(-,root,root)
  130. %{_libdir}/libsndfile.so.*
  131. %files -n compat32-%{name}-devel
  132. %defattr(-,root,root)
  133. %{_includedir}/sndfile-%{wordsize}.h
  134. %{_libdir}/libsndfile.so
  135. %{_libdir}/pkgconfig/sndfile.pc
  136. %endif
  137. %changelog
  138. * Fri Mar 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.31-1
  139. - new upstream release.
  140. - dropped Patch100-111: fixed in upstream.
  141. - dropped ldconfig scriptlets.
  142. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.28-2
  143. - removed a comment in %%postun script.
  144. * Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.28-1
  145. - new upstream release.
  146. - dropped Patch100-101.
  147. - imported Patch100-111 from debian.
  148. * Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.25-2
  149. - added Patch0, 1 and 101 from Fedora
  150. * Tue Jan 13 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-14
  151. - fix CVE-2014-9496: 2 buffer overruns in sd2_parse_rsrc_fork (#1178840)
  152. - division by zero leading to denial of service in psf_fwrite (#1177254)
  153. * Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.0.25-2
  154. - Patch to use system libgsm instead of a bundled copy.
  155. - added BR: flac-devel, libogg-devel, libvorbis-devel, pkgconfig,
  156. sqlite3-devel and gsm-devel
  157. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.25-1
  158. - new upstream release
  159. * Sun Jul 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-3
  160. - change spec filename (-vl)
  161. * Sat Jul 30 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-2
  162. - add patch100 for fix CVE-2011-2696 (IOF) from debian, thanks.
  163. * Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
  164. - new upstream release
  165. - built with rpm-4.8.1-1
  166. * Mon Jun 1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
  167. - new upstream release with security fix (CVE-2009-1788, 1791)
  168. - add patch110 to fix devide by 0 issues
  169. - drop patch100 (is included in new release)
  170. - change configure option to fix new release
  171. - revome "TODO" file from file list
  172. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
  173. - added compat32 package for x86_64 arch support
  174. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
  175. - spec in utf-8
  176. - remove static lib
  177. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
  178. - applied new versioning policy
  179. - removed lib*.la file from devel package
  180. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
  181. - rebuild for VineSeed
  182. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
  183. - new upstream release
  184. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
  185. - add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
  186. - built for VinePlus 4.x
  187. * Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
  188. - add BuildRequires: alsa-lib-devel
  189. - add '--disable-sqlite --disable-flac' options to %%configure
  190. * Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
  191. - rebuilt for VineSeed Plus
  192. * Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
  193. - new upstream release
  194. - fixed Japanese summary
  195. * Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
  196. - initial build for VinePlus/3.0
  197. - modified spec file
  198. * Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
  199. - Add html files to the files section.
  200. * Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
  201. - Apply corrections from Andrew Schultz.
  202. * Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
  203. - Force installation of sndfile.pc file.
  204. * Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
  205. - Created libsndfile.spec.in
  206. # end of file