self-build-ffmpeg-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %global gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) && \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
  5. /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
  6. %global pkgname ffmpeg
  7. %global name self-build-%{pkgname}
  8. %global version 0.9.1
  9. #% define svndate 20110326
  10. %global release 1%{?svndate:.%svndate}%{?_dist_release}
  11. %global sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  12. ## available for v0.6 or lower
  13. %global with_libfaad 1
  14. %global with_faac 1
  15. %global with_vaapi 1
  16. %global with_libvpx 1
  17. Summary: Package to automatically build %{pkgname} rpm package
  18. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  19. Name: %{name}
  20. Version: %{version}
  21. Release: %{release}
  22. Source0: %{pkgname}-vl.spec
  23. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  24. Source2: %{pkgname}-snapshot.sh
  25. # pre-built man files
  26. Source90: ffmpeg-%{version}-doc.tar.xz
  27. License: GPLv2+
  28. Group: Restricted Software
  29. Requires(post): self-build-setup >= 0.9.9
  30. #Requires(post): subversion
  31. # (build)requies of target package.
  32. Requires(post): bzip2-devel
  33. Requires(post): celt-devel
  34. ##Requires(post): dirac-devel
  35. Requires(post): freetype2-devel
  36. Requires(post): gsm-devel
  37. Requires(post): imlib2-devel
  38. Requires(post): libdc1394-devel
  39. Requires(post): libraw1394-devel
  40. Requires(post): librtmp-devel >= 2.3
  41. Requires(post): libtheora-devel
  42. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  43. Requires(post): libvdpau-devel
  44. Requires(post): libvorbis-devel
  45. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.6}
  46. %{?_with_opencore_amr:Requires(post): opencore-amr-devel vo-amrwbenc-devel}
  47. ##Requires(post): openjpeg-devel
  48. ##Requires(post): schroedinger-devel
  49. Requires(post): SDL-devel
  50. Requires(post): speex-devel
  51. ##Requires(post): texi2html
  52. Requires(post): zlib-devel
  53. Requires(post): libogg-devel
  54. Requires(post): yasm
  55. Requires(post): self-build-a52dec
  56. Requires(post): self-build-faac
  57. Requires(post): self-build-faad2
  58. Requires(post): self-build-lame
  59. Requires(post): self-build-libdca
  60. Requires(post): self-build-x264 >= 0.0.0-18.20111216
  61. Requires(post): self-build-xvidcore
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  63. BuildArch: noarch
  64. Packager: munepi
  65. %description
  66. FFMpeg is a complete and free Internet live audio and video
  67. broadcasting solution for Linux/Unix. It also includes a
  68. digital VCR. It can encode in real time in many formats
  69. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  70. real, mjpeg, and flash.
  71. If you install this package, it automaticaly downloads source
  72. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  73. And the created rpm packages are automatically installed
  74. if installation is executed by apt-get command or synaptic
  75. package manager.
  76. [Note]
  77. This package requires many other packages to compile
  78. target software. So it consume more disk space than usual.
  79. Also installation takes longer time because of compilation.
  80. (This will take a few minutes to quarter or half of an hour,
  81. depends on building environment)
  82. [About self-build package]
  83. For some kind of software, distributing of binary package
  84. may viorate the patent or law. Therefore we chose self-build
  85. packge, create binary package on your machine, for such kind
  86. of softwares instead of distributing binary package.
  87. Please obey the national law when you use the created binary
  88. packages. And if you want to use the softwares using patented
  89. thechnology, it may be required to get a permission, make an
  90. agreement or purchas a license. Please consider it with your
  91. purpose or way of use and take appropriate action.
  92. %description -l ja
  93. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  94. ブオーティオ・ビデオブロードキャスティングソリューションです.
  95. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  96. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  97. 多様なフォーマットをリアルタイムにエンコードすることができます.
  98. このパッケージをインストールすると、自動的にソースコードを
  99. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  100. の rpm パッケージを作成します。
  101. また apt-get コマンドや synaptic パッケージマネージャから実行
  102. した場合は、作成された rpm パッケージのインストールも自動的に
  103. 行います。
  104. [注意]
  105. コンパイルに必要な多くの関連パッケージを要求するので通常より
  106. ディスクの領域を多く消費します。
  107. またインストール時にコンパイルを行うため、通常より時間がかか
  108. る場合があります。(環境にもよりますが数分から数十分程度)
  109. [self-build パッケージについて]
  110. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  111. 違反する可能性があるものがあります。その為、このような問題が
  112. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  113. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  114. ジという方法を採っています。
  115. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  116. アのライセンス、および利用する国の各種法令に従ってください。
  117. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  118. センスの購入などが必要となる場合がありますので、利用する目的
  119. や形態に応じて各自で判断し適切な対応を取ってください。
  120. %prep
  121. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  122. %install
  123. %{__rm} -rf ${RPM_BUILD_ROOT}
  124. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  125. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  126. %{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  127. %clean
  128. %{__rm} -rf ${RPM_BUILD_ROOT}
  129. %posttrans
  130. #/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
  131. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
  132. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  133. %{pkgname}-libs-%{version}-%{release} \
  134. %{pkgname}-devel-%{version}-%{release}
  135. ## Rebuild gpac with ffmpeg-devel
  136. # set locale
  137. case $LANG in
  138. ja*)LOCALE=ja ;;
  139. *) LOCALE=C ;;
  140. esac
  141. Rebuild_gpac_C(){
  142. echo -n " "
  143. echo "Rebuild gpac with ffmpeg-devel"
  144. }
  145. Rebuild_gpac_ja(){
  146. echo -n " "
  147. echo "ffmpeg-devel で gpac をリビルドします。"
  148. }
  149. Rebuild_gpac_$LOCALE
  150. %{gpac_postinstall}
  151. %files
  152. %defattr(-,root,root)
  153. %{_datadir}/%{name}
  154. %changelog
  155. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  156. - new upstream release
  157. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  158. - new upstream release
  159. - enable CELT decoding via libcelt
  160. - enable FreeType support
  161. - drop faad2 support (dropped upstream)
  162. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  163. - added BuildArch: noarch
  164. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  165. - new upstream release
  166. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  167. - new upstream release
  168. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  169. - required latest x264 build
  170. - added BuildRequires: librtmp-devel >= 2.3
  171. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  172. - new upstream release
  173. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  174. - unpacked source archives
  175. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  176. - fixed some dependencies
  177. - Requires(post): libva-devel
  178. - Requires(post): libvpx-devel >= 0.9.1
  179. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  180. - new upstream release
  181. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  182. - bumped version to pre-0.6
  183. - updated source snapshot 20100410
  184. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  185. - fixed self-build log size
  186. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  187. - added ffprobe.1.gz
  188. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  189. - updated source snapshot 20100401
  190. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  191. - renamed %%{Source0} to ffmpeg-vl.spec
  192. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  193. - updated source snapshot 20100216
  194. - rebuild with recent x264-devel
  195. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  196. - added BuildRequires: libvdpau-devel
  197. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  198. - dropped BuildArch: noarch
  199. - added ffmpeg.1, ffplay.1, ffserver.1
  200. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  201. - avoided to execute self-build-rpm.sh on RPM transaction
  202. - moved %%post actions to %%posttrans
  203. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  204. - added BuildArch: noarch
  205. - added ffmpeg-0.5-disable-texi2html.patch
  206. - dropped PreReq: texi2html
  207. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  208. - added %%{gpac_postinstall} in %%post
  209. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  210. - corrected release number
  211. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  212. - new upstream release
  213. - added PreReq:
  214. - speex-devel
  215. - bzip2-devel
  216. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  217. - change release to sync with ffmpeg
  218. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  219. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  220. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  221. - 20090202 snapshot
  222. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  223. - 20090110 snapshot
  224. - dropped some patches
  225. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  226. - source updated (r15488)
  227. - fixed License: GPLv2+
  228. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  229. - added BuildRequires: yasm (only %%ix86)
  230. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  231. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  232. - spec in utf8
  233. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  234. - run pre-allocate-rpm.sh in %%post
  235. - set PreReq: self-build-setup >= 0.8
  236. - change release number
  237. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  238. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  239. include Source1 in the binary package.
  240. - drop "Source100: ffmpeg-vine.patch".
  241. - drop "PreReq: subversion".
  242. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  243. - build with new versioning policy
  244. - change to use svn export from svn checkout on post install
  245. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  246. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  247. - For all pre-required package that is provied by self-build,
  248. changed to its self-build package
  249. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  250. - initial build for Vine Linux 4.2
  251. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  252. ### end of file