self-build-xbmc-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182
  1. %define pkgname xbmc
  2. %define name self-build-%{pkgname}
  3. %define version 10.0
  4. %define release 1%{?_dist_release}
  5. %define sourceurl http://mirrors.xbmc.org/releases/source/%{pkgname}-%{version}.tar.gz
  6. %define build_vine5 0
  7. %if "%{?_dist_release}" == "vl5"
  8. %define build_vine5 1
  9. %endif
  10. Summary: Package to automatically build %{pkgname} rpm package
  11. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  12. Name: %{name}
  13. Version: %{version}
  14. Release: %{release}
  15. Source0: %{pkgname}-vl.spec
  16. Source1: %{pkgname}.desktop
  17. Source2: %{pkgname}-%{version}-strings.xml
  18. Source3: %{pkgname}-%{version}-Confluence-strings.xml
  19. Source4: %{pkgname}-%{version}-default-locale.patch
  20. License: GPL
  21. Group: Restricted Software
  22. Requires(post): self-build-setup >= 0.8
  23. # (build)requies of target package.
  24. Requires(post): lsb
  25. Requires(post): python-imaging
  26. Requires(post): pysqlite
  27. Requires(post): hicolor-icon-theme
  28. Requires(post): desktop-file-utils
  29. Requires(post): MySQL-devel
  30. Requires(post): SDL_image-devel
  31. Requires(post): SDL_mixer-devel
  32. Requires(post): alsa-lib-devel
  33. Requires(post): avahi-devel
  34. Requires(post): bzip2-devel
  35. Requires(post): cmake
  36. Requires(post): curl-devel
  37. Requires(post): cvs
  38. Requires(post): dbus-devel
  39. Requires(post): desktop-file-utils
  40. Requires(post): enca-devel
  41. Requires(post): flac-devel
  42. Requires(post): fontconfig-devel
  43. Requires(post): fribidi-devel
  44. Requires(post): glew-devel
  45. Requires(post): gperf
  46. Requires(post): hal-devel
  47. Requires(post): jasper-devel
  48. Requires(post): libXinerama-devel
  49. Requires(post): libXmu-devel
  50. Requires(post): libXrandr-devel
  51. Requires(post): libXtst-devel
  52. Requires(post): libboost-devel
  53. Requires(post): libcdio-devel
  54. Requires(post): expat-devel
  55. Requires(post): libjpeg-devel
  56. Requires(post): libmicrohttpd-devel
  57. Requires(post): libmms-devel
  58. Requires(post): libmodplug-devel
  59. Requires(post): libogg-devel
  60. Requires(post): libpng-devel
  61. Requires(post): libsamplerate-devel
  62. Requires(post): libsmbclient-devel
  63. Requires(post): libtiff-devel
  64. Requires(post): libvorbis-devel
  65. Requires(post): nasm
  66. Requires(post): openssl-devel
  67. Requires(post): lzo-devel
  68. Requires(post): pcre-devel
  69. Requires(post): pulseaudio-libs-devel
  70. Requires(post): sqlite3-devel
  71. Requires(post): unzip
  72. Requires(post): wavpack-devel
  73. Requires(post): zlib-devel
  74. Requires(post): self-build-faac
  75. Requires(post): self-build-faad2
  76. Requires(post): self-build-libmad
  77. Requires(post): self-build-libmpeg2
  78. %if !%{build_vine5}
  79. Requires(post): libvdpau-devel
  80. %endif
  81. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  82. Packager: kazutaka
  83. %description
  84. XBMC is an award-winning free and open source (GPL) software
  85. media player and entertainment hub for digital media.
  86. If you install this package, it automaticaly downloads source
  87. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  88. And the created rpm packages are automatically installed
  89. if installation is executed by apt-get command or synaptic
  90. package manager.
  91. [Note]
  92. This package requires many other packages to compile
  93. targetsoftware. So it consume more disk space than usual.
  94. Also installation takes logner time because of compilation.
  95. (This will take a few minutes to quarter or half of an hour,
  96. depends on building environment)
  97. [About self-build package]
  98. For some kind of software, distributing of binary package
  99. may viorate the patent or law. Therefore we chose self-build
  100. packge, create binary package on your machine, for such kind
  101. of softwares instead of distributing binary package.
  102. Please obey the national law when you use the created binary
  103. packages. And if you want to use the softwares using patented
  104. thechnology, it may be required to get a permission, make an
  105. agreement or purchas a license. Please consider it with your
  106. purpose or way of use and take appropriate action.
  107. %description -l ja
  108. XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
  109. デジタルメディア向けのメディアプレイヤー/メディアセンターです。
  110. このパッケージをインストールすると、自動的にソースコードを
  111. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  112. パッケージを作成します。
  113. また apt-get コマンドや synaptic パッケージマネージャから実行
  114. した場合は、作成された rpm パッケージのインストールも自動的に
  115. 行います。
  116. [注意]
  117. コンパイルに必要な多くの関連パッケージを要求するので通常より
  118. ディスクの領域を多く消費します。
  119. またインストール時にコンパイルを行うため、通常より時間がかか
  120. る場合があります。(環境にもよりますが数分から数十分程度)
  121. [self-build パッケージについて]
  122. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  123. 違反する可能性があるものがあります。その為、このような問題が
  124. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  125. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  126. ジという方法を採っています。
  127. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  128. アのライセンス、および利用する国の各種法令に従ってください。
  129. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  130. センスの購入などが必要となる場合がありますので、利用する目的
  131. や形態に応じて各自で判断し適切な対応を取ってください。
  132. %prep
  133. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  134. %install
  135. %{__rm} -rf ${RPM_BUILD_ROOT}
  136. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  137. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  138. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  139. %{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  140. %{__install} -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  141. %{__install} -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  142. %clean
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %posttrans
  145. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 2447000
  146. %files
  147. %defattr(-,root,root)
  148. %{_datadir}/%{name}
  149. %changelog
  150. * Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
  151. - initial build for Vine Linux