libmicrohttpd-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. Summary: Lightweight library for embedding a webserver in applications
  2. Name: libmicrohttpd
  3. Version: 0.9.2
  4. Release: 1%{?_dist_release}
  5. Group: Development/Libraries
  6. License: LGPLv2+
  7. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  8. URL: http://www.gnu.org/software/libmicrohttpd/
  9. Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
  10. #Patch0: %{name}-0.9.2-fix-https-tests.patch
  11. BuildRequires: autoconf, automake, libtool
  12. BuildRequires: curl-devel
  13. BuildRequires: gnutls-devel
  14. BuildRequires: libgcrypt-devel
  15. BuildRequires: graphviz
  16. BuildRequires: doxygen
  17. Requires(post): info
  18. Requires(preun): info
  19. %description
  20. GNU libmicrohttpd is a small C library that is supposed to make it
  21. easy to run an HTTP server as part of another application.
  22. Key features that distinguish libmicrohttpd from other projects are:
  23. * C library: fast and small
  24. * API is simple, expressive and fully reentrant
  25. * Implementation is http 1.1 compliant
  26. * HTTP server can listen on multiple ports
  27. * Support for IPv6
  28. * Support for incremental processing of POST data
  29. * Creates binary of only 25k (for now)
  30. * Three different threading models
  31. %package devel
  32. Summary: Development files for libmicrohttpd
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. Development files for libmicrohttpd
  37. %package doc
  38. Summary: Documentation for libmicrohttpd
  39. Group: Documentation
  40. Requires: %{name} = %{version}-%{release}
  41. %description doc
  42. Doxygen documentation for libmicrohttpd and some example source code
  43. %prep
  44. %setup -q
  45. #patch0 -p1 -b .explicit-dso
  46. # The doxygen file contains references to /home/grothoff/svn/libmicrohttpd/... replace these with .
  47. sed s/\\/home\\/grothoff\\/svn\\/libmicrohttpd/./ doc/Doxyfile > tmp
  48. unlink doc/Doxyfile
  49. mv tmp doc/Doxyfile
  50. %build
  51. # Required because patches modify .am files
  52. # autoreconf --force
  53. %configure --disable-static --with-gnutls
  54. make %{?_smp_mflags}
  55. doxygen doc/Doxyfile
  56. # Disabled for now due to problems reported at
  57. # https://gnunet.org/bugs/view.php?id=1619
  58. #check
  59. #make check %{?_smp_mflags}
  60. %install
  61. rm -rf %{buildroot}
  62. make install DESTDIR=%{buildroot}
  63. rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
  64. rm -f %{buildroot}%{_infodir}/dir
  65. # Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
  66. mkdir examples
  67. install -m 644 src/examples/*.c examples
  68. # Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
  69. cp -R doc/doxygen/html html
  70. %clean
  71. rm -rf %{buildroot}
  72. %post doc
  73. /sbin/install-info %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
  74. /sbin/install-info %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
  75. %preun doc
  76. if [ $1 = 0 ] ; then
  77. /sbin/install-info --delete %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
  78. /sbin/install-info --delete %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
  79. fi
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc COPYING
  85. %{_libdir}/libmicrohttpd.so.*
  86. %files devel
  87. %defattr(-,root,root,-)
  88. %{_includedir}/microhttpd.h
  89. %{_libdir}/libmicrohttpd.so
  90. %{_libdir}/pkgconfig/libmicrohttpd.pc
  91. %files doc
  92. %doc AUTHORS README ChangeLog
  93. %doc examples
  94. %doc html
  95. %defattr(-,root,root,-)
  96. %{_mandir}/man3/libmicrohttpd.3.gz
  97. %{_infodir}/microhttpd.info.gz
  98. %{_infodir}/microhttpd-tutorial.info.gz
  99. %changelog
  100. * Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
  101. - initial build for Vine Linux based on fedora development
  102. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
  103. - Add missing BR gnutls-devel and libgcrypt-devel
  104. - Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
  105. implicit DSO linking)
  106. - Disable test cases for now due to false errors, reported upstream
  107. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
  108. - Re-enable HTTPS, configure flags had unexpected result
  109. * Sun Nov 7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
  110. - Update to 0.9.2
  111. * Sun Jun 4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
  112. - Update to 0.4.6
  113. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  115. * Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
  116. - Update to version 0.4.2
  117. - Drop upstreamed patch
  118. * Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
  119. - Update to version 0.4.0a
  120. - Drop upstreamed patch
  121. - Added a new patch to fix a 64bit issue
  122. - The -devel package now contains a pkgconfig file
  123. - The configure script is now run with '--enable-messages --enable-https'
  124. - Made the -doc subpackage noarch (F11+)
  125. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  127. * Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
  128. - Update to version 0.4.0
  129. - This version introduces a API bump (which is required for
  130. supporting large files on 32bit environments)
  131. - The license issues we had with version 0.3.1 of this package (as
  132. discussed in #457924) are resolved in this version. The license
  133. of this package is now changed to LGPLv2+
  134. - Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
  135. * Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
  136. - Changed license to GPLv3+ and added some comments
  137. regarding the license issues with this package
  138. * Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
  139. - Changed license to LGPLv2+
  140. - Moved the COPYING file to the main package
  141. * Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
  142. - Initial release