docbook-style-xsl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. Name: docbook-style-xsl
  2. Version: 1.75.2
  3. Release: 6%{?_dist_release}
  4. Group: Applications/Text
  5. Summary: Norman Walsh's XSL stylesheets for DocBook XML.
  6. Summary(ja): DocBook XML用 XSLスタイルシート
  7. License: Copyright only
  8. URL: http://docbook.sourceforge.net/projects/xsl/
  9. Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
  10. Source1: %{name}.Makefile
  11. Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
  12. # Avoid proportional-column-width for passivetex (bug #176766).
  13. Patch1: docbook-xsl-pagesetup.patch
  14. # Hard-code the margin-left work around to expect passivetex (bug #113456).
  15. Patch2: docbook-xsl-marginleft.patch
  16. # fix of #161619 - adjustColumnWidths now available
  17. Patch3: docbook-xsl-newmethods.patch
  18. # change a few non-constant expressions to constant - needed for passivetex(#366441)
  19. Patch4: docbook-xsl-non-constant-expressions.patch
  20. # added fixes for passivetex extension and list-item-body(#161371)
  21. Patch5: docbook-xsl-list-item-body.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. Provides: docbook-xsl = %{version}
  25. Requires: docbook-dtd-xml
  26. # xml-common was using /usr/share/xml until 0.6.3-8.
  27. Requires: xml-common >= 0.6.3-8
  28. # required because of usage of /usr/bin/xmlcatalog
  29. Requires(post): libxml2 >= 2.4.8
  30. Requires(postun): libxml2 >= 2.4.8
  31. # PassiveTeX before 1.21 can't handle the newer stylesheets.
  32. Conflicts: passivetex < 1.21
  33. %description
  34. These XSL stylesheets allow you to transform any DocBook XML document to
  35. other formats, such as HTML, FO, and XHMTL. They are highly customizable.
  36. %description -l ja
  37. この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
  38. を HTML や FO や XHTML などの他のフォーマットに変換することができます.
  39. %prep
  40. %setup -q -n docbook-xsl-%{version}
  41. pushd ..
  42. tar jxf %{SOURCE2}
  43. popd
  44. %patch1 -p1 -b .pagesetup
  45. %patch2 -p1 -b .marginleft
  46. %patch3 -p1 -b .newmethods
  47. %patch4 -p1 -b .nonconstant
  48. %patch5 -p1 -b .listitembody
  49. cp %{SOURCE1} Makefile
  50. # fix of non UTF-8 files rpmlint warnings
  51. for fhtml in $(find ./doc -name '*.html' -type f)
  52. do
  53. iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
  54. mv -f "$fhtml".tmp "$fhtml"
  55. sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
  56. done
  57. for f in $(find -name "*'*")
  58. do
  59. mv -v "$f" $(echo "$f" | tr -d "'")
  60. done
  61. %build
  62. %install
  63. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  64. DESTDIR=$RPM_BUILD_ROOT
  65. make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  66. ln -s xsl-stylesheets-%{version} \
  67. $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
  68. # Don't ship the extensions (bug #177256).
  69. rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
  70. %clean
  71. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  72. %post
  73. CATALOG=%{_sysconfdir}/xml/catalog
  74. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  75. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  76. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  77. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  78. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  79. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  80. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  81. "http://docbook.sourceforge.net/release/xsl/current" \
  82. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  83. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  84. "http://docbook.sourceforge.net/release/xsl/current" \
  85. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  86. %postun
  87. # remove entries only on removal of package
  88. if [ "$1" = 0 ]; then
  89. CATALOG=%{_sysconfdir}/xml/catalog
  90. %{_bindir}/xmlcatalog --noout --del \
  91. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  92. fi
  93. %files
  94. %defattr (-,root,root)
  95. %doc BUGS README TODO doc
  96. %{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  97. %{_datadir}/sgml/docbook/xsl-stylesheets
  98. %changelog
  99. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
  100. - updated based on FC 1.75.3-5
  101. * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
  102. - comment patches purpose
  103. - License Copyright only
  104. * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
  105. - New upstream release 1.75.0
  106. - update marginleft patch
  107. * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
  108. - updated Makefile: do ship .svg images(#486849), xsl
  109. stylesheets for website, xhtml-1_1, docbook -> epub
  110. convertor
  111. * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
  112. - fix broken varlistentry (#479683)
  113. * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
  114. - fix improper localization for rtl languages, thanks
  115. Muayyad Alsadi(#475077)
  116. * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
  117. - fix xsl stylesheets for rtl languages(#475077)
  118. * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
  119. - Author_Group "<orgname>" merged between "<surname>"
  120. and "<surname>" (#473019)
  121. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
  122. - Rediffed all patches to work with patch --fuzz=0
  123. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
  124. - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
  125. (#452867)
  126. * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
  127. - added fixes for passivetex extension and list-item-body
  128. (#161371)
  129. * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
  130. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  131. documentation for nonpassivetex processing(#307001)
  132. * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
  133. - convert all html files in doc to UTF-8 in prep
  134. (latest rpmlint gives warnings)
  135. - no longer using release in style-xsl dir(#389231)
  136. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
  137. - applied new versioning policy, spec in utf-8
  138. * Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
  139. - updated to 1.73.2 based on Fedora development
  140. * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
  141. - remove entries from xmlcatalog only on removal of package
  142. (required because of the last change with droping release
  143. -caused drop of catalog entries during update)
  144. * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
  145. - change a few non-constant expressions to constant that
  146. could now be handled by passivetex(#366441)
  147. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  148. documentation for nonpassivetex processing(#307001)
  149. (use passivetex.extensions = 1 option in param.xsl for
  150. processing with passivetex)
  151. * Fri Sep 7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
  152. - Added PreReq of libxml2(#253962)
  153. * Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
  154. - updated to 1.72.0 based on Fedora development
  155. * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
  156. - patch fixing #161619 taken from upstream
  157. * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
  158. - 1.72.0.
  159. * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
  160. - Add new wordml and especially highlighting (which is referenced
  161. from html) subdirs to Makefile.
  162. * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
  163. - Don't ship docsrc/* (bug #177256).
  164. - Don't ship the extensions (bug #177256).
  165. * Sun Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
  166. - updated to 1.69.1 based on Fedora development
  167. * Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
  168. - updated to 1.67.2 based on Fedora development
  169. * Wed Dec 8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
  170. - Prevent expressions in passivetex output from index.xsl (bug #142229).
  171. * Thu Dec 2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
  172. - No longer need nbsp or listblock patches.
  173. * Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
  174. - patch from Fedora 1.64.1-6
  175. * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
  176. - Fix last margin-left fix (bug #113456).
  177. - Reduce instances of itemized/ordered lists having misalignments.
  178. * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
  179. - And another (bug #113456).
  180. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
  181. - Fixed another instance of bug #113456 in lists layout.
  182. * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
  183. - Hard-code the margin-left work around to expect passivetex (bug #113456).
  184. * Mon Jan 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
  185. - based on Fedora 1.64.1-2
  186. - fixed Japanese summary
  187. * Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
  188. - based on Redhat Rawhide 1.61.1-1
  189. - add Japanese summary and description
  190. * Tue Feb 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
  191. - upstream release
  192. * Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
  193. - based on Redhat Rawhide 1.57.0-2
  194. * Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
  195. - 1.57.0
  196. * Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
  197. - Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
  198. - based on rawhide 1.50.0 and source updated 1.55.0
  199. - use better macros
  200. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  201. - automated rebuild
  202. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  203. - automated rebuild
  204. * Wed May 1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
  205. - 1.50.0.
  206. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
  207. - 1.49.
  208. - Rebuild in new environment.
  209. * Fri Feb 1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
  210. - Put URIs instead of pathnames in the XML catalog.
  211. * Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
  212. - Back to /usr/share/sgml.
  213. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
  214. - automated rebuild
  215. * Mon Jan 7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
  216. - 1.48.
  217. * Sat Dec 8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
  218. - Conflict with PassiveTeX before 1.11.
  219. * Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
  220. - 1.47-experimental.
  221. * Tue Oct 9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
  222. - Fix unversioned symlink.
  223. * Mon Oct 8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
  224. - XML Catalog entries.
  225. - Move files to /usr/share/xml.
  226. * Mon Oct 1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
  227. - 1.45.
  228. - Built for Red Hat Linux.
  229. * Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
  230. - 1.40
  231. * Fri Jun 09 2001 Chris Runge <crunge@pobox.com>
  232. - added extensions and additional doc
  233. - bin added to doc; the Perl files are for Win32 Perl and so need some
  234. conversion first
  235. * Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
  236. - Initial RPM (based on docbook-style-dsssl RPM)
  237. - note: no catalog right now (I don't know how to do it; and not sure why
  238. it is necessary)