STLport-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. Name: STLport
  2. Version: 5.1.5
  3. Release: 2%{?_dist_release}
  4. Summary: C++ STL library compatible with the latest ANSI/ISO C++ specification
  5. Summary(ja): ANSI/ISO C++ 仕様に沿った C++ 標準テンプレートライブラリ
  6. Group: System Environment/Libraries
  7. License: Opensource (Free and Unrestricted)
  8. URL: http://www.stlport.org/
  9. Source: %{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. %description
  14. The ANSI/ISO C++ specifcation includes a standard C++ library, also known as
  15. the STL. GCC by default comes with an implementation that does not comply
  16. with this standard, but instead partly implements an older version. STLport
  17. is freely available version, based on the SGI STL implementation. It is
  18. fully-compliant, supported, and very fast. Includes special debugging
  19. facilities, and interesting and useful extensions to the standard.
  20. %package devel
  21. Summary: STLport development headers and documentation
  22. Summary(ja): STL の開発用ヘッダファイルとドキュメント
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. Documentarion and headers for STLport
  27. %prep
  28. %setup -q
  29. %build
  30. #cd src
  31. #make -f gcc.mak INSTALLDIR=$RPM_BUILD_ROOT%{_prefix} clean all
  32. pushd build/lib
  33. export OPT="${RPM_OPT_FLAGS} -fPIC"
  34. make %{?_smp_mflags} -f gcc.mak all
  35. popd
  36. %install
  37. rm -rf %{buildroot}
  38. #cd src
  39. #make -f gcc.mak INSTALLDIR=$RPM_BUILD_ROOT%{_prefix} install
  40. #cd $RPM_BUILD_ROOT/usr/include/stlport
  41. #ln -s . ext
  42. pushd build/lib
  43. make -f gcc.mak install
  44. make -f gcc.mak \
  45. install-release-static \
  46. install-dbg-static \
  47. install-stldbg-static
  48. popd
  49. echo "Installing libs"
  50. install -d $RPM_BUILD_ROOT%{_libdir}
  51. #install -m0755 lib/* $RPM_BUILD_ROOT%{_libdir}
  52. cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
  53. echo "Installing includes"
  54. install -d $RPM_BUILD_ROOT%{_includedir}/stlport
  55. cp -a stlport $RPM_BUILD_ROOT%{_includedir}/stlport
  56. %post -p /sbin/ldconfig
  57. %postun -p /sbin/ldconfig
  58. %clean
  59. rm -rf %{buildroot}
  60. %files
  61. %defattr(-,root,root)
  62. %doc INSTALL README
  63. %defattr(0644,root,root,0755)
  64. %{_libdir}/*.so.*
  65. %files devel
  66. %defattr(0644,root,root,0755)
  67. %doc doc/*
  68. %{_includedir}/stlport
  69. %{_libdir}/*.a
  70. %{_libdir}/*.so
  71. %changelog
  72. * Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-2vl5
  73. - fixed copy option for symlink at %%install
  74. * Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-1vl5
  75. - updated to 5.1.5
  76. - modified build, install scripts
  77. - applied new versioning policy, spec in utf-8
  78. * Wed Dec 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl2
  79. - fixed typo at Group:
  80. * Mon Dec 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl1
  81. - updated to 4.6.2
  82. - rebuilt with new toolchains
  83. - changed Group:
  84. - added Japanese summary
  85. - added %post, %postun section
  86. * Fri Sep 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0-0vl1
  87. - built for Vine