xsp-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. %define mono_dir %(/usr/bin/monodir)
  2. Summary: Small Web Server Hosting ASP.NET
  3. Summary(ja): ASP.NET を提供する小さなウェブサーバ
  4. Name: xsp
  5. URL: http://go-mono.com/
  6. License: GNU General Public License (GPL)
  7. Group: Applications/Internet
  8. Version: 2.6.5
  9. Release: 1%{?_dist_release}
  10. Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: mono-devel mono-web
  14. BuildRequires: mono-data-sqlite mono-data-oracle mono-jscript mono-extras mono-nunit
  15. BuildRequires: pkgconfig
  16. # One of the test runs requires this
  17. BuildRequires: sqlite
  18. # This must be manually entered according to xsp's protocol version
  19. # Since this package is currently noarch, and mod_mono's name is different
  20. # on different distros, we can't use this... yet
  21. #Requires: mod_mono >= %{version}
  22. %description
  23. The XSP server is a small Web server that hosts the Mono System.Web
  24. classes for running what is commonly known as ASP.NET.
  25. %prep
  26. %setup -q
  27. %build
  28. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  29. # Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --libexecdir=%{_prefix}/lib \
  33. --libdir=%{_prefix}/lib \
  34. --mandir=%{_prefix}/share/man \
  35. --infodir=%{_prefix}/share/info \
  36. --sysconfdir=%{_sysconfdir}
  37. make
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  41. make install DESTDIR=$RPM_BUILD_ROOT
  42. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
  43. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %defattr(-,root,root)
  48. %doc NEWS README
  49. %{_bindir}/*
  50. %{_prefix}/lib/xsp
  51. %{mono_dir}/gac/Mono.WebServer
  52. %{mono_dir}/1.0/Mono.WebServer.dll
  53. %{mono_dir}/gac/Mono.WebServer2
  54. %{mono_dir}/2.0/Mono.WebServer2.dll
  55. %{mono_dir}/gac/xsp
  56. %{mono_dir}/1.0/xsp.exe
  57. %{mono_dir}/gac/xsp2
  58. %{mono_dir}/2.0/xsp2.exe
  59. %{mono_dir}/gac/mod-mono-server
  60. %{mono_dir}/1.0/mod-mono-server.exe
  61. %{mono_dir}/gac/mod-mono-server2
  62. %{mono_dir}/2.0/mod-mono-server2.exe
  63. %{mono_dir}/gac/fastcgi-mono-server
  64. %{mono_dir}/1.0/fastcgi-mono-server.exe
  65. %{mono_dir}/gac/fastcgi-mono-server2
  66. %{mono_dir}/2.0/fastcgi-mono-server2.exe
  67. %{_datadir}/pkgconfig/*
  68. %{_mandir}/*/*
  69. %changelog
  70. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
  71. - updated xsp to 2.6.5
  72. * Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  73. - updated xsp to 2.6.4
  74. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  75. - updated xsp to 2.6.3
  76. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
  77. - updated to 2.6
  78. - rebuilt with new toolchain
  79. * Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
  80. - updated to 2.4.3
  81. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  82. - changed Group to Applications/Internet
  83. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  84. - updated to 2.4
  85. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  86. - initial build for VineSeed
  87. - updated xsp to 2.0
  88. - added japanese summary
  89. - applied vine versioning policy
  90. - spec in utf-8
  91. * Tue Apr 22 2008 wberrier@suse.de
  92. - update to 1.9.1 (bugfix release)
  93. - Output date header (instead of asp.net doing it)
  94. * Tue Mar 25 2008 wberrier@suse.de
  95. - update to 1.9
  96. - minor test updates
  97. - BaseRequestBroker fix: Check if the request ID is valid inside
  98. the lock.
  99. * Mon Jan 14 2008 wberrier@suse.de
  100. - update to 1.2.6
  101. - FastCGI support
  102. * Thu Aug 30 2007 wberrier@suse.de
  103. - xsp_1.2.5_p5_final.patch: Fix for regression in the request
  104. broker
  105. * Fri Aug 17 2007 wberrier@suse.de
  106. - xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
  107. - bugs: 81699, 81906, 82379, 82057
  108. - fixes ability to handle large (GB) uploads (needed for iFolder)
  109. * Fri Aug 3 2007 wberrier@suse.de
  110. - Update to 1.2.5
  111. - More robust exception handling
  112. - Fixed permissions bits for non executable scripts
  113. - virtual host support
  114. - New Documentation for Mono.WebServer
  115. - Improved event handling
  116. * Tue Jun 5 2007 wberrier@novell.com
  117. - Remove unnecessary path defines (prefix, sysconfdir)
  118. - Update to 1.2.4
  119. - fix some race conditions and crashes
  120. - add tracing support
  121. * Fri Apr 13 2007 wberrier@novell.com
  122. - add %%debug_package so debug packages get created
  123. * Wed Apr 11 2007 wberrier@novell.com
  124. - Add mono dep/req for older distros
  125. * Thu Mar 1 2007 wberrier@suse.de
  126. - Update Update to 1.2.3
  127. - Bug fix #80230 (prevents possible nullref)
  128. - Support for response header encoding
  129. * Mon Jan 22 2007 ro@suse.de
  130. - drop requires for gnome-filesystem
  131. * Sat Dec 2 2006 wberrier@suse.de
  132. - Update to 1.2.1 (Fate #301111)
  133. - Bugfixes:
  134. - close the connection if there's an error reading the headers
  135. (including assembly loading exceptions due to a bad installation).
  136. - kill the warning that everyone is worried about.
  137. * Fri Oct 20 2006 wberrier@suse.de
  138. - Update to 1.1.18
  139. - 2.0 updates
  140. * Thu Oct 19 2006 wberrier@suse.de
  141. - Add mono-devel to fix bnc #213576 (missing provides)
  142. * Tue Sep 5 2006 wberrier@suse.de
  143. - Update to 1.1.17.1 bugfix release
  144. - Read from the stream, not the socket as the socket data is
  145. encrypted when using SSL.
  146. * Wed Aug 30 2006 wberrier@suse.de
  147. - Update to 1.1.17
  148. - Added support for X.509 client certificates
  149. - Update to handle newly created AppDomains
  150. * Mon Jul 31 2006 wberrier@suse.de
  151. - update to 1.1.16.1
  152. - better connection handling
  153. - fixes bugs: 77698,78034,78621
  154. * Tue Apr 25 2006 wberrier@suse.de
  155. - Security update (remove all the duplicated slashes
  156. and don't do an extra Replace on non-windows.) and minor fix for
  157. [#78034].
  158. * Wed Jan 25 2006 mls@suse.de
  159. - converted neededforbuild to BuildRequires
  160. * Fri Jan 6 2006 wberrier@suse.de
  161. - Update to 1.1.13, clean up deps
  162. * Thu Nov 10 2005 wberrier@suse.de
  163. - Update to 1.1.10, set libdir to lib/
  164. * Fri Oct 7 2005 wberrier@suse.de
  165. - Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
  166. libexec, so I disabled the patch)
  167. * Tue Jul 19 2005 sbrabec@suse.cz
  168. - Build as noarch (#81109).
  169. * Fri Jul 15 2005 sbrabec@suse.cz
  170. - Updated to version 1.0.9 (#96776).
  171. * Mon Feb 21 2005 clahey@suse.de
  172. - Updated to 1.0.6.
  173. * Sun Feb 6 2005 ro@suse.de
  174. - use /usr/lib/mono
  175. * Mon Dec 13 2004 clahey@suse.de
  176. - New package.