mono-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813
  1. Summary: .NET runtime environment
  2. Summary(ja): .NET ランタイム環境
  3. Name: mono
  4. Version: 2.6.7
  5. Release: 1%{?_dist_release}
  6. Group: Development/Languages
  7. License: GPL, LGPL, MIT X11
  8. URL: http://www.mono-project.com/
  9. Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
  10. Source1: monodir.c
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: bison
  13. BuildRequires: glib2-devel
  14. BuildRequires: pkgconfig
  15. BuildRequires: libicu-devel
  16. BuildRequires: libgdiplus-devel >= 2.0
  17. BuildRequires: zlib-devel
  18. # JIT only availible on these:
  19. ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
  20. %description
  21. The Mono runtime implements a JIT engine for the ECMA CLI
  22. virtual machine (as well as a byte code interpreter, the
  23. class loader, the garbage collector, threading system and
  24. metadata access libraries.
  25. %description -l ja
  26. Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
  27. コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
  28. およびメタデータアクセスライブラリの機能を持ちます。
  29. %package core
  30. Summary: The Mono CIL runtime, suitable for running .NET code
  31. Summary(ja): .NET の実行に適した Mono CIL ランタイム
  32. Group: Development/Languages
  33. Requires: libgdiplus
  34. %description core
  35. This package contains the core of the Mono runtime including its
  36. Virtual Machine, Just-in-time compiler, C# compiler, security
  37. tools and libraries (corlib, XML, System.Security, ZipLib,
  38. I18N, Cairo and Mono.*).
  39. %package devel
  40. Summary: Development tools for Mono
  41. Summary(ja): Mono 開発ツール
  42. Group: Development/Languages
  43. Requires: mono-core = %{version}-%{release}
  44. Requires: glib2-devel
  45. %description devel
  46. This package completes the Mono developer toolchain with the mono profiler,
  47. assembler and other various tools.
  48. %package nunit
  49. Summary: NUnit Testing Framework
  50. Summary(ja): NUnit テストフレームワーク
  51. Group: Development/Languages
  52. Requires: mono-core = %{version}-%{release}
  53. Requires: glib2-devel
  54. %description nunit
  55. NUnit is a unit-testing framework for all .NET languages. Initially
  56. ported from JUnit, the current release, version 2.2, is the fourth
  57. major release of this Unit based unit testing tool for Microsoft .NET.
  58. It is written entirely in C# and has been completely redesigned to
  59. take advantage of many .NET language features, for example
  60. custom attributes and other reflection related capabilities. NUnit
  61. brings xUnit to all .NET languages.
  62. %package locale-extras
  63. Summary: Extra locale information for Mono
  64. Summary(ja): Mono 用追加ロケール情報
  65. Group: Development/Languages
  66. Requires: mono-core = %{version}-%{release}
  67. %description locale-extras
  68. This package contains assemblies to support I18N applications for
  69. non-latin alphabets.
  70. # The above seems safe
  71. %package jscript
  72. Summary: JScript .NET support for Mono
  73. Summary(ja): Mono 用 JScript .NET サポート
  74. Group: Development/Languages
  75. Requires: mono-core = %{version}-%{release}
  76. %description jscript
  77. This package contains the JScript .NET compiler and language runtime.
  78. This allows you to compile and run JScript.NET application and
  79. assemblies.
  80. %package extras
  81. Summary: Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
  82. Group: Development/Languages
  83. Requires: mono-core = %{version}-%{release}
  84. %description extras
  85. This package provides the libary and application to run services
  86. and daemons with Mono. It also includes stubs for the following
  87. .NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
  88. System.Configuration.Install, System.Management, System.Messaging.
  89. %package winforms
  90. Summary: Windows Forms implementation for Mono
  91. Group: Development/Languages
  92. Requires: mono-core = %{version}-%{release}
  93. %description winforms
  94. This package provides a fully managed implementation of
  95. System.Windows.Forms, the default graphical toolkit for .NET
  96. applications.
  97. %package web
  98. Summary: ASP.NET, Remoting, and Web Services for Mono
  99. Group: Development/Languages
  100. Requires: mono-core = %{version}-%{release}
  101. %description web
  102. This package provides the ASP.NET libraries and runtime for
  103. development of web application, web services and remoting support.
  104. %package data
  105. Summary: Database connectivity for Mono
  106. Group: Development/Languages
  107. Requires: mono-core = %{version}-%{release}
  108. %description data
  109. This package provides a Mono assembly to facilitate data access
  110. and manipulation with databases, LDAP compatible directory servers
  111. and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
  112. System.DirectoryServices assemblies, it also includes a command
  113. line sql application as well as the Microsoft SQL Server and ODBC
  114. data providers.
  115. %package data-sqlite
  116. Summary: sqlite database connectivity for Mono
  117. Group: Development/Languages
  118. Requires: mono-core = %{version}-%{release}
  119. Requires: sqlite
  120. %description data-sqlite
  121. This package contains the ADO.NET Data provider for the sqlite
  122. database.
  123. %package data-sybase
  124. Summary: Sybase database connectivity for Mono
  125. Group: Development/Languages
  126. Requires: mono-core = %{version}-%{release}
  127. %description data-sybase
  128. This package contains the ADO.NET Data provider for the Sybase
  129. database.
  130. %package data-oracle
  131. Summary: Oracle database connectivity for Mono
  132. Group: Development/Languages
  133. Requires: mono-core = %{version}-%{release}
  134. %description data-oracle
  135. This package contains the ADO.NET Data provider for the Oracle
  136. database.
  137. %package data-postgresql
  138. Summary: Postgresql database connectivity for Mono
  139. Group: Development/Languages
  140. Requires: mono-core = %{version}-%{release}
  141. %description data-postgresql
  142. This package contains the ADO.NET Data provider for the PostgreSQL
  143. database.
  144. %package data-firebird
  145. Summary: Firebird database connectivity for Mono
  146. Group: Development/Languages
  147. Requires: mono-core = %{version}-%{release}
  148. %description data-firebird
  149. This package contains the ADO.NET Data provider for the Firebird
  150. database.
  151. %package -n ibm-data-db2
  152. Summary: IBM DB2 database connectivity for Mono
  153. Group: Development/Languages
  154. Requires: mono-core = %{version}-%{release}
  155. %description -n ibm-data-db2
  156. This package contains the ADO.NET Data provider for the IBM DB2
  157. Universal database.
  158. %package -n bytefx-data-mysql
  159. Summary: MySQL database connectivity for Mono
  160. Group: Development/Languages
  161. Requires: mono-core = %{version}-%{release}
  162. %description -n bytefx-data-mysql
  163. This package contains the ADO.NET Data provider for MySQL. This is
  164. no longer maintained. MySQL AB now provides MySQL Connector/Net
  165. which is fully managed and actively maintained.
  166. %package -n monodoc
  167. Summary: The Mono documentation system
  168. Group: Development/Tools
  169. Requires: mono-core = %{version}-%{release}
  170. Requires: libgluezilla >= 2.4
  171. Obsoletes: monodoc-core <= 2.0-1vl5
  172. %description -n monodoc
  173. monodoc is the documentation package for the mono .NET environment
  174. ## macros
  175. %define mono_dir %{_prefix}/lib/mono
  176. %define mono_doc %{_prefix}/lib/monodoc
  177. %define gac_and_1dll(dll) %{mono_dir}/gac/%{1} \
  178. %{mono_dir}/%{2}/%{1}.dll \
  179. %{nil}
  180. %define gac_and_2dll(dll) %{mono_dir}/gac/%{1} \
  181. %{mono_dir}/%{2}/%{1}.dll \
  182. %{mono_dir}/%{3}/%{1}.dll \
  183. %{nil}
  184. %define bin_and_exe(bin, exe) %{_bindir}/%{1} \
  185. %{mono_dir}/%{2}.exe \
  186. %{mono_dir}/%{2}.exe.mdb \
  187. %{nil}
  188. %define bin_exe_and_conf(bin, exe) %{_bindir}/%{1} \
  189. %{mono_dir}/%{2}.exe \
  190. %{mono_dir}/%{2}.exe.mdb \
  191. %{mono_dir}/%{2}.exe.config \
  192. %{nil}
  193. %prep
  194. %setup -q
  195. ## These are only needed if there are patches to the runtime
  196. #rm -f libgc/libtool.m4
  197. #autoreconf --force --install
  198. #autoreconf --force --install libgc
  199. # Remove prebuilt binaries
  200. rm -rf mcs/class/lib/monolite/*
  201. %build
  202. gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
  203. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  204. %configure \
  205. --with-jit=yes \
  206. --with-ikvm=yes \
  207. --with-sigaltstack=no \
  208. --with-moonlight=yes \
  209. --with-libgdiplus=installed
  210. # don't use parallel builds
  211. # make %{?_smp_mflags}
  212. make
  213. %install
  214. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
  215. make install DESTDIR=%{buildroot}
  216. install monodir %{buildroot}%{_bindir}
  217. %{__rm} %{buildroot}%{_libdir}/*.la
  218. %{__rm} %{buildroot}%{_libdir}/*.a
  219. ## Remove unused files
  220. %{__rm} %{buildroot}%{_bindir}/mono-find-provides
  221. %{__rm} %{buildroot}%{_bindir}/mono-find-requires
  222. # This was removed upstream:
  223. %{__rm} -fr %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/[12]*
  224. %{__rm} -rf %{buildroot}%{mono_dir}/1.0/Mono.Security.Win32.dll
  225. %{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
  226. %{__rm} %{buildroot}%{_datadir}/libgc-mono/README*
  227. %{__rm} %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
  228. %{__rm} %{buildroot}%{_datadir}/libgc-mono/*.html
  229. %{__rm} %{buildroot}%{_datadir}/libgc-mono/gc.man
  230. %{__rm} %{buildroot}/%{_bindir}/jay
  231. %{__rm} -r %{buildroot}%{_datadir}/jay
  232. %{__rm} %{buildroot}%{_mandir}/man1/jay.1
  233. %{__rm} %{buildroot}%{_mandir}/man1/monostyle.1
  234. %{__rm} %{buildroot}%{_mandir}/man1/oldmono.1
  235. %{__rm} %{buildroot}%{_mandir}/man1/mint.1
  236. %{__rm} %{buildroot}%{mono_dir}/1.0/browsercaps-updater.exe*
  237. %find_lang mcs
  238. %clean
  239. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
  240. %post core -p /sbin/ldconfig
  241. %postun core -p /sbin/ldconfig
  242. %post devel -p /sbin/ldconfig
  243. %postun devel -p /sbin/ldconfig
  244. %files core -f mcs.lang
  245. %defattr(-,root,root,-)
  246. %doc AUTHORS COPYING.LIB ChangeLog NEWS README
  247. %dir %{mono_dir}
  248. %dir %{mono_dir}/1.0
  249. %dir %{mono_dir}/2.0
  250. %dir %{mono_dir}/3.5
  251. %dir %{mono_dir}/gac
  252. %dir %{mono_dir}/compat-*
  253. %bin_and_exe csharp 2.0/csharp
  254. %bin_and_exe certmgr 1.0/certmgr
  255. %bin_and_exe chktrust 1.0/chktrust
  256. %bin_and_exe lc 2.0/lc
  257. %{_bindir}/gacutil
  258. %bin_and_exe gacutil1 1.0/gacutil
  259. %bin_and_exe gacutil2 2.0/gacutil
  260. %bin_exe_and_conf gmcs 2.0/gmcs
  261. %bin_and_exe installvst 1.0/installvst
  262. %bin_and_exe mconfig 2.0/mconfig
  263. %bin_and_exe mod 1.0/mod
  264. %{_bindir}/mono
  265. %{_bindir}/monodir
  266. %{_bindir}/mono-api-*
  267. %bin_and_exe mono-cil-strip 1.0/mono-cil-strip
  268. %{_bindir}/mono-test-install
  269. %bin_and_exe monolinker 2.0/monolinker
  270. %bin_and_exe mozroots 1.0/mozroots
  271. %{_bindir}/mcs
  272. %bin_exe_and_conf mcs1 1.0/mcs
  273. %bin_and_exe setreg 1.0/setreg
  274. %bin_and_exe sn 1.0/sn
  275. %bin_exe_and_conf sqlmetal 2.0/sqlmetal
  276. %bin_and_exe svcutil 2.0/svcutil
  277. %{_libdir}/libMonoPosixHelper.so
  278. %{_libdir}/libmono.so.*
  279. %{_libdir}/libmono-profiler-logging.so.*
  280. %{mono_dir}/1.0/ictool.exe
  281. %{mono_dir}/1.0/ictool.exe.mdb
  282. %{mono_dir}/?.0/installutil.*
  283. %{mono_dir}/?.0/mono-api-info*
  284. %{mono_dir}/?.0/mscorlib.dll
  285. %{mono_dir}/?.0/mscorlib.dll.mdb
  286. %{mono_dir}/3.5/System.Web.Extensions*
  287. %{mono_dir}/3.5/Microsoft.Build.*
  288. %{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
  289. %{mono_dir}/gac/Mono.Cecil
  290. %{mono_dir}/gac/Mono.Cecil.Mdb
  291. %{mono_dir}/xbuild/*
  292. %gac_and_2dll cscompmgd 2.0 1.0
  293. %gac_and_2dll Commons.Xml.Relaxng 2.0 1.0
  294. %gac_and_2dll CustomMarshalers 2.0 1.0
  295. %gac_and_2dll I18N 2.0 1.0
  296. %gac_and_2dll I18N.West 2.0 1.0
  297. %gac_and_2dll ICSharpCode.SharpZipLib 2.0 1.0
  298. %gac_and_1dll Mono.C5 2.0
  299. %gac_and_2dll Mono.Cairo 2.0 1.0
  300. %gac_and_2dll Mono.CompilerServices.SymbolWriter 2.0 1.0
  301. %gac_and_2dll Mono.GetOptions 2.0 1.0
  302. %gac_and_2dll Mono.Posix 2.0 1.0
  303. %gac_and_2dll Mono.Security 2.0 1.0
  304. %gac_and_2dll System 2.0 1.0
  305. %gac_and_1dll System.Configuration 2.0
  306. %gac_and_2dll System.Drawing 2.0 1.0
  307. %gac_and_2dll System.Security 2.0 1.0
  308. %gac_and_2dll System.Xml 2.0 1.0
  309. %gac_and_1dll System.Xml.Linq 2.0
  310. %gac_and_1dll System.Core 2.0
  311. %gac_and_1dll Mono.CSharp 2.0
  312. %gac_and_1dll Mono.Debugger.Soft 2.0
  313. %gac_and_1dll Mono.Management 2.0
  314. %gac_and_1dll Mono.Simd 2.0
  315. %gac_and_1dll Mono.Tasklets 2.0
  316. %gac_and_1dll System.ComponentModel.DataAnnotations 2.0
  317. %gac_and_1dll System.IdentityModel.Selectors 2.0
  318. %gac_and_1dll System.IdentityModel 2.0
  319. %gac_and_1dll System.Runtime.Serialization 2.0
  320. %gac_and_2dll OpenSystem.C 2.0 1.0
  321. %gac_and_1dll WindowsBase 2.0
  322. %dir %{_sysconfdir}/mono
  323. %dir %{_sysconfdir}/mono/1.0
  324. %dir %{_sysconfdir}/mono/2.0
  325. %dir %{_sysconfdir}/mono/mconfig
  326. %config (noreplace) %{_sysconfdir}/mono/config
  327. %config (noreplace) %{_sysconfdir}/mono/1.0/machine.config
  328. %config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
  329. %config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
  330. %config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
  331. %{_prefix}/lib/mono-source-libs/
  332. %{_mandir}/man1/certmgr.1.gz
  333. %{_mandir}/man1/chktrust.1.gz
  334. %{_mandir}/man1/csharp.1.gz
  335. %{_mandir}/man1/gacutil.1.gz
  336. %{_mandir}/man1/lc.1.gz
  337. %{_mandir}/man1/mconfig.1.gz
  338. %{_mandir}/man1/mcs.1.gz
  339. %{_mandir}/man1/mono.1.gz
  340. %{_mandir}/man1/monolinker.1.gz
  341. %{_mandir}/man1/mozroots.1.gz
  342. %{_mandir}/man1/setreg.1.gz
  343. %{_mandir}/man1/sn.1.gz
  344. %{_mandir}/man1/resgen.1.gz
  345. %{_mandir}/man1/mono-cil-strip.1.gz
  346. %{_mandir}/man1/xbuild.1.gz
  347. %{_mandir}/man5/mono-config.5.gz
  348. %files devel
  349. %defattr(-,root,root,-)
  350. %{_bindir}/al
  351. %{_bindir}/genxs
  352. %{_bindir}/ilasm1
  353. %{_bindir}/mkbundle
  354. %bin_and_exe mkbundle1 1.0/mkbundle
  355. %bin_and_exe mkbundle2 2.0/mkbundle
  356. %{_bindir}/monodis
  357. %{_bindir}/monograph
  358. %{_bindir}/monop1
  359. %{_bindir}/mono-gdb.py
  360. %{_bindir}/pedump
  361. %{_bindir}/resgen1
  362. %bin_and_exe al1 1.0/al
  363. %bin_and_exe al2 2.0/al
  364. %bin_and_exe caspol 1.0/caspol
  365. %bin_and_exe cert2spc 1.0/cert2spc
  366. %bin_and_exe cilc 1.0/cilc
  367. %bin_and_exe dtd2xsd 1.0/dtd2xsd
  368. %bin_and_exe dtd2rng 1.0/dtd2rng
  369. %bin_and_exe genxs1 1.0/genxs
  370. %bin_and_exe sgen 2.0/sgen
  371. %bin_and_exe ilasm 1.0/ilasm
  372. %bin_and_exe ilasm2 2.0/ilasm
  373. %bin_and_exe macpack 1.0/macpack
  374. %bin_and_exe makecert 1.0/makecert
  375. %bin_and_exe monop 1.0/monop
  376. %bin_and_exe monop2 2.0/monop
  377. %bin_exe_and_conf mono-shlib-cop 2.0/mono-shlib-cop
  378. %bin_and_exe mono-xmltool 2.0/mono-xmltool
  379. %bin_and_exe pdb2mdb 2.0/pdb2mdb
  380. %bin_and_exe permview 1.0/permview
  381. %bin_and_exe prj2make 1.0/prj2make
  382. %bin_and_exe resgen 1.0/resgen
  383. %bin_and_exe resgen2 2.0/resgen
  384. %bin_and_exe secutil 1.0/secutil
  385. %bin_and_exe signcode 1.0/signcode
  386. %bin_and_exe xbuild 2.0/xbuild
  387. %bin_and_exe xbuild 3.5/xbuild
  388. %{mono_dir}/1.0/culevel*
  389. %{mono_dir}/2.0/MSBuild
  390. %{mono_dir}/2.0/Microsoft.Build.xsd
  391. %{mono_dir}/2.0/Microsoft.*.targets
  392. %{mono_dir}/2.0/Microsoft.Common.tasks
  393. %{mono_dir}/2.0/xbuild.rsp
  394. %{mono_dir}/3.5/MSBuild
  395. %{mono_dir}/3.5/Microsoft.*.targets
  396. %{mono_dir}/3.5/Microsoft.Common.tasks
  397. %{mono_dir}/3.5/xbuild.rsp
  398. %gac_and_2dll PEAPI 2.0 1.0
  399. %gac_and_2dll Microsoft.Build.Engine 3.5 2.0
  400. %gac_and_2dll Microsoft.Build.Framework 3.5 2.0
  401. %gac_and_1dll Microsoft.Build.Tasks 2.0
  402. %gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
  403. %gac_and_1dll Microsoft.Build.Utilities 2.0
  404. %gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
  405. %gac_and_2dll Microsoft.VisualC 2.0 1.0
  406. %{_libdir}/libmono-profiler-aot.*
  407. %{_libdir}/libmono-profiler-cov.*
  408. %{_libdir}/libmono.so
  409. %{_libdir}/libMonoSupportW.so
  410. %{_libdir}/libmono-profiler-logging.so
  411. %{_libdir}/libikvm-native.so
  412. %{_libdir}/pkgconfig/dotnet.pc
  413. %{_libdir}/pkgconfig/mono-cairo.pc
  414. %{_libdir}/pkgconfig/mono.pc
  415. %{_libdir}/pkgconfig/cecil.pc
  416. %{_libdir}/pkgconfig/dotnet35.pc
  417. %{_libdir}/pkgconfig/mono-lineeditor.pc
  418. %{_libdir}/pkgconfig/mono-options.pc
  419. %{_libdir}/pkgconfig/wcf.pc
  420. %{_includedir}/mono-1.0
  421. %dir %{_datadir}/mono-1.0
  422. %dir %{_datadir}/mono-1.0/mono
  423. %dir %{_datadir}/mono-1.0/mono/cil
  424. %{_datadir}/mono-1.0/mono/cil/cil-opcodes.xml
  425. %{_mandir}/man1/al.1.gz
  426. %{_mandir}/man1/cert2spc.1.gz
  427. %{_mandir}/man1/cilc.1.gz
  428. %{_mandir}/man1/dtd2xsd.1.gz
  429. %{_mandir}/man1/genxs.1.gz
  430. %{_mandir}/man1/ilasm.1.gz
  431. %{_mandir}/man1/macpack.1.gz
  432. %{_mandir}/man1/makecert.1.gz
  433. %{_mandir}/man1/mkbundle.1.gz
  434. %{_mandir}/man1/mono-shlib-cop.1.gz
  435. %{_mandir}/man1/mono-xmltool.1.gz
  436. %{_mandir}/man1/monodis.1.gz
  437. %{_mandir}/man1/monop.1.gz
  438. %{_mandir}/man1/pdb2mdb.1.gz
  439. %{_mandir}/man1/permview.1.gz
  440. %{_mandir}/man1/prj2make.1.gz
  441. %{_mandir}/man1/secutil.1.gz
  442. %{_mandir}/man1/sgen.1.gz
  443. %{_mandir}/man1/signcode.1.gz
  444. %files nunit
  445. %defattr(-,root,root,-)
  446. %bin_exe_and_conf nunit-console 1.0/nunit-console
  447. %bin_exe_and_conf nunit-console2 2.0/nunit-console
  448. %gac_and_2dll nunit.core 2.0 1.0
  449. %gac_and_2dll nunit.framework 2.0 1.0
  450. %gac_and_2dll nunit.util 2.0 1.0
  451. %gac_and_2dll nunit.mocks 2.0 1.0
  452. %gac_and_2dll nunit-console-runner 2.0 1.0
  453. %gac_and_2dll nunit.core.extensions 2.0 1.0
  454. %gac_and_2dll nunit.core.interfaces 2.0 1.0
  455. %gac_and_2dll nunit.framework.extensions 2.0 1.0
  456. %{_libdir}/pkgconfig/mono-nunit.pc
  457. %files locale-extras
  458. %defattr(-,root,root,-)
  459. %gac_and_2dll I18N.MidEast 2.0 1.0
  460. %gac_and_2dll I18N.Rare 2.0 1.0
  461. %gac_and_2dll I18N.CJK 2.0 1.0
  462. %gac_and_2dll I18N.Other 2.0 1.0
  463. %files jscript
  464. %defattr(-,root,root,-)
  465. %bin_and_exe mjs 1.0/mjs
  466. %gac_and_2dll Microsoft.JScript 2.0 1.0
  467. %files extras
  468. %defattr(-,root,root,-)
  469. %{_mandir}/man1/mono-service.1.gz
  470. %bin_and_exe mono-service 1.0/mono-service
  471. %bin_and_exe mono-service2 2.0/mono-service
  472. %{mono_dir}/gac/mono-service
  473. %gac_and_2dll System.Management 2.0 1.0
  474. %gac_and_2dll System.Messaging 2.0 1.0
  475. %gac_and_2dll System.ServiceProcess 2.0 1.0
  476. %gac_and_1dll System.ServiceModel 2.0
  477. %gac_and_2dll System.Configuration.Install 2.0 1.0
  478. %gac_and_2dll Microsoft.Vsa 2.0 1.0
  479. %gac_and_2dll Mono.Messaging.RabbitMQ 2.0 1.0
  480. %gac_and_2dll Mono.Messaging 2.0 1.0
  481. %gac_and_2dll RabbitMQ.Client 2.0 1.0
  482. %{mono_dir}/1.0/RabbitMQ.Client.Apigen.exe*
  483. %{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
  484. %files winforms
  485. %defattr(-,root,root,-)
  486. %gac_and_2dll System.Windows.Forms 2.0 1.0
  487. %gac_and_2dll Accessibility 2.0 1.0
  488. %gac_and_2dll System.Design 2.0 1.0
  489. %gac_and_2dll System.Drawing.Design 2.0 1.0
  490. %files web
  491. %defattr(-,root,root,-)
  492. %bin_and_exe httpcfg 2.0/httpcfg
  493. %bin_and_exe disco 1.0/disco
  494. %bin_and_exe soapsuds 1.0/soapsuds
  495. %bin_and_exe wsdl 1.0/wsdl
  496. %{_bindir}/wsdl1
  497. %bin_and_exe wsdl2 2.0/wsdl
  498. %bin_and_exe xsd2 2.0/xsd
  499. %bin_and_exe xsd 1.0/xsd
  500. %gac_and_2dll Mono.Http 2.0 1.0
  501. %gac_and_1dll Mono.Web 2.0
  502. %gac_and_2dll Mono.WebBrowser 2.0 1.0
  503. %gac_and_2dll System.Runtime.Remoting 2.0 1.0
  504. %gac_and_2dll System.Web 2.0 1.0
  505. %gac_and_2dll System.Runtime.Serialization.Formatters.Soap 2.0 1.0
  506. %{mono_dir}/compat-2.0/System.Web.Extensions*dll
  507. %{mono_dir}/compat-2.0/System.Web.Mvc.dll
  508. %gac_and_1dll System.ServiceModel.Web 2.0
  509. %gac_and_1dll System.Web.Abstractions 2.0
  510. %gac_and_1dll System.Web.DynamicData 2.0
  511. %gac_and_1dll System.Web.Mvc 2.0
  512. %gac_and_1dll System.Web.Routing 2.0
  513. %gac_and_2dll System.Web.Services 2.0 1.0
  514. %gac_and_2dll System.Web.Extensions.Design 3.5 2.0
  515. %gac_and_1dll System.Web.Extensions 2.0
  516. %{_mandir}/man1/disco.1.gz
  517. %{_mandir}/man1/soapsuds.1.gz
  518. %{_mandir}/man1/wsdl.1.gz
  519. %{_mandir}/man1/xsd.1.gz
  520. %config (noreplace) %{_sysconfdir}/mono/browscap.ini
  521. %config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
  522. %config (noreplace) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
  523. %config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
  524. %config (noreplace) %{_sysconfdir}/mono/2.0/web.config
  525. %{_mandir}/man1/httpcfg.1.gz
  526. %{_libdir}/pkgconfig/mono.web.pc
  527. %{_libdir}/pkgconfig/system.web.extensions_1.0.pc
  528. %{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
  529. %{_libdir}/pkgconfig/system.web.mvc.pc
  530. %files data
  531. %defattr(-,root,root,-)
  532. %bin_and_exe sqlsharp 2.0/sqlsharp
  533. %{mono_dir}/gac/System.Data.Services
  534. %gac_and_2dll System.Data 2.0 1.0
  535. %gac_and_1dll System.Data.DataSetExtensions 2.0
  536. %gac_and_1dll System.Data.Linq 2.0
  537. %gac_and_2dll Mono.Data 2.0 1.0
  538. %gac_and_2dll Mono.Data.Tds 2.0 1.0
  539. %gac_and_2dll Mono.Data.TdsClient 2.0 1.0
  540. %gac_and_2dll System.EnterpriseServices 2.0 1.0
  541. %gac_and_2dll Novell.Directory.Ldap 2.0 1.0
  542. %gac_and_2dll System.DirectoryServices 2.0 1.0
  543. %gac_and_1dll System.Transactions 2.0
  544. %{_mandir}/man1/sqlsharp.1.gz
  545. %files data-sqlite
  546. %defattr(-,root,root,-)
  547. %gac_and_2dll Mono.Data.SqliteClient 2.0 1.0
  548. %gac_and_2dll Mono.Data.Sqlite 2.0 1.0
  549. %files data-sybase
  550. %defattr(-,root,root,-)
  551. %gac_and_2dll Mono.Data.SybaseClient 2.0 1.0
  552. %files data-oracle
  553. %defattr(-,root,root,-)
  554. %gac_and_2dll System.Data.OracleClient 2.0 1.0
  555. %files data-postgresql
  556. %defattr(-,root,root,-)
  557. %gac_and_2dll Npgsql 2.0 1.0
  558. %files data-firebird
  559. %defattr(-,root,root,-)
  560. %gac_and_1dll FirebirdSql.Data.Firebird 1.0
  561. %files -n bytefx-data-mysql
  562. %defattr(-,root,root,-)
  563. %gac_and_2dll ByteFX.Data 2.0 1.0
  564. %files -n ibm-data-db2
  565. %defattr(-,root,root,-)
  566. %gac_and_2dll IBM.Data.DB2 2.0 1.0
  567. %files -n monodoc
  568. %defattr(-, root, root)
  569. %bin_and_exe mdoc 2.0/mdoc
  570. %{_bindir}/mdoc-*
  571. %{_bindir}/mdass*
  572. %{_bindir}/mdval*
  573. %{_bindir}/mod
  574. %{_bindir}/monodoc*
  575. %{mono_dir}/gac/monodoc
  576. %{mono_dir}/monodoc/monodoc.dll
  577. %{mono_doc}/*
  578. %{_mandir}/man1/md*
  579. %{_mandir}/man1/monodoc*
  580. %{_mandir}/man5/mdoc*
  581. %{_libdir}/pkgconfig/monodoc.pc
  582. %changelog
  583. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
  584. - updated mono to 2.6.7
  585. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  586. - updated mono to 2.6.4
  587. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  588. - updated mono to 2.6.3
  589. added RabbitMQ.Client.Apigen.exe
  590. * Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
  591. - unuse _smp_mflags
  592. * Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
  593. - updated mono to 2.6.1
  594. - simplified macros
  595. * Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
  596. - updated mono to 2.4.3
  597. added %%{mono_dir}/2.0/lc.exe*
  598. added %%gac_dll System.Web.Mvc
  599. added %%{mono_dir}/xbuild/*
  600. added %%{_mandir}/man1/lc.1.gz
  601. added %%{_mandir}/man1/xbuild.1.gz
  602. * Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
  603. - updated mono to 2.4.2.3
  604. * Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
  605. - updated mono to 2.4.2.2
  606. * Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
  607. - new upstream release
  608. - build with latest rpm to update mono-dependencies
  609. * Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
  610. - updated mono to 2.4.2
  611. * Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
  612. - fix temporary workaround against build failure on ppc,
  613. from RH bugzilla #494026
  614. - statically link mono to libmono: remove "--disable-static" from configure
  615. - ensure removing *.a files in the install section
  616. - remove prebuilt binaries under mcs/class/lib/monolite/ before building
  617. * Sun Apr 5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  618. - fixed paths using %%mono_dir, %%mono_doc macros
  619. - added Requires:libgluezilla >= 2.4 in monodoc
  620. * Sat Apr 4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
  621. - new upstream release
  622. - added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
  623. * Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
  624. - new upstream release
  625. - dropt %%{_bindir}/mono-find-{provides,requires}
  626. - added --with-libgdiplus=installed
  627. * Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
  628. - update to mono-2.0 released source
  629. - BR: libgdiplus-devel >= 2.0
  630. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
  631. - removed *.la
  632. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
  633. - updated mono to 2.0
  634. - updated url
  635. - changed macro %%monodir to %%mono_dir
  636. - dropt mono-1.1.13.4-selinux-ia64.patch
  637. - dropt mono-1.1.13.4-ppc-threading.patch
  638. - dropt mono-1.2.3-use-monodir.patch
  639. * Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
  640. - applied new versioning policy, spec in utf-8
  641. - dropt mono-1.2.5-libdir.patch
  642. - reverted monodir macro to using %%{_prefix}/lib/mono
  643. * Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
  644. - updated monodir to %%{_libdir}/mono
  645. * Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
  646. - new upstream release
  647. - splited mono-basic package
  648. * Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
  649. - new upstream release
  650. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
  651. - new upstream release
  652. * Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
  653. - disabled Patch2 on Vine/ppc environment
  654. * Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
  655. - updated source and sub-packages based on Fedora packages
  656. * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
  657. - new upstream version(mono-1.0.6)
  658. * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
  659. - new upstream version(mono-1.0.5)
  660. * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
  661. - new upstream version(mono-1.0.4)
  662. -- changed to use configure
  663. * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  664. - rebuild for Vine Linux (based on mono.spec inside src archive)
  665. - Fixed BuildRequires: gc-devel, libicu-devel
  666. - add Japanese translation
  667. * Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
  668. - rebuild for ppc TLS issue (#184446)
  669. * Fri Mar 3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
  670. - Update to 1.1.13.4
  671. - Add patch so mono doesn't segfault on PPC SMP machines
  672. - Minor spec cleanup
  673. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
  674. - Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
  675. for bug 182965)
  676. * Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
  677. - Updated patch from Paolo Molaro <lupus@ximian.com>
  678. * Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
  679. - Patch from Jakub to make work with SELinux better
  680. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
  681. - Rebuild
  682. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
  683. - rebuilt for new gcc4.1 snapshot and glibc changes
  684. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
  685. - Update to 1.1.13.2
  686. * Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
  687. - Update to 1.13
  688. - Add libgdiplus dep to mono-core
  689. - Add s390x to build
  690. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
  691. - Update to 1.1.12.1
  692. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
  693. - rebuild
  694. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
  695. - Disable s390 due to some build failure
  696. * Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
  697. - Build on s390 and x86-64 now
  698. * Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
  699. - Initial version