neon-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.30.0
  6. Release: 1%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: gnutls-devel
  17. BuildRequires: krb5-devel
  18. BuildRequires: libxml2-devel
  19. BuildRequires: sed
  20. BuildRequires: zlib-devel
  21. BuildRequires: keyutils-libs-devel
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. neon is an HTTP and WebDAV client library, with a C interface;
  26. providing a high-level interface to HTTP and WebDAV methods along
  27. with a low-level interface for HTTP request handling. neon
  28. supports persistent connections, proxy servers, basic, digest and
  29. Kerberos authentication, and has complete SSL support.
  30. %package devel
  31. Summary: Development libraries and C header files for the neon library
  32. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}
  35. Requires: zlib-devel
  36. #Requires: openssl-devel
  37. Requires: expat-devel
  38. Requires: gnutls-devel
  39. Requires: krb5-devel
  40. Requires: keyutils-libs-devel
  41. %description devel
  42. The development library for the C language HTTP and WebDAV client library.
  43. %description devel -l ja
  44. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-%{name}
  47. Summary: C language HTTP and WebDAV client library.
  48. Group: System Environment/Libraries
  49. Requires: expat
  50. Requires: zlib >= 1.1.4
  51. %description -n compat32-%{name}
  52. A C language HTTP and WebDAV client library.
  53. %package -n compat32-%{name}-devel
  54. Summary: A C language HTTP and WebDAV client library.
  55. Group: Development/Libraries
  56. Requires: compat32-%{name} = %{version}
  57. Requires: compat32-zlib-devel
  58. #Requires: compat32-openssl-devel
  59. Requires: compat32-expat-devel
  60. Requires: compat32-keyutils-libs-devel
  61. Requires: compat32-krb5-devel
  62. %description -n compat32-%{name}-devel
  63. The development library for the C language HTTP and WebDAV client library.
  64. %prep
  65. %setup -q
  66. %build
  67. %configure \
  68. --with-expat \
  69. --with-ssl=gnutls \
  70. --enable-threadsafe-ssl=posix \
  71. --enable-shared \
  72. --disable-static \
  73. --with-force-ssl
  74. %__make %{?_smp_mflags}
  75. %install
  76. %__rm -rf %{buildroot}
  77. %makeinstall
  78. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  79. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  80. %find_lang %{name}
  81. ## remove unuse files
  82. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %post -n compat32-%{name} -p /sbin/ldconfig
  88. %postun -n compat32-%{name} -p /sbin/ldconfig
  89. %files -f %{name}.lang
  90. %defattr(-,root,root)
  91. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  92. %doc doc/html
  93. %{_libdir}/*.so.*
  94. %files devel
  95. %defattr(-,root,root)
  96. %{_bindir}/*
  97. %{_includedir}/*
  98. %{_mandir}/man1/*
  99. %{_mandir}/man3/*
  100. #{_libdir}/*.a
  101. #{_libdir}/*.la
  102. %{_libdir}/*.so
  103. %{_libdir}/pkgconfig/*.pc
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr(-,root,root)
  107. %{_libdir}/*.so.*
  108. %files -n compat32-%{name}-devel
  109. %defattr(-,root,root)
  110. #{_libdir}/*.a
  111. #{_libdir}/*.la
  112. %{_libdir}/pkgconfig/*.pc
  113. %endif
  114. %changelog
  115. * Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
  116. - update to 0.30.0
  117. * Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
  118. - rebuild with VineSeed environment
  119. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
  120. - update to 0.29.6
  121. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  122. - add BuildRequires: keyutils-libs-devel
  123. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  124. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  125. - new upstream release
  126. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  127. - rebuilt with krb5-libs-1.8.2
  128. - removed BR: openssl-devel
  129. - removed static library from devel package
  130. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  131. - rebuilt with rpm-4.8.1 for pkg-config
  132. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  133. - new upstream release with security fix (CVE-2009-2473, 2474)
  134. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  135. - rebuild with gnutls-2.6.3
  136. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  137. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  138. - add _smp_mflags into make section
  139. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  140. - new upstream release with security fix (CVE-2008-3746)
  141. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  142. - removed *.la
  143. - spec in utf-8
  144. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  145. - added --with-ssl=gnutls --enable-threadsafe-ssl
  146. - added BuildRequires: gnutls-devel
  147. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  148. - new upstream release
  149. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  150. - removed %%if !%%{build_compat32} case condition
  151. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  152. - rebuild with expat-2.0.1
  153. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  154. - new upstream release
  155. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  156. - add Requires: zlib-devel, openssl-devel, expat-devel
  157. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  158. - move %%configure from %%prep to %%build
  159. - remove unneeded locales.patch (for neon-0.26.x or later)
  160. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  161. - new upstream release
  162. - drop doc.patch (patch0)
  163. - use more macros
  164. - drop BuildRequires: autoconf, automake
  165. - add *.pc to -devel (and compat32's) package
  166. - change group
  167. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  168. - add doc/html instead of doc/* to %%doc
  169. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  170. - run ldconfig in %%post,postun
  171. - add locales.patch (patch0)
  172. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  173. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  174. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  175. - added compat32- packages for x86_64 architecture support
  176. - added --libdir=%{_libdir} option to configure
  177. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  178. - new upstream release
  179. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  180. - upstream release
  181. - update URL and Source0 tag: valid URL
  182. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  183. - upstream release
  184. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  185. - add Japanese Summary and %%description
  186. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  187. - build VineLinux
  188. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  189. - Updated to 0.23.5.
  190. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  191. - Upgraded to 0.23.2.
  192. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  193. - Upgraded to 0.22.0.
  194. - Fixed compilation from CVS.
  195. - Took out man pages until I can figure out xmlto program.
  196. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  197. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  198. to RedHat 7.3 versions and fixing bug in spec file.
  199. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  200. work.
  201. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  202. - Fixed file ownership problems. Made them owned by root.
  203. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  204. - Updated to neon 0.21.3.
  205. * Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  206. - Updated to neon 0.21.2.
  207. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  208. - Updated to neon 0.21.1.
  209. - Now requires zlib >= 1.1.4.
  210. - Broke into zlib and zlib-devel.
  211. - Now builds shared library.
  212. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  213. - Updated to neon 0.19.4.
  214. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  215. - Updated to neon 0.19.2.
  216. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  217. - Updated to neon 0.18.2.
  218. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  219. - Took out dependency on libxml and w3c-libwww packages.
  220. - Added dependency on expat.
  221. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  222. - Release 0.17.2-1: Updated neon.
  223. * Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  224. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  225. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  226. - Release 2001-10-20: Initial Version.