gtk-sharp2-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gtk-sharp
  3. Name: gtk-sharp2
  4. Version: 2.12.27
  5. Release: 1%{?_dist_release}
  6. Summary: GTK+ bindings for Mono
  7. Summary(ja): Mono 用 GTK+ バインディング
  8. Group: System Environment/Libraries
  9. License: LGPLv2
  10. URL: http://www.mono-project.com/docs/gui/gtksharp/
  11. Source: https://github.com/mono/gtk-sharp/archive/%{_name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: mono-devel
  14. BuildRequires: monodoc
  15. BuildRequires: glib2-devel >= 2.12.0
  16. BuildRequires: pango-devel
  17. BuildRequires: atk-devel
  18. BuildRequires: gtk2-devel >= 2.12.0
  19. BuildRequires: libglade2-devel
  20. BuildRequires: automake, libtool
  21. BuildRequires: nkf
  22. # Mono only availible on these:
  23. ExclusiveArch: %{ix86} x86_64 ppc ia64 armv4l sparc s390 s390x
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. This package provides a library that allows you to build
  28. fully native graphical GNOME applications using Mono. Gtk#
  29. is a binding to GTK+, the cross platform user interface
  30. toolkit used in GNOME. It includes bindings for Gtk, Atk,
  31. Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. Gtk#
  32. 2.12.x binds GTK+ 2.12.
  33. %package gapi
  34. Summary: Glib and GObject C source parser and C generator for the creation and maintenance of managed bindings for Mono and .NET
  35. Group: Development/Tools
  36. Requires: perl-XML-LibXML-Common
  37. Requires: perl-XML-LibXML
  38. Requires: perl-XML-SAX
  39. %description gapi
  40. This package provides developer tools for the creation and
  41. maintenance of managed bindings to native libraries which utilize
  42. glib and GObject. Some examples of libraries currently bound using
  43. the GAPI tools and found in Gtk# include Gtk, Atk, Pango, Gdk.
  44. %package devel
  45. Summary: Files needed for developing with gtk-sharp2
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig
  49. %description devel
  50. This package provides the necessary development libraries and headers
  51. for writing gtk-sharp2 applications.
  52. %package doc
  53. Summary: Gtk# documentation
  54. Group: Documentation
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: monodoc
  57. %description doc
  58. This package provides the Gtk# documentation for monodoc.
  59. %prep
  60. # name duplication may be bug...
  61. %setup -q -n %{_name}-%{_name}-%{version}
  62. ./bootstrap-2.12
  63. %build
  64. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  65. %configure --enable-silent-rules
  66. make
  67. %install
  68. %{__rm} -rf $RPM_BUILD_ROOT
  69. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  70. make install DESTDIR=$RPM_BUILD_ROOT GACUTIL_FLAGS="/package gtk-sharp /gacdir %{_prefix}/lib /root ${RPM_BUILD_ROOT}%{_prefix}/lib"
  71. ## remove unused files
  72. %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.a
  73. %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
  74. mv $RPM_BUILD_ROOT%{mono_dir}/gtk-sharp $RPM_BUILD_ROOT%{mono_dir}/gtk-sharp-2.0
  75. for file in $RPM_BUILD_ROOT%{_bindir}/gapi2-codegen $RPM_BUILD_ROOT%{_bindir}/gapi2-fixup $RPM_BUILD_ROOT%{_bindir}/gapi2-parser $RPM_BUILD_ROOT%{_prefix}/lib/gtk-sharp-2.0/gapi2xml.pl $RPM_BUILD_ROOT%{_prefix}/lib/gtk-sharp-2.0/gapi_pp.pl
  76. do
  77. mv $file $file.orig
  78. nkf -w --unix $file.orig > $file
  79. chmod 755 $file
  80. rm $file.orig
  81. done
  82. %clean
  83. %{__rm} -rf $RPM_BUILD_ROOT
  84. %files
  85. %defattr(-,root,root,-)
  86. %doc COPYING ChangeLog README
  87. %{_libdir}/libatksharpglue-2.so
  88. %{_libdir}/libgdksharpglue-2.so
  89. %{_libdir}/libgladesharpglue-2.so
  90. %{_libdir}/libglibsharpglue-2.so
  91. %{_libdir}/libgtksharpglue-2.so
  92. %{_libdir}/libpangosharpglue-2.so
  93. %dir %{_prefix}/lib/gtk-sharp-2.0
  94. %{mono_dir}/gac/atk-sharp
  95. %{mono_dir}/gac/gdk-sharp
  96. %{mono_dir}/gac/glade-sharp
  97. %{mono_dir}/gac/glib-sharp
  98. %{mono_dir}/gac/gtk-dotnet
  99. %{mono_dir}/gac/gtk-sharp
  100. %{mono_dir}/gac/pango-sharp
  101. %{mono_dir}/gac/policy.2.10.*
  102. %{mono_dir}/gac/policy.2.4.*
  103. %{mono_dir}/gac/policy.2.6.*
  104. %{mono_dir}/gac/policy.2.8.*
  105. %{mono_dir}/gtk-sharp-2.0
  106. %files gapi
  107. %defattr(-,root,root,-)
  108. %{_bindir}/gapi2-codegen
  109. %{_bindir}/gapi2-fixup
  110. %{_bindir}/gapi2-parser
  111. %{_prefix}/lib/gtk-sharp-2.0/gapi-fixup.exe
  112. %{_prefix}/lib/gtk-sharp-2.0/gapi-parser.exe
  113. %{_prefix}/lib/gtk-sharp-2.0/gapi_codegen.exe
  114. %{_prefix}/lib/gtk-sharp-2.0/gapi2xml.pl
  115. %{_prefix}/lib/gtk-sharp-2.0/gapi_pp.pl
  116. %{_libdir}/pkgconfig/gapi-2.0.pc
  117. %{_prefix}/share/gapi-2.0
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_libdir}/pkgconfig/*-sharp-2.0.pc
  121. %{_libdir}/pkgconfig/gtk-dotnet-2.0.pc
  122. %files doc
  123. %defattr(-,root,root,-)
  124. %{_prefix}/lib/monodoc/sources/*
  125. %changelog
  126. * Mon Nov 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.12.27-1
  127. - updated to 2.12.27
  128. - split devel and doc subpackage
  129. - fixed gapi2xml.pl and gapi_pp.pl encoding
  130. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.21-1
  131. - update to 2.12.21
  132. * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.12.10-6
  133. - rebuilt with mono-2.10.1-3
  134. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.12.10-5
  135. - rebuilt with mono-2.10.1
  136. * Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.10-4
  137. - rebuilt with mono-2.8
  138. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.12.10-3
  139. - build with rpm-4.8.1-1 for pkg-config file
  140. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.10-2
  141. - updated build dependencies
  142. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.10-1
  143. - updated gtk-sharp to 2.12.10
  144. * Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.9-2
  145. - rebuilt with mono-2.6.1
  146. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.9-1
  147. - updated gtk-sharp to 2.12.9
  148. - built with latest rpm to update mono-dependencies
  149. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.8-1vl5
  150. - updated gtk-sharp to 2.12.8
  151. * Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.5-1vl5
  152. - updated gtk-sharp to 2.12.5
  153. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1vl5
  154. - updated gtk-sharp to 2.12.3
  155. - dropt gtk-sharp2-vtelibs.patch
  156. - built with mono-2.0
  157. * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.2-2vl5
  158. - applied new versioning policy, spec in utf-8
  159. - use automake-1.7
  160. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.8.2-1vl1
  161. - rebuilt for Vine Linux
  162. * Fri Mar 3 2006 Christopher Aillon <caillon@redhat.com> - 2.8.2-1
  163. - Update to 2.8.2 to fix an issue with marshalling on x86-64
  164. * Fri Feb 10 2006 Christopher Aillon <caillon@redhat.com> - 2.8.1-1
  165. - Update to 2.8.1
  166. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.8.0-1.1
  167. - rebuilt for new gcc4.1 snapshot and glibc changes
  168. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> 2.8.0-1
  169. - Update to 2.8.0
  170. * Thu Jan 19 2006 Alexander Larsson <alexl@redhat.com> 2.4.0-3
  171. - Mono now builds on s390x
  172. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 2.4.0-2
  173. - Fix vte build
  174. * Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 2.4.0-1
  175. - Initial version