libserf-vl.spec 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. %global oname serf
  2. Name: libserf
  3. Version: 1.3.4
  4. Release: 2%{?dist}
  5. Summary: High-Performance Asynchronous HTTP Client Library
  6. Summary(ja): 高性能な非同期 HTTP クライアントのライブラリ
  7. License: ASL 2.0
  8. Group: System Environment/Libraries
  9. Url: http://code.google.com/p/serf
  10. Source0: https://serf.googlecode.com/files/serf-%{version}.tar.bz2
  11. BuildRequires: apr-util-devel, apr-devel, krb5-devel,
  12. BuildRequires: krb5-devel, openssl-devel, zlib-devel
  13. BuildRequires: scons, pkgconfig
  14. %description
  15. The serf library is a C-based HTTP client library built upon the Apache
  16. Portable Runtime (APR) library. It multiplexes connections, running the
  17. read/write communication asynchronously. Memory copies and transformations are
  18. kept to a minimum to provide high performance operation.
  19. %package devel
  20. Summary: Development files for %{name}
  21. Summary(ja): %{name} の開発用ファイル群
  22. Group: Development/Libraries
  23. Requires: %{name}%{?_isa} = %{version}-%{release}
  24. Requires: apr-devel%{?_isa}
  25. %description devel
  26. The %{name}-devel package contains libraries and header files for
  27. developing applications that use %{name}.
  28. %prep
  29. %setup -q -n %{oname}-%{version}
  30. # Shared library versioning support in scons is worse than awful...
  31. # minimally, here fix the soname to match serf-1.2.x. Minor version
  32. # handling should be fixed too; really requires better upstream support:
  33. # http://scons.tigris.org/issues/show_bug.cgi?id=2869
  34. sed -i '/SHLIBVERSION/s/MAJOR/0/' SConstruct
  35. %build
  36. scons \
  37. CFLAGS="%{optflags}" \
  38. PREFIX=%{_prefix} \
  39. LIBDIR=%{_libdir} \
  40. GSSAPI=%{_prefix} \
  41. %{?_smp_mflags}
  42. %install
  43. scons install --install-sandbox=%{buildroot}
  44. find %{buildroot} -name '*.*a' -exec rm -vf {} ';'
  45. %check
  46. scons %{?_smp_mflags} check || true
  47. %post -p /sbin/ldconfig
  48. %postun -p /sbin/ldconfig
  49. %files
  50. %doc CHANGES LICENSE NOTICE README design-guide.txt
  51. %{_libdir}/*.so.*
  52. %files devel
  53. %{_includedir}/%{oname}-1/
  54. %{_libdir}/*.so
  55. %{_libdir}/pkgconfig/%{oname}*.pc
  56. %changelog
  57. * Sun Mar 16 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.3.4-2
  58. - initial build for Vine Linux
  59. * Mon Feb 17 2014 Joe Orton <jorton@redhat.com> - 1.3.4-1
  60. - update to 1.3.4
  61. * Tue Dec 10 2013 Joe Orton <jorton@redhat.com> - 1.3.3-1
  62. - update to 1.3.3
  63. * Wed Nov 6 2013 Joe Orton <jorton@redhat.com> - 1.3.2-1
  64. - update to 1.3.2
  65. - require krb5-devel for libgssapi (#1027011)
  66. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  68. * Mon Jun 17 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-3
  69. - SPEC cleanup.
  70. * Thu Jun 13 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-2
  71. - Fix the permission of the library.
  72. * Sun Jun 09 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-1
  73. - Initial Package.