libproxy-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %{!?python_sitelib: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Summary: A library handling all the details of proxy configuration
  3. Name: libproxy
  4. Version: 0.4.11
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://code.google.com/p/libproxy/
  9. Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  11. BuildRequires: python-devel
  12. #Virtual Provides - We need either mozjs or WebKit
  13. Requires: %{name}-pac >= %{version}
  14. #
  15. Requires: libproxy-python = %{version}-%{release}
  16. Requires: libproxy-bin = %{version}-%{release}
  17. BuildRequires: cmake
  18. # gnome
  19. BuildRequires: GConf2-devel
  20. # mozjs
  21. BuildRequires: js-devel
  22. # NetworkManager
  23. BuildRequires: NetworkManager-devel
  24. BuildRequires: dbus-devel
  25. # webkit (gtk)
  26. BuildRequires: WebKit3-gtk-devel
  27. # kde
  28. BuildRequires: kdelibs-devel
  29. BuildRequires: libXmu-devel
  30. BuildRequires: libX11-devel
  31. Provides: %{name}-webkit = %{version}-%{release}
  32. Obsoletes: %{name}-webkit < %{version}-%{release}
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. libproxy offers the following features:
  37. * extremely small core footprint (< 35K)
  38. * no external dependencies within libproxy core
  39. (libproxy plugins may have dependencies)
  40. * only 3 functions in the stable external API
  41. * dynamic adjustment to changing network topology
  42. * a standard way of dealing with proxy settings across all scenarios
  43. * a sublime sense of joy and accomplishment
  44. Non-default rpmbuild options:
  45. --with webkit: Enable WebKit-gtk support
  46. %package bin
  47. Summary: Binary to test %{name}
  48. Group: Applications/System
  49. Requires: %{name} = %{version}-%{release}
  50. %description bin
  51. The %{name}-bin package contains the proxy binary for %{name}
  52. %package python
  53. Summary: Binding for %{name} and python
  54. Group: System Environment/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. %description python
  57. The %{name}-python package contains the python binding for %{name}
  58. %package gnome
  59. Summary: Plugin for %{name} and gnome
  60. Group: System Environment/Libraries
  61. Requires: %{name} = %{version}-%{release}
  62. %description gnome
  63. The %{name}-gnome package contains the %{name} plugin for gnome.
  64. %package kde
  65. Summary: Plugin for %{name} and kde
  66. Group: System Environment/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. %description kde
  69. The %{name}-kde package contains the %{name} plugin for kde.
  70. %package mozjs
  71. Summary: Plugin for %{name} and mozjs
  72. Group: System Environment/Libraries
  73. Requires: %{name} = %{version}
  74. #Tweak this according to the current gecko-libs version
  75. Requires: js
  76. Provides: %{name}-pac = %{version}-%{release}
  77. %description mozjs
  78. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  79. %package webkitgtk3
  80. Summary: Plugin for %{name} and webkitgtk3
  81. Group: System Environment/Libraries
  82. Requires: %{name} = %{version}
  83. Provides: %{name}-pac = %{version}-%{release}
  84. %description webkitgtk3
  85. The %{name}-webkitgtk3 package contains the %{name} plugin for
  86. webkitgtk3.
  87. %package devel
  88. Summary: Development files for %{name}
  89. Group: Development/Libraries
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: pkgconfig
  92. %description devel
  93. The %{name}-devel package contains libraries and header files for
  94. developing applications that use %{name}.
  95. %prep
  96. %setup -q
  97. %build
  98. %cmake \
  99. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  100. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  101. -DWITH_PERL=OFF \
  102. -DWITH_WEBKIT3=ON \
  103. .
  104. make VERBOSE=1 %{?_smp_mflags}
  105. %install
  106. rm -rf $RPM_BUILD_ROOT
  107. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  108. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  109. %clean
  110. rm -rf $RPM_BUILD_ROOT
  111. %post -p /sbin/ldconfig
  112. %postun -p /sbin/ldconfig
  113. %files
  114. %defattr(-,root,root,-)
  115. %doc AUTHORS COPYING README
  116. %{_libdir}/*.so.*
  117. %dir %{_libdir}/%{name}
  118. %dir %{_libdir}/%{name}/%{version}
  119. %dir %{_libdir}/%{name}/%{version}/modules
  120. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  121. %files bin
  122. %defattr(-,root,root,-)
  123. %{_bindir}/proxy
  124. %files python
  125. %defattr(-,root,root,-)
  126. %{python_sitelib}/libproxy.py
  127. %files gnome
  128. %defattr(-,root,root,-)
  129. %{_libdir}/%{name}/%{version}/modules/config_gnome3.so
  130. %{_libexecdir}/pxgsettings
  131. %files kde
  132. %defattr(-,root,root,-)
  133. %{_libdir}/%{name}/%{version}/modules/config_kde4.so
  134. %files mozjs
  135. %defattr(-,root,root,-)
  136. %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
  137. %files webkitgtk3
  138. %defattr(-,root,root,-)
  139. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  140. %files devel
  141. %defattr(-,root,root,-)
  142. %{_includedir}/proxy.h
  143. %{_libdir}/*.so
  144. %{_libdir}/pkgconfig/libproxy-1.0.pc
  145. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  146. %changelog
  147. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  148. - update to 0.4.11
  149. - remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
  150. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  151. - rebuild with python-2.7.2
  152. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  153. - new upstream release
  154. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  155. - change BuildRequires: js-devel instead of gecko-devel
  156. - replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
  157. - detele -webkit sub package
  158. - create -webkitgtk3 sub package
  159. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  160. - new upstream release
  161. - drop Patch0
  162. - add BuildRequires: cmake, kdelibs-devel
  163. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  164. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  165. - rebuild with rpm-4.8.1 for pkg-config file
  166. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  167. - rebuild with python-2.6
  168. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  169. - rebuild with gecko-1.9.1
  170. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  171. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  172. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  173. - initial build for Vine Linux
  174. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  175. - Rebuild for webkit
  176. - Raise requirement for xulrunner to 1.9.1
  177. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  179. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  180. - Merge NetworkManager module into the main libproxy package
  181. - Main Requires the -python and -bin subpackage
  182. (splitted for multilibs compliance).
  183. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  184. - Disable Gnome/KDE default support via builtin modules.
  185. (it needs to be integrated via Gconf2/neon instead).
  186. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  187. - Disable Obsoletes.
  188. - Requires ev instead of evr for optionnals sub-packages.
  189. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  190. - Use conditionals build.
  191. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  192. - Remove plugin- in the name of the packages
  193. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  194. - Move proxy.h to libproxy/proxy.h
  195. This will prevent it to be included in the default include path
  196. - Split main to libs and util and use libproxy to install all
  197. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  198. - Rename binding-python to python
  199. - Add Requires: gecko-libs >= %%{gecko_version}
  200. - Fix some descriptions
  201. - Add plugin-webkit package
  202. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  203. - Convert to Fedora spec
  204. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  205. - Updated to version 0.2.3
  206. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  207. - Extended spec file to build all available plugins
  208. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  209. - Initial spec file for Version 0.2.2