graphviz-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. Name: graphviz
  2. Summary: Graph Visualization Tools
  3. Summary(ja): グラフ可視化ツール
  4. Version: 2.38.0
  5. Release: 1%{?_dist_release}
  6. Group: Applications/Graphics
  7. License: CPL
  8. URL: http://www.graphviz.org/
  9. Source: http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: bison
  12. BuildRequires: cairo-devel
  13. BuildRequires: expat-devel
  14. BuildRequires: flex
  15. BuildRequires: fontconfig-devel
  16. BuildRequires: freetype2-devel
  17. BuildRequires: gd-devel
  18. BuildRequires: gtk2-devel
  19. BuildRequires: guile-devel
  20. BuildRequires: libjpeg-turbo-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  24. BuildRequires: libXaw-devel
  25. BuildRequires: libXext-devel
  26. BuildRequires: librsvg2-devel
  27. BuildRequires: m4
  28. BuildRequires: perl
  29. BuildRequires: python-devel
  30. BuildRequires: ruby-devel
  31. BuildRequires: swig
  32. BuildRequires: tcl >= 8.4
  33. BuildRequires: tk >= 8.4
  34. BuildRequires: zlib-devel
  35. Requires: urw-fonts
  36. # only for this release
  37. BuildConflicts: graphviz-devel
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: daisuke
  41. %description
  42. A collection of tools and tcl packages for the manipulation and layout
  43. of graphs (as in nodes and edges, not as in barcharts).
  44. %package devel
  45. Group: Development/Libraries
  46. Summary: Development tools for version %{version} of %{name}
  47. Requires: %{name} = %{version}
  48. %description devel
  49. The %{name}-devel package contains the header files
  50. and man3 pages necessary for developing programs
  51. using version %{version} of the %{name} libraries.
  52. %package doc
  53. Summary: PDF and HTML documents for graphviz
  54. Group: Applications/Documentation
  55. %description doc
  56. Provides some additional PDF and HTML documentation for graphviz.
  57. %package guile
  58. Group: Applications/Graphics
  59. Summary: Guile extension for graphviz
  60. Requires: %{name} = %{version}-%{release}, guile
  61. %description guile
  62. Guile extension for graphviz.
  63. %package perl
  64. Group: Applications/Graphics
  65. Summary: Perl extension for graphviz
  66. Requires: %{name} = %{version}-%{release}
  67. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  68. %description perl
  69. Perl extension for graphviz.
  70. %package python
  71. Group: Applications/Graphics
  72. Summary: Python extension for graphviz
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: python
  75. %description python
  76. Python extension for graphviz.
  77. %package ruby
  78. Group: Applications/Multimedia
  79. Summary: Ruby extension for graphviz
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: ruby
  82. %description ruby
  83. Ruby extension for graphviz.
  84. %package tcl
  85. Group: Applications/Graphics
  86. Summary: Tcl extension & tools for graphviz
  87. Requires: tcl >= 8.4, tk >= 8.4
  88. Requires: %{name} = %{version}
  89. %description tcl
  90. Various tcl packages (extensions) for the graphviz tools.
  91. %prep
  92. %setup -q
  93. # using archdir instead of sitearchdir for Vine
  94. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  95. %build
  96. # Rewrite config_ruby.rb to work with Ruby 1.9
  97. sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
  98. sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
  99. export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
  100. # XXX ix86 only used to have -ffast-math, let's use everywhere
  101. %{expand: %%define optflags %{optflags} -ffast-math}
  102. %configure \
  103. --with-x \
  104. --disable-static \
  105. --with-mylibgd \
  106. --with-ipsepcola \
  107. --with-pangocairo \
  108. --with-gdk-pixbuf \
  109. --without-mylibgd \
  110. --without-ming \
  111. --disable-sharp \
  112. --enable-guile \
  113. --enable-io \
  114. --disable-java \
  115. --disable-lua \
  116. --disable-ocaml \
  117. --enable-perl \
  118. --disable-php \
  119. --enable-python \
  120. --disable-r \
  121. --enable-ruby \
  122. --enable-tcl
  123. make %{?_smp_mflags}
  124. %install
  125. rm -rf $RPM_BUILD_ROOT __doc
  126. make DESTDIR=$RPM_BUILD_ROOT \
  127. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  128. pkgconfigdir=%{_libdir}/pkgconfig \
  129. install
  130. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  131. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  132. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  133. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  134. %clean
  135. rm -rf $RPM_BUILD_ROOT
  136. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  137. %post
  138. /sbin/ldconfig
  139. %{_bindir}/dot -c
  140. # if there is no dot after everything else is done, then remove config
  141. %postun
  142. if [ $1 -eq 0 ]; then
  143. rm -f %{_libdir}/graphviz/config || :
  144. fi
  145. /sbin/ldconfig
  146. %files
  147. %defattr(-,root,root)
  148. %doc AUTHORS COPYING ChangeLog NEWS README
  149. %{_bindir}/*
  150. %dir %{_datadir}/%{name}
  151. %{_datadir}/%{name}/gvpr
  152. %{_datadir}/%{name}/lefty
  153. %{_mandir}/man1/*
  154. %{_mandir}/man7/*
  155. %dir %{_libdir}/%{name}
  156. %{_libdir}/*.so.*
  157. %{_libdir}/%{name}/*.so.*
  158. %exclude %{_libdir}/graphviz/*/*
  159. %files devel
  160. %defattr(-,root,root)
  161. %{_includedir}/%{name}
  162. %{_libdir}/*.so
  163. %{_libdir}/%{name}/*.so
  164. %{_libdir}/pkgconfig/*.pc
  165. %{_datadir}/%{name}/graphs
  166. %{_mandir}/man3/*.3.gz
  167. %files doc
  168. %defattr(-,root,root,-)
  169. %doc __doc/*
  170. %files guile
  171. %defattr(-,root,root,-)
  172. %{_libdir}/graphviz/guile/
  173. %{_mandir}/man3/gv.3guile*
  174. %files perl
  175. %defattr(-,root,root,-)
  176. %{_libdir}/graphviz/perl/
  177. %{perl_vendorarch}/*
  178. %{_mandir}/man3/gv.3perl*
  179. %files python
  180. %defattr(-,root,root,-)
  181. %{_libdir}/graphviz/python/
  182. %{_libdir}/python*/*
  183. %{_mandir}/man3/gv.3python*
  184. %files ruby
  185. %defattr(-,root,root,-)
  186. %{_libdir}/graphviz/ruby/
  187. %{_libdir}/*ruby*/*
  188. %{_mandir}/man3/gv.3ruby*
  189. %files tcl
  190. %defattr(-,root,root)
  191. %{_libdir}/%{name}/tcl/*
  192. %{_libdir}/tcl*/*
  193. %{_datadir}/%{name}/demo
  194. # hack to include gv.3tcl only if available
  195. # always includes tcldot.3tcl, gdtclft.3tcl
  196. %{_mandir}/man3/*.3tcl*
  197. %{_mandir}/man3/tkspline.3tk*
  198. %changelog
  199. * Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
  200. - update to 2.38.0
  201. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
  202. - new upstream release
  203. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
  204. - rebuilt with gd-2.1.0.
  205. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  206. - new upstream release
  207. * Mon Jan 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
  208. - build with Tcl/Tk 8.5.7-1
  209. - stop running autoreconf
  210. - add Vendor and Distribution tags
  211. * Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  212. - re-enable ruby binding, which is accidentally disabled in 2.28.0-1
  213. - rewrite config_ruby.rb to build with ruby-1.9.3
  214. - add search path for ruby/config.h to CPPFLAGS for configure
  215. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  216. - new upstream release
  217. - remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
  218. - add BuildRequires: librsvg2-devel
  219. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  220. - add Patch10 to avoid build failure on ppc
  221. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  222. - new upstream release
  223. - built with rpm-4.8.1
  224. - split doc, guile, perl, python, ruby subpackage
  225. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  226. - rebuild with libtool-2.2.6a
  227. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  228. - new upstream release
  229. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  230. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  231. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  232. - new upstream release
  233. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  234. - new upstream release
  235. - build with expat-2.0.1
  236. - add man7
  237. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  238. - rebuild with tcl/tk-8.4.16
  239. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  240. - new upstream release
  241. - add BuildPrereq: swig
  242. - delete BuildPrereq: gd-progs gd-devel
  243. - add --with-mylibgd and --disable-FEATURE to configure option
  244. - update %%files
  245. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  246. - added BuildPrereq: ruby-devel
  247. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  248. - new upstream release
  249. - add BuildPrereq: libtool-ltdl-devel
  250. - move pkgconfig files to %%{_libdir}/pkgconfig
  251. - add --disable-rpath --disable-static to configure option
  252. - add %%post to every package
  253. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  254. - new upstream release
  255. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  256. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  257. - update %%files
  258. - remove lines about Vine2.6
  259. - change License to CPL
  260. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  261. - source upgrade
  262. - remove patch0 and commented lines
  263. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  264. - build for VineSeed
  265. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  266. - source upgrade
  267. - change spec to build both VineSeed and Vine2.5/2.6
  268. - add BuildPrereq: expat-devel and Requires: libexpat
  269. - add patch0 to build against freetype2-2.1.7
  270. - stop using autogen.sh script
  271. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  272. - add graphviz-tcl package (VineSeed)
  273. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  274. - rebuild for new Vine
  275. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  276. - import from offical site (src.rpm)