gnuplot-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253
  1. %define gpmainver 4.6
  2. %define gpver %{gpmainver}.4
  3. Summary: A program for plotting mathematical expressions and data.
  4. Summary(ja): 数学系の関数やデータのプロット・プログラム
  5. Name: gnuplot
  6. Version: %{gpver}
  7. Release: 1%{?_dist_release}
  8. License: gnuplot and GPLv2
  9. Group: Applications/Engineering
  10. URL: http://gnuplot.sourceforge.net/
  11. Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
  12. Patch0: gnuplot-4.6.4-font.patch
  13. # submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558970&group_id=2055&atid=302055
  14. Patch1: gnuplot-4.6.1-xcopygc-sigsegv.patch
  15. # submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
  16. Patch2: gnuplot-4.6.1-plot-sigsegv.patch
  17. BuildRoot: %{_tmppath}/%{name}-root
  18. BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
  19. BuildRequires: libX11-devel, libXt-devel, wxGTK-devel
  20. BuildRequires: readline-devel
  21. BuildRequires: lua-devel cairo-devel pango-devel
  22. BuildRequires: libXpm-devel libjpeg-turbo-devel
  23. BuildRequires: texlive
  24. BuildRequires: texlive-common
  25. BuildRequires: texlive-collection-latexextra
  26. BuildRequires: texlive-collection-htmlxml
  27. BuildRequires: texinfo, emacsen
  28. Requires(post): install-info
  29. Requires(preun): install-info
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: daisuke, inagaki, shaolin
  33. %description
  34. Gnuplot is a command-line driven, interactive function plotting
  35. program especially suited for scientific data representation. Gnuplot
  36. can be used to plot functions and data points in both two and three
  37. dimensions and in many different formats.
  38. Install gnuplot if you need a graphics package for scientific data
  39. representation.
  40. %description -l ja
  41. Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
  42. 操作によるインタラクティブな関数プロット・プログラムです。
  43. Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
  44. まな形式で表現するのに利用することができます。
  45. 科学データプレゼンテーション用のグラフィック・パッケージが必要な
  46. 場合、gnuplotをインストールしてください。
  47. %prep
  48. %setup -q
  49. %patch0 -p1 -b .font
  50. %patch1 -p1 -b .xcopygc
  51. %patch2 -p1 -b .plot-sigsegv
  52. %build
  53. #autoreconf -f -i
  54. %ifarch alpha
  55. %define optflags -O0
  56. %endif
  57. %configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file --with-tutorial
  58. make %{?_smp_mflags}
  59. make -C docs html info
  60. export GNUPLOT_PS_DIR=../../term/PostScript
  61. make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
  62. rm -rf docs/htmldocs/images.idx
  63. make -C tutorial
  64. %install
  65. rm -rf %{buildroot}
  66. make install DESTDIR=%{buildroot}
  67. make -C docs install-info DESTDIR=%{buildroot} INSTALL='install -p'
  68. rm -f demo/Makefile* tutorial/Makefile*
  69. # move app-dafaults to %%_datadir
  70. #mv %{buildroot}%{_libdir}/X11 %{buildroot}%{_datadir}/
  71. # move texmf config
  72. #mv %{buildroot}%{_datadir}/texmf-local %{buildroot}%{_datadir}/texmf
  73. # remove unneeded files
  74. rm -f %{buildroot}%{_infodir}/dir
  75. %clean
  76. rm -rf %{buildroot}
  77. %post
  78. /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
  79. %preun
  80. if [ $1 = 0 ]; then
  81. /sbin/install-info --quiet --info-dir=%{_infodir} \
  82. --delete %{_infodir}/gnuplot.info.gz
  83. fi
  84. %files
  85. %defattr(-,root,root)
  86. %doc demo tutorial
  87. %doc README README.1ST INSTALL Copyright
  88. %doc PATCHLEVEL VERSION BUGS ChangeLog
  89. %{_bindir}/gnuplot
  90. %{_libexecdir}/gnuplot/%{gpmainver}/*
  91. %{_datadir}/gnuplot/%{gpmainver}/*
  92. #{_datadir}/X11/app-defaults/Gnuplot
  93. %{_datadir}/texmf/tex/latex/gnuplot
  94. %{_datadir}/emacs/site-lisp/*
  95. %{_infodir}/gnuplot.info*
  96. %{_mandir}/man1/gnuplot.*
  97. %changelog
  98. * Thu Jan 16 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.4-1
  99. - new upstream release
  100. - add Patch0, Patch1 and Patch2 (font paths, upstream fixes)
  101. - modify spec to build/install docs correctly
  102. * Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
  103. - changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
  104. - added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
  105. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  106. - update to gnuplot-4.4.3
  107. - use BR: texlive instead of tetex
  108. * Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
  109. - update to gnuplot-4.2.5
  110. - drop plus patch (merged in upstream)
  111. - update URL: to new upstream homepage
  112. - fix License:
  113. - build with wxGTK
  114. - add BR: libX11-devel, libXt-devel, wx-gtk2-devel
  115. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
  116. - applied new versioning policy, spec in utf-8
  117. * Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
  118. - add BuildRequires: texinfo, emacsen
  119. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
  120. - rebuild with readline-5.1
  121. * Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
  122. - update Patch0 to fix 'Invalid char in eps file'
  123. (thanks to HANAWA Toshihiro)
  124. - add BuildRequires: autoconf, automake
  125. * Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
  126. - enabled history-file
  127. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
  128. - source update
  129. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
  130. - source update
  131. - patch update and modified
  132. - add info
  133. * Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
  134. - rebuild
  135. - fix license
  136. - remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
  137. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
  138. - rebuild with readline-4.3
  139. * Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
  140. - syncd with RH 3.7.3-2
  141. - modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
  142. * Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
  143. - added pathes (patch1,2) from RH
  144. * Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
  145. - syncd rawhide
  146. - updated to 3.7.1-1.2.0
  147. * Mon Jun 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  148. - updated to 3.7.1
  149. - updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
  150. - remake SPEC from rawhide.
  151. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  152. - rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
  153. * Mon May 08 2000 Preston Brown <pbrown@redhat.com>
  154. - build for 7.0
  155. * Thu Apr 6 2000 Bill Nottingham <notting@redhat.com>
  156. - use gnu readline, not built-in version
  157. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  158. - add latex tutorial, demo files, other docs (#10508)
  159. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  160. - update to 3.7.1. Oops.
  161. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  162. - handle compressed man pages
  163. * Thu Nov 4 1999 Bill Nottingham <notting@redhat.com>
  164. - update to 3.7.1
  165. * Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
  166. - ship some docs.
  167. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  168. - add a patch to fix postscript output from Bernd Kischnick
  169. (kisch@die-herrmanns.de)
  170. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  171. - fix license
  172. * Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
  173. - rebuild without svgalib
  174. * Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
  175. - update to 3.7.0.1
  176. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  177. - auto rebuild in the new build environment (release 2)
  178. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  179. - update to 3.7.
  180. * Thu Dec 17 1998 Michael Maher <mike@redhat.com>
  181. - built package for 6.0
  182. * Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
  183. - update to 2.6beta347
  184. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  185. - build root
  186. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  187. - translations modified for de, fr, tr
  188. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  189. - spec file cleanups
  190. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  191. - built against glibc