gnokii-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477
  1. # TODO: merge patches upstream where applicable
  2. Name: gnokii
  3. Version: 0.6.30
  4. Release: 1%{?_dist_release}
  5. Summary: Linux/Unix tool suite for various mobile phones
  6. Summary(ja): Linux/Unix tool suite for various mobile phones
  7. Group: Applications/Communications
  8. License: GPLv2+
  9. URL: http://www.gnokii.org/
  10. Source0: http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
  11. #----------------------------------------------------------------------------
  12. Source2: gnokii-smsd.init
  13. Source3: gnokii-smsd.sysconfig
  14. Source4: gnokii-smsd.logrotate
  15. Source5: gnokii-smsd2mail.sh
  16. Source6: gnokii-smsd-README.smsd2mail
  17. # Patch to remove port locking and apply the system-wide /usr/sbin directory
  18. # to the path instead of the default /usr/local
  19. Patch1: gnokii-config.patch
  20. #----------------------------------------------------------------------------
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. #----------------------------------------------------------------------------
  23. BuildRequires: flex
  24. BuildRequires: gettext
  25. BuildRequires: ImageMagick
  26. BuildRequires: bluez-libs-devel
  27. BuildRequires: desktop-file-utils
  28. BuildRequires: gtk2-devel
  29. BuildRequires: libusb-devel
  30. BuildRequires: mysql-devel
  31. BuildRequires: postgresql-devel
  32. BuildRequires: readline-devel
  33. BuildRequires: sqlite3-devel
  34. BuildRequires: zlib-devel
  35. BuildRequires: libical-devel >= 0.24
  36. # VineSeed
  37. BuildRequires: libXt-devel
  38. BuildRequires: libXpm-devel
  39. ## VineLinux-4.x
  40. ## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
  41. BuildRequires: perl(XML::Parser)
  42. Requires(pre): %{_sbindir}/groupadd
  43. #----------------------------------------------------------------------------
  44. %description
  45. Gnokii provides tools and a user space driver for use with mobile
  46. phones under Linux, various unices and Win32. With gnokii you can do
  47. such things as make data calls, update your address book, change
  48. calendar entries, send and receive SMS messages and load ring tones
  49. depending on the phone you have.
  50. #----------------------------------------------------------------------------
  51. %package -n xgnokii
  52. Summary: Graphical Linux/Unix tool suite for various mobile phones
  53. Group: Applications/Communications
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n xgnokii
  56. Xgnokii is graphical Linux/Unix tool suite for various mobile
  57. phones. It allows you to edit your contacts book, send/read SMS's
  58. from/in computer and more other features.
  59. #----------------------------------------------------------------------------
  60. %package smsd
  61. Summary: Gnokii SMS daemon
  62. Group: System Environment/Daemons
  63. Requires: %{name} = %{version}-%{release}
  64. Requires(pre): %{_sbindir}/useradd
  65. Requires(post): /sbin/chkconfig
  66. Requires(preun): /sbin/chkconfig
  67. %description smsd
  68. The Gnokii SMS daemon receives and sends SMS messages.
  69. #----------------------------------------------------------------------------
  70. %package smsd-pgsql
  71. Summary: PostgreSQL support for Gnokii SMS daemon
  72. Group: System Environment/Daemons
  73. Requires: %{name}-smsd = %{version}-%{release}
  74. Obsoletes: %{name}-smsd-postgresql < 0.6.4-0.lvn.2
  75. %description smsd-pgsql
  76. %{summary}.
  77. #----------------------------------------------------------------------------
  78. %package smsd-mysql
  79. Summary: MySQL support for Gnokii SMS daemon
  80. Group: System Environment/Daemons
  81. Requires: %{name}-smsd = %{version}-%{release}
  82. %description smsd-mysql
  83. %{summary}.
  84. #----------------------------------------------------------------------------
  85. %package devel
  86. Summary: Gnokii development files
  87. Group: Development/Libraries
  88. Requires: %{name} = %{version}-%{release}
  89. Requires: pkgconfig
  90. %description devel
  91. %{summary}.
  92. #----------------------------------------------------------------------------
  93. %prep
  94. %setup -q
  95. %patch1 -p0
  96. install -pm 644 %{SOURCE5} smsd2mail.sh
  97. install -pm 644 %{SOURCE6} README.smsd2mail
  98. %build
  99. %configure --enable-security --disable-rpath --disable-static \
  100. --enable-libical
  101. make %{?_smp_mflags}
  102. #----------------------------------------------------------------------------
  103. %install
  104. make install DESTDIR=$RPM_BUILD_ROOT
  105. # Rename smsd to gnokii-smsd
  106. mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
  107. mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
  108. sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  109. sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  110. # Remove libtool droppings
  111. rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
  112. # Fix up the default desktop file
  113. desktop-file-install \
  114. --delete-original \
  115. --vendor "" \
  116. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  117. --mode 644 \
  118. --add-category X-VineLinux \
  119. $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
  120. # Convert the default icons to PNG
  121. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
  122. convert Docs/sample/logo/gnokii.xpm \
  123. $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  124. chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  125. # Install the configuration files
  126. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
  127. install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
  128. install -Dpm 644 %{SOURCE4} \
  129. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
  130. cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
  131. # Install the docs
  132. mkdir -p temporary-gnokii-docs/
  133. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
  134. %find_lang %{name}
  135. %clean
  136. rm -rf $RPM_BUILD_ROOT
  137. #----------------------------------------------------------------------------
  138. %pre
  139. %{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
  140. %pre smsd
  141. %{_sbindir}/useradd -r -M -d / -g gnokii \
  142. -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
  143. %post -p /sbin/ldconfig
  144. %postun -p /sbin/ldconfig
  145. %post smsd
  146. /sbin/chkconfig --add gnokii-smsd
  147. %preun smsd
  148. if [ $1 -eq 0 ] ; then
  149. %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
  150. /sbin/chkconfig --del gnokii-smsd
  151. fi
  152. %postun smsd
  153. if [ $1 -ge 1 ] ; then
  154. %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
  155. fi
  156. #----------------------------------------------------------------------------
  157. %files -f %{name}.lang
  158. %defattr(-,root,root,-)
  159. %doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
  160. %config(noreplace) %{_sysconfdir}/gnokiirc
  161. %attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
  162. %{_bindir}/gnokii
  163. %{_bindir}/sendsms
  164. %{_bindir}/gnokiid
  165. %{_libdir}/libgnokii.so.*
  166. %{_mandir}/man1/gnokii.1*
  167. %{_mandir}/man1/sendsms.1*
  168. %{_mandir}/man8/gnokiid.8*
  169. %{_mandir}/man8/mgnokiidev.8*
  170. %files -n xgnokii
  171. %defattr(-,root,root,-)
  172. %doc xgnokii/ChangeLog xgnokii/README.vcard
  173. %{_bindir}/xgnokii
  174. %{_datadir}/pixmaps/xgnokii.png
  175. %{_datadir}/applications/*xgnokii.desktop
  176. %{_mandir}/man1/xgnokii.1*
  177. %files smsd
  178. %defattr(-,root,root,-)
  179. %doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
  180. %attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
  181. %config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
  182. %{_initrddir}/gnokii-smsd
  183. %{_bindir}/gnokii-smsd
  184. %{_mandir}/man8/gnokii-smsd.8*
  185. %dir %{_libdir}/smsd/
  186. %{_libdir}/smsd/libsmsd_file.so
  187. %{_libdir}/smsd/libsmsd_sqlite.so
  188. %files smsd-pgsql
  189. %defattr(-,root,root,-)
  190. %doc smsd/sms.tables.pq.sql
  191. %{_libdir}/smsd/libsmsd_pq.so
  192. %files smsd-mysql
  193. %defattr(-,root,root,-)
  194. %doc smsd/sms.tables.mysql.sql
  195. %{_libdir}/smsd/libsmsd_mysql.so
  196. %files devel
  197. %defattr(-,root,root,-)
  198. %{_includedir}/gnokii*
  199. %{_libdir}/libgnokii.so
  200. %{_libdir}/pkgconfig/gnokii.pc
  201. %{_libdir}/pkgconfig/xgnokii.pc
  202. #----------------------------------------------------------------------------
  203. # Maintainers: babasaki@mindgear.org
  204. #
  205. #----------------------------------------------------------------------------
  206. %changelog
  207. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
  208. - new upstream release
  209. - remove Patch0
  210. - add BuildRequires: sqlite3-devel
  211. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
  212. - add BuildRequires: readline-devel
  213. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
  214. - rebuilt with postgresql-9.0.3
  215. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
  216. - rebuilt with rpm-4.8.1 for pkg-config
  217. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
  218. - rebuilt with MySQL-5.1.34.
  219. * Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
  220. - Import gnokii - Packager: Babasaki
  221. - Updated specfile
  222. #----------------------------------------------------------------------------
  223. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
  224. - Fix htmlview patch
  225. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
  226. - Update to 0.6.27
  227. * Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
  228. - Rebuild
  229. * Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
  230. - Rebuild with libical support
  231. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
  232. - Update to 0.6.26
  233. * Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
  234. - Set empty --vendor rather none for using desktop-file-install
  235. - Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
  236. * Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
  237. - Update to 0.6.25
  238. * Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
  239. - Update to 0.6.24
  240. * Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
  241. - Rebuild for GCC 4.3.
  242. * Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
  243. - Pick up new libssl .solib version dependency.
  244. * Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
  245. - Update to 0.6.22
  246. * Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
  247. - Update to 0.6.20
  248. * Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
  249. - Even better multilib fixing (#335161)
  250. * Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
  251. - Quick fix to multilib conflict (#335161)
  252. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
  253. - New upstream release
  254. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
  255. - Update license field from GPL to GPLv2+
  256. * Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
  257. - New upstream release
  258. * Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
  259. - New upstream release
  260. - Update smsd name change patch
  261. - ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
  262. upstream
  263. * Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
  264. - Rebuild to pick up new libpq IF
  265. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
  266. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  267. * Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
  268. - New upstream release.
  269. * Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
  270. - Rebuild for Fedora Extras 6.
  271. * Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
  272. - Bump because tagged before committing sources and I just
  273. dont know how the f* you delete a tag in CVS at the moment
  274. and it does seem like a too big endavour to find out just
  275. in order to have a nice release tag.
  276. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
  277. - New upstream release.
  278. - New dependency on libusb for USB serial, DKU no longer needed/wanted
  279. so now we have that troublesome issue resolved once and for all.
  280. - Remove patches to SQL files: these are now fixed upstream!
  281. * Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  282. - Rebuilding due to changed interface on libbluetooth.
  283. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  284. - Goofed up. Fixit it...
  285. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
  286. - Post-import updates.
  287. * Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
  288. - Updated after comments from Ville.
  289. * Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
  290. - New upstream tarball
  291. * Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
  292. - Updated after comments from Ville.
  293. * Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
  294. - 0.6.11
  295. - Modified to drop into the Fedora Extras as the nice package it now is
  296. - Based work off Ville's good olde package
  297. * Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
  298. - 0.6.10.
  299. - Clean up pkgconfig file and -devel dependencies from bits needed only
  300. for static libs.
  301. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
  302. - 0.6.9, desktop entry file included upstream.
  303. - Drop zero Epochs.
  304. * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
  305. - 0.6.8.
  306. - Don't ship static libraries.
  307. - Rename smsd to gnokii-smsd to avoid conflicts with smstools.
  308. - Remove not included files instead of using %%exclude.
  309. * Sat Jun 4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
  310. - BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
  311. * Thu Jun 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
  312. - 0.6.7.
  313. - Build unconditionally with bluetooth support.
  314. * Mon May 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
  315. - 0.6.5.
  316. * Fri Nov 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
  317. - Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
  318. packages in FC/Extras.
  319. * Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
  320. - Update to 0.6.4, perms and pgsql patches applied upstream.
  321. - Xgnokii help locale symlink hack no longer necessary.
  322. - Don't remove user/group on last erase, move smsd user to -smsd subpackage.
  323. - Add libical support (disabled), rebuild with "--with libical" to enable.
  324. * Mon Jul 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
  325. - Update to 0.6.3.
  326. * Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
  327. - Improve Xgnokii desktop entry according to GNOME HIG.
  328. * Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
  329. - Remove duplicate gettext build dependency (bug 95).
  330. * Sun Jun 6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
  331. - Fix chown syntax in smsd init script.
  332. - Summary and description improvements.
  333. - Trim $RPM_OPT_FLAGS out from gnokii.pc.
  334. - Make -devel require XFree86-devel.
  335. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
  336. - Update to 0.6.1.
  337. * Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
  338. - Make -devel require pkgconfig.
  339. * Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
  340. - Update to 0.6.0.
  341. * Mon Feb 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
  342. - Update to 0.5.10.
  343. * Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
  344. - Update to 0.5.9.
  345. - Specfile cleanups, small init script enhancements.
  346. * Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
  347. - Update to 0.5.7.
  348. - Move smsd man page into -smsd subpackage.
  349. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
  350. - Update to 0.5.6.
  351. - Include sample action script for forwarding SMSD messages to mail.
  352. - s/fedora/livna/.
  353. - Specfile and init script cleanups.
  354. * Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
  355. - Disable smp flags to prevent build failure
  356. * Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
  357. - Update to 0.5.2.
  358. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
  359. - Update to 0.5.1.
  360. - Include init script, sysconfig and logrotate config for smsd.
  361. * Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
  362. - Update to 0.5.0.
  363. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
  364. - RedHat'ified PLD version.