gd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. %bcond_with libvpx
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: A graphics library for drawing .png files.
  4. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  5. Name: gd
  6. Version: 2.1.0
  7. Release: 3%{_dist_release}
  8. Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
  9. Patch0: gd-2.1.0-multilib.patch
  10. Patch1: gd-fixautoconf.patch
  11. Patch100: gd-2.1.0-fonts-vine.patch
  12. License: BSD-style
  13. URL: http://www.libgd.org/
  14. Group: System Environment/Libraries
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: freetype2-devel
  17. BuildRequires: fontconfig-devel
  18. BuildRequires: gettext-devel
  19. BuildRequires: libjpeg-turbo-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libtiff-devel
  22. %if %{with libvpx}
  23. BuildRequires: libvpx-devel
  24. %endif
  25. BuildRequires: libX11-devel
  26. BuildRequires: libXpm-devel
  27. BuildRequires: zlib-devel
  28. BuildRequires: pkgconfig
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: daisuke
  32. %description
  33. Gd is a graphics library for drawing .png files. Gd allows your code to
  34. quickly draw images (lines, arcs, text, multiple colors, cutting and
  35. pasting from other images, flood fills) and write out the result as a
  36. .png file. Gd is particularly useful in web applications, where .pngs
  37. are commonly used as inline images. Note, however, that gd is not a
  38. paint program.
  39. Install gd if you are developing applications which need to draw .png
  40. files. If you install gd, you'll also need to install the gd-devel
  41. package.
  42. %description -l ja
  43. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  44. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  45. 簡単に描写して、PNGファイルへ結果を出力することができます。
  46. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  47. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  48. ん。
  49. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  50. Gdをインストールしてください。gdをインストールした場合、gd-devel
  51. パッケージも必要になります。
  52. %package progs
  53. Summary: Utility programs that use libgd.
  54. Summary(ja): libgd を用いたユーティリティプログラム
  55. Group: Applications/Graphics
  56. Requires: gd = %{version}
  57. Requires: perl
  58. %description progs
  59. These are utility programs supplied with gd, the .png graphics library.
  60. If you install these, you must install gd.
  61. %description progs -l ja
  62. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  63. プログラムです。これをインストールするには, gdをインストールする必要
  64. があります。
  65. %package devel
  66. Summary: The development libraries and header files for gd.
  67. Summary(ja): Gd用の開発ライブラリとヘッダファイル
  68. Group: Development/Libraries
  69. Requires: gd = %{version}
  70. Requires: freetype2-devel
  71. Requires: fontconfig-devel
  72. Requires: libjpeg-turbo-devel
  73. Requires: libpng-devel
  74. Requires: libtiff-devel
  75. %if %{with libvpx}
  76. Requires: libvpx-devel
  77. %endif
  78. Requires: libX11-devel
  79. Requires: libXpm-devel
  80. Requires: zlib-devel
  81. %description devel
  82. These are the development libraries and header files for gd, the .png
  83. graphics library.
  84. If you're installing the gd graphics library, you must install gd-devel.
  85. %description devel -l ja
  86. これらは開発ライブラリです。
  87. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  88. です。
  89. gdをインストールした場合、gd-develパッケージも必要になります。
  90. ## to build compat32 for x86_64 architecture support
  91. %package -n compat32-%{name}
  92. Summary: A graphics library for drawing .png files.
  93. Group: System Environment/Libraries
  94. %description -n compat32-%{name}
  95. Gd is a graphics library for drawing .png files. Gd allows your code to
  96. quickly draw images (lines, arcs, text, multiple colors, cutting and
  97. pasting from other images, flood fills) and write out the result as a
  98. .png file. Gd is particularly useful in web applications, where .pngs
  99. are commonly used as inline images. Note, however, that gd is not a
  100. paint program.
  101. Install gd if you are developing applications which need to draw .png
  102. files. If you install gd, you'll also need to install the gd-devel
  103. package.
  104. %package -n compat32-%{name}-devel
  105. Summary: The development libraries and header files for gd.
  106. Group: Development/Libraries
  107. Requires: compat32-freetype2-devel
  108. Requires: compat32-fontconfig-devel
  109. Requires: compat32-libjpeg-turbo-devel
  110. Requires: compat32-libpng-devel
  111. Requires: compat32-libtiff-devel
  112. %if %{with libvpx}
  113. Requires: compat32-libvpx-devel
  114. %endif
  115. Requires: compat32-libX11-devel
  116. Requires: compat32-libXpm-devel
  117. Requires: compat32-zlib-devel
  118. %description -n compat32-%{name}-devel
  119. These are the development libraries and header files for gd, the .png
  120. graphics library.
  121. If you're installing the gd graphics library, you must install gd-devel.
  122. %prep
  123. %setup -q -n libgd-%{version}
  124. %patch0 -p1 -b .mlib
  125. %patch1 -p1 -b .automake
  126. %patch100 -p1 -b .fonts-vine
  127. # https://bitbucket.org/libgd/gd-libgd/issue/77
  128. sed -e '/GD_VERSION_STRING/s/-alpha//' \
  129. -e '/GD_EXTRA_VERSION/s/alpha//' \
  130. -i src/gd.h
  131. grep VERSION src/gd.h
  132. : regenerate autotool stuff
  133. if [ -f configure ]; then
  134. libtoolize --copy --force
  135. autoreconf -vif
  136. else
  137. ./bootstrap.sh
  138. fi
  139. %build
  140. # Provide a correct default font search path
  141. CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
  142. /usr/share/fonts/TrueType-vlgothic:\
  143. /usr/share/fonts/bitstream-vera:\
  144. /usr/share/fonts/dejavu:\
  145. /usr/share/fonts/default/Type1:\
  146. /usr/share/X11/fonts/Type1:\
  147. /usr/share/fonts/liberation\"'"
  148. %configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
  149. --with-tiff=%{_prefix} \
  150. %if %{with libvpx}
  151. --with-vpx=%{_prefix} \
  152. %endif
  153. --disable-rpath
  154. make %{?_smp_mflags}
  155. %install
  156. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  157. make DESTDIR=$RPM_BUILD_ROOT install
  158. ## remove unuse files
  159. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  160. %clean
  161. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  162. %post -p /sbin/ldconfig
  163. %postun -p /sbin/ldconfig
  164. %if %{build_compat32}
  165. %post -n compat32-%{name} -p /sbin/ldconfig
  166. %postun -n compat32-%{name} -p /sbin/ldconfig
  167. %endif
  168. %files
  169. %defattr(-,root,root)
  170. %doc ChangeLog COPYING NEWS docs/*
  171. %{_libdir}/*.so.*
  172. %files progs
  173. %defattr(-,root,root)
  174. %{_bindir}/*
  175. %exclude %{_bindir}/gdlib-config
  176. %files devel
  177. %defattr(-,root,root)
  178. %{_bindir}/gdlib-config
  179. %{_includedir}/*
  180. %{_libdir}/*.so
  181. %{_libdir}/pkgconfig/*.pc
  182. %if %{build_compat32}
  183. %files -n compat32-%{name}
  184. %defattr(-,root,root)
  185. %{_libdir}/*.so.*
  186. %files -n compat32-%{name}-devel
  187. %defattr(-,root,root)
  188. %{_libdir}/*.so
  189. %endif
  190. %changelog
  191. * Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
  192. - BR: freetype2-devel instead of freetype-devel on devel package
  193. * Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
  194. - fixed version in gd.h.
  195. - added fontconfig and tiff support.
  196. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  197. - new upstream release.
  198. - dropped unnecessary patches.
  199. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
  200. - import patches from fedora package
  201. - modified font path patch for Vine Linux
  202. - drop static library
  203. - remove "-DJISX0208"
  204. - add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
  205. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
  206. - move gdlib-config from gd-progs subpackage to gd-devel subpackage
  207. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  208. - build on current VineSeed
  209. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  210. - fix build_compat32 if-endif sections
  211. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  212. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  213. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  214. - updated URL
  215. - changed progs Group to Applications/Graphics
  216. - added %%postun section
  217. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  218. - removed *.la
  219. - spec in utf-8
  220. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  221. - add patch1 from centos5
  222. - new versioning policy
  223. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  224. - new upstream release with security fix (CVE-2007-2756)
  225. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  226. - new upstream release with security fix
  227. - change source tarball format gz -> bz2
  228. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  229. - added compat32-* packages for x86_64 architecture support
  230. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  231. - source upgrade
  232. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  233. - source update
  234. - added -DJISX0208 flag
  235. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  236. - source upgrade
  237. - BuildPrereq: XOrg-devel instead of XFree86-devel
  238. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  239. - source upgrade
  240. - remove patch0 (no need for freetype2-2.1.7)
  241. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  242. - add patch0 to build against freetype2-2.1.7
  243. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  244. - source upgrade
  245. - add URL
  246. - remove all patches
  247. - use %%configure script
  248. - add BuildPrereq: freetype2-devel XFree86-devel
  249. - remove BuildPrereq: VFlib-devel
  250. - update %%files
  251. - update Requires:
  252. - use License tag instead of Copyright
  253. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  254. - rebuild with libpng-devel-1.2.5-0vl1
  255. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  256. - rebuild with new toolchain
  257. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  258. - 1.8.3-0vl2
  259. - symlink to libgd.so.1 (for backward compatibility)
  260. * Tue Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  261. - first gd 1.8.x release for Vine from rawhide.
  262. - enable freetype support and defined JISX208 macro.
  263. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  264. - break out a -progs subpackage
  265. - disable freetype support
  266. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  267. - update to latest version (1.8.2)
  268. - disable xpm support
  269. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  270. - auto rebuild in the new build environment (release 6)
  271. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  272. - auto rebuild in the new build environment (release 5)
  273. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  274. - buiuld for glibc 2.1
  275. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  276. - built for 5.2