elfutils-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741
  1. %define eu_version 0.157
  2. %define eu_release 1
  3. %global nocheck true
  4. Summary: A collection of utilities and DSOs to handle compiled objects
  5. Name: elfutils
  6. Version: %{eu_version}
  7. Release: %{eu_release}%{?_dist_release}
  8. License: GPLv2 with exceptions
  9. Group: Development/Tools
  10. URL: https://fedorahosted.org/elfutils/
  11. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
  12. Patch1: elfutils-robustify.patch
  13. Patch2: elfutils-portability.patch
  14. ##VINE##
  15. Patch10: elfutils-0.131-readelf_c.patch
  16. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  17. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  19. BuildRequires: bison >= 1.875
  20. BuildRequires: flex >= 2.5.4a
  21. BuildRequires: bzip2
  22. BuildRequires: bzip2-devel
  23. BuildRequires: zlib-devel
  24. BuildRequires: xz-devel
  25. BuildRequires: gettext
  26. BuildRequires: m4
  27. BuildRequires: gcc >= 3.4
  28. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  29. BuildRequires: glibc-headers >= 2.3.4-11
  30. %define _gnu %{nil}
  31. %define _program_prefix eu-
  32. %description
  33. Elfutils is a collection of utilities, including ld (a linker),
  34. nm (for listing symbols from object files), size (for listing the
  35. section sizes of an object or archive file), strip (for discarding
  36. symbols), readelf (to see the raw ELF file structures), and elflint
  37. (to check for well-formed ELF files).
  38. %package libs
  39. Summary: Libraries to handle compiled objects
  40. Group: System Environment/Libraries
  41. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  42. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  43. Conflicts: elfutils < %{version}-%{release}
  44. Conflicts: elfutils > %{version}-%{release}
  45. Conflicts: elfutils-devel < %{version}-%{release}
  46. Conflicts: elfutils-devel > %{version}-%{release}
  47. %description libs
  48. The elfutils-libs package contains libraries which implement DWARF, ELF,
  49. and machine-specific ELF handling. These libraries are used by the programs
  50. in the elfutils package. The elfutils-devel package enables building
  51. other programs using these libraries.
  52. %package devel
  53. Summary: Development libraries to handle compiled objects
  54. Group: Development/Libraries
  55. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  56. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  57. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  58. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  59. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  60. %description devel
  61. The elfutils-devel package contains the libraries to create
  62. applications for handling compiled objects. libebl provides some
  63. higher-level ELF access functionality. libdw provides access to
  64. the DWARF debugging information. libasm provides a programmable
  65. assembler interface.
  66. %package devel-static
  67. Summary: Static archives to handle compiled objects
  68. Group: Development/Libraries
  69. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  70. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  71. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  72. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  73. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  74. %description devel-static
  75. The elfutils-devel-static package contains the static archives
  76. with the code to handle compiled objects.
  77. %package libelf
  78. Summary: Library to read and write ELF files
  79. Group: System Environment/Libraries
  80. Provides: libelf = %{version}-%{release}
  81. Obsoletes: libelf <= 0.8.2-2
  82. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  83. Conflicts: elfutils < %{version}-%{release}
  84. Conflicts: elfutils > %{version}-%{release}
  85. Conflicts: elfutils-libs < %{version}-%{release}
  86. Conflicts: elfutils-libs > %{version}-%{release}
  87. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  88. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  89. %description libelf
  90. The elfutils-libelf package provides a DSO which allows reading and
  91. writing ELF files on a high level. Third party programs depend on
  92. this package to read internals of ELF files. The programs of the
  93. elfutils package use it also to generate new ELF files.
  94. %package libelf-devel
  95. Summary: Development support for libelf
  96. Group: Development/Libraries
  97. Provides: libelf-devel = %{version}-%{release}
  98. Obsoletes: libelf-devel <= 0.8.2-2
  99. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  100. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  101. Conflicts: libelf-devel < %{version}-%{release}
  102. %description libelf-devel
  103. The elfutils-libelf-devel package contains the libraries to create
  104. applications for handling compiled objects. libelf allows you to
  105. access the internals of the ELF object file format, so you can see the
  106. different sections of an ELF file.
  107. %package libelf-devel-static
  108. Summary: Static archive of libelf
  109. Group: Development/Libraries
  110. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  111. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  112. %description libelf-devel-static
  113. The elfutils-libelf-static package contains the static archive
  114. for libelf.
  115. %prep
  116. %setup -q
  117. %patch1 -p1 -b .robustify
  118. %patch2 -p1 -b .portability
  119. %patch10 -p0 -b .readelf_c
  120. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  121. %build
  122. # Remove -Wall from default flags. The makefiles enable enough warnings
  123. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  124. # the makefiles disable some specific warnings for specific code.
  125. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  126. %configure --enable-dwz CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  127. make -s %{?_smp_mflags}
  128. %install
  129. rm -rf ${RPM_BUILD_ROOT}
  130. make -s install DESTDIR=${RPM_BUILD_ROOT}
  131. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  132. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  133. %find_lang %{name}
  134. # XXX Nuke unpackaged files
  135. { cd ${RPM_BUILD_ROOT}
  136. rm -f .%{_bindir}/eu-ld
  137. }
  138. %check
  139. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  140. %clean
  141. rm -rf ${RPM_BUILD_ROOT}
  142. %post libs -p /sbin/ldconfig
  143. %postun libs -p /sbin/ldconfig
  144. %post libelf -p /sbin/ldconfig
  145. %postun libelf -p /sbin/ldconfig
  146. %files -f %{name}.lang
  147. %defattr(-,root,root)
  148. %doc README TODO
  149. %{_bindir}/eu-addr2line
  150. %{_bindir}/eu-ar
  151. %{_bindir}/eu-elfcmp
  152. %{_bindir}/eu-elflint
  153. %{_bindir}/eu-findtextrel
  154. %{_bindir}/eu-nm
  155. %{_bindir}/eu-objdump
  156. %{_bindir}/eu-ranlib
  157. %{_bindir}/eu-readelf
  158. %{_bindir}/eu-size
  159. %{_bindir}/eu-strings
  160. %{_bindir}/eu-strip
  161. #%{_bindir}/eu-ld
  162. %{_bindir}/eu-unstrip
  163. %{_bindir}/eu-make-debug-archive
  164. %files libs
  165. %defattr(-,root,root)
  166. %{_libdir}/libasm-%{version}.so
  167. %{_libdir}/libasm.so.*
  168. %{_libdir}/libdw-%{version}.so
  169. %{_libdir}/libdw.so.*
  170. %dir %{_libdir}/elfutils
  171. %{_libdir}/elfutils/lib*.so
  172. %files devel
  173. %defattr(-,root,root)
  174. %{_includedir}/dwarf.h
  175. %dir %{_includedir}/elfutils
  176. %{_includedir}/elfutils/elf-knowledge.h
  177. %{_includedir}/elfutils/libasm.h
  178. %{_includedir}/elfutils/libebl.h
  179. %{_includedir}/elfutils/libdw.h
  180. %{_includedir}/elfutils/libdwfl.h
  181. %{_includedir}/elfutils/version.h
  182. %{_libdir}/libebl.a
  183. %{_libdir}/libasm.so
  184. %{_libdir}/libdw.so
  185. %files devel-static
  186. %defattr(-,root,root)
  187. %{_libdir}/libasm.a
  188. %{_libdir}/libdw.a
  189. %files libelf
  190. %defattr(-,root,root)
  191. %{_libdir}/libelf-%{version}.so
  192. %{_libdir}/libelf.so.*
  193. %files libelf-devel
  194. %defattr(-,root,root)
  195. %{_includedir}/libelf.h
  196. %{_includedir}/gelf.h
  197. %{_includedir}/nlist.h
  198. %{_libdir}/libelf.so
  199. %files libelf-devel-static
  200. %defattr(-,root,root)
  201. %{_libdir}/libelf.a
  202. %changelog
  203. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  204. - update to 0.157
  205. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  206. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  207. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  208. - update to 0.152
  209. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  210. - elfutils-libs: changed Group to System Environment/Libraries
  211. - elfutils-libelf: changed Group to System Environment/Libraries
  212. - elfutils-devel: changed Group to Development/Libraries
  213. - elfutils-devel-static: changed Group to Development/Libraries
  214. - elfutils-libelf-devel: changed Group to Development/Libraries
  215. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  216. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  217. - merged with Fedora 9 0.135-1
  218. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  219. - applied new versioning policy
  220. - added elfutils-0.131-readelf_c.patch
  221. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  222. - new upstream release
  223. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  224. - remove Obsoletes: libelf, libelf-devel from elfutils
  225. - add Obsoletes: libelf to elfutils-libelf
  226. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  227. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  228. - Update to 0.135
  229. - libdwfl: bug fixes
  230. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  231. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  232. - Update to 0.134
  233. - elflint: backend improvements for sparc, alpha (#204170)
  234. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  235. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  236. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  237. - Update to 0.133
  238. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  239. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  240. - libdwfl: bug fixes and optimization in relocation handling
  241. - elfcmp: bug fix for non-allocated section handling
  242. - ld: implement newer features of binutils linker.
  243. - Install eu-objdump and libasm, now has limited disassembler support.
  244. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  245. - Update to 0.132
  246. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  247. - eu-readelf: Fix handling of ET_REL files in archives.
  248. - libcpu: Implement x86 and x86-64 disassembler.
  249. - libasm: Add interface for disassembler.
  250. - all programs: add debugging of branch prediction.
  251. - libelf: new function elf_scnshndx.
  252. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  253. - Update to 0.131
  254. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  255. bug fixes for oddly-formatted DWARF
  256. - libdwfl: bug fixes in offline archive support, symbol table handling;
  257. apply partial relocations for dwfl_module_address_section on ET_REL
  258. - libebl: powerpc backend support for Altivec registers
  259. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  260. - Fix ET_REL support.
  261. - Fix odd indentation in eu-readelf -x output.
  262. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  263. - Update to 0.130
  264. - eu-readelf -p option can take an argument like -x for one section
  265. - eu-readelf --archive-index (or -c)
  266. - eu-readelf -n improved output for core dumps
  267. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  268. - eu-elflint: ditto
  269. - eu-elflint: stricter checks on debug sections
  270. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  271. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  272. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  273. - libebl: backend improvements (#324031)
  274. - libdwfl: build_id support, new functions for it
  275. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  276. - libdwfl offline archive support, new script eu-make-debug-archive
  277. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  278. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  279. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  280. - Update to 0.129
  281. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  282. - addr2line: new option --symbols (or -S)
  283. - libdw: dwarf_getscopes fixes (#230235)
  284. - libdwfl: dwfl_module_addrsym fixes (#249490)
  285. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  286. - Update to 0.128
  287. - new program: unstrip
  288. - elfcmp: new option --hash-inexact
  289. - Replace Conflicts: with Provides/Requires using -arch
  290. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  291. - Update to 0.127
  292. - libdw: new function dwarf_getsrcdirs
  293. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  294. dwfl_module_address_section
  295. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  296. - Update to 0.126
  297. - New program eu-ar.
  298. - libdw: fix missing dwarf_getelf (#227206)
  299. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  300. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  301. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  302. - Fix overeager warn_unused_result build failures.
  303. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  304. - Update to 0.125
  305. - elflint: Compare DT_GNU_HASH tests.
  306. - move archives into -static RPMs
  307. - libelf, elflint: better support for core file handling
  308. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  309. - Resolves: RHBZ #220817, RHBZ #213792
  310. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  311. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  312. - Update to 0.124
  313. - libebl: fix ia64 reloc support (#206981)
  314. - libebl: sparc backend support for return value location
  315. - libebl, libdwfl: backend register name support extended with more info
  316. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  317. - readelf, elflint: trivial bugs fixed
  318. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  319. - Update to 0.123
  320. - libebl: Backend build fixes, thanks to Stepan Kasal.
  321. - libebl: ia64 backend support for register names, return value location
  322. - libdwfl: Handle truncated linux kernel module section names.
  323. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  324. - elflint: Fix checks to permit --hash-style=gnu format.
  325. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  326. - Fix warnings in elflint compilation.
  327. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  328. - Update to 0.122
  329. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  330. - libebl: add function to test for relative relocation
  331. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  332. - elflint, readelf: add support for DT_GNU_HASH
  333. - libelf: add elf_gnu_hash
  334. - elflint, readelf: add support for 64-bit SysV-style hash tables
  335. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  336. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  337. - Update to 0.121
  338. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  339. - make all installed headers usable in C++ code (#193153).
  340. - eu-readelf: better output format.
  341. - eu-elflint: fix tests of dynamic section content.
  342. - libdw, libdwfl: handle files without aranges info.
  343. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  344. - rebuild to pick up -devel deps
  345. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  346. - Update to 0.120
  347. - License changed to GPL, with some exceptions for using
  348. the libelf, libebl, libdw, and libdwfl library interfaces.
  349. Red Hat elfutils is an included package of the Open Invention Network.
  350. - dwarf.h updated for DWARF 3.0 final specification.
  351. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  352. - libdwfl: New function dwfl_version; fixes for offline.
  353. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  354. - bump again for double-long bug on ppc(64)
  355. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  356. - rebuilt for new gcc4.1 snapshot and glibc changes
  357. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  358. - update to 0.119
  359. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  360. - rebuilt
  361. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  362. - update to 0.118
  363. - elflint: more tests.
  364. - libdwfl: New function dwfl_module_register_names.
  365. - libebl: New backend hook for register names.
  366. - Make sure -fexceptions is always in CFLAGS.
  367. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  368. - update to 0.117
  369. - libdwfl: New function dwfl_module_return_value_location (#166118)
  370. - libebl: Backend improvements for several CPUs
  371. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  372. - update to 0.116
  373. - libdw fixes, API changes and additions
  374. - libdwfl fixes (#169672)
  375. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  376. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  377. - Update requires/conflicts for better biarch update behavior.
  378. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  379. - update to 0.115
  380. - New program eu-strings.
  381. - libdw: New function dwarf_getscopes_die.
  382. - libelf: speed-ups of non-mmap reading.
  383. - Implement --enable-gcov option for configure.
  384. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  385. - update to 0.114
  386. - new program eu-ranlib
  387. - libdw: new calls for inlines
  388. - libdwfl: new calls for offline modules
  389. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  390. - update to 0.113
  391. - elflint: relax a bit. Allow version definitions for defined symbols
  392. against DSO versions also for symbols in nobits sections.
  393. Allow .rodata section to have STRINGS and MERGE flag set.
  394. - strip: add some more compatibility with binutils.
  395. - libdwfl: bug fixes.
  396. - Separate libdw et al into elfutils-libs subpackage.
  397. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  398. - update to 0.112
  399. - elfcmp: some more relaxation.
  400. - elflint: many more tests, especially regarding to symbol versioning.
  401. - libelf: Add elfXX_offscn and gelf_offscn.
  402. - libasm: asm_begin interface changes.
  403. - libebl: Add three new interfaces to directly access machine, class,
  404. and data encoding information.
  405. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  406. - update portability patch
  407. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  408. - update to 0.111
  409. - libdwfl library now merged into libdw
  410. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  411. - update to 0.110
  412. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  413. - update to 0.109
  414. - verify that libebl modules are from the same build
  415. - new eu-elflint checks on copy relocations
  416. - new program eu-elfcmp
  417. - new experimental libdwfl library
  418. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  419. - robustification of eu-strip and eu-readelf
  420. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  421. - more robustification
  422. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  423. - robustification
  424. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  425. - update to 0.108
  426. - merge strip fixes
  427. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  428. - update elf.h from glibc
  429. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  430. - fix strip -f byte-swapping bug
  431. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  432. - update to 0.107
  433. - readelf: improve DWARF output format
  434. - elflint: -d option to support checking separate debuginfo files
  435. - strip: fix ET_REL debuginfo files (#156341)
  436. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  437. - fix some bugs in new code, reenable make check
  438. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  439. - disable make check for most arches, for now
  440. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  441. - update to 0.106
  442. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  443. - update to 0.104
  444. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  445. - update to 0.103
  446. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  447. - update to 0.101.
  448. - use %%configure macro to get CFLAGS etc. right
  449. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  450. - upgrade to 0.99.
  451. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  452. - upgrade to 0.97.
  453. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  454. - upgrade to 0.96.
  455. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  456. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  457. warning
  458. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  459. - rebuilt
  460. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  461. - upgrade to 0.95.
  462. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  463. - rebuilt
  464. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  465. - rebuilt
  466. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  467. - upgrade to 0.94
  468. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  469. - upgrade to 0.93
  470. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  471. - full version
  472. - macroized spec file for GPL or OSL builds
  473. - include only libelf under GPL plus wrapper scripts
  474. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  475. - macroized spec file for GPL or OSL builds
  476. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  477. - split elfutils-devel into two packages.
  478. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  479. - include only libelf under GPL plus wrapper scripts
  480. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  481. - readelf, not readline, in %%description (#111214).
  482. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  483. - update to 0.89 (fix eu-strip)
  484. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  485. - update to 0.86 (fix eu-strip on s390x/alpha)
  486. - libebl is an archive now; remove references to DSO
  487. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  488. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  489. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  490. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  491. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  492. - upgrade to 0.82 (strip tests fixed on big-endian).
  493. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  494. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  495. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  496. - upgrade to 0.80 (debugedit changes for kernel in progress).
  497. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  498. - rebuilt
  499. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  500. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  501. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  502. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  503. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  504. - debuginfo rebuild
  505. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  506. - use the correct way of identifying the section via the sh_info link.
  507. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  508. - update to 0.75 (eu-strip -g fix)
  509. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  510. - update to 0.74 (fix for writing with some non-dirty sections)
  511. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  512. - another -0.73 update (with sparc fixes).
  513. - do "make check" in %%check, not %%install, section.
  514. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  515. - update to 0.73 (with s390 fixes).
  516. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  517. - rebuilt
  518. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  519. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  520. - fix other warnings
  521. - reenable checks on s390x
  522. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  523. - temporarily disable checks on s390x, until someone has
  524. time to look at it
  525. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  526. - update to 0.72
  527. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  528. - update to 0.71
  529. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  530. - update to 0.69.
  531. - add "make check" and segfault avoidance patch.
  532. - elfutils-libelf needs to run ldconfig.
  533. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  534. - update to 0.68.
  535. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  536. - update to 0.67.
  537. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  538. - update to 0.65.
  539. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  540. - update to 0.64.
  541. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  542. - split packages further into elfutils-libelf
  543. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  544. - update to 0.63.
  545. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  546. - Adjust for dropping libtool
  547. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  548. - update to 0.59
  549. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  550. - update to 0.56
  551. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  552. - update to 0.54
  553. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  554. - update to 0.53
  555. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  556. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  557. - get beehive to punch a rhpkg generated package.
  558. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  559. - build in 8.0.1.
  560. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  561. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  562. - Add libelf-devel to conflicts for elfutils-devel
  563. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  564. - Split into runtime and devel package
  565. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  566. - integrate into official sources
  567. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  568. - Swaddle.