perl-Test-LeakTrace-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. Name: perl-Test-LeakTrace
  2. Summary: Traces memory leaks
  3. Version: 0.14
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Source0: http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Test-LeakTrace-%{version}.tar.gz
  8. URL: http://search.cpan.org/dist/Test-LeakTrace
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  11. BuildRequires: perl(Exporter) >= 5.57
  12. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.42
  13. BuildRequires: perl(Test::More) >= 0.62
  14. Requires: perl(Exporter) >= 5.57
  15. %{?perl_default_filter}
  16. %{?perl_default_subpackage_tests}
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: shaolin
  20. %description
  21. 'Test::LeakTrace' provides several functions that trace memory leaks.
  22. This module scans arenas, the memory allocation system, so it can detect
  23. any leaked SVs in given blocks. *Leaked SVs* are SVs which are not
  24. released after the end of the scope they have been created. These SVs
  25. include global variables and internal caches. For example, if you call a
  26. method in a tracing block, perl might prepare a cache for the method.
  27. Thus, to trace true leaks, 'no_leaks_ok()' and 'leaks_cmp_ok()' executes
  28. a block more than once.
  29. %prep
  30. %setup -q -n Test-LeakTrace-%{version}
  31. find . -type f -exec chmod -c -x {} +
  32. %build
  33. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf %{buildroot}
  37. make pure_install DESTDIR=%{buildroot}
  38. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  39. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  40. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  41. %{_fixperms} %{buildroot}/*
  42. %check
  43. make test
  44. %clean
  45. rm -rf %{buildroot}
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc Changes README
  49. %{perl_vendorarch}/*
  50. %exclude %dir %{perl_vendorarch}/auto
  51. %{_mandir}/man3/*.3*
  52. %changelog
  53. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.14-1
  54. - new upstream release.
  55. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.13-1
  56. - initial build for Vine Linux
  57. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  59. * Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.13-3
  60. - Perl mass rebuild
  61. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-2
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  63. * Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.13-1
  64. - update to 0.13
  65. - use ">= 0", instead of "== 0" for no_leaks_ok()
  66. - add count_sv() to count all the SVs in a perl interpreter
  67. - fix tests broken for some perls in 0.12
  68. * Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.11-1
  69. - update to 0.11 (#654301)
  70. - fix false-positive related to XS code (CPAN RT #58133)
  71. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.10-2
  72. - Mass rebuild with perl-5.12.0
  73. * Sun Apr 04 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.10-1
  74. - specfile by Fedora::App::MaintainerTools 0.006