123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157 |
- Name: jsoncpp
- Version: 0.7.1
- Release: 1%{?_dist_release}
- Summary: JSON library implemented in C++
- Summary(ja): C++ で実装された JSON ライブラリ
- Group: System Environment/Libraries
- License: Public Domain or MIT
- URL: http://sourceforge.net/projects/%{name}/
- Source0: https://github.com/open-source-parsers/jsoncpp/archive/0.7.1.tar.gz
- Source1: jsoncpp.pc
- Patch0: asstring.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: python scons doxygen
- BuildRequires: graphviz
- %description
- %{name} is an implementation of a JSON (http://json.org) reader and writer in
- C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
- It is easy for humans to read and write. It is easy for machines to parse and
- generate.
- %package devel
- Summary: Development headers and library for %{name}
- Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- This package contains the development headers and library for %{name}.
- %package doc
- Summary: Documentation for %{name}
- Summary(ja): %{name} のドキュメント
- Group: Documentation
- BuildArch: noarch
- %description doc
- This package contains the documentation for %{name}
- %prep
- %setup -q
- #%patch0 -dsrc/lib_json -p1
- grep -e "-Wall" SConstruct
- sed 's/CCFLAGS = "-Wall"/CCFLAGS = "%{optflags}"/' -i SConstruct
- sed 's/README\.txt/README\.md/' -i SConstruct
- %build
- scons platform=linux-gcc %{?_smp_mflags}
- # Now, lets make a proper shared lib. :P
- g++ -o libjsoncpp.so.0.0.0 -shared -Wl,-soname,libjsoncpp.so.0 buildscons/linux-gcc-*/src/lib_json/*.os -lpthread
- # Build the doc
- python doxybuild.py --with-dot --doxygen %{_bindir}/doxygen
- %check
- # Fails due to patch0
- # scons platform=linux-gcc check %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- install -p -D lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0.0.0
- ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
- ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
- install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/json
- install -p -m 0644 include/json/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/json
- mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/html
- for f in AUTHORS LICENSE NEWS.txt README.md; do
- install -p -m 0644 $f $RPM_BUILD_ROOT%{_docdir}/%{name}
- done
- install -p -m 0644 dist/doxygen/*/*.{html,png} $RPM_BUILD_ROOT%{_docdir}/%{name}/html
- install -d $RPM_BUILD_ROOT%{_libdir}/pkgconfig
- install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
- sed -i 's|@@LIBDIR@@|%{_libdir}|g' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/jsoncpp.pc
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %{_docdir}/%{name}/
- %exclude %{_docdir}/%{name}/html
- %{_libdir}/lib%{name}.so.0
- %{_libdir}/lib%{name}.so.0.0.0
- %files devel
- %{_libdir}/lib%{name}.so
- %{_includedir}/%{name}/
- %{_libdir}/pkgconfig/jsoncpp.pc
- %files doc
- %{_docdir}/%{name}/
- %changelog
- * Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
- - Initial build for Vine Linux
- * Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
- - Allow int values to be converted to string (#1143774)
- * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
- - https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
- patch to fix duplicated documentation
- * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
- - Changed Summary
- - Added %%doc files to the doc package
- - Added python as an explicit BuildRequires
- * Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
- - Added documentation sub-package
- * Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
- - Added graphviz as a BuildRequire
- * Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
- - Install the corrected library
- * Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
- - Added libjsoncpp.so.0
- - Moved the shared lib build to the correct section
- * Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
- - Removed doc subpackage
- - Added .pc file
- - Fixed shared lib
- * Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
- - Removed static package
- - Preserving timestamp on installed files
- - Added guard grep to the sed expression
- - Removed duplicated doc files
- - Removed dependency on pkgconfig
- - Changed base package group
- * Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
- - Changed license field to Public Domain or MIT
- * Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
- - Creation of the spec file
|