Zope-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680
  1. #%define _pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. #%define _python %{_bindir}/python
  3. %define _pyver 2.4
  4. %define _python %{_bindir}/python%{_pyver}
  5. %define zope_user zope
  6. %define zope_home %{_libdir}/%{zope_user}
  7. %define zope_conf %{_sysconfdir}/%{zope_user}
  8. %define software_home %{zope_home}/lib/python
  9. %define instance_home %{_var}/lib/%{zope_user}
  10. %define _http_port 8080
  11. %define _ftp_port 8021
  12. %define _admin admin
  13. %define _password 123
  14. #%define _hotfix Hotfix_20080812
  15. %define _hotfix 0
  16. Summary: An application server and portal toolkit for building Web sites.
  17. Summary(ja): アプリケーションサーバおよびウェブサイト構築ツールキット
  18. Name: Zope
  19. Version: 2.11.6
  20. Release: 1%{?_dist_release}
  21. License: ZPL (Zope Public License) 2.1
  22. URL: http://www.zope.org/
  23. Group: Development/Web Applications
  24. Source0: http://www.zope.org/Products/Zope/%{version}/Zope-%{version}-final.tgz
  25. Source1: init.sh
  26. %if %{_hotfix}
  27. Source2: %{_hotfix}.tar.gz
  28. %endif
  29. Prereq: /sbin/chkconfig /usr/sbin/useradd
  30. #Buildrequires: python-devel
  31. #Requires: python >= 2.4.4
  32. Buildrequires: python24-devel
  33. Requires: python24
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. #Packager: Shu KONNO <owa@bg.wakwak.com>
  37. Packager: <owa>
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. %description
  40. The Z Object Programming Environment (Zope) is a free, Open Source[tm]
  41. Python-based application server for building high-performance, dynamic
  42. web sites, using a powerful and simple scripting object model and
  43. high-performance, integrated object database.
  44. For a fully functional installation of Zope, install this single huge
  45. package and then the Zope-zserver RPM
  46. %description -l ja
  47. Zオブジェクトプログラミング環境(Zope)はフリーです,オープンソースである
  48. Pythonをベースにした、高性能で動的なWebサイトを構築するためのアプリケー
  49. ションサーバです.強力でしかも単純なスクリプトからなるオブジェクトモデル
  50. と高性能な統合オブジェクトデータベースを使うことができます.
  51. Zope の全機能をインストールするには,この一個の大きなパッケージをインスト
  52. ールし, 次に Zope-zserver RPM をインストールします.
  53. ##
  54. ## Zope-zserver
  55. ##
  56. %package zserver
  57. Summary: Initial Object Database/Standalone HTTP Server
  58. Summary(ja): Zope インスタンス
  59. Group: Development/Web Applications
  60. Requires: Zope
  61. Prereq: /etc/rc.d/init.d
  62. %description zserver
  63. The Zope-zserver package contains the files needed for setting up a
  64. Zope website, including an empty object database. Zope is an application
  65. server and portal toolkit.
  66. Also included is the ZServer, which is a small, standalone web server
  67. written in Python. The ZServer uses the very fast Medusa technology
  68. and is multithreaded. This package comes preconfigured to serve
  69. web pages on port %{_http_port} and ftp access on %{_ftp_port}. The programmer's port
  70. interface comes disabled for security reasons but can be reenabled.
  71. %description -l ja zserver
  72. Zope-zserver パッケージは Zope web サイトをセットアップするのに必要な
  73. ファイルを含んでいます,そこには空のオブジェクトデータベースも含みます.
  74. Zope はアプリケーションサーバであり,Webサイト構築のためのツール集です.
  75. また Python で書かれた小さなスタンドアロン Web サーバである ZServer も
  76. 含まれています. ZServer は非常に高速な Medusa の技術を利用し,マルチス
  77. レッド化されています.このパッケージでは Web ページを %{_http_port} ポート, FTP
  78. アクセスを %{_ftp_port} でサービスするようにあらかじめ設定してあります.セキュ
  79. リティ上の理由のため,プログラマ用ポートインタフェースは使用できないよ
  80. うになっていますが,再び利用できるように戻すことが可能です.
  81. 初期ユーザは "%{_admin}" パスワードは "%{_password}" に設定されています。
  82. 初回の起動直後にこれらは変更すべきです。
  83. %prep
  84. %setup -q -n Zope-%{version}-final
  85. %if %{_hotfix}
  86. %{__tar} -xzf %{SOURCE2}
  87. %endif
  88. %build
  89. rm -rf $RPM_BUILD_ROOT
  90. ./configure \
  91. --with-python=%{_python} \
  92. --prefix="$RPM_BUILD_ROOT%{zope_home}"
  93. make %{?_smp_mflags}
  94. %install
  95. rm -rf $RPM_BUILD_ROOT
  96. make install
  97. $RPM_BUILD_ROOT%{zope_home}/bin/mkzopeinstance.py \
  98. --dir $RPM_BUILD_ROOT%{instance_home} \
  99. --user %{_admin}:%{_password}
  100. install -d $RPM_BUILD_ROOT%{zope_conf}
  101. ( cd $RPM_BUILD_ROOT%{instance_home}%{_sysconfdir}
  102. sed "s|$RPM_BUILD_ROOT||" zope.conf \
  103. | sed 's|^#.*effective-user chrism$|effective-user %{zope_user}|' \
  104. | sed 's|\$INSTANCE/log|/var/log/%{zope_user}|' \
  105. > $RPM_BUILD_ROOT%{zope_conf}/%{zope_user}.conf
  106. install -m 644 site.zcml $RPM_BUILD_ROOT%{zope_conf}/
  107. )
  108. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  109. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{zope_user}
  110. install -d $RPM_BUILD_ROOT/var/log/%{zope_user}
  111. ( cd $RPM_BUILD_ROOT%{instance_home}/bin
  112. mv runzope runzope.old
  113. sed "s|$RPM_BUILD_ROOT||" runzope.old | \
  114. sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > runzope
  115. rm -f runzope.old
  116. )
  117. ( cd $RPM_BUILD_ROOT%{instance_home}/bin
  118. mv zopectl zopectl.old
  119. sed "s|$RPM_BUILD_ROOT||" zopectl.old | \
  120. sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > zopectl
  121. rm -f zopectl.old
  122. )
  123. %if %{_hotfix}
  124. install -d $RPM_BUILD_ROOT%{instance_home}/Products/%{_hotfix}
  125. #install -m644 %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
  126. cp -a %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
  127. %endif
  128. ## remove unused files
  129. rm -f $RPM_BUILD_ROOT%{instance_home}/bin/zopectl.bat
  130. %clean
  131. rm -rf $RPM_BUILD_ROOT
  132. %post
  133. # byte-compile installed Python files
  134. pushd "%{zope_home}" > /dev/null 2>&1
  135. %{_python} "%{zope_home}/bin/compilezpy.py" > /dev/null 2>&1 || :
  136. popd > /dev/null 2>&1
  137. %pre zserver
  138. if [ "$1" = 1 ] ; then
  139. %{__grep} "%{zope_user}:" /etc/group > /dev/null 2>&1
  140. if [ $? == 0 ]; then
  141. /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} -g %{zope_user} \
  142. %{zope_user} > /dev/null 2>&1 || :
  143. else
  144. /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} \
  145. %{zope_user} > /dev/null 2>&1 || :
  146. fi
  147. fi
  148. %post zserver
  149. if [ "$1" = 1 ] ; then
  150. /sbin/chkconfig --add %{zope_user}
  151. ln -sf /var/log/%{zope_user} %{instance_home}/log
  152. /etc/rc.d/init.d/%{zope_user} start
  153. else
  154. mv %{instance_home}/inituser %{instance_home}/inituser.admin
  155. /etc/rc.d/init.d/%{zope_user} condrestart
  156. fi
  157. %preun zserver
  158. if [ "$1" = 0 ] ; then
  159. /etc/rc.d/init.d/%{zope_user} stop > /dev/null 2>&1
  160. /sbin/chkconfig --del %{zope_user}
  161. if [ /var/log/%{zope_user} -ef %{instance_home}/log ]; then
  162. rm -rf %{instance_home}/log
  163. fi
  164. fi
  165. %postun zserver
  166. if [ "$1" = 0 ] ; then
  167. /usr/sbin/userdel %{zope_user} > /dev/null 2>&1 || :
  168. fi
  169. %files
  170. %defattr(-, root, root)
  171. %doc %{zope_home}/doc
  172. %{zope_home}/bin
  173. %{zope_home}/lib/python
  174. %{zope_home}/skel
  175. %files zserver
  176. %defattr(-, root, root)
  177. %config %{_sysconfdir}/rc.d/init.d/%{zope_user}
  178. %config(noreplace) %{zope_conf}/%{zope_user}.conf
  179. %{zope_conf}/site.zcml
  180. %defattr(700, %{zope_user}, %{zope_user})
  181. %dir /var/log/%{zope_user}
  182. %defattr(700, %{zope_user}, %{zope_user})
  183. %dir %{instance_home}/
  184. %dir %{instance_home}/bin/
  185. %dir %{instance_home}/Extensions/
  186. %dir %{instance_home}/Products/
  187. %dir %{instance_home}/import/
  188. %config %{instance_home}/bin/runzope
  189. %config %{instance_home}/bin/zopectl
  190. %config %{instance_home}/bin/zopeservice.py
  191. %attr(600, %{zope_user}, %{zope_user})
  192. %{instance_home}/inituser
  193. %defattr(1703, %{zope_user}, %{zope_user})
  194. %dir %{instance_home}/var/
  195. %defattr(-, %{zope_user}, %{zope_user})
  196. %{instance_home}/Products/__init__.py
  197. %{instance_home}/import/Examples.zexp
  198. %{instance_home}/import/ZopeTutorialExamples.zexp
  199. %exclude %{instance_home}/Extensions/README.txt
  200. %exclude %{instance_home}/Products/README.txt
  201. %exclude %{instance_home}/README.txt
  202. %exclude %{instance_home}/bin/runzope.bat
  203. %exclude %{instance_home}/etc/zope.conf
  204. %exclude %{instance_home}/etc/site.zcml
  205. %exclude %{instance_home}/import/README.txt
  206. %exclude %{instance_home}/lib/python/README.txt
  207. %exclude %{instance_home}/log/README.txt
  208. %exclude %{instance_home}/var/README.txt
  209. %if %{_hotfix}
  210. %defattr(-, %{zope_user}, %{zope_user})
  211. %{instance_home}/Products/%{_hotfix}
  212. %endif
  213. %changelog
  214. * Thu Jan 14 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.6-1
  215. - updated zope to 2.11.6-final
  216. * Thu Dec 24 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.5-1
  217. - updated zope to 2.11.5-final
  218. * Thu Aug 06 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.4-1
  219. - updated zope to 2.11.4-final
  220. * Sun May 03 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.3-1vl5
  221. - updated zope to 2.11.3-final
  222. * Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.2-1vl5
  223. - updated zope to 2.11.2-final
  224. - dropt Hotfix_20080812.tar.gz
  225. * Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-4vl5
  226. - rebuilt with python24
  227. - added BuildRequires: python24
  228. - added Requires: python24
  229. * Wed Aug 13 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-3vl5
  230. - added Hotfix_20080812.tar.gz
  231. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-2vl5
  232. - rebuilt with python-2.5.2
  233. * Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-1vl5
  234. - updated zope to 2.11.1-final
  235. * Tue Jul 01 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.0-1vl5
  236. - updated zope to 2.11.0-final
  237. * Mon Jun 09 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.6-1vl5
  238. - applied new versioning policy and spec in utf-8
  239. - updated zope to 2.10.6-final
  240. * Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl2
  241. - fixed prereq, buildrequires pkgs
  242. * Tue Oct 30 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl1
  243. - updated zope to 2.10.5-final
  244. - updated Requires python >= 2.4.4
  245. * Thu Aug 23 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.4-0vl1
  246. - updated zope to 2.10.4-final
  247. - updated %%install scripts
  248. - dropped Hotfix_20070320.tgz
  249. * Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.2-0vl1
  250. - updated zope to 2.10.2
  251. - added Hotfix_20070320.tgz
  252. * Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl3
  253. - added japanese summary
  254. * Fri Oct 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl2
  255. - updated zope to 2.9.5-final
  256. * Thu Jul 20 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.4-0vl1
  257. - updated zope to 2.9.4
  258. - dropped Hotfix_20060705.tar.gz
  259. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl2
  260. - added Hotfix_20060705.tar.gz
  261. * Fri May 12 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl1
  262. - updated zope to 2.9.3
  263. * Tue Mar 28 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.2-0vl1
  264. - updated zope to 2.9.2
  265. * Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.1-0vl1
  266. - updated zope to 2.9.1
  267. - x86_64 architecture support
  268. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.0-0vl1
  269. - updated zope to 2.9.0
  270. * Thu Oct 27 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.4-0vl1
  271. - updated zope to 2.8.4-final
  272. * Wed Oct 19 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.3-0vl1
  273. - updated zope to 2.8.3-final
  274. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.2-0vl1
  275. - updated zope to 2.8.2-final
  276. * Mon Oct 10 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl2
  277. - added Hotfix_2005-10-09.tar.gz (security)
  278. * Thu Aug 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl1
  279. - updated zope to 2.8.1-final
  280. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.0-0vl1
  281. - updated zope to 2.8.0-final
  282. * Sun May 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl2
  283. - updated init.sh (added condrestart)
  284. - updated spec 'post zserver section'
  285. * Fri Apr 29 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl1
  286. - updated zope to 2.7.6-final
  287. * Wed Apr 06 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl4
  288. - added Hotfix_20050405.tar.gz
  289. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl2
  290. - rebuilded with python 2.4.1
  291. * Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl1
  292. - updated zope to 2.7.5-final
  293. * Fri Mar 18 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl0.c1
  294. - updated zope to 2.7.5-rc1
  295. * Sat Jan 15 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl2
  296. - updated zope to 2.7.4-0
  297. * Sat Jan 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.c2
  298. - updated zope to 2.7.4-RC2
  299. * Thu Dec 16 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.b2
  300. - updated zope to 2.7.4-b2
  301. * Sun Oct 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl1
  302. - updated zope to 2.7.3
  303. * Mon Oct 11 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.2
  304. - updated zope to 2.7.3b2
  305. * Sun Sep 26 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.1
  306. - updated zope to 2.7.3b1
  307. - droped Hotfix-20040807.tar.gz
  308. * Tue Aug 10 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl2
  309. - added Hotfix-20040807.tar.gz
  310. * Wed Jul 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl1
  311. - updated zope to 2.7.2
  312. * Thu Jul 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl3
  313. - droped Hotfix_2004-07-13.tar.gz
  314. - added Hotfix_2004-07-14.tar.gz
  315. * Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl2
  316. - added Hotfix_2004-07-13.tar.gz
  317. * Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl1
  318. - updated zope to 2.7.1
  319. - added option with '--no-compile' to configure at the %build section
  320. - added to compile at the %post section
  321. * Sat Apr 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.0-0vl1
  322. - build with python-2.3.3-0vl1
  323. - added 'Obsoletes: Zope27'
  324. * Tue Mar 02 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl3
  325. - changed init.sh to use zopectl
  326. * Tue Feb 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl1
  327. - updated zope to 2.7.0
  328. - rewrited spec file
  329. * Sun Feb 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.4-0vl1
  330. - updated zope to 2.6.4
  331. * Fri Jan 9 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.3-0vl1
  332. - updated zope to 2.6.3
  333. * Wed Sep 10 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2-0vl1
  334. - updated zope to 2.6.2
  335. * Fri Aug 29 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b6-0vl1
  336. - updated zope to 2.6.2b6
  337. * Thu Jul 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl2
  338. - rebuild with python-2.2.3
  339. * Wed Jul 30 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl1
  340. - updated zope to 2.6.2b5
  341. * Sat Jul 19 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b4-0vl1
  342. - updated zope to 2.6.2b4
  343. * Sat Jul 12 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b3-0vl1
  344. - updated zope to 2.6.2b3
  345. * Sat May 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b2-0vl1
  346. - updated zope to 2.6.2b2
  347. - fixed many important bugs
  348. * Sun Apr 13 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1-0vl1
  349. - updated zope to 2.6.1
  350. - changed 'Requires: python >= 2.2.2'
  351. - japanese patch below has been included in zope 2.6.1
  352. * Thu Jan 16 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1b1-0vp1
  353. - updated zope to 2.6.1b1
  354. - added Zope261b.patch (by fukamachi, nakagami, tahara)
  355. - changed option parameter with -Z in startup script
  356. - added command 'umask 077' in startup script
  357. - added option -D in startup script that logout debug infomation
  358. - added 'chown root', 'chmod o+t' script in %%post section
  359. - this is a experimental release!!
  360. * Fri Oct 4 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl3
  361. Security fix for XML-RPC handling (by tahara)
  362. * Fri Jun 21 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl2
  363. added Hotfix_2002-06-14.tgz
  364. * Sat Jun 15 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl1
  365. modified for Vine
  366. * Sat May 18 2002 Adam Manock <abmanock@earthlink.net>
  367. Completely reworked the spec for Zope 2.5.1
  368. PCGI is no longer built by default.
  369. Build now simply wraps up the default "wo_pcgi" build, creating 2 packages.
  370. (This will make it trivial to upgrade the spec for new Zope versions.)
  371. Logging via syslog is now turned off by default. See the RPM-README
  372. * Wed Nov 14 2001 Jeff Rush <jrush@taupro.com>
  373. bumped to zope 2.4.3.
  374. * Sat Nov 10 2001 Jeff Rush <jrush@taupro.com>
  375. changed args to useradd, to work with Red Hat 7.2.
  376. * Sun Oct 21 2001 Jeff Rush <jrush@taupro.com>
  377. bumped to zope 2.4.2, removed Hotfix 2001-09-28.
  378. * Thu Oct 18 2001 Jeff Rush <jrush@taupro.com>
  379. Fixed broken syslogging facility and added Hotfix 2001-09-28.
  380. * Mon Sep 04 2001 Jeff Rush <jrush@taupro.com>
  381. bumped to zope 2.4.1, removed Hotfix 2001-08-04.
  382. * Mon Aug 15 2001 Jeff Rush <jrush@taupro.com>
  383. bumped to zope 2.4.0, changed to use python2.1, added Hotfix 2001-08-04.
  384. Merged in Jun 29 2001 patch from Durval Menezes re support for ZPatterns:
  385. "No longer removes cPersistence.h from lib/python/ZODB before installing
  386. (this is needed to compile DynPersist, as part of the ZPatterns
  387. installation. Installs ExtensionClass.h into /usr/include/python2.1
  388. (it too is needed to compile DynPersist, as part of the ZPatterns install)"
  389. Merged in Jun 12 2001 additions from Jared Kelsey <jared@dolphinsearch.com>
  390. to make more compatible with future releases of python.
  391. * Mon Aug 14 2001 Jeff Rush <jrush@taupro.com>
  392. bumped to zope 2.3.3, added Hotfix 2001-08-04.
  393. * Mon May 07 2001 Jeff Rush <jrush@taupro.com>
  394. bumped to zope 2.3.2, added Hotfix 2001-05-01, revised access
  395. file permissions (600->640) and ownership (root.root->root.zope)
  396. to fix the "can't log in" bug under ZServer subpackage.
  397. * Sat Mar 31 2001 Jeff Rush <jrush@taupro.com>
  398. bumped to zope 2.3.1
  399. * Mon Jan 29 2001 Jeff Rush <jrush@taupro.com>
  400. bumped to zope 2.3.0; removed obsolete Hotfixes.
  401. * Fri Dec 08 2000 Jeff Rush <jrush@taupro.com>
  402. bumped to zope 2.2.4; removed obsolete Hotfixes.
  403. * Fri Nov 03 2000 Jeff Rush <jrush@taupro.com>
  404. fixed misplaced SiteAccess, where dirs in tar moved btw v1 and v2.
  405. * Sun Oct 16 2000 Jeff Rush <jrush@taupro.com>
  406. bumped to zope 2.2.2; added Hotfixes 2000-10-02 and 2000-10-11.
  407. * Sun Aug 27 2000 Jeff Rush <jrush@taupro.com>
  408. bumped to zope 2.2.1; removed no-longer-needed Hotfix_2000-08-17
  409. * Tue Aug 22 2000 Jeff Rush <jrush@taupro.com>
  410. - added Hotfix_2000-08-17
  411. - temporarily removed /etc/init.d (RH7.0) until I figure out how
  412. to support both RH6.x *and* RH7.0 in the same RPM. <sigh>
  413. - removed troublesome/obsolete ComputedAttribute.py
  414. * Sun Jul 16 2000 Jeff Rush <jrush@taupro.com>
  415. - bumped to zope 2.2.0; removed no-longer-needed Hotfix-06_16_2000
  416. * Thu Jul 06 2000 Tim Powers <timp@redhat.com>
  417. - fixed PreReq to PreReq /etc/init.d
  418. - added Hotfix-06_16_2000
  419. * Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
  420. - moved init script, added condrestart directive
  421. - auto stop/restart service on upgrades
  422. * Thu Jun 1 2000 Tim Powers <timp@redhat.com>
  423. - fixed so that it's no longer putting files into /home, instead they are
  424. going into /var/www (FHS compliant).
  425. * Mon May 22 2000 Tim Powers <timp@redhat.com>
  426. - built for 7.0, thanks Jeff!
  427. * Fri Apr 28 2000 Jeff Rush <jrush@taupro.com>
  428. - bumped to zope 2.1.6
  429. * Sun Mar 12 2000 Jeff Rush <jrush@taupro.com>
  430. - added zpasswd.py back in, since my rename to just zpasswd confused some.
  431. both are now present in the RPM, for all audiences.
  432. - modified the README.RPM re the section about Apache rewrite rules; I
  433. discussed and removed the trailing slash, the presence of which causes
  434. Zope to reject attempts to delete objects in the root folder.
  435. * Thu Feb 26 2000 Jeff Rush <jrush@taupro.com>
  436. - 2.1.4-1 Release on Zope.org site
  437. - bumped to zope 2.1.4
  438. - changed Zope-core to provide 'Zope', to satisfy zserver and pcgi subpkgs.
  439. * Fri Jan 14 2000 Tim Powers <timp@redhat.com>
  440. - added Provides lines to Zope-pcgi and Zope-zserver so that addon packages
  441. such as Squishdot have something useful to require.
  442. * Thu Jan 13 2000 Tim Powers <timp@redhat.com>
  443. - built for Powertools 6.2
  444. * Thu Jan 11 2000 Jeff Rush <jrush@taupro.com>
  445. - bumped to zope 2.1.2
  446. - folded in Jonathan Marsden <jonathan@xc.org> Changes (many below)
  447. - used zpasswd.py to generate initial pw in encrypted form.
  448. - fixed syslog logging in various ways, and re-enabled it, for both
  449. - ZServer AND pcgi-wrapper.
  450. - fixed /etc/rc.d/init.d/zope to be consistent about pid file.
  451. - fixed /etc/rc.d/init.d/zope to use RH killproc function.
  452. - added 'noreplace' so that Zope database and access file are retained
  453. - on an RPM upgrade.
  454. - patched PCGI to support syslog logging, and then default to it.
  455. - patched ZServer/Medusa to properly support syslog logging.
  456. - added a user 'zope' and made many zope files/dirs owned by it.
  457. - cleaned up pcgi-wrapper's msg about can't find ZServer, since it is
  458. - one of the most common errors. It now explains what it is doing.
  459. - moved all *.{pid,soc} files into /var/run, to cleanly separate ownership
  460. - issues in /var/zope hierarchy for user 'zope' and user 'nobody'.
  461. * Mon Jan 03 2000 Jeff Rush <jrush@taupro.com>
  462. - bumped to zope 2.1.1
  463. - added to /etc/rc.d/init.d/zope code to correctly kill the process specified
  464. - in /var/zope/pcgi.pid
  465. - changed permissions on /var/zope/access such that only root can read/write
  466. - it, to protect the Zope superuser password.
  467. * Sat Nov 29 1999 Jeff Rush <jrush@taupro.com>
  468. - changed ownership on /var/zope/access from nobody.nobody to root.root.
  469. * Sat Nov 20 1999 Jeff Rush <jrush@taupro.com>
  470. - updated to zope 2.1.0beta2
  471. - fixed permissions/ownership on /var/zope/access to be more secure (600).
  472. - removed pypath.patch, as those changes got into the zope distribution.
  473. * Tue Nov 2 1999 Jeff Rush <jrush@taupro.com>
  474. - added accidentally omitted /usr/bin/zpasswd to the RPM output.
  475. - clarified wording re use of zpasswd in README.RPM file.
  476. - added "-u nobody" to both zserver_*.sh files, for clarity of intent;
  477. - it already ran as nobody by default, but some people worried.
  478. * Wed Oct 27 1999 Jeff Rush <jrush@taupro.com>
  479. - fixed /etc/rc.d/init.d/zope file to *NOT* delete /var/zope/zserver.pid
  480. - fixed /var/zope/Zope.cgi to use PCGI_PUBLISHER=/var/zope/pcgi_nullpublisher.py,
  481. - so that when the PCGI wrapper can't find ZServer, it won't try to start one
  482. - and generate bogus error messages, because PCGI doesn't do it right.
  483. - fixed /var/zope/zserver.sh to NOT specify syslog-style logging, since under
  484. - Red Hat 6.1, the syslog daemon no longer listens to the port we expected.
  485. * Sat Sep 25 1999 Jeff Rush <jrush@taupro.com>
  486. - updated documents ZCMG, ZSQL and ZDTML to Sep 24th 1999 versions
  487. - added empty directories /var/zope/{import,Extensions}
  488. - relocated zope from /usr/lib/python1.5/site-packages/ZopeWorld/
  489. - to /usr/share/zope/
  490. - added user zope, for better security control
  491. * Fri Sep 17 1999 Jeff Rush <jrush@taupro.com>
  492. - updated sources to minor (security fix) release 2.0.1
  493. * Fri Sep 10 1999 Jeff Rush <jrush@taupro.com>
  494. - heavily reworked spec file for 2.0.0
  495. * Thu Sep 9 1999 Tim Powers <timp@redhat.com>
  496. - updated sources to 2.0.0
  497. - _major_ spec file cleanups
  498. - merged patch from src.rpm authored by Andreas Kostyrka <andreas@mtg.co.at>
  499. - borrowed some things from Andreas Kostyrka's spec file
  500. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  501. - changed groups
  502. * Tue Aug 17 1999 Tim Powers <timp@redhat.com>
  503. - chown permissions on some files in /var/local for the pcgi package
  504. * Mon Aug 2 1999 Tim Powers <timp@redhat.com>
  505. - changed buildroot to be in /var/tmp instead of /tmp
  506. - rebuilt for 6.1
  507. * Mon Jul 21 1999 Jeff Rush <jrush@taupro.com>
  508. - Added in accidently omitted SearchIndex/{Query,Splitter}.so
  509. * Tue Jul 6 1999 Tim Powers <timp@redhat.com>
  510. - started changelog
  511. - cleaned up spec file
  512. - built for powertools
  513. * Mon Jun 24 1999 Jeff Rush <jrush@taupro.com>
  514. - Updated to 1.10.3
  515. * Mon Jun 23 1999 Jeff Rush <jrush@taupro.com>
  516. - Added /etc/rc.d/init.d/zope and reworked scripts
  517. * Tue Mar 1 1999 Jeff Rush <jrush@taupro.com>
  518. - Updated to 1.10.2
  519. * Wed Jan 29 1999 Jeff Rush <jrush@taupro.com>
  520. - Updated to 1.9.0 Final Release
  521. * Wed Dec 9 1998 Jeff Rush <jrush@taupro.com>
  522. - Original 1.9beta1 Release