subversion-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595
  1. %define neon_version 0.30.2
  2. %define swig_version 3.0.0
  3. %define apache_version 2.4
  4. %define apache_dir /usr
  5. %define swigdirs swig_pydir=%{python3_sitearch}/libsvn swig_pydir_extra=%{python3_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.13.0
  12. Release: 1%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: https://subversion.apache.org/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: iwaim, daisuke
  19. SOURCE0: http://ftp.jaist.ac.jp/pub/apache/subversion/subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch1: subversion-1.12.0-linking.patch
  24. Patch2: subversion-1.12.2-py3tests.patch
  25. Patch4: subversion-1.8.0-rubybind.patch
  26. Patch5: subversion-1.8.5-swigplWall.patch
  27. BuildRequires: apache2-devel >= %{apache_version}
  28. BuildRequires: apr-devel, apr-util-devel
  29. BuildRequires: autoconf >= 2.53
  30. BuildRequires: libdb-devel
  31. BuildRequires: expat-devel
  32. BuildRequires: gdbm-devel
  33. BuildRequires: libtool >= 1.4.2
  34. BuildRequires: neon-devel >= %{neon_version}
  35. BuildRequires: openssl-devel
  36. BuildRequires: swig >= %{swig_version}
  37. BuildRequires: texinfo
  38. BuildRequires: zlib-devel
  39. BuildRequires: lz4-devel
  40. BuildRequires: utf8proc-devel
  41. BuildRequires: openldap-devel
  42. BuildRequires: ruby >= 2.2.3
  43. BuildRequires: ruby-devel >= 2.2.3
  44. BuildRequires: perl >= 2:5.26.2
  45. BuildRequires: sqlite3-devel
  46. BuildRequires: krb5-devel
  47. BuildRequires: keyutils-libs-devel
  48. BuildRequires: dbus-devel
  49. BuildRequires: libsecret-devel
  50. BuildRequires: libserf-devel
  51. BuildRequires: libxcrypt-devel
  52. BuildRequires: libnsl2-devel
  53. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  54. %define __perllib_requires %{SOURCE3}
  55. %description
  56. Subversion is a concurrent version control system which enables one
  57. or more users to collaborate in developing and maintaining a
  58. hierarchy of files and directories while keeping a history of all
  59. changes. Subversion only stores the differences between versions,
  60. instead of every complete file. Subversion is intended to be a
  61. compelling replacement for CVS.
  62. %package devel
  63. Group: Development/Libraries
  64. Summary: Development package for Subversion developers.
  65. Requires: subversion = %{version}-%{release}
  66. Requires: apr-devel, apr-util-devel
  67. %description devel
  68. The subversion-devel package includes the static libraries and include files
  69. for developers interacting with the subversion package.
  70. %package mod_dav_svn
  71. Group: System Environment/Daemons
  72. Summary: Apache server module for Subversion server.
  73. Requires: apache2 >= %{apache_version}
  74. Requires: subversion = %{version}-%{release}
  75. %description mod_dav_svn
  76. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  77. the Apache directories and configuration.
  78. %package tools
  79. Group: Development/Tools
  80. Summary: Tools for Subversion
  81. BuildRequires: perl >= 5.8.0
  82. Requires: perl >= 5.8.0
  83. Requires: subversion = %{version}-%{release}
  84. %description tools
  85. Tools for Subversion.
  86. %package perl
  87. Group: Development/Libraries
  88. Summary: Perl bindings to the Subversion libraries
  89. Requires: subversion = %{version}-%{release}
  90. Requires: perl >= 5.8.0
  91. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  92. %description perl
  93. This package includes the Perl bindings to the Subversion libraries.
  94. %package ruby
  95. Group: Development/Libraries
  96. Summary: Ruby bindings to the Subversion libraries
  97. Requires: subversion = %{version}-%{release}
  98. Requires: ruby >= 2.0
  99. %description ruby
  100. This package includes the Ruby bindings to the Subversion libraries.
  101. %package -n python3-subversion
  102. Group: Development/Libraries
  103. Summary: Python bindings to the Subversion libraries
  104. BuildRequires: python3
  105. BuildRequires: python3-devel
  106. BuildRequires: python3-rpm-macros
  107. Requires: subversion = %{version}-%{release}, python3
  108. %description -n python3-subversion
  109. This package includes the Python bindings to the Subversion libraries.
  110. %prep
  111. %setup -q
  112. %patch1 -p1 -b .link
  113. %patch2 -p1 -b .python3
  114. %patch4 -p1 -b .rubybind
  115. %patch5 -p1 -b .swigplWall
  116. %build
  117. export LANG=ja_JP.UTF-8
  118. # Regenerate the buildsystem, so that:
  119. # 1) patches applied to configure.in take effect
  120. # 2) the swig bindings are regenerated using the system swig
  121. # (2) is not ideal since typically upstream test with a different
  122. # swig version
  123. # This PATH order makes the fugly test for libtoolize work...
  124. mv build-outputs.mk build-outputs.mk.old
  125. export PYTHON=%{__python3}
  126. PATH=/usr/bin:$PATH ./autogen.sh --release
  127. # fix shebang lines, #111498
  128. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  129. # fix python executable
  130. perl -pi -e 's|/usr/bin/env python.*|%{svn_python}|' subversion/tests/cmdline/svneditor.py
  131. # override weird -shrext from ruby
  132. export svn_cv_ruby_link="%{__cc} -shared"
  133. export svn_cv_ruby_sitedir_libsuffix=""
  134. export svn_cv_ruby_sitedir_archsuffix=""
  135. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  136. export LIBTOOL=/usr/bin/libtool
  137. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  138. --with-swig --with-serf=%{_prefix} \
  139. --with-ruby-sitedir=%{rarchdir} \
  140. --with-apxs=%{_bindir}/apxs \
  141. --disable-mod-activation \
  142. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  143. --with-gnome-keyring \
  144. --with-berkeley-db \
  145. --disable-mod-activation \
  146. --disable-static
  147. make %{?_smp_mflags} all tools
  148. make swig-py swig-py-lib %{swigdirs}
  149. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  150. %install
  151. echo %{rarchdir}
  152. rm -rf $RPM_BUILD_ROOT
  153. make install \
  154. install-swig-py \
  155. install-swig-pl-lib \
  156. install-swig-rb \
  157. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  158. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  159. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  160. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  161. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  162. # Add subversion.conf configuration file into apache2/conf.d directory.
  163. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  164. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  165. # Remove unpackaged files
  166. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  167. $RPM_BUILD_ROOT%{python3_sitearch}/*/*.{a,la} \
  168. $RPM_BUILD_ROOT%{_libdir}/*.la
  169. # The SVN build system is broken w.r.t. DSO support; it treats
  170. # normal libraries as DSOs and puts them in $libdir, whereas they
  171. # should go in some subdir somewhere, and be linked using -module,
  172. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  173. # since nothing should ever link against them directly.
  174. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  175. # remove stuff produced with Perl modules
  176. find $RPM_BUILD_ROOT -type f \
  177. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  178. -print0 | xargs -0 rm -f
  179. # make Perl modules writable so they get stripped
  180. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  181. xargs -0 chmod 755
  182. # unnecessary libraries for swig bindings
  183. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  184. # Remove unnecessary ruby libraries
  185. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  186. # Trim what goes in docdir
  187. rm -rf tools/*/*.in tools/test-scripts
  188. # Rename authz_svn INSTALL doc for docdir
  189. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  190. # Install bash completion
  191. install -Dpm 644 tools/client-side/bash_completion \
  192. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  193. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  194. ln -s svn \
  195. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  196. done
  197. # Install tools ex diff*
  198. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  199. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  200. for f in svn-populate-node-origins-index \
  201. svnauthz-validate svnmucc svnraisetreeconflict; do
  202. echo %{_bindir}/$f
  203. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  204. %find_lang %{name}
  205. cat %{name}.lang exclude.tools.files >> %{name}.files
  206. %clean
  207. rm -rf $RPM_BUILD_ROOT
  208. %post -p /sbin/ldconfig
  209. %postun -p /sbin/ldconfig
  210. %post perl -p /sbin/ldconfig
  211. %postun perl -p /sbin/ldconfig
  212. %post ruby -p /sbin/ldconfig
  213. %postun ruby -p /sbin/ldconfig
  214. %post -n python3-subversion -p /sbin/ldconfig
  215. %postun -n python3-subversion -p /sbin/ldconfig
  216. %post tools -p /sbin/ldconfig
  217. %postun tools -p /sbin/ldconfig
  218. %files
  219. %defattr(-,root,root)
  220. %license LICENSE
  221. %doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
  222. %{_bindir}/*
  223. %{_libdir}/libsvn_*.so.*
  224. %{_localedir}/*/*/subversion.mo
  225. %{_mandir}/man*/*
  226. %{_datadir}/bash-completion/completions/*
  227. %dir %{_sysconfdir}/subversion
  228. %exclude %{_mandir}/man*/*::*
  229. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  230. %exclude %{_libdir}/libsvn_swig_py*.so.*
  231. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  232. %files devel
  233. %defattr(-,root,root)
  234. %{_includedir}/subversion-1
  235. %{_libdir}/libsvn*.so
  236. %exclude %{_libdir}/libsvn_swig_perl*
  237. %exclude %{_libdir}/libsvn_swig_py*
  238. %exclude %{_libdir}/libsvn_swig_ruby*
  239. %{_datadir}/pkgconfig/*
  240. %files mod_dav_svn
  241. %defattr(-,root,root)
  242. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  243. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  244. %files tools -f tools.files
  245. %defattr(-,root,root)
  246. %files perl
  247. %defattr(-,root,root,-)
  248. %{perl_vendorarch}/auto/SVN
  249. %{perl_vendorarch}/SVN
  250. %{_libdir}/libsvn_swig_perl*
  251. %{_mandir}/man*/*::*
  252. %files ruby
  253. %defattr(-,root,root,-)
  254. %{_libdir}/libsvn_swig_ruby*
  255. %{rarchdir}/svn
  256. %files -n python3-subversion
  257. %defattr(-,root,root,-)
  258. %{_libdir}/libsvn_swig_py*
  259. %{python3_sitearch}/*
  260. %changelog
  261. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
  262. - new upstream release.
  263. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.2-1
  264. - new upstream release.
  265. - dropped Patch1 and 2.
  266. - imported Patch1 and 2 from rawhide.
  267. - switched to python3.
  268. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  269. - new upstream release.
  270. - rebuilt with perl-5.26.
  271. - dropped BR:libgnome-keyring-devel.
  272. - added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
  273. * Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
  274. - update to 1.8.17
  275. * Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
  276. - rebuild with ruby-2.2.3
  277. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  278. - build with Perl 5.16
  279. - using %%__perllib_requires
  280. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  281. - rebuild with ruby-2.1.2-6
  282. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  283. - update to 1.8.9
  284. - remove unneeded explisit dependency
  285. - add BR: apache2-devel >= 2.4
  286. - add BR: libdb-devel instead of db4-devel
  287. - add R: apache2 > 2.4 to mod_dav_svn
  288. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  289. - update to 1.8.8
  290. - add BR: libserf-devel to handle http* scheme
  291. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  292. - update to 1.7.7
  293. - rebuild with ruby-1.9.3
  294. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  295. - new upstream release
  296. - update License
  297. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  298. - drop deplibs patch (Patch1)
  299. - drop obsolete patch files: Patch6, 10
  300. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  301. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  302. - add configure option with-gnome-keyring
  303. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  304. - fix Packager name
  305. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  306. - build with perl 5.12.3
  307. - add Requires: perl(:MODULE_COMPAT_...)
  308. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  309. - new upstream release with security fix
  310. - add Vendor/Distri tags
  311. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  312. - new upstream release
  313. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  314. - fix <BTS:VineLinux:941>
  315. - using rpm macro: rarchdir
  316. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  317. - using rpm macros: perl_vendorarch and python_sitearch
  318. - add BuildRequires: sqlite3-devel krb5-devel
  319. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  320. - new upstream release
  321. - update URL
  322. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  323. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  324. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  325. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  326. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  327. - new upstream release
  328. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  329. - new upstream release
  330. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  331. - rebuilt with python-2.5.2
  332. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  333. - new upstream release
  334. - rebuild with neon-0.28.2
  335. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  336. - added Patch6, 8, 9, 10 from Fedora Core
  337. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  338. - Correct install location of java stuff (#433295)
  339. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  340. - fix build with new glibc open()-as-macro
  341. - build all swig code in %%build, not %%install
  342. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  343. - build /usr/bin/* as PIEs
  344. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  345. - rebuild with expat-2.0.1
  346. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  347. - new upstream release
  348. - add Patch10 to build with neon.
  349. 1.3.2-0vl5 does not support neon..
  350. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  351. - rebuild with new neon
  352. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  353. - rebuilt with new toolchain and db4-4.3.x
  354. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  355. - modified %%files section for lib64 architecture
  356. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  357. - new upstream release
  358. - rebuild with new openldap-2.3.24
  359. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  360. - new upstream release
  361. - change Group to Develoment/Tools
  362. - build with apr-1.2.7/apr-util-1.2.7
  363. - require apr/apr-util instead of apache2-apr
  364. - build with swig-1.3.29
  365. - split {perl,python,ruby} related files to subpackage.
  366. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  367. - new upstream release
  368. - add noreplace option for config file
  369. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  370. - fix Requires and BuildPreReq.
  371. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  372. - new upstream release.
  373. - add swig-runtime to 'BuildPreReq:'.
  374. - fix %%files.
  375. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  376. - require neon version 0.24.7 for ra_dav
  377. - add BuildPreReq: openldap-devel
  378. - replace BuildPreReq: httpd to BuildPreReq: apache2
  379. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  380. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  381. - new upstream release
  382. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  383. - new upstream release
  384. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  385. - new upstream release
  386. - clean up specfile.
  387. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  388. - new upstream release
  389. - build with apache2-2.0.47
  390. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  391. - build Vine Linux
  392. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  393. - Enabled RA_DAV checking.
  394. Now requires httpd package to build because of RA_DAV tests.
  395. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  396. - Created tools package to hold the tools.
  397. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  398. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  399. version of APR/APR-UTILS as of 2003.01.15.
  400. - Added svnversion command.
  401. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  402. - Create a svnadmin.static which is copied to svnadmin-version-release
  403. when the package is erased, so users can still dump/load their repositories
  404. even after they have upgraded the RPM package.
  405. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  406. - SWIG now builds so we can use cvs2svn.
  407. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  408. - Made cvs2svn conditional (at least until we can get it to build consistently
  409. and work).
  410. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  411. - Added SWIG dependencies to add cvs2svn capabilities.
  412. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  413. - Now requires neon-0.22.0.
  414. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  415. - Took out loading mod_dav_svn from subversion.spec file and put it in
  416. subversion.conf file which goes into the apache conf directory.
  417. - Simplify what gets put into httpd.conf to only the include for the
  418. subversion.conf file.
  419. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  420. me to do this).
  421. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  422. - Updated to APR/APR-UTIL 2002-08-08.
  423. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  424. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  425. - Previous version had a few problems because of missing apache error/ files.
  426. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  427. - Updated to apache-2.0.40-0.3.
  428. - Updated to subversion-0.13.1-2318.
  429. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  430. - Updated for RedHat 7.3 (autoconf253).
  431. - Added a bunch of pre-requisites I didn't know were needed because I built a
  432. new machine that didn't have them already installed.
  433. - Fixed installation of man and info documentation pages.
  434. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  435. - Back to apache-libapr* stuff, hopefully to stay.
  436. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  437. - Fixed expat.patch to not have to make so many changes by writing a small
  438. shell script that changes libexpat to -lexpat.
  439. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  440. - Updated to neon-0.19.2.
  441. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  442. - Back to using apr and apr-util separately from apache.
  443. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  444. - Updated to APR and APR-UTIL 2002.02.11.
  445. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  446. - Took out a (now non-existant) documentation file.
  447. - Moved SPEC file changelog to after all package definitions.
  448. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  449. - Updated to neon-0.18.5.
  450. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  451. apache-apr-utils, and apache-apr-utils-devel.
  452. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  453. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  454. - Now builds without the separate APR package as it is built into and
  455. "exported" from apache-2.0.31-0.3.
  456. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  457. - Took out patches to install procedure now not required because of fixes
  458. in rev 1130.
  459. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  460. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  461. program was added.
  462. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  463. - Release M5-r340: Added the subversion-server package.
  464. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  465. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  466. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  467. - Release M3-r117: Initial Version.