xorg-x11-xsm-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. %define pkgname xsm
  2. Summary: X.Org X11 X Session Manager
  3. Summary(ja): X.Org X11 X セッションマネージャ
  4. Name: xorg-x11-%{pkgname}
  5. # NOTE: The Version field should be the version of the xsm tarball.
  6. Version: 1.0.3
  7. # Bump the release on rebuilds/bugfixes/etc.
  8. Release: 3%{?_dist_release}
  9. License: MIT
  10. Group: User Interface/X
  11. URL: http://www.x.org
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.3.tar.bz2
  14. Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.6.tar.bz2
  15. Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
  16. # Patches for xsm (10-19)
  17. # Patches for smproxy (20-29)
  18. # Patches for rstart (30-39)
  19. Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
  20. # FIXME: Temporary dependency on automake/autoconf while they're still needed.
  21. BuildRequires: automake autoconf
  22. BuildRequires: pkgconfig
  23. BuildRequires: xorg-x11-util-macros
  24. BuildRequires: xorg-x11-proto-devel
  25. BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
  26. BuildRequires: rsh
  27. # NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
  28. # monolithic X releases to modular X releases to work properly.
  29. Requires(pre): xorg-x11-filesystem
  30. # rstart script invokes xauth, rsh
  31. Requires: xauth, rsh
  32. Provides: xsm, smproxy, rstart, rstartd
  33. # NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
  34. Obsoletes: XFree86
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: Takemikaduchi
  38. %description
  39. X.Org X11 X Session Manager
  40. %prep
  41. %setup -q -c %{name}-%{version} -a1 -a2
  42. %patch30 -p0 -b .rstart-installation-location-fixes
  43. %build
  44. # Build everything
  45. {
  46. for pkg in xsm smproxy rstart ; do
  47. pushd $pkg-*
  48. sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
  49. autoreconf -if
  50. %configure --disable-xprint
  51. make
  52. popd
  53. done
  54. }
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. # Install everything
  58. {
  59. for pkg in xsm smproxy rstart ; do
  60. pushd $pkg-*
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. popd
  63. done
  64. }
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %files
  68. %defattr(-,root,root,-)
  69. # FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
  70. # can't use the %%version macro here until a upstream xsm is released as
  71. # version 1.0.2 or higher.
  72. #%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
  73. #%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
  74. %doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
  75. %doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
  76. %{_bindir}/rstart
  77. %{_bindir}/rstartd
  78. %{_bindir}/smproxy
  79. %{_bindir}/xsm
  80. %dir %{_datadir}/X11
  81. %dir %{_datadir}/X11/rstart
  82. %dir %{_datadir}/X11/rstart/commands
  83. %{_datadir}/X11/rstart/commands/@List
  84. %{_datadir}/X11/rstart/commands/ListContexts
  85. %{_datadir}/X11/rstart/commands/ListGenericCommands
  86. %dir %{_datadir}/X11/rstart/commands/x11r6
  87. %{_datadir}/X11/rstart/commands/x11r6/@List
  88. %{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
  89. %{_datadir}/X11/rstart/commands/x11r6/Terminal
  90. %dir %{_datadir}/X11/rstart/contexts
  91. %{_datadir}/X11/rstart/contexts/@List
  92. %{_datadir}/X11/rstart/contexts/default
  93. %{_datadir}/X11/rstart/contexts/x
  94. %{_datadir}/X11/rstart/contexts/x11
  95. %{_datadir}/X11/rstart/contexts/x11r6
  96. %{_datadir}/X11/app-defaults/XSm
  97. %dir %{_libdir}/X11
  98. %dir %{_libdir}/X11/rstart
  99. # NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
  100. %{_libdir}/X11/rstart/rstartd.real
  101. #%dir %{_mandir}/man1x
  102. %{_mandir}/man1/rstart.1*
  103. %{_mandir}/man1/rstartd.1*
  104. %{_mandir}/man1/smproxy.1*
  105. %{_mandir}/man1/xsm.1*
  106. %dir %{_sysconfdir}/X11
  107. %dir %{_sysconfdir}/X11/rstart
  108. %config %{_sysconfdir}/X11/rstart/config
  109. %dir %{_sysconfdir}/X11/xsm
  110. %config %{_sysconfdir}/X11/xsm/system.xsm
  111. %changelog
  112. * Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
  113. - smproxy-1.0.6
  114. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
  115. - rebuild with VineSeed environment
  116. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  117. - update to 1.0.3
  118. - remove Patch10 (xsm-1.0.2-xsm-installation-location-fixes.patch)
  119. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-5
  120. - smproxy-1.0.5
  121. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
  122. - delete Obsoletes: xorg-x11
  123. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
  124. - xsm-1.0.2
  125. - smproxy-1.0.4
  126. - rstart-1.0.4
  127. - update Patch10, Patch30
  128. - fix %%files
  129. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  130. - smproxy-1.0.3
  131. - rstart-1.0.3
  132. * Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  133. - initial build for Vine Linux
  134. * Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
  135. - Fix license tag.
  136. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
  137. - Autorebuild for GCC 4.3
  138. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
  139. - Rebuild for build id
  140. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
  141. - Fix man page globs and rebuild for FC7.
  142. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
  143. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  144. - Add 'dist' tag to package release string.
  145. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
  146. - rebuild
  147. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  148. - Added xsm documentation to doc macro.
  149. - The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
  150. an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
  151. in a few places temporarily until xsm-1.0.2 is available.
  152. * Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
  153. - Fix BuildRequires (#191802)
  154. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  155. - Update smproxy and rstart
  156. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  157. - bump again for double-long bug on ppc(64)
  158. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  159. - rebuilt for new gcc4.1 snapshot and glibc changes
  160. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  161. - Updated all apps to version 1.0.1 from X11R7.0
  162. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  163. - Updated all apps to version 1.0.0 from X11R7 RC4.
  164. - Changed manpage dir from man1x to man1 to match upstream default.
  165. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
  166. - Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
  167. - Added rstart-0.99.1-rstart-installation-location-fixes.patch and
  168. xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
  169. /etc and data files in /usr/share where they belong.
  170. - Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
  171. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  172. - require newer filesystem package (#172610)
  173. * Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
  174. - Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
  175. - Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
  176. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  177. - Initial build of xsm, smproxy, and rstart from X11R7 RC1