xorg-x11-drv-intel-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. #%define gputoolsdate 20130611
  8. %define gputoolsdate 1.12
  9. %else
  10. %define accel sna
  11. %define gputoolsdate 20110817
  12. %endif
  13. Summary: Xorg X11 Intel video driver
  14. Summary(ja): Xorg X11 Intel ビデオドライバ
  15. Name: xorg-x11-drv-intel
  16. Epoch: 1
  17. Version: 2.99.917
  18. Release: 2%{?_dist_release}
  19. URL: http://intellinuxgraphics.org/
  20. License: MIT
  21. Group: User Interface/X Hardware Support
  22. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  23. Source2: intel.xinf
  24. #Source3: intel-gpu-tools-%{gputoolsdate1}.tar.bz2
  25. Source3: intel-gpu-tools-1.12.tar.bz2
  26. # vine patch
  27. Patch0: xf86-video-intel-2.99.917-git20151019.patch
  28. ExclusiveArch: %{ix86} x86_64 ia64
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  30. BuildRequires: autoconf, automake, libtool
  31. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  32. BuildRequires: libXvMC-devel
  33. BuildRequires: libGL-devel >= 7.10
  34. BuildRequires: libdrm-devel >= 2.4.25
  35. BuildRequires: kernel-headers >= 2.6.33
  36. BuildRequires: eudev-libudev-devel
  37. BuildRequires: libxcb-devel >= 1.5
  38. BuildRequires: xcb-util-devel
  39. BuildRequires: cairo-devel
  40. Requires: hwdata
  41. Requires: xorg-x11-server-Xorg
  42. Requires: xcb-util
  43. Obsoletes: xorg-x11-drv-i810
  44. Provides: xorg-x11-drv-i810
  45. #Conflicts: kudzu < 1.2.42-1
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: daisuke
  49. %description
  50. X.Org X11 Intel video driver.
  51. %package devel
  52. Summary: Xorg X11 Intel video driver XvMC development package
  53. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  54. Group: Development/System
  55. Requires: %{name} = %{epoch}:%{version}-%{release}
  56. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  57. %description devel
  58. X.Org X11 Intel video driver XvMC development package.
  59. %package -n intel-gpu-tools
  60. Summary: Debugging tools for Intel graphics chips
  61. Group: Development/Tools
  62. %description -n intel-gpu-tools
  63. Debugging tools for Intel graphics chips
  64. %prep
  65. %setup -q -n xf86-video-intel-%{version} -b3
  66. %patch0 -p1
  67. %build
  68. autoreconf -vi
  69. %if "%{?_dist_release}" < "vl7"
  70. export CFLAGS="-I/usr/include/X11/dri"
  71. %endif
  72. %configure \
  73. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  74. --enable-dri --enable-xvmc \
  75. --enable-sna --enable-uxa \
  76. --with-default-accel=%{accel} \
  77. --enable-xaa=no
  78. make
  79. pushd ../intel-gpu-tools-%{gputoolsdate}
  80. autoreconf -v --install
  81. %configure --disable-nouveau --disable-dumper --without-libunwind
  82. make
  83. popd
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  88. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  89. pushd ../intel-gpu-tools-%{gputoolsdate}
  90. make install DESTDIR=$RPM_BUILD_ROOT
  91. popd
  92. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
  93. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %triggerpostun -- XOrg < 7.0
  97. if (grep -q i810 /etc/X11/xorg.conf)
  98. then
  99. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  100. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  101. fi ||:
  102. %files
  103. %defattr(-,root,root,-)
  104. %{driverdir}/intel_drv.so
  105. %{_datadir}/hwdata/videoaliases/intel.xinf
  106. %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
  107. %{_libdir}/libI810XvMC.so.*
  108. %{_libdir}/libIntelXvMC.so.*
  109. %{_libexecdir}/xf86-video-intel-backlight-helper
  110. %{_mandir}/man4/i*
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_libdir}/libI810XvMC.so
  114. %{_libdir}/libIntelXvMC.so
  115. %files -n intel-gpu-tools
  116. %defattr(-,root,root,-)
  117. %{_bindir}/*
  118. %{_libdir}/intel_aubdump.so
  119. %{_libexecdir}/intel-gpu-tools/
  120. %{_datadir}/intel-gpu-tools/
  121. %{_mandir}/man1/intel_*.1*
  122. %changelog
  123. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
  124. - update Source3 (intel-gpu-tools-1.12.tar.bz2)
  125. - update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
  126. - remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
  127. - Source4 (intel-gpu-tools-20110817.tar.bz2)
  128. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
  129. - update to 2.99.917
  130. - update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
  131. - update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
  132. - update Source3 (intel-gpu-tools-1.10.tar.bz2)
  133. * Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
  134. - add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
  135. - update Source3 (intel-gpu-tools-1.8.tar.bz2)
  136. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
  137. - update to 2.99.916
  138. * Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
  139. - update to 2.99.912
  140. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
  141. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  142. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  143. - rebuild with VineSeed environment
  144. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  145. - new upstream release
  146. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  147. - new upstream release
  148. - change default accel method to sna.
  149. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  150. - new upstream release
  151. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  152. - new upstream release
  153. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  154. - new upstream release
  155. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  156. - new upstream release
  157. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  158. - new upstream release
  159. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  160. - new upstream release
  161. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  162. - new upstream release
  163. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  164. - new upstream release
  165. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  166. - new upstream release
  167. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  168. - new upstream release
  169. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  170. - rebuild with xcb-util-0.3.9
  171. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  172. - disable sna, enable uxa
  173. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  174. - new upstream release
  175. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  176. - rebuild with xserver-1.12.0
  177. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  178. - new upstream release
  179. - enable sna
  180. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  181. - disable sna/vmap
  182. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  183. - new upstram release
  184. - disable copy-fb patch
  185. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  186. - rebuild with xserver-1.11.1.902
  187. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  188. - add --enable-sna --enable-vmap
  189. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  190. - new upstream release
  191. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  192. - rebuild with xcb-util-0.3.8
  193. - drop Patch200
  194. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  195. - update to disable copy_fb on sandybridge/ivybridge
  196. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  197. - update intel.xinf
  198. - add patch10 from fedora
  199. - Clamp VGA pixel clock to 250MHz,
  200. anything higher's going to look awful anyway. (#559426)
  201. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  202. - drop patch1-3 and replaced with new patch1 from git master
  203. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  204. - update intel-gpu-tools
  205. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  206. - add Patch1-3 from upstream
  207. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  208. - new upstream release
  209. - drop upstream patches: 107-115
  210. - temporary disabled patch101
  211. - BR: libdrm >= 2.4.25
  212. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  213. - add Patch101-115 from ubuntu/debian package
  214. - Patch101: Plymouth integration patch
  215. - Patch107: Check null return from uxa_acquire_solid()
  216. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  217. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  218. - Patch110,114: Cherry picks to fix a large number of build warnings.
  219. - Patch111: Fix clipped window plane offset
  220. - Patch112: Fix issue where vertical green line and strange colors
  221. shows up when playing gstreamer with certain videos,
  222. when dragged. (LP 460677)
  223. - Patch113: Fixes GPU lockup during login with
  224. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  225. error messages listed in the gpu dump text. (LP 710321)
  226. - Patch115: Don't fill up Xorg.0.log with
  227. "get vblank counter failed: Invalid argument" warnings.
  228. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  229. - rebuild with xserver-1.10.0
  230. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  231. - new upstream release
  232. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  233. - new upstream release
  234. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  235. - rebuild with xserver-1.9.2
  236. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  237. - new upstream release
  238. - add Patch40: fix uxa planemask (backported)
  239. - add Patch61: add support for backlight on macbooks
  240. - add Patch62: disable page flipping for stability
  241. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  242. - new upstream release
  243. - drop patch70
  244. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  245. - rebuild again with xserver-1.8rc
  246. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  247. - add intel-gpu-tools as sub-package
  248. - rebuild with libdrm-2.4.18
  249. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  250. - new upstream release
  251. - import Patch1,2,60,70 from fedora
  252. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  253. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  254. - add BR; libudev-devel and autoreconf for Patch60
  255. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  256. - rebuild with libdrm-2.4.17
  257. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  258. - new upstream release
  259. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  260. - new upstream release (hopefully fixes severe issues w/ efifb)
  261. - drop all patches already upstreamed; import Patch20/21 from Fedora
  262. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  263. - import Patch121,122 from ubuntu
  264. - build with libdrm-2.4.12 which fixes vt switch crash
  265. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  266. - apply patch114 to fix Xv with non-GEM kernel
  267. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  268. - update to 2.6.3
  269. - add patch106,107,115,118,119,120 from ubuntu
  270. - add Patch106: remove triple buffering
  271. - add Patch107: remove page flipping
  272. - add Patch115: fix crash Xv overlay
  273. - add Patch118: drop legacy3d
  274. - add Patch119: fix crashes in drm bo
  275. - add Patch120: fix vt switch
  276. - add patch130-134 from upstream git
  277. - add Patch130: fix another vt switch leak
  278. - add Patch131: Create known output configuration at EnterVT time
  279. - add Patch132: fix leak of some 965 render state on VT switch
  280. - add Patch133: fix crash with fake bufmgr and UXA
  281. - add Patch134: fix EnterVT/LeaveVT
  282. - add Patch135: add new chip supoprt
  283. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  284. - revert to 2.6.1, add Epoch
  285. - add Patch103-121 from ubuntu
  286. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  287. - new upstream release
  288. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  289. - new upstream release
  290. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  291. - new upstream release
  292. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  293. - add Patch5 - Dont die on irq handler failure
  294. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  295. - new upstream release
  296. - add BR: libdrm-devel >= 2.4.0-3
  297. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  298. - import Patch10,11,12 from ubuntu
  299. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  300. - new upstream release
  301. - add triggerpostun script to replace i810 driver to intel driver
  302. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  303. - new upstream release
  304. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  305. - new upstream release
  306. - rename i810.xinf to intel.xinf
  307. - update intel.xinf (add Intel 4 series)
  308. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  309. - rebuild with new xserver
  310. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  311. - new upstream release
  312. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  313. - new upstream release
  314. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  315. - new upstream release
  316. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  317. - initial build for Vine Linux
  318. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  319. - Rebuild for new server ABI.
  320. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  321. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  322. - hook up ch7017 (bz#408471)
  323. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  324. - xf86-video-intel 2.2.0
  325. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  326. - xf86-video-intel 2.1.99.
  327. - Drop the i810 driver. Time to move on.
  328. - Require xserver 1.4.99.1
  329. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  330. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  331. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  332. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  333. for textured Xv to use as an offscreen pixmap so xv actually works under
  334. compiz - granted it may be unusably slow but at least stuff shows up.
  335. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  336. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  337. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  338. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  339. - intel-2.1.1-quirk-update.patch - update quirks from master
  340. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  341. - i810.xinf: Flip everything over to -intel by default now. Still install
  342. i810 driver just in case.
  343. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  344. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  345. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  346. - xf86-video-intel 2.1.1.
  347. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  348. - xf86-video-intel 2.1.0.
  349. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  350. - Update Requires and BuildRequires.
  351. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  352. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  353. 965GME, G33, Q33, and Q35 chips.
  354. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  355. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  356. DRI clients are active, for better battery life.
  357. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  358. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  359. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  360. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  361. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  362. rename this at some point.
  363. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  364. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  365. 915GM.
  366. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  367. - i810.xinf: More intel whitelisting (#214011, #234877)
  368. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  369. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  370. - i810.xinf: Point 965GM support at the intel driver since it's not present
  371. in old i810.
  372. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  373. - xf86-video-intel-1.9.93 (RC3).
  374. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  375. - fix typo with 945GM pci id from my laptop
  376. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  377. - xf86-video-intel 1.9.92 (RC2).
  378. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  379. - Updated modesetting driver to one that will actually work with a 1.3 server.
  380. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  381. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  382. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  383. code anywhere
  384. - Disown the module
  385. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  386. - update modesetting driver to git snapshot from today
  387. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  388. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  389. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  390. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  391. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  392. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  393. actually require kudzu to run.
  394. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  395. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  396. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  397. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  398. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  399. driver match the corresponding terrible heuristic in the server.
  400. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  401. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  402. correctly distinguish between Mac Mini and Macbook Pro.
  403. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  404. - i810.xinf: PCI IDs for i965.
  405. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  406. - i810.xinf: Uppercase PCI IDs.
  407. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  408. - Update i810 to 1.6.5, should fix DRI.
  409. - Add kuzdu requires.
  410. - i810.xinf: Start whitelisting devices over to intel.
  411. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  412. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  413. you know, load.
  414. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  415. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  416. LFP special casing in favor of the blacklist.
  417. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  418. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  419. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  420. and is selected with Driver "intel" in xorg.conf. Individual devices will
  421. whitelist over to "intel" until that branch gets merged into head.
  422. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  423. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  424. the BIOS is known to lie.
  425. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  426. - Today's snapshot: I2C bus creation fix.
  427. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  428. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  429. clock when computing the modes list.
  430. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  431. in centimeters as the size of the display in pixels.
  432. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  433. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  434. probing.
  435. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  436. - Update again for a mode comparison bugfix.
  437. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  438. - Update to today's git; crash fixes, better pre-915 support, slightly better
  439. autoconfigurability.
  440. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  441. - rebuild
  442. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  443. - Fix Revision number to match naming policy.
  444. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  445. - Add back modesetting changes.
  446. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  447. - Roll back modesetting changes and build for fc5 aiglx repo.
  448. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  449. - Snapshot of the git modesetting branch.
  450. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  451. - Update i810.xinf to include entries for E7221 and 945GM.
  452. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  453. - Add with_dri macro to spec file, and conditionalize build time DRI support
  454. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  455. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  456. to pick up proto-devel as well.
  457. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  458. - Rebuild for 7.1 ABI fix.
  459. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  460. - Bump for fc5-bling build.
  461. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  462. - Update to 1.6.0 from 7.1RC1.
  463. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  464. - Add patch to add missing #include's, specifically assert.h.
  465. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  466. - Update to CVS snapshot of 20060322.
  467. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  468. - rebuilt for new gcc4.1 snapshot and glibc changes
  469. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  470. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  471. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  472. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  473. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  474. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  475. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  476. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  477. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  478. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  479. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  480. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  481. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  482. - Fix *.la file removal.
  483. - Added 'devel' subpackage for XvMC .so
  484. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  485. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  486. - Update BuildRoot to use Fedora Packaging Guidelines.
  487. - Deglob file manifest.
  488. - Limit "ExclusiveArch" to x86, x86_64, ia64
  489. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  490. - Initial spec file for i810 video driver generated automatically
  491. by my xorg-driverspecgen script.