guile-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 2.0
  3. Name: guile
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 2.0.12
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.xz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  16. BuildRequires: gmp-devel readline-devel emacs
  17. BuildRequires: libunistring-devel
  18. BuildRequires: libffi-devel
  19. BuildRequires: gc-devel
  20. Requires(post): /sbin/install-info
  21. Requires(preun): /sbin/install-info
  22. Requires: coreutils
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: yasumichi
  26. %description
  27. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  28. implementation of the Scheme programming language, written in C. GUILE
  29. provides a machine-independent execution platform that can be linked in
  30. as a library during the building of extensible programs.
  31. Install the guile package if you'd like to add extensibility to programs
  32. that you are developing.
  33. %package devel
  34. Summary: Libraries and header files for the GUILE extensibility library.
  35. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: gmp-devel
  39. Requires: gc-devel
  40. %description devel
  41. The guile-devel package includes the libraries, header files, etc.,
  42. that you'll need to develop applications that are linked with the
  43. GUILE extensibility library.
  44. You need to install the guile-devel package if you want to develop
  45. applications that will be linked to GUILE. You'll also need to
  46. install the guile package.
  47. %package -n compat32-%{name}
  48. Summary: A GNU implementation of Scheme for application extensibility.
  49. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  50. Group: System Environment/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  54. implementation of the Scheme programming language, written in C. GUILE
  55. provides a machine-independent execution platform that can be linked in
  56. as a library during the building of extensible programs.
  57. Install the guile package if you'd like to add extensibility to programs
  58. that you are developing.
  59. %package -n compat32-%{name}-devel
  60. Summary: Libraries and header files for the GUILE extensibility library.
  61. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  62. Group: Development/Libraries
  63. Requires: %{name}-devel = %{version}-%{release}
  64. Requires: compat32-%{name} = %{version}-%{release}
  65. Requires: compat32-gmp-devel
  66. Requires: compat32-gc-devel
  67. %description -n compat32-%{name}-devel
  68. The guile-devel package includes the libraries, header files, etc.,
  69. that you'll need to develop applications that are linked with the
  70. GUILE extensibility library.
  71. You need to install the guile-devel package if you want to develop
  72. applications that will be linked to GUILE. You'll also need to
  73. install the guile package.
  74. %prep
  75. %setup -q
  76. %patch1 -p1 -b .multilib
  77. %build
  78. %configure --disable-static --disable-error-on-warning
  79. # Remove RPATH
  80. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  81. libtool
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make DESTDIR=$RPM_BUILD_ROOT install
  86. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  88. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  89. # Our gdb doesn't support guile yet
  90. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
  91. # Compress large documentation
  92. bzip2 NEWS
  93. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  94. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  95. done
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. /sbin/install-info %{_infodir}/guile.info.gz %{_infodir}/dir
  101. /sbin/install-info %{_infodir}/r5rs.info.gz %{_infodir}/dir
  102. %postun -p /sbin/ldconfig
  103. %preun
  104. if [ "$1" = 0 ]; then
  105. /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
  106. /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
  107. fi
  108. :
  109. %if %{build_compat32}
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %endif
  113. %files
  114. %defattr(-,root,root,-)
  115. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  116. %{_bindir}/guild
  117. %{_bindir}/guile
  118. %{_bindir}/guile-tools
  119. %{_libdir}/libguile*.so.*
  120. %{_libdir}/libguilereadline-*.so
  121. %dir %{_libdir}/guile/%{mver}
  122. %{_libdir}/guile/%{mver}/ccache
  123. %dir %{_datadir}/guile
  124. %dir %{_datadir}/guile/%{mver}
  125. %{_datadir}/guile/%{mver}/*.scm
  126. %{_datadir}/guile/%{mver}/ice-9
  127. %{_datadir}/guile/%{mver}/language
  128. %{_datadir}/guile/%{mver}/oop
  129. %{_datadir}/guile/%{mver}/rnrs
  130. %{_datadir}/guile/%{mver}/scripts
  131. %{_datadir}/guile/%{mver}/srfi
  132. %{_datadir}/guile/%{mver}/sxml
  133. %{_datadir}/guile/%{mver}/system
  134. %{_datadir}/guile/%{mver}/texinfo
  135. %{_datadir}/guile/%{mver}/web
  136. %{_datadir}/guile/%{mver}/guile-procedures.txt
  137. %dir %{_datadir}/guile/site
  138. %{_infodir}/*
  139. %{_mandir}/man1/guile.1*
  140. %files devel
  141. %defattr(-,root,root,-)
  142. %{_bindir}/guile-config
  143. %{_bindir}/guile-snarf
  144. %{_datadir}/aclocal/*
  145. %{_libdir}/libguile-%{mver}.so
  146. %{_libdir}/pkgconfig/*.pc
  147. %{_includedir}/guile/%{mver}
  148. # compat32
  149. %if %{build_compat32}
  150. %files -n compat32-%{name}
  151. %defattr(-,root,root,-)
  152. %{_libdir}/libguile*.so.*
  153. %{_libdir}/libguilereadline-*.so
  154. %files -n compat32-%{name}-devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libguile-%{mver}.so
  157. %endif
  158. %changelog
  159. * Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.12-1
  160. - update to 2.0.12
  161. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.11-2
  162. - rebuilt with readline 6.3
  163. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
  164. - update to 2.0.11
  165. - add BuildRequires: libunistring-devel, libffi-devel, gc-devel
  166. - remove Patch2,4
  167. * Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
  168. - update to 1.8.8
  169. - remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
  170. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  171. - rebuilt with rpm-4.8.1
  172. - added Patch1, 2, 3, 5 and 6 from Fedora
  173. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  174. - new upstream release.
  175. - comment out Patch11,12.
  176. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  177. - added Requires: gmp-devel to guile-devel
  178. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  179. - added compat32 package for x86_64 arch support
  180. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  181. - rebuild with libtool-2.2.6a
  182. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  183. - new upstream release
  184. - import some patches from fedora development
  185. - drop some old patches
  186. - update spec based on fedora package
  187. - spec in utf-8
  188. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  189. - use macro for Release
  190. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  191. - apply new virsioning policy.
  192. - remove *.la
  193. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  194. - rebuilt with readline 5.1
  195. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  196. - added Patches from Fedora
  197. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  198. - Fix dynamic linking on 64bit archs (#159971)
  199. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  200. - Moved info files to base package as they are not devel related (#139948)
  201. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  202. - Fixed guile-tools not finding guile lib dir (#142642)
  203. - Added some nice tools (#142642)
  204. - Removed smp build, seems to be broken atm
  205. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  206. - new upstream release
  207. - dropped patch2, 4, 6
  208. - added BuildPrereq: perl
  209. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  210. - rebuild with new toolchains
  211. - s/Copyright/License/
  212. - added srfi libs
  213. - patch for ppc64 from Fedora package
  214. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  215. - update to 1.6.4
  216. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  217. - rebuild with readline-4.3
  218. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  219. - based on Rawhide 1.6.0-4
  220. - Included s390 as working arch as well, switch to general unknown arch patch
  221. - rebuild to fix broken deps
  222. - fix continuations.h on ia64
  223. - new upstream 1.6.3
  224. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  225. - porting for Vine Linux
  226. - remove 1.3 patches( not required so that upstream upgrade )
  227. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  228. - Add version number to prereq for umb-scheme to get the post-install to
  229. work properly.
  230. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  231. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  232. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  233. - automatic rebuild
  234. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  235. - Back down to 1.3.4.
  236. - Fix to actually link against the version of libguile in the package.
  237. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  238. - FHS fixups using the %%{makeinstall} macro.
  239. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  240. - fix preun-devel
  241. - call ldconfig directly in postun
  242. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  243. - rebuild with new readline
  244. - update to 1.3.4
  245. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  246. - using the same catalog as umb-scheme makes umb-scheme a prereq
  247. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  248. - readline is needed for %post
  249. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  250. - use the same catalog as umb-scheme
  251. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  252. - fix broken %postun
  253. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  254. - auto rebuild in the new build environment (release 6)
  255. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  256. - added .ansi patch to fix #endif
  257. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  258. - add patch for the scm stuff
  259. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  260. - integrate changes from rhcn version (#640)
  261. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  262. - call libtoolize first to get it to compile on the arm
  263. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  264. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  265. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  266. - guile-devel does depend on guile
  267. - remove devel dependancy on m4
  268. - move guile-snarf from guile to guile-devel
  269. - Converted to rhcn
  270. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  271. - update to 1.3.
  272. - don't strip libguile.so.*.0.0. (but set the execute bits).
  273. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  274. - spec file fixups
  275. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  276. - Updated for RH 5.2
  277. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  278. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  279. - added slib link
  280. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  281. - added %attr(-, root, root) for %doc,
  282. - in %post, %postun ldconfig runed as parameter "-p",
  283. - removed /bin/sh from requires,
  284. - added %description,
  285. - changes in %files.
  286. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  287. - all rewrited for using Buildroot,
  288. - added %postun,
  289. - removed making buid logs,
  290. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  291. parameters,
  292. - added striping shared libs and /usr/bin/guile,
  293. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  294. "Requires: m4" for guile-devel,
  295. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  296. - added %attr macros in %files.